Jump to content
hobbzilla

Multi-Stores Multiple Shops Support

Recommended Posts

I just wanted to get some advice regarding the capabilities of this contribution. I understand that if a customer adds something to their cart in one store that they cannot then go to your other store and add another item to the same cart. Is this correct?

 

Secondly, I am wondering if this contribution would work with a subdomain so if my main store was at www.mystore.com, could I place a second store at www.betterstore.mystore.com? How would this work with the admin section - would it get awfully confusing?

 

Sarah

 

By default, the cart is shared across stores, so if the customer adds a product from one store into their cart, then flip over to the other store, that product will show up in the other stores cart.

 

Having a subdomain should be no problem. Right now, I have two stores that are running in two different domains but share a domain for SSL so I only have to buy I cert. IE:

www.domain1.com //store 1

www.domain2.com //store 2

secure.mydomain.com //Secure site for store 1

secure.mydomain.com/domain2 //secure site for store 2

 

Every thing seems to work fine.


osCommerce is a great piece of software with wonderful contributions.

Spend some time in the contribution area. There are a lot of gems there.

Share this post


Link to post
Share on other sites
By default, the cart is shared across stores

 

Are you sure about this? I think I have read in this thread that carts are not shared between stores, but it can be adapted to that.

 

// Fredrik

Share this post


Link to post
Share on other sites
Are you sure about this? I think I have read in  this thread that carts are not shared between stores, but it can be adapted to that.

 

// Fredrik

If anyone could provide some confirmation about this I'd appreciate it before I installed it!

 

Thanks

 

Sarah

Share this post


Link to post
Share on other sites

Ok.. I will assume the cart *IS* shared between all stores.. Which store rules the shipping method & costs?

 

If Store A sells bakery items and needs overnight or 2nd day at most

Store B ships UPS only

Store C gives customer the option of UPS or USPS

Store D ships FedEx only

 

Customer bought an item from each store and is ready to checkout. How is the shipping handled?

 

Thanks

Lori

Share this post


Link to post
Share on other sites
Ok.. I will assume the cart *IS* shared between all stores.. Which store rules the shipping method & costs?

 

If Store A sells bakery items and needs overnight or 2nd day at most

Store B ships UPS only

Store C gives customer the option of UPS or USPS

Store D ships FedEx only

 

Customer bought an item from each store and is ready to checkout.  How is the shipping handled?

 

Thanks

Lori

I think that shipping will be handled from the store that the customer checked out from.


osCommerce is a great piece of software with wonderful contributions.

Spend some time in the contribution area. There are a lot of gems there.

Share this post


Link to post
Share on other sites

Where Is Hobbzilla

hasn't posted since Jul

 

and where has the contribution gone link I bookmarked does not exist

Edited by crashwave

q_|_|| _|9~~J >-o>-o q_|_|| )| q_|| )

Share this post


Link to post
Share on other sites

I have Multi Stores loaded on my site along with quite a few other contributions, but the only two that I think would interfere with each other in this instance is MultiStores & QTPro. I've checked the database and things are being inserted properly, however they are not being updated. So I am guessing somehow when I merged the two together that the query for the updates somehow became unhappy.

 

here is the case insert code from page catalog/admin/specials.php:

  case 'insert':
       $products_id = tep_db_prepare_input($HTTP_POST_VARS['products_id']);
       $products_price = tep_db_prepare_input($HTTP_POST_VARS['products_price']);
       $specials_price = tep_db_prepare_input($HTTP_POST_VARS['specials_price']);
       $day = tep_db_prepare_input($HTTP_POST_VARS['day']);
       $month = tep_db_prepare_input($HTTP_POST_VARS['month']);
       $year = tep_db_prepare_input($HTTP_POST_VARS['year']);
       //******ADD SPECIAL START DATE BEGIN*************//
         $vday = tep_db_prepare_input($HTTP_POST_VARS['vday']);
       $vmonth = tep_db_prepare_input($HTTP_POST_VARS['vmonth']);
       $vyear = tep_db_prepare_input($HTTP_POST_VARS['vyear']);
       
               // check if valid from date is later than expires date
       if (tep_not_null($day) && tep_not_null($month) && tep_not_null($year) &&
      	 tep_not_null($vday) && tep_not_null($vmonth) && tep_not_null($vyear)) {

      	 if (($vyear > $year) ||
         ($vmonth > $month && $vyear == $year) ||
         ($vday > $day && $vmonth == $month && $vyear == $year))
         {
        	 // if so, swap the dates
        	 $tempdate = $vyear; $vyear = $year; $year = $tempdate;
        	 $tempdate = $month; $vmonth = $month; $month = $tempdate;
        	 $tempdate = $vday; $vday = $day; $day = $tempdate;
         }
       }
       //******ADD SPECIAL START DATE END***************//

       if (substr($specials_price, -1) == '%') {
         $new_special_insert_query = tep_db_query("select products_id, products_price from " . TABLE_PRODUCTS . " where products_id = '" . (int)$products_id . "'");
         $new_special_insert = tep_db_fetch_array($new_special_insert_query);

         $products_price = $new_special_insert['products_price'];
         $specials_price = ($products_price - (($specials_price / 100) * $products_price));
       }

       $expires_date = '';
       if (tep_not_null($day) && tep_not_null($month) && tep_not_null($year)) {
         $expires_date = $year;
         $expires_date .= (strlen($month) == 1) ? '0' . $month : $month;
         $expires_date .= (strlen($day) == 1) ? '0' . $day : $day;
       }
       //*******ADD SPECIAL START DATE BEGIN***********//
        $validfrom_date = '';
       if (tep_not_null($vday) && tep_not_null($vmonth) && tep_not_null($vyear)) {
         $validfrom_date = $vyear;
         $validfrom_date .= (strlen($vmonth) == 1) ? '0' . $vmonth : $vmonth;
         $validfrom_date .= (strlen($vday) == 1) ? '0' . $vday : $vday;
       }
//$result = tep_db_query("insert into " . TABLE_SPECIALS . " (products_id, specials_new_products_price, specials_date_added, expires_date, status, valid_from_date) values ('" . (int)$products_id . "', '" . tep_db_input($specials_price) . "', now(), '" . tep_db_input($expires_date) . "', '1', '".  tep_db_input($validfrom_date)  ."')");

//rmh M-S_multi-stores edited next line & Special Start Date combined
     $result =  tep_db_query("insert into " . TABLE_SPECIALS . " (products_id, specials_new_products_price, specials_date_added, expires_date, status, valid_from_date, stores_id) values ('" . (int)$products_id . "', '" . tep_db_input($specials_price) . "', now(), '" . tep_db_input($expires_date) . "', '1', '".  tep_db_input($validfrom_date)  ."', " .  (int)$selected_store_id . ")");

       // maybe the special product must be deactivated or actived (depending on wether the valid from/expires dates had been changed)
       if ($result == 1) {
      	 $new_specials_id = tep_db_insert_id();
      	 tep_db_query("update " . TABLE_SPECIALS . " set status = '0' where (now() < valid_from_date or (now() >= expires_date and expires_date > 0)) and specials_id = '" . (int)$specials_id . "'");
      	 tep_db_query("update " . TABLE_SPECIALS . " set status = '1' where (now() >= valid_from_date and now() < expires_date) and specials_id = '" . (int)$new_specials_id . "'");
       }

       //*******ADD SPECIAL START DATE END*************//
//rmh M-S_multi-stores edited next line
       //tep_db_query("insert into " . TABLE_SPECIALS . " (products_id, specials_new_products_price, specials_date_added, expires_date, status, stores_id) values ('" . (int)$products_id . "', '" . tep_db_input($specials_price) . "', now(), '" . tep_db_input($expires_date) . "', '1', " .  (int)$selected_store_id . ")");

       tep_redirect(tep_href_link(FILENAME_SPECIALS, 'page=' . $HTTP_GET_VARS['page']));
       break;

 

And here is the case update code from page catalog/admin/specials.php

  case 'update':
       $specials_id = tep_db_prepare_input($HTTP_POST_VARS['specials_id']);
       $products_price = tep_db_prepare_input($HTTP_POST_VARS['products_price']);
       $specials_price = tep_db_prepare_input($HTTP_POST_VARS['specials_price']);
       //**********ADD SPECIAL START DATE*************//
      // $day = tep_db_prepare_input($HTTP_POST_VARS['day']);
     //  $month = tep_db_prepare_input($HTTP_POST_VARS['month']);
     //  $year = tep_db_prepare_input($HTTP_POST_VARS['year']);
       $vday = tep_db_prepare_input($HTTP_POST_VARS['vday']);
       $vmonth = tep_db_prepare_input($HTTP_POST_VARS['vmonth']);
       $vyear = tep_db_prepare_input($HTTP_POST_VARS['vyear']);
         // check if valid from date is later than expires date
       if (tep_not_null($day) && tep_not_null($month) && tep_not_null($year) &&
      	 tep_not_null($vday) && tep_not_null($vmonth) && tep_not_null($vyear)) {

      	 if (($vyear > $year) ||
         ($vmonth > $month && $vyear == $year) ||
         ($vday > $day && $vmonth == $month && $vyear == $year))
         {
        	 // if so, swap the dates
        	 $tempdate = $vyear; $vyear = $year; $year = $tempdate;
        	 $tempdate = $month; $vmonth = $month; $month = $tempdate;
        	 $tempdate = $vday; $vday = $day; $day = $tempdate;
         }
       }

      
      //***********ADD SPECIAL START DATE END 
       if (substr($specials_price, -1) == '%') $specials_price = ($products_price - (($specials_price / 100) * $products_price));

       $expires_date = '';
       if (tep_not_null($day) && tep_not_null($month) && tep_not_null($year)) {
         $expires_date = $year;
         $expires_date .= (strlen($month) == 1) ? '0' . $month : $month;
         $expires_date .= (strlen($day) == 1) ? '0' . $day : $day;
       }
//**************ADD SPECIAL START DATE BEGIN******//

       $validfrom_date = '';
       if (tep_not_null($vday) && tep_not_null($vmonth) && tep_not_null($vyear)) {
         $validfrom_date = $vyear;
         $validfrom_date .= (strlen($vmonth) == 1) ? '0' . $vmonth : $vmonth;
         $validfrom_date .= (strlen($vday) == 1) ? '0' . $vday : $vday;
       }

      // $result = tep_db_query("insert into " . TABLE_SPECIALS . " (products_id, specials_new_products_price, specials_date_added, expires_date, status, valid_from_date) values ('" . (int)$products_id . "', '" . tep_db_input($specials_price) . "', now(), '" . tep_db_input($expires_date) . "', '1', '".  tep_db_input($validfrom_date)  ."')");
//ADDED SPECIALS AND MULTI STORES TO BELOW LINE
$result =  tep_db_query("insert into " . TABLE_SPECIALS . " (products_id, specials_new_products_price, specials_date_added, expires_date, status, valid_from_date, stores_id) values ('" . (int)$products_id . "', '" . tep_db_input($specials_price) . "', now(), '" . tep_db_input($expires_date) . "', '1', '".  tep_db_input($validfrom_date)  ."', " .  (int)$selected_store_id . ")");


       // maybe the special product must be deactivated or actived (depending on wether the valid from/expires dates had been changed)
       if ($result == 1) {
      	 $new_specials_id = tep_db_insert_id();
      	 tep_db_query("update " . TABLE_SPECIALS . " set status = '0' where (now() < valid_from_date or (now() >= expires_date and expires_date > 0)) and specials_id = '" . (int)$new_specials_id . "'");
      	 tep_db_query("update " . TABLE_SPECIALS . " set status = '1' where (now() >= valid_from_date and now() < expires_date) and specials_id = '" . (int)$new_specials_id . "'");
       }

//**************ADD SPECIAL START DATE END********//
      // tep_db_query("update " . TABLE_SPECIALS . " set specials_new_products_price = '" . tep_db_input($specials_price) . "', specials_last_modified = now(), expires_date = '" . tep_db_input($expires_date) . "' where specials_id = '" . (int)$specials_id . "'");

       tep_redirect(tep_href_link(FILENAME_SPECIALS, 'page=' . $HTTP_GET_VARS['page'] . '&sID=' . $specials_id));
       break;
     case 'deleteconfirm':
       $specials_id = tep_db_prepare_input($HTTP_GET_VARS['sID']);

       tep_db_query("delete from " . TABLE_SPECIALS . " where specials_id = '" . (int)$specials_id . "'");

       tep_redirect(tep_href_link(FILENAME_SPECIALS, 'page=' . $HTTP_GET_VARS['page']));
       break;

 

Here is my function from catalog/admin/includes/functions/general.php

 function tep_is_allowed_special($special_id = '') {
   global $admin_allowed_stores;

     if ($admin_allowed_stores[0] != '*') {
       $product_query = tep_db_query("select p.products_id from " . TABLE_PRODUCTS . " p LEFT JOIN " . TABLE_SPECIALS . " s ON p.products_id = s.products_id where s.specials_id = '" . (int)$special_id . "' and s.stores_id in(" . implode(',' , $admin_allowed_stores) . ")");
       $product = tep_db_fetch_array($product_query);
     }

   if (tep_not_null($product) || $admin_allowed_stores[0] == '*') {
     return true;
   } else {
     return false;

 

And Lastly here is the query from catalog/specials.php

I'm guessing it is in this area where the problem is, but I am no PHP whiz!

<?php
//rmh M-S_multi-stores edited next line
 $specials_query_raw = "select p.products_id, pd.products_name, p.products_price, p.products_tax_class_id, p.products_image, s.specials_new_products_price from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_SPECIALS . " s, " . TABLE_PRODUCTS_TO_STORES . " p2s where p.products_status = '1' and s.products_id = p.products_id and p.products_id = pd.products_id and s.products_id = p2s.products_id and pd.language_id = '" . (int)$languages_id . "' and s.status = '1' and p2s.stores_id = '" . STORES_ID . "' and s.stores_id = '" . STORES_ID . "' order by s.specials_date_added DESC";
 $specials_split = new splitPageResults($specials_query_raw, MAX_DISPLAY_SPECIAL_PRODUCTS);
 if (($specials_split->number_of_rows > 0) && ((PREV_NEXT_BAR_LOCATION == '1') || (PREV_NEXT_BAR_LOCATION == '3'))) {
?>

Anyone out there see any glaring booboos that might be causing this problem. Apparently there are no parse errors, because no errors come up at all, but there is absolutely nothing on my specials page or in the columns infobox

Thanks for any input!

Teresa

Share this post


Link to post
Share on other sites

can any one help me to understund what I have doing vrong

 

every thing works out fine until

I shold pay

 

I click on

 

I am a new customer.

 

when I write in the Your Personal Details

and click on continue

 

this comming

 

1054 - Unknown column 'customers_info_source_id' in 'field list'

 

insert into customers_info (customers_info_id, customers_info_date_of_last_logon, customers_info_number_of_logons, customers_info_date_account_created, customers_info_date_account_last_modified, customers_info_source_id, customers_info_stores_id) values ('3', now(), '1', now(), now(), '0', '2')

 

[TEP STOP]

 

 

What can I do to fix this.

 

Alfa

Edited by alfa

Share this post


Link to post
Share on other sites

Are you having an affiliate related contrib.

The field name that is missing appears to be an addition that should come with an affiliate contribution.

 

Satish Mantri


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites

Alfa,

See posts #311 through 314 for your answer. To better help yourself, I would suggest you read the posts from #306 on.

 

Later.

FoodDude

 

can any one help me to understund what I have doing vrong

 

every thing works out fine until

I shold pay

 

I click on

 

I am a new customer.

 

when I write in the Your Personal Details

and click on continue

 

this comming

 

1054 - Unknown column 'customers_info_source_id' in 'field list'

 

insert into customers_info (customers_info_id, customers_info_date_of_last_logon, customers_info_number_of_logons, customers_info_date_account_created, customers_info_date_account_last_modified, customers_info_source_id, customers_info_stores_id) values ('3', now(), '1', now(), now(), '0', '2')

 

[TEP STOP]

What can I do to fix this.

 

Alfa

Share this post


Link to post
Share on other sites

Hi

this is going to sound dumb but I'm a little confused...In the install directions it says to go into the admin and define the catalog paths for each store....THEN go and comment out the paths in configure.php for each as admin SHOULD be commanding them, but whenever anyone asks a question in this thread about configuration problems, we keep getting referred back to "check your configure.php paths are correct" Well If I commented them out, why would I be checking there? wouldn't I go to admin?

Plus....For as little as I know about php, I know even less about paths....so I've used the examples, but I dont have a

/home/domain/public_html/

anywhere that I've seen ftp -ing or anywhere else...so if my modules lay in

http://teenietinystitches.com/NewTTS/RIB/c...cludes/modules/

do I just put

/NewTTS/RIB/catalog/includes/modules/

in htat spot???

I'm sure my paths are the problem because everything works great in my default store along with store #1 and store #2, its just they are all exactly the same even after moving stuff to stores and distributors and checking tables to see that there are indeed store IDs

Can anyone help this big dummy???

Teresa

Share this post


Link to post
Share on other sites

I'm no expert and perhaps somebody who knows more can put us both right BUT in the interests of helping out a fellow 'dummy'...

 

... whenever anyone asks a question in this thread about configuration problems, we keep getting referred back to "check your configure.php paths are correct" Well If I commented them out, why would I be checking there? wouldn't I go to admin?

 

Yes you would if the problem paths were the ones you commented out. But there are some paths which you didn't comment out - to your backup directory for example

I haven't checked the posts you refer to but I guess they would be referring to paths in /catalog/includes/configure.php - none of which should be commented out..

 

Plus....For as little as I know about php, I know even less about paths....so I've used the examples, but I dont have a /home/domain/public_html/ anywhere that I've seen ftp -ing or anywhere else...

 

Computer paths are like any other kinds of paths - routes to get you where you want to go. Take a look at configure.php (either catalog or admin) and you'll see there are two different kinds of paths: Web System (_WS_) and File System (_FS_).

 

W_S paths are paths through the Web to directories on your server - and are always in the form http://www.yourdomain.com/etc - as in the address bar of your browser.

 

F_S paths are paths through the server's own filesystem. On your own computer they might be in the form C:\websites\catalog\etc.

 

Servers are just computers which are configured mainly to serve files. If, like most, you are hosted on a shared or virtual rather than a dedicated server, then there will be hundreds of different sites, each in different directories on the same server.

 

To make navigation easier and more like web system paths, directories are given aliases, nicknames, or A.K.A type names if you like, in a form more like web paths - using forward slashes rather than backslashes.

 

If you look in your configure.php file you will see that the _FS_ type paths are in the form /home/domain/public_html/ OR /var/www/html OR whatever, depending on whatever convention your hosting provider has chosen to use.

 

Hope this helps.

Edited by imac

Share this post


Link to post
Share on other sites

Dear Imac

Thanks for your input, it was a BIG help. I did figure things out for the most part. I have a default store that seems to be responding to admin, a second store that seems to be responding and a third store that partially responds to admin

Explaination

The proper product is in the third store, images and such. I can check out and get all my emails and such, however I decided to change my logo (make it a little smaller) changed it in admin but the 3rd store does not respond to it. So I went to the database....it had the right url for the image, but still doesn't respond....So I'm playing with that right now. Also used Define Main News contribution so that I could have different blurbs on the index page in each store....Again, got it working for default and 2nd store, but not 3rd store.

So if anyone has any thoughts on why that might be happening, I'd love to hear from you, otherwise I will just keep pluggiing along.

One question I have for those of you out there that have this working....In Admin - Specials I would prefer to have the item description AND model number and I go more by my model numbers than descriptions, but it would be nice to have both....Any way I can add that to the query without damaging it??? Which query would I need to add it to? what should it look like?

Thanks for any help....

and thanks again Imac

Teresa

Share this post


Link to post
Share on other sites

Hi

Has anyone out there merged products attributes - option type features v.1.7.1 with multi stores....I am having a heck of a time merging these two files

 

catalog/includes/classes/shopping_cart.php

and

catalog/includes/functions/general.php

 

If anyone has done this successfully, would you be willing to share these two files....I've been at it for 2 days. I'm close, but I keep getting parse errors.

Your help would be greatly appreciated...

Teresa

Share this post


Link to post
Share on other sites

I seem to be posting to a bottomless pit or just have really mind boggling problems.....

Hope someone can answer this problem in the near future...

I set up a "Test" Site that completely duplicates my working site with a default store and 2 extra stores. I even added a new database so that I didn't mess up my Master. Well of course I had to change all the periperal stuff, like database user names, passwords.........

and change all the configure.php files and all seemed well until I added a new contribution (account balance) which adds a order total module... thats when I noticed this:

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_account_balance.php): failed to open stream: No such file or directory in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(): Failed opening 'DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_account_balance.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_coupon.php): failed to open stream: No such file or directory in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(): Failed opening 'DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_coupon.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_gv.php): failed to open stream: No such file or directory in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(): Failed opening 'DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_gv.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_loworderfee.php): failed to open stream: No such file or directory in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(): Failed opening 'DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_loworderfee.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_shipping.php): failed to open stream: No such file or directory in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(): Failed opening 'DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_shipping.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_subtotal.php): failed to open stream: No such file or directory in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(): Failed opening 'DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_subtotal.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_tax.php): failed to open stream: No such file or directory in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(): Failed opening 'DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_tax.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_total.php): failed to open stream: No such file or directory in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Warning: main(): Failed opening 'DIR_FS_CATALOG_LANGUAGESenglish/modules/order_total/ot_total.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php on line 130

 

Now after many hours of searching support threads I have found that this is related to catalog/includes/configure.php which is this:

<?php
/*
 $Id: configure.php,v 1.14 2003/07/09 01:15:48 hpdl Exp $

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://teenietinystitches.netfirms.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://teenietinystitches.sslpowered.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'teenietinystitches.netfirms.com');
 define('HTTPS_COOKIE_DOMAIN', 'teenietinystitches.sslpowered.com');
 define('HTTP_COOKIE_PATH', '/TestWebsite/nfoscomm/catalog/');
 define('HTTPS_COOKIE_PATH', '/TestWebsite/nfoscomm/catalog/');
 define('DIR_WS_HTTP_CATALOG', '/TestWebsite/nfoscomm/catalog/');
 define('DIR_WS_HTTPS_CATALOG', '/TestWebsite/nfoscomm/catalog/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
define('DB_SERVER', 'MYSQLHOST'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', '********');
 define('DB_SERVER_PASSWORD', '******');
 define('DB_DATABASE', '**********');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 

now as for the "/mnt/web_k/d09/s01/a00091qk/www/TestWebsite/nfoscomm/catalog/admin/modules.php"....I inserted the "/mnt/web_k/d09/s01/a00091qk/www/" in the admin page for that particular Store.....I got this info from my phpinfo file because I had no idea what to put there and I read somewhere that I could get the path name.....So Is it right....hell if I know, but you saw all the errors. The weird thing is if I put anything BUT the "/mnt/web_k/d09/s01/a00091qk/www/" in those areas called for in MultiStores, nothing will show up at all on the Module area, not Module Payment, not Module Shipping or Module Order Total. But if I do put it in the path I get all the errors but at the very bottom the modules do show up and I can edit them and install them at the far right.

Can anyone give me any guidance as to what's going on? Has anyone ever seen anything like this?

Thanks for your help!

Teresa

Share this post


Link to post
Share on other sites

Hi

 

I have multisore running and want to display my product listings in columns.... has anybody done this yet>???

 

I know there is a contribution for product listing in columns but it doesnt work with multistore, i think its down to the page split result page but im still trying to work that out...

 

any ideas would be great

 

 

mark

Share this post


Link to post
Share on other sites
Hi

 

I have multisore running and want to display my product listings in columns.... has anybody done this yet>???

 

I know there is a contribution for product listing in columns but it doesnt work with multistore, i think its down to the page split result page but im still trying to work that out...

 

any ideas would be great

mark

 

Here are two stores we did with multi-stores. They use the column listing to display the products like you want to do.

 

http://4hstore.com

http://cyostore.com

 

Le me know if this is what you were looking for.


osCommerce is a great piece of software with wonderful contributions.

Spend some time in the contribution area. There are a lot of gems there.

Share this post


Link to post
Share on other sites
Here are two stores we did with multi-stores. They use the column listing to display the products like you want to do.

 

http://4hstore.com

http://cyostore.com

 

Le me know if this is what you were looking for.

 

 

Hi Ryan

 

Thanks for your reply, this is exactly what im looking for. How did you go about this?

 

Mark

Share this post


Link to post
Share on other sites
Hi Ryan

 

Thanks for your reply, this is exactly what im looking for. How did you go about this?

 

Mark

 

It's based off the product listing in columns contrib out there. I just modified it in some places to make it work with the multi stores. If I remeber right, this was one of those files that was a bit of a pain to make it work right with multi-stores. Some of the file merging gave me nightmares. If you want to PM me your e-mail, I'll send you our product listing file.

 

I think that it uses the same type of database entries that the normal product listing contrib uses, but you have to make sure when you create a new store that you remeber to copy those changes. I found it easiest that when I create a new store, to just take the default store and do a

create table new_table_config as select * from configuration

.

That way you make sure to get all of your contrib values.


osCommerce is a great piece of software with wonderful contributions.

Spend some time in the contribution area. There are a lot of gems there.

Share this post


Link to post
Share on other sites

Hi Everybody,

 

I Need some help

 

I am newbie - starting a multi shop setup and need easy populate.

 

I have read ALL the preceding 35 pages ( dont look at me like that !! :) ) and from my understanding Hobzilla has ported a version of Easy Pop to work with Multi Stores -

 

frrom what i can see its not avail in contribs ( something political? )

 

does anybody have a copy of this particular contrib that they can email me.. ??

 

PLEASE???

 

thanking you all in advance

 

Andrew

Share this post


Link to post
Share on other sites

Hello all. I am another newbie around here, and this may seem a bit obvious to you guys, but i would really appreciate the help. I have just installed Multiple stores 1.4 over a fresh install of MS2.2. I updated the db by simply merging the original with the update.sql in a text editor and then reloading (all the new tables appear to be present ....55 in all).

 

My first store appears to be working ok, but am having trouble adding additional stores in Administration/Stores Admin.

 

Am I right in assuming that as long as I put a new name in the "Stores Config Table:" field (e.g. configuration2" and checking the "Insert default configuration table?" box, a new table will automatically be created in the MySQL database? Because when I hit the save button, nothing hapens! I remain on the current page, and on checking the db, no additional table is created.

 

Thanks for any help you can give me in getting an additional store to register in Stores Admin. I have been really impressed with osCommerce so far, it has done a terrific job.

 

Thanks

Share this post


Link to post
Share on other sites
I have just installed Multiple stores 1.4 over a fresh install of MS2.2. I updated the db by simply merging the original with the update.sql in a text editor and then reloading (all the new tables appear to be present ....55 in all).

 

My first store appears to be working ok, but am having trouble adding additional stores in Administration/Stores Admin.

 

Please ignore my last post. I have found the issue....there appears to be a conflict with assigning the same image to more than one store. In setting up the stores I was assigning the default oscommerce.gif image to the different sores. As soon as i tried another image, hey presto the new store saves correctly, and I have a new table in the MySQL database. Terriffic.

 

PS It was v1.7 that I have just installed, not 1.4.

 

Thanks

Share this post


Link to post
Share on other sites

I just did a vanilla install, IE installed MS.17 over a clean install of OSc MS2 and it wont let me log into the Admin area, the default username and password is admin, but it just reloads the login page.

 

Anyone else found this problem?

 

If i bypass the login routine, then all i get is Warnings about a bad implode, all over general.php.

 

Anyone got any ideas, absolutely no other contribs install, just a clean instal over a newly downloaded files :(

 

thnx

Paul


Feel free to ask me for help

beep... beep....My Pager

Share this post


Link to post
Share on other sites
I just did a vanilla install, IE installed MS.17 over a clean install of OSc MS2 and it wont let me log into the Admin area, the default username and password is admin, but it just reloads the login page.

 

Anyone else found this problem?

 

If i bypass the login routine, then all i get is Warnings about a bad implode, all over general.php.

 

Anyone got any ideas, absolutely no other contribs install, just a clean instal over a newly downloaded files :(

 

thnx

Paul

 

I had this problem. It has to do with your paths not being set exactly right. If you have an extra / in you path, or use www with no www, it won't let you in. When you in the login page, hover over the admin icon in the top right, and make sure that path matches exactly whats in the URL. I was sure I had my paths exactly right, but it was one subtle little difference that cause me all the aggervation.

 

Hope that helps.


osCommerce is a great piece of software with wonderful contributions.

Spend some time in the contribution area. There are a lot of gems there.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×