Jump to content
hobbzilla

Multi-Stores Multiple Shops Support

Recommended Posts

after uploading it to the online server it works, but i can't get it to work on localhost, probably something windows related. But i can't seem to figure out what it is

Share this post


Link to post
Share on other sites

Anyone got a good order editor working for the backend?

 

Looking for something really great for reps to enter orders in the backend easily.

Share this post


Link to post
Share on other sites
Anyone got a good order editor working for the backend?

 

Looking for something really great for reps to enter orders in the backend easily.

 

Why not simply use osCommerce catalog to place the orders from salespeople.. with the sales people effectively logging in as the customer? Thats what I do! There was a previous "un-named" version that contained a "enable b2b functionality" that provided this for you. PM me if you have additional questions.

Share this post


Link to post
Share on other sites
of course, but i think it's not a problem of incorrect login, it's more the passing of the variables

 

Please double check the paths in your admin's configure.php if you are entering the user/password and it continues to send you right back to the login screen.

Share this post


Link to post
Share on other sites
Please double check the paths in your admin's configure.php if you are entering the user/password and it continues to send you right back to the login screen.

the paths should be correct, it works with the default version installed and i double checked afterwards too.

i'm running php5 tho, maybe this could have something to do with it.

Share this post


Link to post
Share on other sites

Hi Everyone again,

 

My multi store works great now. But when i set the products out of stock. It still shows almost all the time, but when i click on it it says that product not found. If i then go back to the category it stands there again?

 

Someone that have an answer to that?

 

-Thomas-

Share this post


Link to post
Share on other sites

Happy Memorial Day Multi-Store users ...

 

I've recently installed STS (Simple Template system), and would love to install Multi-Store.

 

Is there a specific version I need? Has anyone contributed this Add-on?

 

Here is the site under development:

 

www.mhvacsew.com/store

 

You'll notice there are 3 main categories, Vacuums, Sewing Machines and Air Purifiers. I want to separate each into its own store.

 

The Vacuum template can be found at:

 

http://mhvacsew.com/mhvacsew-gradientOrange.html

 

Its a non-functioning version. but has all elements I intend on integrating with OsC ie New products, random specials on front etc.

 

The following page is an actively retrofitted Osc catalog page (still under const.)complete with STS installed. If you navigate through the rest of the site, its a canned OSc site.

 

http://mhvacsew.com/store/index.php/cPath/67_72

 

The moral of the story is, I intend on installing Multi-store, and was wondering if anyone has tried it and STS with any success yet? Has it been attempted? Is there maybe something else I might be looking for? Am I asking for trouble? ;)

 

 

Any and all help is always greatly appreciated,

 

Respectfully,

 

Chris

Share this post


Link to post
Share on other sites
Happy Memorial Day Multi-Store users ...

 

I've recently installed STS (Simple Template system), and would love to install Multi-Store.

 

Is there a specific version I need? Has anyone contributed this Add-on?

 

Here is the site under development:

 

www.mhvacsew.com/store

 

You'll notice there are 3 main categories, Vacuums, Sewing Machines and Air Purifiers. I want to separate each into its own store.

 

The Vacuum template can be found at:

 

http://mhvacsew.com/mhvacsew-gradientOrange.html

 

Its a non-functioning version. but has all elements I intend on integrating with OsC ie New products, random specials on front etc.

 

The following page is an actively retrofitted Osc catalog page (still under const.)complete with STS installed. If you navigate through the rest of the site, its a canned OSc site.

 

http://mhvacsew.com/store/index.php/cPath/67_72

 

The moral of the story is, I intend on installing Multi-store, and was wondering if anyone has tried it and STS with any success yet? Has it been attempted? Is there maybe something else I might be looking for? Am I asking for trouble? ;)

Any and all help is always greatly appreciated,

 

Respectfully,

 

Chris

 

chris,

 

using multistores with bts is possible but it will take a lot of work on your part.....

 

basically you need to convert most of the multi-store "catalog-side" files into the bts format ie. a little bit of the multi-stores file code will go into the first "non-template" file that resides in the non-template locations in your main catalog and then a majority of the multi-stores file code will need to be placed into the template file in the template directory or the content directory for the templates.....

 

a good compare and merge utility could help you get this done......

 

i did this for about 100 files and then put the project on the back burner and have not gotten back to it......

Share this post


Link to post
Share on other sites
using multistores with bts is possible but it will take a lot of work on your part.....

 

Sorry if I didn't make myself clear .. I was referring to STS (simple template system), not BTS.

 

I'm actually in the process now of debating the install all together due to SSL issues. Seems like my host wont assign more then 1 IP per account. Something ill obviously need for each stores SSL cert (not interested in shared certs). *sighs*

 

I can point 10 domains into the account, but not SSL certs ... I'm ganna try to convince them to sell me a small block of IP's. We will wait and see. I might have to switch hosts all together, but I don't want to go through the entire process.

 

In reference to STS and multi-store, I've recently spoke with a current user of both, and he says they work like a charm - encouraging words to those out there looking for the same options.

 

I'll keep you guys posted on my outcome and possible solution, if any.

 

 

Chris

Share this post


Link to post
Share on other sites
Sorry if I didn't make myself clear .. I was referring to STS (simple template system), not BTS.

 

I'm actually in the process now of debating the install all together due to SSL issues. Seems like my host wont assign more then 1 IP per account. Something ill obviously need for each stores SSL cert (not interested in shared certs). *sighs*

 

I can point 10 domains into the account, but not SSL certs ... I'm ganna try to convince them to sell me a small block of IP's. We will wait and see. I might have to switch hosts all together, but I don't want to go through the entire process.

 

In reference to STS and multi-store, I've recently spoke with a current user of both, and he says they work like a charm - encouraging words to those out there looking for the same options.

 

I'll keep you guys posted on my outcome and possible solution, if any.

Chris

 

my bad....but my answer should apply to any template system......later

Share this post


Link to post
Share on other sites

Hi

 

I believe there was a work around for easy populate to work with multi-stores....having gone to the easy populate download as linked to in an earlier thread and downloaded 3 different versions.....i cannot seem to find anything relating to multi-stores..

 

Did I miss something ...? and if so could anyone point me in the right direction with a little bit of info as to what to do.....

 

Thanks appreciate any help....

Share this post


Link to post
Share on other sites

OK I read this whole post and found one thing and tryed it and it didn't work

 

I have my main store

 

ellemercantile.. selling clothes and patches

 

ok now I have a second store and I am selling hosting.

 

in my clothing store my hosting categoires are showing up.

(in the correct categories are showing up in the hosting store)

and I under where you select categories and pick store I have pick the correct store.

and no clothes categories are showing up in the hosting store

 

I check the database_tables.php configuration and that is correct.

 

my configuration.php is correct.. and the configuration in the under the the admin configuartion

where it says "multi-stores" I have that all correct.

 

Ok I read that I need to make Distributors for each store and I did that.

ONe called clothes

and one called host. I added the hosting

I even make a seperate admin with distributor for each store at no avail

 

I don't know what else to do.

Please help.

noppie

 

default store is

http://ellemercantile.com

hosting is

http://ellehosting.com


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

boy do I feel stupid, I figured out what is wrong it is the dhml menu I am using..

it goes and reads and picks up all the categories.. I should have realized that..

now I have to figure something out.

noppie


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

Haven't seen my problem echoed in this string of replies. I installed a fresh version of oscommerce, installed the newest version of this contrib, and I'm getting the catalog side to show up with no products. Good right? Now the problem. The admin side doesn't error out if I type an incorrect admin login and it doesn't log me in with the correct one. The only thing I can see that's a little quirky is when I added the update.sql info to my site I got a password of about 40 characters. Is this normal? How do I get logged in so I can finish the install? I even tried changing the pass and the username. I'm stuck :'(

Share this post


Link to post
Share on other sites
Haven't seen my problem echoed in this string of replies.  I installed a fresh version of oscommerce, installed the newest version of this contrib, and I'm getting the catalog side to show up with no products.  Good right?  Now the problem.  The admin side doesn't error out if I type an incorrect admin login and it doesn't log me in with the correct one.  The only thing I can see that's a little quirky is when I added the update.sql info to my site I got a password of about 40 characters.  Is this normal?  How do I get logged in so I can finish the install? I even tried changing the pass and the username.  I'm stuck  :'(

 

It may having somthing to do with your htaccess files. After freshly installing OsC a few weeks ago, i came across this same issue. I simply reinstalled a fresh htaccess file and it fixed the problem. This may be totally unrelated, but its worth looking at.

 

Good Luck

Share this post


Link to post
Share on other sites
Hi

 

I believe there was a work around for easy populate to work with multi-stores....having gone to the easy populate download as linked to in an earlier thread and downloaded 3 different versions.....i cannot seem to find anything relating to multi-stores..

 

Did I miss something ...?  and if so could anyone point me in the right direction with a little bit of info as to what to do.....

 

Thanks appreciate any help....

 

Well, I did upload it to the easy populate contribution section but apparently either the people there didn't appreciate that.. or the development team didn't. Either way, I have a version that I tested with multi-stores and will try and post it under the multi-stores contribution section in the next few days.

 

It is really sad how things get deleted or moved around here... Oh well.

Share this post


Link to post
Share on other sites
Haven't seen my problem echoed in this string of replies.  I installed a fresh version of oscommerce, installed the newest version of this contrib, and I'm getting the catalog side to show up with no products.  Good right?  Now the problem.  The admin side doesn't error out if I type an incorrect admin login and it doesn't log me in with the correct one.  The only thing I can see that's a little quirky is when I added the update.sql info to my site I got a password of about 40 characters.  Is this normal?  How do I get logged in so I can finish the install? I even tried changing the pass and the username.  I'm stuck  :'(

 

Please double & triple check your admin's configure.php paths.. FS & WS paths both. It can get stuck in a login loop if not set correctly.

Share this post


Link to post
Share on other sites
Please double & triple check your admin's configure.php paths.. FS & WS paths both.  It can get stuck in a login loop if not set correctly.

 

Well what should I change it to?! it works fine until I plug in the add on.

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://mall.mandarinllc.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http://mall.mandarinllc.com');
 define('HTTPS_CATALOG_SERVER', 'https://mandarinllc.com');
 define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/home/mandarin/public_html/mall/'); // where the pages are located on the server
 define('DIR_WS_ADMIN', '/admin/'); // absolute path required
 define('DIR_FS_ADMIN', '/home/mandarin/public_html/mall/admin/'); // absolute pate required
 define('DIR_WS_CATALOG', '/'); // absolute path required
 define('DIR_FS_CATALOG', '/home/mandarin/public_html/mall/'); // absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'mandarin_osc1');
 define('DB_SERVER_PASSWORD', 'PsWuQ0ubZsHU');
 define('DB_DATABASE', 'mandarin_osc1');
 define('USE_PCONNECT', 'false'); // use persisstent connections?
 define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'
?>

 

That's what it looks like. I DID notice that I get an error with the STORE_SESSIONS definition if it's not defined as 'mysql'. Other than that, I don't know how to fix it.

 

Strange, but it won't print an error either. It'll redirect if I add the code in and put a false name in, but no error.

Share this post


Link to post
Share on other sites

I reinstalled everthing from scratch and it appears to be working now. I don't know why I had to do this 3 times to get it working, but I'm NOT complaining that it's working. Thanks.

Share this post


Link to post
Share on other sites

Glad it is working.. However, just a quick suggestion.. after posting your username/password to the internet.. now would be a good time to change those! :P

Share this post


Link to post
Share on other sites
That's what it looks like.  I DID notice that I get an error with the STORE_SESSIONS definition if it's not defined as 'mysql'.  Other than that, I don't know how to fix it.

 

Strange, but it won't print an error either.  It'll redirect if I add the code in and put a false name in, but no error.

 

The sessions problem is answered in the install file.

Share this post


Link to post
Share on other sites

Okay. Next part I'm a bit lost on. When I go to add a store, it asks for a 'configuration table' name. I don't even know where to look for the name

Share this post


Link to post
Share on other sites
Okay.  Next part I'm a bit lost on.  When I go to add a store, it asks for a 'configuration table' name.  I don't even know where to look for the name

 

pick any name you want to use....it then creates a new configuration table by that name for you.....

Share this post


Link to post
Share on other sites
Well, I did upload it to the easy populate contribution section but apparently either the people there didn't appreciate that.. or the development team didn't.  Either way, I have a version that I tested with multi-stores and will try and post it under the multi-stores contribution section in the next few days.

 

It is really sad how things get deleted or moved around here... Oh well.

 

 

Hi

 

Thanks I really appreciate that.....I thought i was going mad.......i couldnt see it anywhere..

 

:thumbsup:

Edited by found it

Share this post


Link to post
Share on other sites
Okay. Next part I'm a bit lost on. When I go to add a store, it asks for a 'configuration table' name. I don't even know where to look for the name

 

Ok make sure that your first configuration table is the default one.

on store two is where you need to change the name. you can call something like configuration_02

or what ever you want.

I have a clothing store for first store and book store for second store

and my second configuration is called configuration_books

I may have spelled configuration wrong but You should get the idea..

 

I was confused on this also

noppie


Peace is possible.. Please don't give up.

 

"War is --the old betraying the young"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×