Jump to content
joekushner

Actual Attribute Price V1.0

Recommended Posts

I have been looking at installing Actual Attribute Price v1.2.2, but something looks a little odd to me. It seems like there is a lot of unnecessary code in general.php included in this contribution package, maybe from Easy Populate or some other contribution. I also haven't seen where the included categories_lookup.php is needed beyond the require statement at the end of the modified general.php.

// WebMakers.com Added: Look up category functions
require(DIR_WS_FUNCTIONS . 'categories_lookup.php')
?>

 

I'm comparing the AAP 1.2.2 contribution to the 2.2ms2 osCommerce release unmodified general.php.

 

Can anyone confirm my suspicions, or am I trying to debug something that isn't messed up?

 

 

Also, does anyone have AAP working with Add Weight To Product Attributes? Any issues to look out for?

Share this post


Link to post
Share on other sites

Does anyone have this working with on new versions of OSC?

 

Works fine using set price attributes, but doesn't cope at all with attributes that either don't effect the price (price of the item ends up as 0), or with a price adjustment (base price + 2.00 will give a total cost of 2.00).

 

Would really like to get this one working, as we have edited over 3000 attributes to be in line with this set-up.

Share this post


Link to post
Share on other sites
Eveyrthing aside with Esay Populate...

 

I'm having problems with my shopping cart which is showing the base price + double the  value of the attribute.  For example, if hte base price is $100 and the attribute value is +20, the item in the cart would show $140.  Can someone please show me how to fix this problem??

 

 

Not found the specific problem with this but have found a fix which appears to work..

 

In includes/classes/shopping_cart.php after

          if ($price_prefix == '+') {
           $attributes_price += $option_price;
         }
         if ($price_prefix == '-') {
           $attributes_price -= $option_price;
         }
         if (($price_prefix == '') and  ($option_price > 0))
           $attributes_price += tep_adjust_price($option_price,$products_price);
         else
           $attributes_price += $option_price;
       }

 

add

	if ($products_price > 0.00) {
     $attributes_price -= $attributes_price / 2;
}

 

The attribute price then comes out correctly.

Share this post


Link to post
Share on other sites

I added my actual attribute to the contribution page. Didn't see a need to start a new one it is for the same thing. I did not use any of the original releases. This one is not the same as the one posted first. Please take a look at it and tell me what you think.

http://www.oscommerce.com/community/contributions,1716

 

Thanks


q_|_|| _|9~~J >-o>-o q_|_|| )| q_|| )

Share this post


Link to post
Share on other sites

hmmmm :'(

 

Cant say that this is the easiest install to follow :blink:

 

Download the most current file, and its an html file.

This file,, I see is clear,, in updating it once you have it installed... those are marked.

But, I do not see a section for new install, so I will wait till someone can advise me.

I am going into a loaded6 with it.

 

So,, Where is the new install instructions..?

:-"

 

Regards

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites
So,, Where is the new install instructions..?

:-"

 

Regards

Tom

 

New Install Instructions?

If you never had it do it all. All the steps.


q_|_|| _|9~~J >-o>-o q_|_|| )| q_|| )

Share this post


Link to post
Share on other sites

Crashwave

Thankkkkkksz,

I figured that was where to start,, but wanted to be safe / instead of sorry.

Cuz if something can go wrong,,, I am the one it will happen to,, lol

 

Gonna work on this now,,

Again, Thanks for the info

 

Regards

 

Tom


no bugs in my stuff,,, just random features ;)

Share this post


Link to post
Share on other sites

Hi,

 

Is it possible to see a screenshot of this contributon in action? So one might see what it look's like? :-"

Edited by Charles_K

/Charles K

Get Tattoo'd and feel the power of the needle's...

Share this post


Link to post
Share on other sites

Without taking credit from the authors of this contribution, I believe the installation directions are somewhat confusing.

 

I didnt find "For the function attributes_price($products_id)

Delete the whole thing and add this

//PHPMOM.COM AAP

---------" in my classes/shoppingcart.php.

 

I will wait till someone comes up with clearer instructions.

Share this post


Link to post
Share on other sites

What version of oscommerce are you using?

I went and checked my original unedited download oscommerce_snapshot-20041003.zip osCommerce 2.2 Milestone 2

It is in there on line 260 in classes/shopping_cart.php

if you are using a version that does not have that function

1- make sure you have all the other functions refered to in the install and

2- install it.

 

 

here is the file with fixes if you have 1.3+

http://www.ehostingsource.com/phpmom/Advan..._Prices_1.4.htm

here is the file from scratch if you never installed it or have anything before 1.3

http://www.ehostingsource.com/phpmom/Advan...Prices_1.4.html

 

thanks kawagner

Edited by crashwave

q_|_|| _|9~~J >-o>-o q_|_|| )| q_|| )

Share this post


Link to post
Share on other sites

I tried to install this and there are some strange things happening.

 

The attribute prices are still showing up in the pull down menus as +/- the base price...I thought this contrib showed the final adjusted price so that customers don't have to add and substract.

 

Also, once an item is in the shopping cart, the pricing is wacky. If an item is added with a + attribute, the price seems to work...it only shows the final price, but if I add a $0 attribute, then the final price is $0 and it's also scratched out.

 

Here's my test site to demonstrate.

 

My Webpage

 

Any assistance would be greatly appreciated.

 

Thanks,

Fred


-Fred

Share this post


Link to post
Share on other sites
but if I add a $0 attribute, then the final price is $0 and it's also scratched out.

You do not pu the 0 if you do not want add or change the price to 0. just leave it blank.

 

 

The attribute prices are still showing up in the pull down menus as +/- the base price...I thought this contrib showed the final adjusted price so that customers don't have to add and substract.

Whatever you did witht he 0 value do it with the price you want to change it to.

If it works with the 0 it will work with others.

 

Modify the way you are adding the attributes.

 

I moved the files here. sorry haven't paid that host yet

here is the file with fixes if you have 1.3+

http://www.dailywholesale.com/creloaded/Ad..._Prices_1.4.htm

here is the file from scratch if you never installed it or have anything before 1.3

http://www.dailywholesale.com/creloaded/Ad...Prices_1.4.html

 

Send me an email if you still have problems

Edited by crashwave

q_|_|| _|9~~J >-o>-o q_|_|| )| q_|| )

Share this post


Link to post
Share on other sites

Crashwave can you help. It seems if my product for one is $2.00 and for a dozen it is $6.00. it shows fine inthe cart but when you go thru the checkout process it adds the $2.00 to the $6.00 price. The $2.00 price is the price I put in when I entered the item. I do not know how to fix this addition problem. Would you be able to help?


Kim

Share this post


Link to post
Share on other sites

I need to be able to use it both ways, with the + and - but with a fixed price. It seems to be adding the attributes price to the price I enter when I am setting up the item. Don't know why or where to go to fix it. I thought it was working fine - shows okay in cart but not once you enter echeckout. Anyone help please. :'(


Kim

Share this post


Link to post
Share on other sites
I need to be able to use it both ways, with the + and - but with a fixed price. It seems to be adding the attributes price to the price I enter when I am setting up the item. Don't know why or where to go to fix it. I thought it was working fine - shows okay in cart but not once you enter echeckout. Anyone help please. :'(

 

Yes that was something I over looked in 1.3.. but everything works in 1.4. Did you go through all the steps? You must do steps 8 and 9 that fixes this problem.


q_|_|| _|9~~J >-o>-o q_|_|| )| q_|| )

Share this post


Link to post
Share on other sites
Your welcome

Anytime  :D

Please someone help me!!!! I installed the 1.4 version. From what i understand you only have to steps 1 and 2. I never installed any other versions. After i did steps 1 and 2 nothing changed. I left my prefix box blank and when i went to test it i added an item to my cart and it was subtracting the number instead. Please tel me what i am doing wrong. I really want this to work for me. I enter setps 1 and two in this file....catalog->includes->classes->shopping_cart.php. let me know if i am doing something wrong. thanks!

Nick

Share this post


Link to post
Share on other sites
Your welcome

Anytime  :D

Please someone help me!!!! I installed the 1.4 version. From what i understand you only have to steps 1 and 2. I never installed any other versions. After i did steps 1 and 2 nothing changed. I left my prefix box blank and when i went to test it i added an item to my cart and it was subtracting the number instead. Please tel me what i am doing wrong. I really want this to work for me. I enter setps 1 and two in this file....catalog->includes->classes->shopping_cart.php. let me know if i am doing something wrong. thanks!

Nick

Share this post


Link to post
Share on other sites
From what i understand you only have to steps 1 and 2. 

 

 

Hi, I'm just reading through the previous posts in this thread getting ready to do the install and what crashwave says on the 20tho f Jan is:

 

New Install Instructions?

If you never had it do it all. All the steps.


"Know that this is your God, who could not consent to send anyone else to save you, but would come himself that he might gain for himself all your love." St Alphonsus Ligouri

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×