Jump to content
RobAnderson

Article Manager v1.0

Recommended Posts

How do I remove the All Topics link in the Articles box? This places itself on the first position before the individual topics.

 

When I press RSS feed and include that in for example Google Reader I get the link "RSS article Feed" in the reader. I should want to change that to the store name. Is that possible?

Does setting the "Display Box Articles - All Topics Section" to off accomplish what you want?

Share this post


Link to post
Share on other sites

"Display Box Articles - All Topics Section" set to false turns off everything

 

"Display Box Articles - All Topics Links?" set to false turns off the topics but not the all topics link (the opposite of what I want)

Share this post


Link to post
Share on other sites

"Display Box Articles - All Topics Section" set to false turns off everything

 

"Display Box Articles - All Topics Links?" set to false turns off the topics but not the all topics link (the opposite of what I want)

Then you would need to edit the articles infobox and comment out the parts you don't want. Each section in that file is labelled so you should be able to find the part you need.

Share this post


Link to post
Share on other sites

OK, I will try to do that. I suppose you mean in the bm_articles.php file, is that correct?

 

But I suppose the way you intended it to work was that setting all topics to false should turn this off?

Share this post


Link to post
Share on other sites

OK, I will try to do that. I suppose you mean in the bm_articles.php file, is that correct?

 

But I suppose the way you intended it to work was that setting all topics to false should turn this off?

If your shop is 2.3, then that is the correct file. Setting that option to true will prevent the Topics section from displaying.

Share this post


Link to post
Share on other sites

We have found a way to globally eliminate the Banners from the articles pseudo pages, but it is a workaround—it doesn't fix the underlying problem of the Boxes/Banner Set filter failing to display the Banners only on the pages selected in the "display on pages" list.

 

The workaround is to use phpMyAdmin to open the database, open the "configuration" table, and edit the "display in pages" of configuration_key MODULE_BOXES_BANNER_SET_DISPLAY_PAGES by removing article_info.php and articles.php from the configuration_value field, leaving only index.php (with no semi-colon) in that field. Save your changes and exit.

 

I hope that in some future release of osC and Article Manager the developers will get the Boxes/Banner Set filter working properly with Article Manager.

Share this post


Link to post
Share on other sites

For anyone that wants to take away the "All topics" link in the box this is how I did it in bm_articles.php fileon line 255:

 

/********************* BUILD TOPICS ********************/

if (ARTICLE_BOX_DISPLAY_TOPICS_SECTION == 'true')

{

// $articlesArray['all_topics']['sort_order'] = ARTICLE_BOX_DISPLAY_TOPICS_SECTION_SORT_ORDER;

// $boldTags = GetBoldTags(FILENAME_ARTICLE_TOPICS);

// $articlesArray['all_topics']['string'] = '<a href="' . tep_href_link(FILENAME_ARTICLE_TOPICS, '', 'NONSSL') . '">' . $boldTags['start'] . BOX_ARTICLE_TOPICS . $boldTags['stop'] . '</a><br />';

if (ARTICLE_BOX_DISPLAY_TOPICS_LINKS == 'true')

$articlesArray['all_topics']['string'] .= $topics_string;

// $articlesArray['all_topics']['string'] .= (SEPARATE_TOPICS == 'true' ? '<hr class="separatorArticle">' : '<br />');

}

 

Just comment out the first three lines. The fourth one is to take away the separator also which is another issue.

Share this post


Link to post
Share on other sites

Has anyone created a next and previous button that is displayed at the bottom of each article post that makes it simpler to quickly browse through the different articles? If someone could share that code that would make my day!

Thanks

Share this post


Link to post
Share on other sites

When editing an article shouldn't I get a field for header tags also in the same way as when editing products? Shouldn't I get the same also when editing topics?

 

What type of fault have I done if I cannot see those fields in admin?

Share this post


Link to post
Share on other sites

When editing an article shouldn't I get a field for header tags also in the same way as when editing products? Shouldn't I get the same also when editing topics?

 

What type of fault have I done if I cannot see those fields in admin?

The title and tags for an article are handled in Header Tags Page Control. When you create an article, a page is added to Page Control to make that possible. There should be a place in Article Manager for that also though. I'll add that in a future version.

Share this post


Link to post
Share on other sites

Problem is I can't get this to work. I can find the articles in the page control so I should be able to change header tags there. However I have problems with that. The different topics I cannot find in page control so I suppose I cannot change that. It should be really good to be able to edit this in article manager instead.

 

I managed to delete article=1 in page control. I thought I could only delete the header contents but the article=1 is now missing in the list of page control. Can I get it back somehow?

Share this post


Link to post
Share on other sites

You can add the page manually by using the pseudo option (lower right on the Page Control page). Topics can also be added that way. You just have to be sure to use the correct format (an example of articles is shown). The articles and topics are not grouped in Page Control. The articles are listed with their page name, like articles_info.php, and the topics are listed with the topic page.

Share this post


Link to post
Share on other sites

Thank you for your help. Problem is I have SEO URL 5 installed also so it's difficult to see the name of the page. Is there a good way to see the old name of the topics and articles without having to switch SEO URL of and on again?

Share this post


Link to post
Share on other sites

You will need to turn that off. It only needs to be off long enough to see the format. Turning it off and on shouldn't cause a problem.

Share this post


Link to post
Share on other sites

OK. Problem is I got it to work for the first topic but not the others. Don't ask me how I did that. All the rest of the topics will have the title "Articles - default title". I'm not able to change that however if I look in page control it's correct. Is there something else that overrides the header tags?

Share this post


Link to post
Share on other sites

Be sure you have checked the root checkbox for the articles/topics in Page Control. And since you are using SEO5, you have to run it in rewrite mode.

Share this post


Link to post
Share on other sites

HI Jack,

I have been using this mod sucessfully for a while. I just added a new article that is several pages long but when viewed through my site it is truncated to the first page of the article. Is there a field I need to change to extend the viewable length?


If the only tool you have is a hammer, all your problems look like nails

Share this post


Link to post
Share on other sites

There aren't any pages code in this addon and the article description field uses text for the size so you wouldn't be reaching its limit. If you are using an html editor, maybe the code is being truncated somehow?

Share this post


Link to post
Share on other sites

Hi! I have a small problem: When selecting "Display Box Articles - All Topics Section" the different topics shows all right, but when clicking on one, it will show all articles from all topics (and not just the one topic selected). Same thing happens when clicking on the topic link in an article - all articles from all topics come on screen.

 

What to do?

 

I have not changed any code (at least I think so), and when looking raw in the database, the articles have the right topic ID. So problem is when calling on a topic?

 

By the way - great contrib! Just what I needed :)

Edited by dvdpusher

Share this post


Link to post
Share on other sites

I don't know what that might be. I just tried it on my site and only the articles in the topic I clicked on are shown. That is controlled by the code in the addon so the only thing that I can think of is that you are not using the latest version. Though I've never heard of this problem before so I don't think that would make a difference. This assumes you are using one of the 1_57 versions.

Share this post


Link to post
Share on other sites

Hi, thanks for the reply. I'm using the latest version. When hoovering over the topic-links, it looks OK (www.mysite.com/articles.php/article_title-t-1

 

But when clicking on it, it will not only list topic 1, but also all the other topics :(

Share this post


Link to post
Share on other sites

If you are using a url rewrtier, try turning it off to see if that is the problem. Otherwise, I've no other ideas.

Share this post


Link to post
Share on other sites

Ahh, yes. When turning off "Ultimate Seo Urls 5 PRO" it works like a charm. Now I just have to figure out a way to prevent that add-on from rewriting the topic urls

Share this post


Link to post
Share on other sites

I have just installed Articles Manager V 1.57_7 and I got a problem with box width.

 

I use images as box headings as per oscommerce documentation (page 31) and I added new class in includes/classes/boxes.php where I also defined box width in pixels - it used to work with all other boxes but when i switch on the article box it is wider and doesn't seem to read the width I have set for that box so all boxes become wider and my layout breaks.

 

Any ideas what i'm doing wrong?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×