Jump to content
RobAnderson

Article Manager v1.0

Recommended Posts

I'm not sure I understand what you are asking but it sounds like you want the articles broken up into separate infoboxes. If that is the case, there isn't anything in the code that will allow that. You would need to duplicate the articles infobox and then edit it to only show what you wanted.

 

Thank you for the response. Unfortunately it seems my second solution would appear to be the case then. I'll also have to filter all of Topic2 out of Topic1 and vice versa; I'm guessing at the page level since it uses the SQL query for other things in articles.php and bm_articles.php.

Share this post


Link to post
Share on other sites

Great contribution it works until know i think ok for the first language

For the second (english ) whwn i am pressing the button for this i am having this error

 

2008 - MySQL client ran out of memory

 

select topics_id from topics where parent_id = '0'

 

[TEP STOP]

 

2013 - Lost connection to MySQL server during query

 

select count(*) as total from sessions where sesskey = '3p2otrt81t1ql817qov82e6rs2'

 

[TEP STOP]

 

How can i solve this?

 

And i want something else that is very difficult for me.

How can i put an article in my index page?

Edited by apolyshow

One amateur made the Arc, 5.000 pro made the Titanic...

Share this post


Link to post
Share on other sites

Great contribution it works until know i think ok for the first language

For the second (english ) whwn i am pressing the button for this i am having this error

 

2008 - MySQL client ran out of memory

 

select topics_id from topics where parent_id = '0'

 

How can i solve this?

 

And i want something else that is very difficult for me.

How can i put an article in my index page?

You can't have a topic ID of 0. There was a fix for this posted in this thread, though I think it is in the most recent update. Or, it might be that you didn't add a topic.

 

You can't put an article on the home page, without coding it, of course. It will be an option in the next version.

Share this post


Link to post
Share on other sites

The latest version of Header Tags SEO has code in it to display social bookmarks on article pages. Ideally, you should upgrade to the latest version but if you just want to add this feature, download the latest Header Tags SEO version, extract the catalog/includes/modules/header_tags_social_bookmarks.php file and upload it to the appropriate place on your server.

Share this post


Link to post
Share on other sites

Ok i have fix the error with the id but when i am trying to change the language i am getting the database error.

Also in the admin panel when i am changing the language to english i have the fatal error with the articles.php line 52. When i am in my default language which is greek everything is ok.

I am using the latest versions of header tags and article manager in a clean osc 2.3.1. Only this contributions are installed....Any idea? I have read all the post and the 130 pages, twice, but i didn't find the solution ....

Edited by apolyshow

One amateur made the Arc, 5.000 pro made the Titanic...

Share this post


Link to post
Share on other sites

Ok i have fix the error with the id but when i am trying to change the language i am getting the database error.

What's the error?

Share this post


Link to post
Share on other sites

I didn't had post any articles and it was showing error at id. My mistake not programs but all the others are coming from this module ....


One amateur made the Arc, 5.000 pro made the Titanic...

Share this post


Link to post
Share on other sites

Ok i have not fix all the other errors but i have an idea.

I have put in my index page this code

 

<

 

div id=«preview»>

 

<div id=«center_preview» >

 

<

 

div id="topic">

<

 

h2>Topic 1</h2>

<

 

p>

Some Description about the Topic 1. Some Description about the Topic 1.

Some Description about the Topic 1. Some Description about the Topic 1.

<

 

a href=«#»>[read more] </a>

 

</p>

</

 

div> <!-- #topic -->

<

 

div id="topic">

<

 

h2>Topic 2</h2>

<

 

p>

Some Description about the Topic 2. Some Description about the Topic 2.

Some Description about the Topic 2. Some Description about the Topic 2.

<

 

a href=«#»>[read more] </a>

 

</p>

</

 

div> <!-- #topic -->

<

 

div id="topic">

<

 

h2>Topic 3</h2>

<

 

p>

Some Description about the Topic 3. Some Description about the Topic 3.

Some Description about the Topic 3. Some Description about the Topic 3.

<

 

a href=«#»>[read more] </a>

 

</p>

</

 

div> <!-- #topic -->

 

</div><!-- #center_preview -->

</

 

div> <!-- #preview -->

 

and in stylesheet the above code

 

 

#

preview{

 

color:#EEEEEE;

 

height: 200px;

}

#

center_preview{

 

height:200px;

 

width:980px;

 

margin:10px auto;

 

background: url(images/wave.png) ;

}

#

topic{

 

background-color: #778899;

 

width:275px;

 

float:left;

 

font-size: 13px;

 

margin:40px 20px 20px 20px;

 

margin-top:5px;

 

border: 0px solid #444;

 

border-radius: 10px;

 

-moz-border-radius: 10px;

 

-webkit-border-radius: 10px;

}

#

topic h2{

 

width:200px;

 

padding: 10px 0 0 50px;

}

#

topic p{

 

padding: 5px 20px 20px 20px;

 

line-height: 20px;

}

#

topic a{

 

color:#FFFFFF;

 

font-weight: bold;

}

 

With that way i am having three squares in my index page where i want to post the 3 first articles when i configure to install right the module. Do you know how we can take the code and what do we have to right in the code of index page so it will take the code from the articles?

Also how we can put a different image background for every topic above this squares?

Edited by apolyshow

One amateur made the Arc, 5.000 pro made the Titanic...

Share this post


Link to post
Share on other sites

hey, i post my little modification (hope it will help) but i forgot something important : Tanks to the original authors and to the famous Jack ! :)

Share this post


Link to post
Share on other sites

hey, i post my little modification (hope it will help) but i forgot something important : Tanks to the original authors and to the famous Jack ! :)

Thanks for posting your code. Others have asked for this so it may help them.

Share this post


Link to post
Share on other sites

I've got a problem with my site being hacked and malicious code has been inserted somewhere which is affecting Article Manager. The specific issue that comes up is that clicking on any topic gets flagged as an error (by security software I have installed) due to address information being collected by a honey pot. The articles themselves are fine but I'm having trouble finding where this code has been added.

 

Do you have any idea what specific file or database could be affected which is only called when trying to display a topic page?

 

Dan Wallace

Share this post


Link to post
Share on other sites

Okay, I was able to fix the hacking issues but still have another problem.

 

Since upgrading to the latest version of Article Manager, the info box now displays all articles instead of just the most recent ones so the list takes up a lot of space. Does anyone know what code controls what articles are displayed in the info box so I can edit that?

 

Dan Wallace

Share this post


Link to post
Share on other sites

The display code is in the articles infobox. There isn't any code in place to choose which to display, short of disabling the article.

Share this post


Link to post
Share on other sites

I think it will be usefull if you have russian language pack on your osc to avoid ??????? instead of cyrilic chars in the tags. When install and tune this mod, coding of following tables in DB should be changed for utf8_general_ci by executing type_any_name.sql file with following content:

 

ALTER TABLE `headertags` CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags_cache` CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags_cache` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags_default` CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags_default` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags_keywords` CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags_keywords` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags_search` CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags_search` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags_silo` CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER TABLE `headertags_silo` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;

 

just put above code in blank plain text file and save with any name with extention *.sql than go to phpMyAdmin-your DB-import-choose this sql file and OK, tables will be recoded.

 

Otherwise cyrilic characters is displayed as ????????????? in tags.

 

PS All mentioned probed by me with 3.2.8 HeaderTags SEO mod and 2.3.1 release of Oscommerse.

 

rgrds

Edited by Андрей Соснин

Share this post


Link to post
Share on other sites

But when i install Article Manager 1.57_7 and than install box Articles in Admin a can see admin panel, but instead of www.mysite.com i see following message:

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

Share this post


Link to post
Share on other sites

But when i install Article Manager 1.57_7 and than install box Articles in Admin a can see admin panel, but instead of www.mysite.com i see following message:

That error can be caused by many things. The reason for it will sometimes show in the error log. Otherwise, you will need to ask your host.

Share this post


Link to post
Share on other sites

Has anyone modified the article.php so that it appears similar to a blog list with image and most of the text from the post instead of headings that you need to click on to show the image and article. Im trying to use the add on to create a simple integrated blog without too many clicks to get to show the information.

 

http://www.myownart.com.au/articles.php

 

Thanks!

Share this post


Link to post
Share on other sites

Has anyone modified the article.php so that it appears similar to a blog list with image and most of the text from the post instead of headings that you need to click on to show the image and article. Im trying to use the add on to create a simple integrated blog without too many clicks to get to show the information.

The articles box in the column will show all of the individual blog articles but other than that, the code in the articles file would have to be edited.

Share this post


Link to post
Share on other sites

The articles box in the column will show all of the individual blog articles but other than that, the code in the articles file would have to be edited.

 

Exactly and it is this edit to the article.php that I was hoping someone might have done or could give advise of how to start tackle.

Thanks

Elin

www.myownart.com dot au

Share this post


Link to post
Share on other sites

The display code is in the articles infobox. There isn't any code in place to choose which to display, short of disabling the article.

 

Prior to upgrading though, the info box displayed the most recent articles with a configuration setting to limit how many articles are displayed and how long to treat them as "new". I can still edit both of those settings but the info box simply displays all articles (up to the maximum setting) in alphabetical order. This prevents and new articles from displaying unless they happen to be very low alphabetically.

 

How can I get it to display only the newest articles?

 

I'm guessing that this has something to do with the fact that the previous version I had installed simply used articles and the new version has them as blogs but i'm not sure what I need to change to get the previous info box formatting with the blog articles.

Share this post


Link to post
Share on other sites

Prior to upgrading though, the info box displayed the most recent articles with a configuration setting to limit how many articles are displayed and how long to treat them as "new". I can still edit both of those settings but the info box simply displays all articles (up to the maximum setting) in alphabetical order. This prevents and new articles from displaying unless they happen to be very low alphabetically.

 

How can I get it to display only the newest articles?

 

I'm guessing that this has something to do with the fact that the previous version I had installed simply used articles and the new version has them as blogs but i'm not sure what I need to change to get the previous info box formatting with the blog articles.

I don't recall there being a limit for the number of articles to display in a box but I suppose there may have been. It's not there though. If you only want to display new articles though, you can turn off the options to display the others.

Share this post


Link to post
Share on other sites

I don't recall there being a limit for the number of articles to display in a box but I suppose there may have been. It's not there though. If you only want to display new articles though, you can turn off the options to display the others.

 

As far as I know, there's always been an option to limit the number of articles to display in the info box. If there weren't, that box would quickly grow out of control in length. The setting that controls this is "Display Box Articles - All Blog Links Limit". there is no "Display Box Articles - New Blog Links Limit" though.

 

I have tried turning off the options to display the other blogs/articles but then only the link to "New Articles" appears. There doesn't seem to be any way to have the individual links to the most recent blog articles appear as was the default before the blog feature was added.

 

Unless I'm missing something, the only article links that the info box can display is "all" and the only order those can display in is alphabetical which means either a list of hundreds of articles which would overwhelm any site visitor or just the first few articles alphabetically which means visitors will never see articles that are higher in the alphabet unless they click on the link to "New Articles" which most visitors will never do.

 

Is there something I'm overlooking or was this display change intentional when the blog feature was added?

Share this post


Link to post
Share on other sites

missing uploaded article image or authors image

 

When i edit artice in admin side , then press save . The image is missing.

 

It's also happen in authors.php

 

oscommerce 2.3.1

article manager 1.5.7_7

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×