Jump to content
RobAnderson

Article Manager v1.0

Recommended Posts

I have installed this add-on 3 times on my localhost, 3 times on 2 different domains and every time i get the same error and am unable to create any articles. There has to be something obvious that i am missing and isn't included in the steps of the installation guide..

I have tried on fresh installs of OsC 2.3.1 with manual install and the file install.

 

Do i need to make change any permissions or is there some configure file somewhere that i have missed?

I tried several times using phpmyadmin and the article_manager_update_configure.php file.

 

I was able to install the boxes eventually, but when i do my page won't show at all.. Most likely part of the same problem.

 

The error is still this:

 

 

I get this error when i'm in admin and press the article manager-->topics/articles

 

Do you have any suggestions where i should be looking?

Be sure you made the correct changes to the includes/application_top.php files (both of them). They are renamed in the contribution and can be overllooked.

Share this post


Link to post
Share on other sites

Hi

Installed both, the SEO Header Tags and the Article Manager on OsC 2.3.1 (quite modified shop) today and it works a treat, thank you Jacks_mcs

 

 

I just have a cosmetic question, i noticed after the last install which was the Article manager, my shop page has moved from the center of the screen, just wondering which file i could of messed up would make this change after the alterations i've made with article manager instuctions, just thought i would ask incase somebody else has the same problem

 

Thanks for all your hard work, its an amazing contrib

It's probably not something you did. I had one site that has this problem but I haven't had time to look into it. If you are having the same problem and don't show the authors infobox the alignement should be OK. You could also try changing the settings so the authors are not displayed in a list (I seem to recall that was a symptom when I looked at).

Share this post


Link to post
Share on other sites

Hi , thanks for the quick reply

 

Ive allready changed the settings of the articles to only show "all articles" and the "rss feed" in the Box, i set false to everything else such as author box, author name visable, Topics, blogs, email friend, replies and reviews and still have the same problem.

 

im hoping to use this to promote products and SEO keywords and would very much love this to work, is there a manual way i can force the page to align center, i did something similar on my current site thats osc 2.2 though CSS, but wouldnt know where to start the 2.3.1, ive had a scan of the forum and even tried installing theme switcher but im not reall happy with that and perfer not to mess about with the js files.

 

Here is a list of my contributes ive installed so far incase you see something that might clash, advanced attributes search, ajax attribute manager, ccgv, ckeditor, fb catalog browse, featured products, magicmagnify, mini images, mdoula front page, multiple product manager, pim slideshow, qtpro, shorter checkout, tms, tms atribute tabs, security pro, SEO header tags plus article manager now, so far i have no conflicts or errors, everything seems to work fine except this alignment issue, once again thanks for taking the time to reply : - )

Share this post


Link to post
Share on other sites

Hi , thanks for the quick reply

 

Ive allready changed the settings of the articles to only show "all articles" and the "rss feed" in the Box, i set false to everything else such as author box, author name visable, Topics, blogs, email friend, replies and reviews and still have the same problem.

Without knowing what is causing it, I can't suggest any way to fix it. It could be something simple like needing a div wrapped aroung part of the code you added. I suggest removing the code that is causing the problem and re-installing one piece at a time. It may not even have anything to do with this contribution. You should first try to isolate the page that is failing. if it fails on every page, then it is one of the column files, most likely.

Share this post


Link to post
Share on other sites

Hi,

same problem as

larryjam

 

bad url redirection.

 

In article_info.php:

 

 

<?php
   if (tep_not_null($article_info['articles_url'])) {
?>
  <tr>
    <td class="main"><?php
//    echo sprintf(TEXT_MORE_INFORMATION, "http://" . urlencode($article_info['articles_url']) );
//    echo sprintf(TEXT_MORE_INFORMATION, "http://" . htmlentities(urlencode($article_info['articles_url'])) );
//    product page example works fine   http://www.web.com/redirect.php?action=url&goto=www.sony.es+
   echo sprintf(TEXT_MORE_INFORMATION, tep_href_link(FILENAME_REDIRECT, 'action=arturl&goto=' . urlencode($article_info['articles_url']), 'NONSSL', true, false));

   ?></td>
  </tr>
<?php
 }
?>

 

The main redirect.php code:

    case 'url':
  if (isset($HTTP_GET_VARS['goto']) && tep_not_null($HTTP_GET_VARS['goto'])) {
    $check_query = tep_db_query("select products_url from " . TABLE_PRODUCTS_DESCRIPTION . " where products_url = '" . tep_db_input($HTTP_GET_VARS['goto']) . "' limit 1");
    if (tep_db_num_rows($check_query)) {
	  tep_redirect('http://' . $HTTP_GET_VARS['goto']);
    }
  }
  break;


   case 'arturl':

  if (isset($HTTP_GET_VARS['goto']) && tep_not_null($HTTP_GET_VARS['goto'])) {
    $check_query = tep_db_query("select articles_url from " . TABLE_ARTICLES_DESCRIPTION . " where articles_url = '" . tep_db_input($HTTP_GET_VARS['goto']) . "' limit 1");
    if (tep_db_num_rows($check_query)) {

// tep_redirect('http://' . $HTTP_GET_VARS['goto']);
tep_redirect($check['articles_url']);
    }
  }
  break;

 

I tried all posibilities.

Share this post


Link to post
Share on other sites

There is also a piece of code in languages/articles.php:

define('TEXT_MORE_INFORMATION', 'For more information visit <a href="http://%s" target="_blank"</a>.');

 

If the url input field is for example www.amd.com

its redirect right.

 

But if www.amd.com/processors/

error

it changes the / bars for %2 characteres.

Share this post


Link to post
Share on other sites

Hi,

same problem as

larryjam

 

bad url redirection.

I don't know what problem that person had and without some kind of description of the problem, I can't even guess at a cause.

Share this post


Link to post
Share on other sites

There is also a piece of code in languages/articles.php:

define('TEXT_MORE_INFORMATION', 'For more information visit <a href="http://%s" target="_blank"</a>.');

 

If the url input field is for example www.amd.com

its redirect right.

 

But if www.amd.com/processors/

error

it changes the / bars for %2 characteres.

That's more bad code left over from the original version that I missed. Even if it works, it won't include the session ID and that can cause problems. Thanks for pointing it out. I'll fix it iin the next version.

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Thanks for response. For the moment i resolved like this:

 

adding sql field:

articles_url_name

 

 

includes/language/*/articles_info.php

// define('TEXT_MORE_INFORMATION', 'For more information visit: <a href="http://%s" target="_blank">webpage</a>.');

define('TEXT_MORE_INFORMATION', 'More information: ');

 

 

 

 

articles_info.php

adding to articles query: ad.articles_url_name

 

then:

<?php
   if (tep_not_null($article_info['articles_url'])) {
?>
  <tr>
    <td class="main">



<?php echo sprintf(TEXT_MORE_INFORMATION); ?>    
<a href="http://<?php echo $article_info['articles_url']; ?>" target="_blank"><u><?php echo sprintf($article_info['articles_url_name']);?></u></a>

   </td>
  </tr>
<?php
 }
?>

 

 

Look if its correct. Security issues or something??

Share this post


Link to post
Share on other sites

Thanks for response. For the moment i resolved like this:

 

adding sql field:

articles_url_name

 

Look if its correct. Security issues or something??

The code may work but the problem is that you can't use a a regular html link because it can cause the loss of the session ID.

Share this post


Link to post
Share on other sites

I reviewed you said.

 

The session ID dont change

 

first time:

osCsid: 69k7439qn8podofsun3od92sp6

 

after clicking url and refreshing:

osCsid: 69k7439qn8podofsun3od92sp6

 

I dont know if for other person this could be troubling. For the moment I will remain like that until somebody gives a solution to the redirect.php issue.

 

 

In other hand I see now a new problem. In this case on breadcrumb:

I see:

HOME > NEWS > AMD > NEWS> PROCESSORS

 

And should be:

HOME > NEWS > AMD > PROCESSORS

 

why? The problematic code that gets the breadcrumb is on aplication_top.php

 



// START Articles Manager [1709]
// include the articles functions
 require(DIR_WS_FUNCTIONS . 'articles.php');

// calculate topic path
 if (isset($HTTP_GET_VARS['tPath'])) {
   $tPath = $HTTP_GET_VARS['tPath'];
 } elseif (isset($HTTP_GET_VARS['articles_id']) && !isset($HTTP_GET_VARS['authors_id'])) {
   $tPath = tep_get_article_path($HTTP_GET_VARS['articles_id']);
 } else {
   $tPath = '';
 }

 if (tep_not_null($tPath)) {
   $tPath_array = tep_parse_topic_path($tPath);
   $tPath = implode('_', $tPath_array);
   $current_topic_id = $tPath_array[(sizeof($tPath_array)-1)];
 } else {
   $current_topic_id = 0;
 }

 if (isset($_GET['articles_id'])) {
   $articlesPage = FILENAME_ARTICLE_INFO . "?articles_id=" . $_GET['articles_id'];
   $pageTags_query = tep_db_query("select page_name, page_title from " . TABLE_HEADERTAGS . " where page_name like '" . $articlesPage . "' and language_id = '" . (int)$languages_id . "' LIMIT 1");
   if (tep_db_num_rows($pageTags_query) == 1) {
  $pageTags = tep_db_fetch_array($pageTags_query);
  $breadcrumb->add('Articles', tep_href_link(FILENAME_ARTICLES));
  $breadcrumb->add($pageTags['page_title'], tep_href_link($articlesPage));
   } 
 }


// add topic names or the author name to the breadcrumb trail
 if (isset($tPath_array)) {
   for ($i=0, $n=sizeof($tPath_array); $i<$n; $i++) {
  $topics_query = tep_db_query("select topics_name from " . TABLE_TOPICS_DESCRIPTION . " where topics_id = '" . (int)$tPath_array[$i] . "' and language_id = '" . (int)$languages_id . "'");
  if (tep_db_num_rows($topics_query) > 0) {
    $topics = tep_db_fetch_array($topics_query);
               $breadcrumb->add(NAVBAR_TITLE_DEFAULT, tep_href_link(FILENAME_ARTICLES));
    $breadcrumb->add($topics['topics_name'], tep_href_link(FILENAME_ARTICLES, 'tPath=' . implode('_', array_slice($tPath_array, 0, ($i+1)))));
  } else {
    break;
  }
   }
 } elseif (isset($HTTP_GET_VARS['authors_id'])) {
   $authors_query = tep_db_query("select authors_name from " . TABLE_AUTHORS . " where authors_id = '" . (int)$HTTP_GET_VARS['authors_id'] . "'");
   if (tep_db_num_rows($authors_query)) {
  $authors = tep_db_fetch_array($authors_query);
  $breadcrumb->add('Articles by ' . $authors['authors_name'], tep_href_link(FILENAME_ARTICLES, 'authors_id=' . $HTTP_GET_VARS['authors_id']));
         $breadcrumb->add(NAVBAR_TITLE_DEFAULT, tep_href_link(FILENAME_ARTICLES));
   }
 }

// products in category for DynaMenu
//   require(DIR_WS_CLASSES . 'ProductsInCategory.php');
//   $pic = new ProductsInCategory;

// articles in topic for DynaMenu multimixer 14 12 09
  require(DIR_WS_CLASSES . 'ArticlesInTopic.php');
  $picar = new ArticlesInTopic;

Share this post


Link to post
Share on other sites

Sorry, fixed:

// add topic names or the author name to the breadcrumb trail
 if (isset($tPath_array)) {
   for ($i=0, $n=sizeof($tPath_array); $i<$n; $i++) {
  $topics_query = tep_db_query("select topics_name from " . TABLE_TOPICS_DESCRIPTION . " where topics_id = '" . (int)$tPath_array[$i] . "' and language_id = '" . (int)$languages_id . "'");
  if (tep_db_num_rows($topics_query) > 0) {
    $topics = tep_db_fetch_array($topics_query);
// $breadcrumb->add(NAVBAR_TITLE_DEFAULT, tep_href_link(FILENAME_ARTICLES));                
    $breadcrumb->add($topics['topics_name'], tep_href_link(FILENAME_ARTICLES, 'tPath=' . implode('_', array_slice($tPath_array, 0, ($i+1)))));
  } else {
    break;
  }
   }
 } elseif (isset($HTTP_GET_VARS['authors_id'])) {
   $authors_query = tep_db_query("select authors_name from " . TABLE_AUTHORS . " where authors_id = '" . (int)$HTTP_GET_VARS['authors_id'] . "'");
   if (tep_db_num_rows($authors_query)) {
  $authors = tep_db_fetch_array($authors_query);
//	 $breadcrumb->add('Articles by ' . $authors['authors_name'], tep_href_link(FILENAME_ARTICLES, 'authors_id=' . $HTTP_GET_VARS['authors_id']));
//    $breadcrumb->add(NAVBAR_TITLE_DEFAULT, tep_href_link(FILENAME_ARTICLES));
 $breadcrumb->add(NAVBAR_TITLE_DEFAULT, tep_href_link(FILENAME_ARTICLES));
  $breadcrumb->add('Articles by ' . $authors['authors_name'], tep_href_link(FILENAME_ARTICLES, 'authors_id=' . $HTTP_GET_VARS['authors_id']));
   }
 }

Share this post


Link to post
Share on other sites

sorry, that doesnt worked.

 

The problem is here:

 

$topics = tep_db_fetch_array($topics_query);
$breadcrumb->add(NAVBAR_TITLE_DEFAULT, tep_href_link(FILENAME_ARTICLES));
$breadcrumb->add($topics['topics_name'], tep_href_link(FILENAME_ARTICLES, 'tPath=' . implode('_', array_slice($tPath_array, 0, ($i+1)))));
} else {

Share this post


Link to post
Share on other sites

Please keep in mind that Article Manager was not, and is not, one of my contributions. If it had been, then I would change it as I want and there wouldn't be any confusion. But since it wasn't, I had the choice of fixing the problem with the 1.56 version and not using Header Tags SEO or creating a new version and use Header Tags SEO. Since the first option would have meant leaving the Header Tags Controller code in place and since the Header Tags Controller contribution has not been undated in over three years, it seems silly to even consider that approach. Also, since Article Manager always used the Header Tags Controller and the Header Tags Controller had been replaced with Header Tags SEO, it seemed an obvious progression. Why release something with broken code that would not be fixed, after all? Maintaining both was out of the question. Not only for the reason just mentioned but because I don't have the time to do it.I understand what you are saying about splitting it and I generally agree. But in this case there wasn't any other option.

 

The differences between my version and the origiinal are mostly coding fixes and replacing the code for an outdated and unsportted contribution with one that is supported. The previous version needed the Header Tags Controller to work properly. It was not required but by skipping it, you lost one of the SEO advantages

 

I understand what you are saying and am not upset in any way. But I'll only make future changes to my version. Otherwise I create another job I don't need. As with any contribution, if a person doesn't like the existing version, they can choose not to use it. I could upload my version under a different support thread to avoid any confusion. But, realistically, if someone were going to upgrade the 1.56 version, they would have done so already. I think it is pretty clear that is a dead version.

 

There are 10 or more contributions meant for handling titles and meta tags. All of them, last I checked, do that. Some allow dynamic keyword creation, which is a big mistake, while others allow setting them in admin. Once that is done, that's it. Header Tags SEO does that as well as providing other SEO changes, like category and maufacturers descriptions. It allows complete control over the title and tags, unlike some of the other contributions. In the next version, there will be even more differences. All aimed at the total SEO of a site, not just the title and tags. But most importantly, in relation to this contribution, it allows you to setup the title and tags for non-physical pages that contributions like this create. If you are serious about the SEO of your shop, Header Tags SEO is the only choice. If you just want a way to control your title and tags, throw a dart and pick one of the others.

 

 

Hi Jack. With ref to the reply you made to me a month ago (http://forums.oscomm...ost__p__1599532);

 

Thanks for explaining. I see things have to move on and it doesnt make sense to hang on to outdated code etc. So now I really want to install the article manager and get a move on and see how I can integrate Header Tags SEO with my existing KissMT Dynamic SEO contribution. Though there are still a few things I don't understand because I'm not familiar with how the header tag controller used to work etc.

 

The dynamic SEO contribution(s) set page title, keyword meta tag & description meta tag dynamically based on the words in the page. It is my understanding that Header Tags SEO does the same job but you set them manually, hence allowing you complete control over what keywords are targeted. Is this correct?

 

Is it possible to install Header Tags SEO and only insert the necessary code on pages I choose, e.g. on article pages, so that I can leave all other pages unchanged? i.e. Can it run side by side with other dynamic SEO contributions without affecting their operation?

 

And lastly, maybe this is a silly question, but I have installed Article Manager 1.57_7 on its own (without the Header Tags SEO), and it seems to be working fine (The page title, description and meta tags you enter for the article are all correctly placed in the header and tite of the of the page). So....what exactly does Header Tags SEO do? lol! Sorry I'm a bit oblivious here. I expected it to completely explode if Header Tags SEO is required but not installed, but it seems to be working fine! What am I missing?

 

Thanks a bunch

 

Kevin

Share this post


Link to post
Share on other sites

Finally solved:

before:

HOME > NEWS > AMD > NEWS> PROCESSORS > NEWS> AM3+

 

now:

HOME > NEWS > AMD > PROCESSORS > AM3+

 

// add topic names or the author name to the breadcrumb trail
 if (isset($tPath_array)) {
$breadcrumb->add(NAVBAR_TITLE_DEFAULT, tep_href_link(FILENAME_ARTICLES));
   for ($i=0, $n=sizeof($tPath_array); $i<$n; $i++) {
  $topics_query = tep_db_query("select topics_name from " . TABLE_TOPICS_DESCRIPTION . " where topics_id = '" . (int)$tPath_array[$i] . "' and language_id = '" . (int)$languages_id . "'");
  if (tep_db_num_rows($topics_query) > 0) {
    $topics = tep_db_fetch_array($topics_query);
$breadcrumb->add($topics['topics_name'], tep_href_link(FILENAME_ARTICLES, 'tPath=' . implode('_', array_slice($tPath_array, 0, ($i+1)))));
  } else {
    break;

Share this post


Link to post
Share on other sites

Thanks for explaining. I see things have to move on and it doesnt make sense to hang on to outdated code etc. So now I really want to install the article manager and get a move on and see how I can integrate Header Tags SEO with my existing KissMT Dynamic SEO contribution. Though there are still a few things I don't understand because I'm not familiar with how the header tag controller used to work etc.

They are different contributions that alter sme of the same code in the shop so, no, they can't be integrated to both work together. I'm sure you could get parts of each to work for different areas but I wouldn't recommend it.

 

The dynamic SEO contribution(s) set page title, keyword meta tag & description meta tag dynamically based on the words in the page. It is my understanding that Header Tags SEO does the same job but you set them manually, hence allowing you complete control over what keywords are targeted. Is this correct?

There is an option to dynamically fill in the title and tags fro the page text in Header Tags but I don't recommend using it, or any such dynamic code. The reason is that for SEO to be effective, you have to streamline the title and tags to the keywords for the page and dynamic selection can't do that. You'll always end up with some words that shouldn't be used and they will hurt the ranking of the page.

Is it possible to install Header Tags SEO and only insert the necessary code on pages I choose, e.g. on article pages, so that I can leave all other pages unchanged? i.e. Can it run side by side with other dynamic SEO contributions without affecting their operation?

Not in this case.

 

And lastly, maybe this is a silly question, but I have installed Article Manager 1.57_7 on its own (without the Header Tags SEO), and it seems to be working fine (The page title, description and meta tags you enter for the article are all correctly placed in the header and tite of the of the page). So....what exactly does Header Tags SEO do? lol! Sorry I'm a bit oblivious here. I expected it to completely explode if Header Tags SEO is required but not installed, but it seems to be working fine! What am I missing?

Try creating a specific title and meta tags for the various pages without it.

Share this post


Link to post
Share on other sites

And lastly, maybe this is a silly question, but I have installed Article Manager 1.57_7 on its own (without the Header Tags SEO), and it seems to be working fine (The page title, description and meta tags you enter for the article are all correctly placed in the header and tite of the of the page). So....what exactly does Header Tags SEO do? lol! Sorry I'm a bit oblivious here. I expected it to completely explode if Header Tags SEO is required but not installed, but it seems to be working fine! What am I missing?

Try creating a specific title and meta tags for the various pages without it.

 

 

I have, and it works (for article pages). So thats not an issue related to getting the article manager working (it sets article page titles / meta tags fine without Header Tags SEO).

 

If a.) Article Manager works without Header Tags SEO installed and b.) Doing this doesn't break my existing setup, - then surely Header Tags SEO is not 'REQUIRED'. What aspect makes it "required" ?

Edited by kevinb456

Share this post


Link to post
Share on other sites

Hi again,

I have a new issue.

On admin/articles.php

 

After completing the description and save the article, the catalog description records on plain text.(No html characters).

If I write a <br> or <ul> or <li> or <b> for example , then this codes disapeared.

 

I think the problem is here:

echo tep_draw_hidden_field('articles_description[' . $languages[$i]['id'] . ']', htmlspecialchars(stripslashes($articles_description[$languages[$i]['id']])));

 

Somebody??

 

For Kevin, you can avoid to use Header Tags and use Kiss Meta tags.

<?php include_once DIR_WS_MODULES . 'kiss_meta_tags/kiss_meta_tags.php'; ?>

 

KissMetaTags is very very easy to install. I use it for articles manager , and for the products Header Tags.

 

I remember to have similar problems like you, in special here:

		  } elseif ($action == 'update_topic') {
		tep_db_perform(TABLE_TOPICS_DESCRIPTION, $sql_data_array, 'update', "topics_id = '" . (int)$topics_id . "' and language_id = '" . (int)$languages[$i]['id'] . "'");
	  }
/***************** ADD AS PSEDUO PAGE FOR HEADER TAGS SEO ****************/
//		  $psedudoPage = sprintf(FILENAME_ARTICLES . "?tPath=%d", $topics_id);
//			require_once(DIR_WS_FUNCTIONS . 'header_tags.php');
//			require(DIR_WS_MODULES . 'articles_pseudo.php');
	}

 

I dont remember exactly what the problem was , but after saving the article it gets and empty white page on catalog and i must to manually delete the last inserts on database.

Edited by bhbilbao

Share this post


Link to post
Share on other sites

Hi again,

I have a new issue.

On admin/articles.php

 

After completing the description and save the article, the catalog description records on plain text.(No html characters).

If I write a <br> or <ul> or <li> or <b> for example , then this codes disapeared.

 

I think the problem is here:

echo tep_draw_hidden_field('articles_description[' . $languages[$i]['id'] . ']', htmlspecialchars(stripslashes($articles_description[$languages[$i]['id']])));

 

Somebody??

 

well you *could* remove the 'htmlspecialchars' and 'stripslashes' functions so that it doesn't mess around with what you type at all (e.g. just using '$articles_description[$languages[$i]['id']]' on its own as the 2nd argument to the tep_draw_hidden_field function - though you will never know how its going to appear in the final page. Its also less secure (in general), although since this is in your admin and on you are editing it this is less of an issue. If its important to you, try it, but it may mess the appearance up. HTML tags work in the main body of the article fine if I'm not mistaken so maybe reserve them for there?

 

 

 

For Kevin, you can avoid to use Header Tags and use Kiss Meta tags.

<?php include_once DIR_WS_MODULES . 'kiss_meta_tags/kiss_meta_tags.php'; ?>

 

KissMetaTags is very very easy to install. I use it for articles manager , and for the products Header Tags.

 

 

Thats what I thought. From what I can see it wont break anything to use that instead of Header Tags SEO. I'll wait until Jack proves me wrong :)

Share this post


Link to post
Share on other sites

Hi jack

 

I fixed my problem with alignment, did a google search found my problem was the same as this guy, his suggestion worked, bit concerned about the question he asked at the bottom, would it affect my site?

 

Thank you for your time and a great contrib, your a star x

 

 

I was having a problem in IE8 where the entire store would align left (not center) if the article infobox was enabled (either left or right column). I removed the css which seems to be a workaround....

In catalog/includes/modules/boxes/bm-articles.php, remove:

?>
  <style type="text/css">
  .separatorArticle {
  height: 1px;
  color: #FF0000;
  }
  .separatorBlogArticle {
  height: 1px;
  color: #FF0000;
  }
  .separatorNewArticle {
  height: 1px;
  color: #FF0000;
  }
  .separatorTopic {
  height: 1px;
  color: #FF0000;
  }
  </style>
  <?php

 

I didn't notice any change in the appearance of the infobox...looks fine, HOWEVER I did notice that separatorArticle and separatorBlogArticle properties are called to further down the file...don't know if that will cause problems in other browsers?? perhaps add these to one of the main css pages if so?

 

Edited by clippers

Share this post


Link to post
Share on other sites

Hello,

 

I've installed the article manager on an almost clean osc v2.3.1 (with latest Header Tags SEO), and i get the same error some other users already encountered - the php memory_limit:

Fatal error: Allowed memory size of 26214400 bytes exhausted (tried to allocate 35 bytes) in...

 

So my webspace would allow 25MB memory, which seems to be enough for php scripts... anything i could do to get article manager work on my webspace?

 

thx!

Share this post


Link to post
Share on other sites

I have, and it works (for article pages). So thats not an issue related to getting the article manager working (it sets article page titles / meta tags fine without Header Tags SEO).

 

If a.) Article Manager works without Header Tags SEO installed and b.) Doing this doesn't break my existing setup, - then surely Header Tags SEO is not 'REQUIRED'. What aspect makes it "required" ?

So if you have an article that is named "My Article," you can change it the title of that page to "My Article?" And you don't get an error in admin when you add the article? I don't see how you can do that without Header Tags installed but if it works for you, that's all that matters.

Share this post


Link to post
Share on other sites

Hi jack

 

I fixed my problem with alignment, did a google search found my problem was the same as this guy, his suggestion worked, bit concerned about the question he asked at the bottom, would it affect my site?

 

Thank you for your time and a great contrib, your a star x

That could be the problem. The css really should be in an external file and is probably interferring with the css in 2.3. It is needed for the separator, if you want that, but it can be done from an external class. It won't affect how the code works though.

Share this post


Link to post
Share on other sites

Hello,

 

I've installed the article manager on an almost clean osc v2.3.1 (with latest Header Tags SEO), and i get the same error some other users already encountered - the php memory_limit:

Fatal error: Allowed memory size of 26214400 bytes exhausted (tried to allocate 35 bytes) in...

 

So my webspace would allow 25MB memory, which seems to be enough for php scripts... anything i could do to get article manager work on my webspace?

 

thx!

The latest version shouldn't have this problem so be sure you are using my latest version. If you are, you could look back through the thread since this has been addressed several times. Maybe on of those posts will help.

Share this post


Link to post
Share on other sites

So if you have an article that is named "My Article," you can change it the title of that page to "My Article?" And you don't get an error in admin when you add the article? I don't see how you can do that without Header Tags installed but if it works for you, that's all that matters.

 

Well, If I set 'HTML Page title', 'meta description' and 'meta keywords' fields when making an article, they then appear in the title, meta description and keywords parts of the HTML once I navigate to the article page.

 

The only part wrong is that there are also other things included in the title/description/keywords which I think are some default ones I set ages ago in KissMT, but I'm pretty sure I can remove them just haven't put the time in to find out where they're defined yet.

 

I don't know... perhaps I've inadvertantly installed Header Tag SEO. I don't really know what files are which, but I didn't download that contribution specifically so I assumed I didn't. But I DO have the file includes/article_header_tags.php on my server, which is what pulls the title and meta tags from the database and inserts them in the head, so I'm not too surprised that it works - the code is there after all! This does seem like a direct 'include' of 'article_header_tags.php' though, and this file, entirely on its own, sets the title and header tags. So I still don't see even if I did install Header Tags SEO how would it hook-in to it?

 

Jeez maybe I just installed a different version of the contribution to what I thought.... no idea lol. As you say though, if it works who cares. Thanks for your assistance.

 

Be happy all. Live it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×