Jump to content
RobAnderson

Article Manager v1.0

Recommended Posts

Yes, as long as it is the V 1_57 version.

 

But V2.3.1 code entirely changed right? we have to add the code manually?

Share this post


Link to post
Share on other sites

Yes, as long as it is the V 1_57 version.

 

But V2.3.1 code entirely changed right? we have to add the code manually?

 

Add the following before the last ?> in includes/column_left.php or

column_right.php (depending on what side you want the boxes):

 

// Article Manager

if (AUTHOR_BOX_DISPLAY == 'true'){

require(DIR_WS_BOXES . 'authors.php');

}

if (ARTICLE_BOX_DISPLAY == 'true'){

require(DIR_WS_BOXES . 'articles.php');

}

 

where i have to provide this code? becuase v2.3.1 dont have a column_left.php or

column_right.php files

Share this post


Link to post
Share on other sites

But V2.3.1 code entirely changed right? we have to add the code manually?

 

Add the following before the last ?> in includes/column_left.php or

column_right.php (depending on what side you want the boxes):

 

where i have to provide this code? becuase v2.3.1 dont have a column_left.php or

column_right.php files

This has been covered in this thread.

Share this post


Link to post
Share on other sites

So as it stands now, NO this does not work with 2.3 as it is currently packaged and will require searching this forum to find a fix...

 

The fix?

 

Ignore the instruction to add it to column left or right and just turn the module on from within Modules - Boxes. Then it will add it to left or right dependent on your instruction and sorting of the box.

 

But...

 

If you have down for maintenance mod installed, the notice The site is down for maintenance will wrap and cause a distorted view of the webpage, still trying to fix that. It only happens when Articles is enabled, admin ip inputted into down for mtce and admin viewing screen.

Edited by carryG

Share this post


Link to post
Share on other sites

we are getting following error the problem is in our function folder dont have clean html comments function.

where can i get this function?. This not inclued in article v1 manager addons

 

Fatal error: Call to undefined function clean_html_comments() in C:\xampp\htdocs\catalog\includes\modules\article_listing.php on line 66

Share this post


Link to post
Share on other sites

we are getting following error the problem is in our function folder dont have clean html comments function.

where can i get this function?. This not inclued in article v1 manager addons

 

Fatal error: Call to undefined function clean_html_comments() in C:\xampp\htdocs\catalog\includes\modules\article_listing.php on line 66

If you installed a version other than 1_57, it is included in the contribuiton. If you are have 1_57, you have to install Header Tags SEO, which contains it.

Share this post


Link to post
Share on other sites

Some of the articles or the new articles i add on my site are getting out of the center box. Can anyone help.

Below is the link of one of the articles having problem.

You are using a template so you have to nodify the code to work with it.

Share this post


Link to post
Share on other sites

You are using a template so you have to nodify the code to work with it.

 

 

How can i do that? Can you please guide me?

Share this post


Link to post
Share on other sites

How can i do that? Can you please guide me?

No, it is not something that can generaly be handled in these forums since the code varies with the template. You can try posting in the general forum and may find someone willing to talk you through it.

Share this post


Link to post
Share on other sites

This has been covered in this thread.

 

Have article manager updated to 1.57.6 (2.2) installed but right column keeps ending under left column on article_info.php

Does anybody have solution?

 

thanks in advance

Geert

Share this post


Link to post
Share on other sites

I have problem after editing article:

 

Fatal error: Using $this when not in object context in /home/xxxxxx/public_html/_FFAdm/includes/classes/upload.php on line 179

 

Page: http://xxxxx.xxx/_FFAdm/articles.php?tPath=11&aID=48&action=article_preview

 

Installed contribution - article manager 1.57.6 (2.2) and Header Tags SEO


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

I have problem after editing article:

 

Fatal error: Using $this when not in object context in /home/xxxxxx/public_html/_FFAdm/includes/classes/upload.php on line 179

 

Page: http://xxxxx.xxx/_FFAdm/articles.php?tPath=11&aID=48&action=article_preview

 

Installed contribution - article manager 1.57.6 (2.2) and Header Tags SEO

Since you mention editing, does that mean you can add an article with an image without any problems? Can you upload an image for a product when editing? For an author when editing?

Share this post


Link to post
Share on other sites

Other error:

 

Fatal error: Call to undefined function set_extensions() in /home/farmgdru/public_html/_FFAdm/articles.php on line 882

 

LINE 882: if (isset($HTTP_GET_VARS['read']) && ($HTTP_GET_VARS['read'] == 'only')) {

 

    $languages = tep_get_languages();
   for ($i=0, $n=sizeof($languages); $i<$n; $i++) {
[b]LINE 882:[/b]      if (isset($HTTP_GET_VARS['read']) && ($HTTP_GET_VARS['read'] == 'only')) {
       $aInfo->articles_name = tep_get_articles_name($aInfo->articles_id, $languages[$i]['id']);
       $aInfo->articles_description = tep_get_articles_description($aInfo->articles_id, $languages[$i]['id']);
       $aInfo->articles_image = tep_get_articles_image($aInfo->articles_id, $languages[$i]['id']);
       $aInfo->articles_url = tep_get_articles_url($aInfo->articles_id, $languages[$i]['id']);
       $aInfo->articles_head_desc_tag = tep_get_articles_head_desc_tag($aInfo->articles_id, $languages[$i]['id']);
     } else {
       $aInfo->articles_name = tep_db_prepare_input($articles_name[$languages[$i]['id']]);
       $aInfo->articles_description = tep_db_prepare_input($articles_description[$languages[$i]['id']]);
       $aInfo->articles_image = tep_db_prepare_input($articles_image[$languages[$i]['id']]);
       $aInfo->articles_url = tep_db_prepare_input($articles_url[$languages[$i]['id']]);
       $aInfo->articles_head_desc_tag = tep_db_prepare_input($articles_head_desc_tag[$languages[$i]['id']]);
     }
?>


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

Sorry Jack...

All that has written in previous message - wrong.

 

Full history:

 

I use Your contribution many Years. Thise very good contribution. Thank You, Jack!

 

On last time, I update oscommerce to last 2.2 version and last Your contribution + small updates and important message for faaliyet

My Articles and images uploaded much time earlier.

I can not add the new Articles.

 

After update I have this error:

 

Error #1 - Fatal error: Call to undefined function set_extensions() in /home/farmgdru/public_html/_FFAdm/articles.php on line 882

 

My File admin/articles.php here: File

 

What error can be in this file?


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites

Other error:

 

Fatal error: Call to undefined function set_extensions() in /home/farmgdru/public_html/_FFAdm/articles.php on line 882

 

LINE 882: if (isset($HTTP_GET_VARS['read']) && ($HTTP_GET_VARS['read'] == 'only')) {

 

    $languages = tep_get_languages();
   for ($i=0, $n=sizeof($languages); $i<$n; $i++) {
[b]LINE 882:[/b]      if (isset($HTTP_GET_VARS['read']) && ($HTTP_GET_VARS['read'] == 'only')) {
       $aInfo->articles_name = tep_get_articles_name($aInfo->articles_id, $languages[$i]['id']);
       $aInfo->articles_description = tep_get_articles_description($aInfo->articles_id, $languages[$i]['id']);
       $aInfo->articles_image = tep_get_articles_image($aInfo->articles_id, $languages[$i]['id']);
       $aInfo->articles_url = tep_get_articles_url($aInfo->articles_id, $languages[$i]['id']);
       $aInfo->articles_head_desc_tag = tep_get_articles_head_desc_tag($aInfo->articles_id, $languages[$i]['id']);
     } else {
       $aInfo->articles_name = tep_db_prepare_input($articles_name[$languages[$i]['id']]);
       $aInfo->articles_description = tep_db_prepare_input($articles_description[$languages[$i]['id']]);
       $aInfo->articles_image = tep_db_prepare_input($articles_image[$languages[$i]['id']]);
       $aInfo->articles_url = tep_db_prepare_input($articles_url[$languages[$i]['id']]);
       $aInfo->articles_head_desc_tag = tep_db_prepare_input($articles_head_desc_tag[$languages[$i]['id']]);
     }
?>

The set_extensions isn't part of Article Manager so that is a different problem. But the code you display is also not part of the last version of Article Manager so it seems you've made a mistake in the installation.

Share this post


Link to post
Share on other sites

I have the same problem that Geert described above in his post of 28 April.

 

"Have article manager updated to 1.57.6 (2.2) installed but right column keeps ending under left column on article_info.php

Does anybody have solution?"

 

Once you activate the articles module and leave the default sort order at 0, the articles box appears right at the top of the left hand column and the right hand column is still fine. The moment you change the sort order of the article box, the right hand column ends beneath the left hand column. This happens in IE, but works fine in Firefox.

 

Any suggestions?

Share this post


Link to post
Share on other sites

Hi Jack_mcs,

 

I installed this contrib Articles Manager V 1.57_6 under oscommerce V 2.3.1

I got this error message:

Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 71 bytes) in /home/marsys01/public_html/mywebpage/myadmin/includes/functions/articles.php on line 52

 

Server info

Can you help me? What could be the problem?

Edited by Marsy

---

Thanks and regards

Marsy from Hungary

Share this post


Link to post
Share on other sites

Hi Jack_mcs,

 

The previous contributions to these omitted. Sorry. :(

 

Header Tags SEO V 3.2.5 is installed

 

Php 5.2.16 (zend 2.2.1)

MySQL 5.0.92-community

Linux: Apache/2.2.17 Unix (mod_ssl/2.2.17

 

Can you help me? What could be the problem?


---

Thanks and regards

Marsy from Hungary

Share this post


Link to post
Share on other sites

just installed this addon, to take a look, but i am having a problem with it.

 

Fatal error: Call to undefined function clean_html_comments() in modules\article_listing.php on line 66

 

using Articles Manager V 1.57_6

Header Tags SEO V 3.2.5

osc 2.3.1

 

The clean_html_comments function is part of Header Tags SEO. If you upgraded either Article Manager or Header Tags SEO from older versions, it might be that that part of code wasn't changed since it is handled differently than in older versions. But if these are new installations, then it appears you've made a mistake in the Header Tags installation.

Share this post


Link to post
Share on other sites

Hi Jack_mcs,

 

I installed this contrib Articles Manager V 1.57_6 under oscommerce V 2.3.1

I got this error message:

Fatal error: Allowed memory size of 50331648 bytes exhausted (tried to allocate 71 bytes) in /home/marsys01/public_html/mywebpage/myadmin/includes/functions/articles.php on line 52

 

Server info

Can you help me? What could be the problem?

There was a problem in earlier versions that caused this but, as far as I know, it has been fixed. As I recall, it had to do with the topics. You may want to read back through the thread to see what others posted about it. Maybe there is a fix there.

Share this post


Link to post
Share on other sites

There was a problem in earlier versions that caused this but, as far as I know, it has been fixed. As I recall, it had to do with the topics. You may want to read back through the thread to see what others posted about it. Maybe there is a fix there.

 

Hi Everybody!

 

eXcaliburN was right for the #1844's contribution. :)

"Looking at the whole function, the error looks like it might be because it doesnt have any topics to read from the database?"

 

The solution:

Table_topics and table_topics_description in the database create a new topic and then it will work.

I work this way. ;)


---

Thanks and regards

Marsy from Hungary

Share this post


Link to post
Share on other sites

Hi everyone!

 

I have installed osc v2.3.1 and Articles Manager V 1.57_6 with HeaderTags SEO V3.2.5. How can i put new aticles with pictures and with summary to the index.php

 

thanks for your help.

Share this post


Link to post
Share on other sites

Hi everyone!

 

I have installed osc v2.3.1 and Articles Manager V 1.57_6 with HeaderTags SEO V3.2.5. How can i put new aticles with pictures and with summary to the index.php

 

thanks for your help.

Displaying them on the index page isn't an option currently. It will be in later releases though since others have asked for it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×