Jump to content
RobAnderson

Article Manager v1.0

Recommended Posts

Hi,

I have problem with remove products from cross-sell,

I get error message:

 

Cross-Sell Articles to Products

 

 

1064 - Something is wrong in your syntax near ')' in line 1

DELETE FROM articles_xsell WHERE articles_id = '1' and )

 

Any suggestion?

thanks

 

 

Hi,

 

I read from the previouse posts in this forum and the solution is that do not uncheck the product you want to remove from the cross selling option. Just click Add/Remove and then select your category>>product from the drop down and click Save. It will remove the product and work fine.

 

Try this :)

Share this post


Link to post
Share on other sites

Notice re: version 1.57

 

I recommend nobody uses version 1.57 of this contribution as it uses bad filenames.

 

osCommerce standard coding practise names files this_filename but NEVER this-filename.

 

Deviating from the standard osCommerce coding practise causes problems as it is simply bad coding .. also it creates problems where other contributions have been written correctly and with security in mind where incorrect filenames are rejected.

Edited by FWR Media

Share this post


Link to post
Share on other sites

Hello-

 

Where are the installation instructions please?

Instructions for what?

Share this post


Link to post
Share on other sites

Does it run on 2.3.1?

No, not yet. I've started a new version but no idea when that will be completed.

Share this post


Link to post
Share on other sites

For some reason when im in articles.php page it dosnt properly display the CSS for my header and categories. Any idea why?

You need to alter the files to match your site.

Share this post


Link to post
Share on other sites

I searched this topic from top till bottom, but i still have a problem with the contrib. Every thing is installed correctly (i quess). But when i go to admin and then to Article Manager, i get a blank page and the error 500. I can make post on the website and i can see them back in the database that there is a post made. So where could be the problem? Maybe in the filenames somewhere.

 

So could someone send me in the good direction to solve the problem. Because i like the contrib and want to use it.

 

greeting

 

Steven

Share this post


Link to post
Share on other sites

I searched this topic from top till bottom, but i still have a problem with the contrib. Every thing is installed correctly (i quess). But when i go to admin and then to Article Manager, i get a blank page and the error 500. I can make post on the website and i can see them back in the database that there is a post made. So where could be the problem? Maybe in the filenames somewhere.

 

So could someone send me in the good direction to solve the problem. Because i like the contrib and want to use it.

You need to figure out which version you are using first and post that. Veiwing previous posts may help too since this has come up before.

Share this post


Link to post
Share on other sites

You need to figure out which version you are using first and post that. Veiwing previous posts may help too since this has come up before.

 

I use the version: Articles Manager V 1.57_5a

 

I have indeed found things, but it didn't clear things out. But maybe u know in with topic to search, or even better a solution.

 

Greetings,

 

Steven

Share this post


Link to post
Share on other sites

I use the version: Articles Manager V 1.57_5a

 

I have indeed found things, but it didn't clear things out. But maybe u know in with topic to search, or even better a solution.

 

Greetings,

 

Steven

 

An update:

 

if i change in articles.php

 

$authors = tep_db_fetch_array($authors_query);
 if ($authors['total'] < 1)

 

to

 

$authors = tep_db_fetch_array($authors_query);
 if ($authors['total'] < 0)

 

it begin to work

 

Now i try to make an new topic. But then i get:

 

1054 - Unknown column 'sortorder_logo_1' in 'field list'

insert into headertags (page_name, page_title, page_description, page_keywords, page_logo, page_logo_1, page_logo_2, page_logo_3, page_logo_4, append_default_title, append_default_description, append_default_keywords, append_default_logo, append_category, append_manufacturer, append_product, append_root, sortorder_title, sortorder_description, sortorder_keywords, sortorder_logo, sortorder_logo_1, sortorder_logo_2, sortorder_logo_3, sortorder_logo_4, sortorder_category, sortorder_manufacturer, sortorder_product, sortorder_root, sortorder_root_1, sortorder_root_2, sortorder_root_3, sortorder_root_4, language_id) values ('articles.php?tPath=2', '', '', '', '', '', '', '', '', '0', '0', '0', '0', '0', '0', '0', '1', '0', '0', '0', '0', '0', '0', '0', '0', '0', '0', '0', '1', '0', '0', '0', '0', '4')

[TEP STOP]

 

So hopefully this clears things out

Share this post


Link to post
Share on other sites

1054 - Unknown column 'sortorder_logo_1' in 'field list'

 

So hopefully this clears things out

That means you don't have a working version of Header Tags installed since it is missing a database field from that contribution.

Share this post


Link to post
Share on other sites

That means you don't have a working version of Header Tags installed since it is missing a database field from that contribution.

 

Strange, since i have a working Headertags for a while.

 

The version i use is Header Tags SEO V 3.2.4

 

So i don´t think dat is missing, but maybe a have made a mistake somewhere.....but were?

 

gr,

 

Steven

Share this post


Link to post
Share on other sites

Strange, since i have a working Headertags for a while.

 

The version i use is Header Tags SEO V 3.2.4

 

So i don´t think dat is missing, but maybe a have made a mistake somewhere.....but were?

 

gr,

 

Steven

 

Ok fixt that problem. I made a mistake in de database input. But the authors is still a blank screen with error 500

Share this post


Link to post
Share on other sites

Ok fixt that problem. I made a mistake in de database input. But the authors is still a blank screen with error 500

If it's a new installation, then there was most likely a mistake made while installing it.

Share this post


Link to post
Share on other sites
it's a new installation, then there was most likely a mistake made while installing it.

 

Thanks Jack for the things you help me with. But still is it not working properly.

 

For now I use version Articles Manager V 1.57_4. Because this version is most stable. There are a lot of sloppy codes in it and I'm trying to fix it all. But the authors and review in admin is not working. I made an author in database by hand, and that works for creating Topics/Articles. So the rest almost work perfectly. So maybe a look in the kitchen can make things clear. So over here you can look at my website with article manager.

 

Gr,

 

Steven

Share this post


Link to post
Share on other sites

Not sure if this has been asked (didn't see anything about it) -

 

I was wondering if there was a way to link customers -> authors which could enable them to add content.

 

In my case I have a number of knowledgeable customers, and would like them to be able to post, but do not want to give them admin access to the site.

 

If there is another addon that would be a better fit, please recommend it.

Thanks and happy holidays!

-P

Share this post


Link to post
Share on other sites

Not sure if this has been asked (didn't see anything about it) -

 

I was wondering if there was a way to link customers -> authors which could enable them to add content.

 

In my case I have a number of knowledgeable customers, and would like them to be able to post, but do not want to give them admin access to the site.

I'm not sure what you mean by "add comment" but there is an article upload option.

Share this post


Link to post
Share on other sites

Dear All,

 

I'm working with Article Manager V 1.57 to be install on OSC 2.3.1, admin side are working well in OSC 2.3.1 after i have change source code.

The problem is i don't have any idea to change source code on boxes front side. Any suggestion???

 

I'm stuck in build catalog/includes/modules/boxes/bm_articles.php

<?php
/*
 $Id$

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2010 osCommerce

 Released under the GNU General Public License
*/

 class bm_articles {
   var $code = 'bm_articles';
   var $group = 'boxes';
   var $title;
   var $description;
   var $sort_order;
   var $enabled = false;

   function bm_articles() {
     $this->title = MODULE_BOXES_ARTICLES_TITLE;
     $this->description = MODULE_BOXES_ARTICLES_DESCRIPTION;

     if ( defined('MODULE_BOXES_ARTICLES_STATUS') ) {
       $this->sort_order = MODULE_BOXES_ARTICLES_SORT_ORDER;
       $this->enabled = (MODULE_BOXES_ARTICLES_STATUS == 'True');

       $this->group = ((MODULE_BOXES_ARTICLES_CONTENT_PLACEMENT == 'Left Column') ? 'boxes_column_left' : 'boxes_column_right');
     }
   }

   function execute() {
	global $oscTemplate;

   //THIS IS SPACE TO SHOW BOXES IN FRONTPAGE, it must be articles.php in catalog/include/boxes/ from OSC 2.2, but i'dont have any idea to change this...

     $oscTemplate->addBlock($data, $this->group);
   }

   function isEnabled() {
     return $this->enabled;
   }

   function check() {
     return defined('MODULE_BOXES_ARTICLES_STATUS');
   }

   function install() {
     tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Enable Articles Module', 'MODULE_BOXES_ARTICLES_STATUS', 'True', 'Do you want to add the module to your shop?', '6', '1', 'tep_cfg_select_option(array(\'True\', \'False\'), ', now())");
     tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Content Placement', 'MODULE_BOXES_ARTICLES_CONTENT_PLACEMENT', 'Left Column', 'Should the module be loaded in the left or right column?', '6', '1', 'tep_cfg_select_option(array(\'Left Column\', \'Right Column\'), ', now())");
     tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) values ('Sort Order', 'MODULE_BOXES_ARTICLES_SORT_ORDER', '0', 'Sort order of display. Lowest is displayed first.', '6', '0', now())");
   }

   function remove() {
     tep_db_query("delete from " . TABLE_CONFIGURATION . " where configuration_key in ('" . implode("', '", $this->keys()) . "')");
   }

   function keys() {
     return array('MODULE_BOXES_ARTICLES_STATUS', 'MODULE_BOXES_ARTICLES_CONTENT_PLACEMENT', 'MODULE_BOXES_ARTICLES_SORT_ORDER');
   }
 }
?>

Share this post


Link to post
Share on other sites

Jack

 

I have installed Articles Manager V 1.57_5 on a rc2a shop running Header Tags SEO V 3.2.5.

 

When I go to http://www.firststopsecurity.com/store/admin4sec/articles.php?selected_box=articles this error appears to the right of the search box.

 

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 71 bytes) in /home1/firstst4/public_html/store/admin4sec/includes/functions/articles.php on line 52

 

The source generated is

 

            <td align="center" colspan="3"><table border="0" width="100%" cellspacing="0" cellpadding="0">
             <tr>
               <td width="70%"></td>
               <td class="smallText" align="right">
<form name="search" action="http://www.firststopsecurity.com/store/admin4sec/articles.php" method="get">Search: <input type="text" name="search"></form>                </td>

               <td class="smallText" align="right">
<form name="goto" action="http://www.firststopsecurity.com/store/admin4sec/articles.php" method="get"><br />
<b>Fatal error</b>:  Allowed memory size of 536870912 bytes exhausted (tried to allocate 71 bytes) in <b>/home1/firstst4/public_html/store/admin4sec/includes/functions/articles.php</b> on line <b>52</b><br />

 

A dump of the query shows

 

select c.topics_id, cd.topics_name, c.parent_id from topics c, topics_description cd where c.topics_id = cd.topics_id and cd.language_id = '1' and c.parent_id = '0' order by c.sort_order, cd.topics_name

select c.topics_id, cd.topics_name, c.parent_id from topics c, topics_description cd where c.topics_id = cd.topics_id and cd.language_id = '1' and c.parent_id = '0' order by c.sort_order, cd.topics_name

select c.topics_id, cd.topics_name, c.parent_id from topics c, topics_description cd where c.topics_id = cd.topics_id and cd.language_id = '1' and c.parent_id = '0' order by c.sort_order, cd.topics_name

select c.topics_id, cd.topics_name, c.parent_id from topics c, topics_description cd where c.topics_id = cd.topics_id and cd.language_id = '1' and c.parent_id = '0' order by c.sort_order, cd.topics_name

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 15265 bytes) in /home1/firstst4/public_html/store/admin4sec/includes/functions/articles.php on line 57

 

Naturally enough, new installation, everything empty: same code in phpmyadmin gives

 

Showing rows 0 - 0 (1 total, Query took 0.3076 sec)

 

Just for the h**l of it I have raised the max memory in steps from 64MB to 512MB and still get the same message.

 

Can you recommend anything to check for?

 

Cheers

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Jack

 

I have installed Articles Manager V 1.57_5 on a rc2a shop running Header Tags SEO V 3.2.5.

 

When I go to http://www.firststopsecurity.com/store/admin4sec/articles.php?selected_box=articles this error appears to the right of the search box.

 

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 71 bytes) in /home1/firstst4/public_html/store/admin4sec/includes/functions/articles.php on line 52

There is a fix for that posted in the last few pages or so.

Share this post


Link to post
Share on other sites

The only one that suggested a possible fix was to re-inistall.

 

I don't think you did anything wrong. Someone else mentioned such a problem, as I recall. The failure is saying all of the database entries can't be loaded because the server is running out of memory, which is very unlikely with this contribution under normal conditions. It could be that the entris in your database are corrupted for some reason. You shouldn't have ran into a problem updating the database with this latest version but since you did, I suspect something went wrong. Since you did a fresh install, the database changes need to be cleared too. To do that, re-load the article_manager_V_1.57.sql file and then run the article_manager_update_configure.php file. Those two together will completely reset your database with regards to this contribution. 

 

I've done that twice.

 

If I comment out this line, the page loads

 

    echo HEADING_TITLE_GOTO . ' ' . tep_draw_pull_down_menu('tPath', tep_get_topic_tree(), $current_topic_id, 'onChange="this.form.submit();"');

 

The "topic tree" at this stage should be empty.

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×