Jump to content
RobAnderson

Article Manager v1.0

Recommended Posts

A new version has been uploaded with these changes:

 

- Added option to let the customer submit an image on the article submit page

- Added a search articles option to the articles infobox

- Changed url for web page in article_info to standard html instead of using goto code to be more compatible

- Changed RSS code so links are in SEO format if a compatible url rewriter is installed

- Fixed many of the STRICT errors

- Fixed some coding errors in articles infobox

- Replaced reference to external website in the RSS feed code with generic code

- Removed the code for CKEditors CKFinder addon since it is not part of the CKEditor package

- Updated files in the catalog directory to have the latest Header Tags SEO changes

 

With regards to submitting an image, I only added the option to upload an image to the shop side due to time constraints. You can enter the name of the image when creating a new article in admin but you will have to manually upload it for now. Or, you can create the new article using the shop side since that will upload the image.

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

 

- Added option to let the customer submit an image on the article submit page

- Added a search articles option to the articles infobox

- Changed url for web page in article_info to standard html instead of using goto code to be more compatible

- Changed RSS code so links are in SEO format if a compatible url rewriter is installed

- Fixed many of the STRICT errors

- Fixed some coding errors in articles infobox

- Replaced reference to external website in the RSS feed code with generic code

- Removed the code for CKEditors CKFinder addon since it is not part of the CKEditor package

- Updated files in the catalog directory to have the latest Header Tags SEO changes

 

With regards to submitting an image, I only added the option to upload an image to the shop side due to time constraints. You can enter the name of the image when creating a new article in admin but you will have to manually upload it for now. Or, you can create the new article using the shop side since that will upload the image.

 

 

Hi Jack,

 

Wow that was a quick update! I'm going to try this again and I noticed that in the new files directory is account_history_info.php. Is that supposed to overwrite the existing file (though it seems unrelated) or is it in there by accident?

Share this post


Link to post
Share on other sites

Hi Jack,

 

Wow that was a quick update! I'm going to try this again and I noticed that in the new files directory is account_history_info.php. Is that supposed to overwrite the existing file (though it seems unrelated) or is it in there by accident?

Thank you for mentioning that file. You are correct - it is a mistake. There is also an english.php file in that directory that shouldn't be there either. Be sure you delete those before uploading. I've uploaded another version with those files removed.

Share this post


Link to post
Share on other sites

I just found another mistake in the latest version that will prevent the articles from showing in the articles infobox. To fix it, open the includes/boxes/articles.php file and remove the last two of the three instances of

$articlesArray = array();

In other words, you will see that line of code in three places in the file. After the edit, there should only be one line near the top.

Share this post


Link to post
Share on other sites

Still not langiage friendly for stores with multiple languages?

I don't understand what you mean by that but it works fine in different languages in my test shop here.

Share this post


Link to post
Share on other sites

Hi I've installed version 1.57_5_1 and when I go to Topics/Articles I get the following error message:

 

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 71 bytes) in /admin/includes/functions/articles.php on line 52

 

Any ideas on where I've gone wrong, I did have a previous version installed, when I followed the upgrade my server had a hissy fit and deleted all of the articles etc. I had in the database. I can't back it up because the file was corrupted (loving my internet connection at the moment!) - so I decided to go for a fresh install.

 

Many Thanks

Dawn

Share this post


Link to post
Share on other sites

Hi I've installed version 1.57_5_1 and when I go to Topics/Articles I get the following error message:

 

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 71 bytes) in /admin/includes/functions/articles.php on line 52

 

Any ideas on where I've gone wrong, I did have a previous version installed, when I followed the upgrade my server had a hissy fit and deleted all of the articles etc. I had in the database. I can't back it up because the file was corrupted (loving my internet connection at the moment!) - so I decided to go for a fresh install.

 

Many Thanks

Dawn

I don't think you did anything wrong. Someone else mentioned such a problem, as I recall. The failure is saying all of the database entries can't be loaded because the server is running out of memory, which is very unlikely with this contribution under normal conditions. It could be that the entris in your database are corrupted for some reason. You shouldn't have ran into a problem updating the database with this latest version but since you did, I suspect something went wrong. Since you did a fresh install, the database changes need to be cleared too. To do that, re-load the article_manager_V_1.57.sql file and then run the article_manager_update_configure.php file. Those two together will completely reset your database with regards to this contribution.

Share this post


Link to post
Share on other sites

I don't think you did anything wrong. Someone else mentioned such a problem, as I recall. The failure is saying all of the database entries can't be loaded because the server is running out of memory, which is very unlikely with this contribution under normal conditions. It could be that the entris in your database are corrupted for some reason. You shouldn't have ran into a problem updating the database with this latest version but since you did, I suspect something went wrong. Since you did a fresh install, the database changes need to be cleared too. To do that, re-load the article_manager_V_1.57.sql file and then run the article_manager_update_configure.php file. Those two together will completely reset your database with regards to this contribution.

 

Thanks Jack, I followed your instructions but the error still exists, should I delete everything an install an earlier version?

Share this post


Link to post
Share on other sites

Thanks Jack, I followed your instructions but the error still exists, should I delete everything an install an earlier version?

It's not a problem with this version. This contribution has been installed into many shops without problems. If might be something related to your server (versions of php or mysql) or maybe your database, as mentioned, but I doubt using an earlier version will help in that case.

Share this post


Link to post
Share on other sites

Any ideas on what I can do to fix this - I'm OK at modding sites but I'm not a professional - if you can point me in the general direction that would be fantastic.

Share this post


Link to post
Share on other sites

Any ideas on what I can do to fix this - I'm OK at modding sites but I'm not a professional - if you can point me in the general direction that would be fantastic.

See the last page or two. I mention several things that can be tried.

Share this post


Link to post
Share on other sites

I did a fresh install of 1.5.6v1 and all is working well, now to repopulate the 1000 or so articles I lost (where's a d'oh smiley when you need it).

 

Thanks for your help Jack :) I appreciate it x

Share this post


Link to post
Share on other sites

I did a fresh install of 1.5.6v1 and all is working well, now to repopulate the 1000 or so articles I lost (where's a d'oh smiley when you need it).

 

Thanks for your help Jack :) I appreciate it x

You're welcome and I'm glad you got it working. I've never seen a site that has that many articles. That is probably why you were getting the error. It looks like it was a legitimate one and the script was just timing out.

Share this post


Link to post
Share on other sites

With that many articles, you need to optimize your database or it will take forever to load. Run this in your sql.

 

ALTER TABLE `articles_to_topics` DROP PRIMARY KEY;

ALTER TABLE `articles_to_topics` ADD INDEX `idx_a2t_topics_id` ( `topics_id` );

ALTER TABLE `articles_to_topics` ADD INDEX `idx_a2t_articles_id` ( `articles_id` );

Share this post


Link to post
Share on other sites

Thank you Debs, we have an awful lot of articles as we're one of the main sites on the web for pagan information - not bad for being self taught.

Share this post


Link to post
Share on other sites

Hello,

 

I have installed the latest version of this mod and would like to have a selection of articles linked directly from the top level of the articles infobox. The rest of the articles would be arranged under topics.

 

I have tried a mod to have this effect for Article Manager v1.2b by Rob Anderson, but it doesn't seem to work with the latest version and rc2.

 

I can get the effect by using the display newest articles option, but my client may want to have a few older articles there too. Does anyone know a workaround for this?

Share this post


Link to post
Share on other sites

I have installed the latest version of this mod and would like to have a selection of articles linked directly from the top level of the articles infobox. The rest of the articles would be arranged under topics.

 

Maybe I don't understand your question but articles can be added as categories are so they nest easily.

Share this post


Link to post
Share on other sites

Maybe I don't understand your question but articles can be added as categories are so they nest easily.

 

Sorry I wasn't clear.

 

I'd like the articles infobox to look something like this:

 

ARTICLES

*link directly to a specific article*

*link directly to a specific article*

*link directly to a specific article*

*link to "Other articles" category*

Share this post


Link to post
Share on other sites

Sorry I wasn't clear.

 

I'd like the articles infobox to look something like this:

 

ARTICLES

*link directly to a specific article*

*link directly to a specific article*

*link directly to a specific article*

*link to "Other articles" category*

No, there's nothing in the code that will do that.

Share this post


Link to post
Share on other sites

Hi Jack,

 

Wow that was a quick update! I'm going to try this again and I noticed that in the new files directory is account_history_info.php. Is that supposed to overwrite the existing file (though it seems unrelated) or is it in there by accident?

 

 

Hi longhorn1999,

 

Did you resolve your problem?

with latest version for me nothing changed

 

Thanks

Share this post


Link to post
Share on other sites

hi

 

i have updated the database with one article:

 

i still have commented the code for article on column_left.php (otherwise the page are blocking like i explaine on other posts)

here nothing chanced - admin/articles.php

here i can see all info - /articles.php?authors_id=1

here i have an blank page - /article_info.php?articles_id=2

link here

 

any ideea

 

Thanks

Edited by danut82

Share this post


Link to post
Share on other sites

i still have commented the code for article on column_left.php (otherwise the page are blocking like i explaine on other posts)

here nothing chanced - admin/articles.php

Does the link work if you turn off your url rewriter? Have you tried creating another article to see if it works?

Share this post


Link to post
Share on other sites

Does the link work if you turn off your url rewriter? Have you tried creating another article to see if it works?

 

i resolved "here i have an blank page - /article_info.php?articles_id=2" where was my mistake

but nothing changing with seo urls on/off

once again - why on windows server (xampp) work and on linux (site) are stopping

i activated kiss error on the above link

 

Thanks,

Share this post


Link to post
Share on other sites

i have installed xampp with php 5.3.1 and i have this errors

in admin/articles.php :

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 35 bytes) in C:\xampp\htdocs\osc\catalog1\admin\includes\functions\articles.php on line 52

if ($exclude != $topics['topics_id']) $topic_tree_array[] = array('id' => $topics['topics_id'], 'text' => $spacing . $topics['topics_name']);

 

in catalog\index.php on articles box:

Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\osc\catalog1\includes\functions\articles.php on line 80

 $articles = tep_db_fetch_array($articles_query);

 

any ideea?

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×