Jump to content
RobAnderson

Article Manager v1.0

Recommended Posts

There is a url setting in the article edit page in admin. You have to enter the url as indicated. I tried it here and it works as expected.

 

I entered the link in the Article URL box as www.yoursite.com but it still directs to the index page of my oscommerce shop. The link I am putting is a wordpress site.

Share this post


Link to post
Share on other sites

Twice now, I have installed the mod on a fresh install, and I have the same problem both times... in Admin, when I click on Topics/Articles I get a page reset. Both times were after Header Tags. And this time, I bumped the installation top top of the to-do list, so very little modification has happened. Any clues?

Share this post


Link to post
Share on other sites

Twice now, I have installed the mod on a fresh install, and I have the same problem both times... in Admin, when I click on Topics/Articles I get a page reset. Both times were after Header Tags. And this time, I bumped the installation top top of the to-do list, so very little modification has happened. Any clues?

What version are you using?

What does "I get a page reset" mean?

What does"installation top top of the to-do list" mean?

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

1. Version "Articles Manager V 1.57_3"

 

2. I click the Admin - Topics/Articles...wait a few seconds... then get a white screen with an Exclamation Point in a triangle: "The connection was reset. The connection to the server was reset while the page was loading." Blah Blah Blah

 

3. I was building a new website, and adding "Articles Manager V 1.57_3" was like the 30th Modification when the above happened. So, being forced to start over (other reasons too), I moved the installation to be in the following order: OSC, CCGV, Header Tags, Ultimate SEO, then this one. I get the same exact error.

 

Funny thing though, is that I have the same installation working fine on another website running from the same server.

Share this post


Link to post
Share on other sites

2. I click the Admin - Topics/Articles...wait a few seconds... then get a white screen with an Exclamation Point in a triangle: "The connection was reset. The connection to the server was reset while the page was loading." Blah Blah Blah

That is generally caused by the code not handling the mysql return properly or some loop in the code. Since the code works for everyone else, at least no one has reported this problem, it is probably not that, unless, maybe, you don't have something setup correctly. Unfortunately, there's no easy way to troubleshoot such a problem in a support thread like this so you're on your own. All I can suggest is to cut everything down to bare minimum. Only install Header Tags and this contribution and then, without making any changes, try to add an author, and so on. Since it is working on a different site, it might be related to the mysql or php versions, though I doubt it.

Share this post


Link to post
Share on other sites

I get this bugging message with the last version af the manager:

 

Notice: Undefined variable: topic_depth in /home/xxxx/public_html/includes/boxes/articles.php on line 167

 

Notice: Undefined variable: topic_depth in /home/xxxx/public_html/includes/boxes/articles.php on line 173

 

Notice: Undefined variable: articles_all_count in /home/xxxx/public_html/includes/boxes/articles.php on line 177

 

Any idea how to solved it ?

Share this post


Link to post
Share on other sites

Hi, after installing the script and clicking another article while reading the first one i get this message:

 

Fatal error: Cannot redeclare do_magic_quotes_gpc() (previously declared in /home/satindi/domains/something.pl/public_html/includes/functions/compatibility.php:18) in /home/satindi/domains/something.pl/public_html/includes/functions/compatibility.php on line 30

 

language files are all in tact. any suggestions?

 

(

Share this post


Link to post
Share on other sites

Fatal error: Cannot redeclare do_magic_quotes_gpc() (previously declared

It's not a problem with this contribution. If you do a search on google, the fix will be found.

Share this post


Link to post
Share on other sites

Hi Jack,

 

Just installed your full version 1.57_3 and all went pretty smoothly until I checked back at my store. When I now click on a product picture to go to the description page I get an error message:

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, webmaster@mysite.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

 

--------------------------------------------------------------------------------

 

Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4 Server at mysite.co.uk Port 80

Share this post


Link to post
Share on other sites

Just installed your full version 1.57_3 and all went pretty smoothly until I checked back at my store. When I now click on a product picture to go to the description page I get an error message:

 

Internal Server Error

That type of error is difficult to diagnose since it is a catch-all type of error. If you have an error_log file (in the directory where the error occurred), it might indicate the reason. Otherwise, you should ask your host to explain the error. If they can't, or won't, help, then you need to try to isolate the problem. Does it fail when you go to the site or just when you click on articles? If the latter, what about topics? And so on. If you have Ultimate SEO installed, that might be related to the cause. In other words, there are to many unknowns to answer a problem like this here.

Share this post


Link to post
Share on other sites

That type of error is difficult to diagnose since it is a catch-all type of error. If you have an error_log file (in the directory where the error occurred), it might indicate the reason. Otherwise, you should ask your host to explain the error. If they can't, or won't, help, then you need to try to isolate the problem. Does it fail when you go to the site or just when you click on articles? If the latter, what about topics? And so on. If you have Ultimate SEO installed, that might be related to the cause. In other words, there are to many unknowns to answer a problem like this here.

 

Hey Jack,

 

I think I determined that it was a buried eval hack that had started to eat away at my files. I have sorted it now, but I have just got to upload these files again.

Share this post


Link to post
Share on other sites

I just finished the installation but have came up to an error in admin:

 

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 24683 bytes) in mysite.co.uk/admin/includes/functions/articles.php on line 51

 

What does that mean?

 

Also when you go to an article by author there needs to be a space in the heading:

 

MiscellaneousArticles by

 

Can't find where to edit that.

Edited by Whiskers

Share this post


Link to post
Share on other sites

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 24683 bytes) in mysite.co.uk/admin/includes/functions/articles.php on line 51

 

What does that mean?

It means all of the servers memory is being used up before it completes. This is unlikely the fault of this contribution but without knowing all that was done, I can't say. If you do a new install and can enter in the first authors name, then it is probably OK. If it fails when you create the first article, then it may be something to do with what you are typing in. Just try Hello.

Share this post


Link to post
Share on other sites

It means all of the servers memory is being used up before it completes. This is unlikely the fault of this contribution but without knowing all that was done, I can't say. If you do a new install and can enter in the first authors name, then it is probably OK. If it fails when you create the first article, then it may be something to do with what you are typing in. Just try Hello.

 

I can't even create an article. That is what is said in that section when I click it.

Share this post


Link to post
Share on other sites

I can't even create an article. That is what is said in that section when I click it.

What section - articles in the left column or the articles page? If you get the error when you click on the link in the left column, then you've most likely made some mistake in the installation since that is just trying to load the links at that point. If you have articles in the database from a previous installation, it could be that there is some incompatibility problem and the code is looping.

Share this post


Link to post
Share on other sites

What section - articles in the left column or the articles page? If you get the error when you click on the link in the left column, then you've most likely made some mistake in the installation since that is just trying to load the links at that point. If you have articles in the database from a previous installation, it could be that there is some incompatibility problem and the code is looping.

 

Yep, left column. I reckon I should reinstall it. I will give that a go tomorrow. Thanks.

Share this post


Link to post
Share on other sites

Can not find any editor in my article manager admin.

 

I have really search the forum and especially this thread. But I cant find the answer I need to my problem, or I did not find an answer that I could understand :( .

 

I have installed the Article Manager v.1.57_3, and everything looks fine, except that I do not have an editor in the article manager in my admin.

I usually use the tiny_mce, it is installed on my shop, but how come it is not showing in the article manager?

 

Maybe there is a differens between tiny_mce and tiny_mce Anywhere?

Is there something else I should install or do to get it working?

Hope someone can help me out there :-)


/Christina

 

 

osCommerce 2.2

Share this post


Link to post
Share on other sites

Article Manager comes setup ready to use the FCKEditor, only because that is how it was originally setup. If you want to use another editor, you will need to make the required changes. That depends on the editor so you need to read the install instructions for the one you want to use.

Share this post


Link to post
Share on other sites

Article Manager comes setup ready to use the FCKEditor, only because that is how it was originally setup. If you want to use another editor, you will need to make the required changes. That depends on the editor so you need to read the install instructions for the one you want to use.

 

Hi Jack

Thanks for replying..

I found this on the TinyMCE website on what I need to do to use it on Article manager. But I just do not get it :blush:

 

It says:

 

TinyMCE in other places

If you have installed article manager, define mainpage, extra pages or whatever where tinyMCE is useful, you can do so:

- place in $mce_str the list of textareas where tinyMCE is to be used.

- between <head> and </head>, place this code:

 

 $mce_str = YOURCODEHERE // Comma separated list of textarea names
// You can add more textareas to convert in the $mce_str, be careful that they are all separated by a comma.
 echo '<script language="javascript" type="text/javascript" src="includes/javascript/tiny_mce/tiny_mce.js"></script>';
 include "includes/javascript/tiny_mce/general.php";

 

I dont understand what I need to change.. and where to put it.. I tried article.php in the admin, but it messed it up. How much of this code do I need to insert, and where excatly?

Hope you can help me on that one?


/Christina

 

 

osCommerce 2.2

Share this post


Link to post
Share on other sites

You need to install the TinyMCE Anywhere changes. You will still need to make the changes for the articles page but the supplied code is close to correct.

Share this post


Link to post
Share on other sites

You need to install the TinyMCE Anywhere changes. You will still need to make the changes for the articles page but the supplied code is close to correct.

 

 

I am sorry, I still do not understand this.. :'(

but thanks for trying, I apriciate that.


/Christina

 

 

osCommerce 2.2

Share this post


Link to post
Share on other sites

I am sorry, I still do not understand this.. :'(

but thanks for trying, I apriciate that.

 

 

I found the solution :-)

 

 

I downloaded the FCKeditor from the website http://www.fckeditor.net/, and installed it via my ftp in my admin on my website.

Then I used the FCK HTML Editor 2.7 (27 Jun 2008) from this thread http://addons.oscommerce.com/info/2900 and followed the small changes..

I just changed these 2 files

 

/admin/articles.php

/admin/includes/functions/html_output.php

 

And now it works for me... With the TinyMCE on my catalog editor and now this FCKeditor on my article manager :-) hope it helps someone

Edited by Blondinen

/Christina

 

 

osCommerce 2.2

Share this post


Link to post
Share on other sites

I get this bugging message with the last version af the manager:

 

Notice: Undefined variable: topic_depth in /home/xxxx/public_html/includes/boxes/articles.php on line 167

 

Notice: Undefined variable: topic_depth in /home/xxxx/public_html/includes/boxes/articles.php on line 173

 

Notice: Undefined variable: articles_all_count in /home/xxxx/public_html/includes/boxes/articles.php on line 177

 

Any idea how to solved it ?

 

I hope you didn`t forget about me :'(

Share this post


Link to post
Share on other sites

I hope you didn`t forget about me :'(

 

Hi mirabilisvoyage,

 

well, here's a code block that seems to work for me (so far):

I was getting several undefined variable errors ($topic_depth, $articles_all_count and $articles_new_count)

The part I added is bold

 

if (DISPLAY_NEW_ARTICLES=='true') {

if (SHOW_ARTICLE_COUNTS == 'true') {

//originale

// $articles_new_query = tep_db_query("select a.articles_id from " . TABLE_ARTICLES . " a, " . TABLE_ARTICLES_TO_TOPICS . " a2t left join " . TABLE_TOPICS_DESCRIPTION . " td on a2t.topics_id = td.topics_id left join " . TABLE_AUTHORS . " au on a.authors_id = au.authors_id, " . TABLE_ARTICLES_DESCRIPTION . " ad where ((a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '" . (int)$languages_id . "' and td.language_id = '" . (int)$languages_id . "' and a.articles_date_added > SUBDATE(now( ), INTERVAL '" . NEW_ARTICLES_DAYS_DISPLAY . "' DAY))");

// modifiée

$articles_new_query = tep_db_query("SELECT a.articles_id from " . TABLE_ARTICLES . " a, " . TABLE_ARTICLES_TO_TOPICS . " a2t, " . TABLE_TOPICS_DESCRIPTION . " td, " . TABLE_AUTHORS . " au, " . TABLE_ARTICLES_DESCRIPTION . " ad where a.authors_id = au.authors_id and a2t.topics_id = td.topics_id and (a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '" . (int)$languages_id . "' and td.language_id = '" . (int)$languages_id . "' and a.articles_date_added > SUBDATE(now( ), INTERVAL '" . NEW_ARTICLES_DAYS_DISPLAY . "' DAY)");

// $articles_new_count = '';

 

// 3-16-10 jk fix

if (tep_db_num_rows($articles_new_query) > 0) {

//echo 'in articles php line 166 count = ' . tep_db_num_rows($articles_new_query);

$articles_new_count = tep_db_num_rows($articles_new_query);

$articles_new_count = ' (' . $articles_new_count . ')';

} else {

$articles_new_count = '';

}

} else {

$articles_new_count = '';

}

// X 3-16-10 jk fix

 

if (strstr($_SERVER['PHP_SELF'],FILENAME_ARTICLES_NEW) or strstr($PHP_SELF,FILENAME_ARTICLES_NEW)) {

$new_articles_string = '<b>';

}

 

$new_articles_string .= '<a href="' . tep_href_link(FILENAME_ARTICLES_NEW, '', 'NONSSL') . '">' . BOX_NEW_ARTICLES . '</a>';

 

if (strstr($_SERVER['PHP_SELF'],FILENAME_ARTICLES_NEW) or strstr($PHP_SELF,FILENAME_ARTICLES_NEW)) {

$new_articles_string .= '</b>';

}

 

$new_articles_string .= $articles_new_count . '<br />';

 

}

 

if (DISPLAY_ALL_ARTICLES=='true') {

if (SHOW_ARTICLE_COUNTS == 'true') {

// $articles_all_query = tep_db_query("select a.articles_id from " . TABLE_ARTICLES . " a, " . TABLE_ARTICLES_TO_TOPICS . " a2t left join " . TABLE_TOPICS_DESCRIPTION . " td on a2t.topics_id = td.topics_id left join " . TABLE_AUTHORS . " au on a.authors_id = au.authors_id, " . TABLE_ARTICLES_DESCRIPTION . " ad where ((a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '" . (int)$languages_id . "' and td.language_id = '" . (int)$languages_id . "')");

$articles_new_query = tep_db_query("SELECT a.articles_id from " . TABLE_ARTICLES . " a, " . TABLE_ARTICLES_TO_TOPICS . " a2t, " . TABLE_TOPICS_DESCRIPTION . " td, " . TABLE_AUTHORS . " au, " . TABLE_ARTICLES_DESCRIPTION . " ad where a.authors_id = au.authors_id and a2t.topics_id = td.topics_id and (a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '" . (int)$languages_id . "' and td.language_id = '" . (int)$languages_id . "'");

 

// 3-16-10 jk fix

if (tep_db_num_rows($articles_new_query) > 0) {

//echo 'in articles php line 166 count = ' . tep_db_num_rows($articles_new_query);

$articles_all_count = tep_db_num_rows($articles_new_query);

$articles_all_count = ' (' . $articles_all_count . ')';

 

} else {

$articles_all_count = '';

}

} else {

$articles_all_count = '';

}

// x 3-16-10 jk fix

 

// 3-16-10 jk fix added - if (isset($topic_depth)) { (because receiving error - Error: Undefined variable: topic_depth) now no errors

if (isset($topic_depth)) {

if ($topic_depth == 'top') {

$all_articles_string = '<b>';

}

}

// X 3-16-10 jk fix added - if (isset($topic_depth)) { (because receiving error - Error: Undefined variable: topic_depth) now no errors

 

good luck,

jk

 

ps - i'm using something by FWR - Contribution Name: KissER Error Handling & Debugging (OSC ID: 7217) to provide a list of errors

throughout the site - you may want to check it out - he has done some great stuff

Share this post


Link to post
Share on other sites

hya - love this contrib! have 2 things i'm trying to work out if someone can help:

 

1) the article URL shows up as -a-7.html in all the links, even though the converted URL les-origines-du-cafe-a-1.html works if i type it manually (site is in French) - using Ultimate_SEO_URLSv22d. Is it a language problem do you think? the .htaccess looks good...can't figure it out.

 

2) would love to get the actual article names to appear below each topic link in the right column infobox. anybody written code for this yet (i browsed the forum but there are a LOT of pages!)

 

and just to show that i'm not all take and no give, here's the code for a cool widget i made (infobox) to allow you to randomly post an abstract from the articles on the home (or other) page :

 

<?php


$info_box_contents = array();  

$article_query = tep_db_query('SELECT articles_name, articles_description, articles_description.articles_id FROM `articles_description` INNER JOIN articles ON articles_description.articles_id = articles.articles_id AND language_id = 4 ORDER BY RAND() LIMIT 0, 1');

while ($liste = tep_db_fetch_array($article_query)) {

   $descrip_courte =  substr($liste['articles_description'], 0, 450);

   $descrip_courte_p = $descrip_courte."...<p><a style='font-size:12px' href=" . tep_href_link(FILENAME_ARTICLE_INFO, 'articles_id=' . $liste['articles_id']) . ">Lisez la suite >></a></p>";

$info_box_contents[] = array('align' => 'left',
'text' => '<h1><a href="' . tep_href_link(FILENAME_ARTICLE_INFO, 'articles_id=' . $liste['articles_id']) . '">' . $liste['articles_name'] . '</a></h1>'. $descrip_courte_p);

 }

 new contentBox($info_box_contents);
 ?>

 

-jennyb

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×