Jump to content
RobAnderson

Article Manager v1.0

Recommended Posts

First of all, this is a GREAT contribution. Easy to install without too many glitches!

 

The one question I have (for now) relates to the word "Article" in the box. I am using the contribution to provide installation guides for the products I sell and would like to change "Articles" to "How-To's" or "Installation Guides" (or whatever).

 

I tried digging around and just can't seem to find where the actual wording is stored. I'm sure I'm missing something obvious and any help is appreciated!

Share this post


Link to post
Share on other sites

Love the potential of this contrib but I can't get it to work for me. Can anyone help? I bought my graphics for my home page and looking through the code it looks like my index page doesn't use column_left or right.

 

1) I manually modified my index file to get it out there but now when I click on an article or any other link, I get the following error message

Fatal error: Cannot redeclare tep_show_category() (previously declared in /home/groupjsk/public_html/shop/includes/header.php:177) in /home/groupjsk/public_html/shop/includes/boxes/categories.php on line 13

 

2) I am assuming that the install instructions to make changes to the "...includes/languages/english/english.php add the following..."

should actually be includes/languages/english.php. I don't have a includes/languages/english directory.

 

3) Can anyone help me with positioning this articles box under my manufacturers box?

 

My site is www.groupjsk.com/shop

 

Thanks in advance for any help. As you can see, I am a novice to PHP and OSC

 

 

-J

Share this post


Link to post
Share on other sites

Hello all,

 

I was wondering if anyone has already installed Article Manager v1.0 in a multi stores shop (using contribution : Multi Stores v1.7).

 

I'm trying to do so, and need some help :)

 

The basic install of Article Manager is done, with little work.

 

Thanks,

Share this post


Link to post
Share on other sites
I had the same problem, changing the query to:

select a.articles_id from (articles a, articles_to_topics a2t) left join topics_description td on a2t.topics_id = td.topics_id left join authors au on a.authors_id = au.authors_id, articles_description ad where (a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '1' and td.language_id = '1' and a.articles_date_added > SUBDATE(now( ), INTERVAL '30' DAY)

Seems to help. Don't know why though...

 

 

Help please....

Where do I find the query I need to changes???

 

HC

Share this post


Link to post
Share on other sites

Hello,

 

I love the article manager and I've started to use it for all my new pages so that the text of the pages can be editied in the admin by the clients. It works well and I just link to the tpath for the page I need. What I'm trying to do is in index.php make this line <td class="main"><?php echo TEXT_MAIN; ?></td> actually insert text from an article tpath so the client can also edit the main text of the index page in the admin. I think I need to create a module but I'm not sure what the module needs to say - any ideas?

 

Here is the site - Supreme Pierogies

Share this post


Link to post
Share on other sites

I just installed it it gave me an error in right column:

 

Articles

1054 - Unknown column 'a.authors_id' in 'on clause'

 

select a.articles_id from articles a, articles_to_topics a2t left join topics_description td on a2t.topics_id = td.topics_id left join authors au on a.authors_id = au.authors_id, articles_description ad where (a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '1' and td.language_id = '1' and a.articles_date_added > SUBDATE(now( ), INTERVAL '30' DAY)

 

[TEP STOP]

 

I guess im just too tired and did some mistake..?

Share this post


Link to post
Share on other sites
Help please....

Where do I find the query I need to changes???

 

HC

 

Hi.. I had the same problem and changed the query as per post by teniemi - thank you!

 

I don't know anything about PHP so take this advice at your own risk!

 

The query you need to change is in catalog>articles.php

Around line 295 you will find something like:

"select a.articles_id, a.articles_date_added, ad.articles_name, ad.articles_head_desc_tag, au.authors_id, au.authors_name, td.topics_id, td.topics_name from " . TABLE_ARTICLES . " a, " . TABLE_ARTICLES_TO_TOPICS . " a2t left join " . TABLE_TOPICS_DESCRIPTION . " td on a2t.topics_id = td.topics_id left join " . TABLE_AUTHORS . " au on a.authors_id = au.authors_id, " . TABLE_ARTICLES_DESCRIPTION . " ad where (a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '" . (int)$languages_id . "' and td.language_id = '" . (int)$languages_id . "' order by a.articles_date_added desc, ad.articles_name"

 

That's the query you need to replace. Worked for me anyway! Good luck.

Share this post


Link to post
Share on other sites
I just installed it it gave me an error in right column:

I guess im just too tired and did some mistake..?

 

Could someone help me, I'd love to get this work. I re-installed and it gave me the same line inside the article-box: "1054 - Unknown column 'a.authors_id' in 'on clause' select a.articles_id from......"

Share this post


Link to post
Share on other sites

Well anyway, in my test enviroment I have MySQL 5.0.18 but in ISP it's 4.1.14 so it should work in there?

 

But this article manager is a bit old version now, becouse the SQL doesnt work in newer mysql?

Edited by aapinen

Share this post


Link to post
Share on other sites
I've tried to replace those lines but doesnt work. :(

 

Perhaps post the relevant part of your articles.php file so we can see any mistakes

Share this post


Link to post
Share on other sites

Hi Rob,

 

I have been playing around with the Article Manager 1.2 contribution, and it is absolutely WONDERFUL! Really, nice work!

 

Currently, I am experiencing some strange behavior. I would like to have articles without having any topics. I am able to add the article via the admin pages, however the article does not show up in my articles info box unless it is tied to a topic. Once the article is added to a topic, it also shows up in the "new" and "all articles" section of the info box.

 

You can see this in action by visiting http://38.99.67.80/articles.php. I have two articles configured in the database, however only the one associated to the topic "test topic" is being found. You are able to view this other article by going straight to the detail page http://38.99.67.80/article_info.php?articles_id=1.

 

Any thoughts or advice you can offer is greatly appreciated!!

 

Thanks again for such a useful contribution!

Share this post


Link to post
Share on other sites

I'm having two issues (solved one):

-When users add or edit an article and they click back and preview a few times as they tweak the article, "quotes" and back-slashes have back slashes added in front of them resulting in things like: \\\\\"Hi Mom\\\\\". What's the fix for this?

 

-On the Cross-Sell Articles (articles_xsell.php) page, nothing was happening when I clicked on Add/Remove. The problem resulted from moving to a server where Register Globals is Off. $add_related_article_ID was never getting set and so I was never seeing the product listing to choose which products to associate with my article. To fix this, I added the following line near the top of the file:

$add_related_article_ID = $_REQUEST['add_related_article_ID'];

Edited by efficiondave

Share this post


Link to post
Share on other sites
-When users add or edit an article and they click back and preview a few times as they tweak the article, "quotes" and back-slashes have back slashes added in front of them resulting in things like: \\\\\"Hi Mom\\\\\". What's the fix for this?

 

The fix for this is to add a strip slashes in two places in articles.php. for both topics_description and articles_head_desc_tag

 

Replace line 707 with (should be identical except for the added stripslashes():

- <td class="main"><?php echo tep_draw_textarea_field('articles_head_desc_tag[' . $languages[$i]['id'] . ']', 'soft', '70', '5', (isset($articles_head_desc_tag[$languages[$i]['id']]) ? stripslashes($articles_head_desc_tag[$languages[$i]['id']]) : tep_get_articles_head_desc_tag($aInfo->articles_id, $languages[$i]['id']))); ?></td>

 

Replace link 744 with (should be identical except for the added stripslashes():

<td class="main"><?php echo tep_draw_textarea_field('articles_description[' . $languages[$i]['id'] . ']', 'soft', '70', '15', (isset($articles_description[$languages[$i]['id']]) ? stripslashes($articles_description[$languages[$i]['id']]) : tep_get_articles_description($aInfo->articles_id, $languages[$i]['id']))); ?></td>

Share this post


Link to post
Share on other sites
My main topics aren't listing the sub topics is this a known problem or something I've done?

 

Here is the site Workshop Page

 

It should also list a link to another workshop that has choices under it and links to this page

 

Help would be great Thanks!!

Does anyone know the answer - I've read through the entire forum thread and tried a few things but no joy.

 

I have topic Quilting Workshops

under that I have four workshops showing up correctly

I also have a topic Applique Alternatives which is a workshop with choice not showing at all

under this topic I have four other workshop choices not showing

 

HELP PLEASE!

Share this post


Link to post
Share on other sites
Hello,

 

I love the article manager and I've started to use it for all my new pages so that the text of the pages can be editied in the admin by the clients. It works well and I just link to the tpath for the page I need. What I'm trying to do is in index.php make this line <td class="main"><?php echo TEXT_MAIN; ?></td> actually insert text from an article tpath so the client can also edit the main text of the index page in the admin. I think I need to create a module but I'm not sure what the module needs to say - any ideas?

 

Here is the site - Supreme Pierogies

Here is the answer to the above if anyone else is interested:

 

You create a topic in your article manager called "Home Page" or whatever you want it to be. Make sure to change the $tID ='5'; to whatever your topic id number is for that topic.

 

		  <tr>
		<td class="main"><?php //echo TEXT_MAIN; ?></td>
	  </tr>
	  <tr>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
	  <tr>
<?php
//here you decide which topic you want to show, you could also create a key for it
$tID = '5';

$topics_query = tep_db_query("select td.topics_description from " . TABLE_TOPICS . " t, " . TABLE_TOPICS_DESCRIPTION . " td where t.topics_id = '" . $tID . "' and t.topics_id = td.topics_id and td.language_id = '" . $languages_id . "'");
$topic = tep_db_fetch_array($topics_query);
?>

				<td class="main"><?php echo $topic['topics_description']; ?></td>

	  </tr>

 

Thanks to Monika in Germany for this :-)

Edited by dandelion

Share this post


Link to post
Share on other sites

I am having a problem with the Articles manager. The contribution is awesome and everything looks fine but for some reason no links appear on the bottom or the top to from one list of articles to the next. What I mean is for example I have 18 articles in one topic however only 10 show up and the link to go to the next page to see the next 8 articles will not appear it is that way thru out the whole thing. They are not showing up in the new articles section nor the al articles section all I can se is the first 10 articles. I can turn it to where if I list 30 articles per page and see them all this works fine however I want just then per page and then a nav link on the bottom or top or both to go to the next page of listings. This part is completely missing. I have turned it on to top and bottom in the configuration and it just will not appear. I am using STS template on this site. I would really appreciate some help if someone has a clue as to what is happening here.

 

 

Thanks for any hep anyone can give me here

 

you can contact me directly at dominik@lucky8s.net.

 

Thanks

Dominik

Share this post


Link to post
Share on other sites

Hi All,

 

I have a FRESH install of Oscommerce 2.2ms2-051113 with only CCGV installed.

 

I performed the install of Article Manager v1.2b (by Pawe? Robaczewski 25 May 04).

All the features for Article Manager work EXCEPT Cross-Sell Articles, there seems to be a problem with the /catalog/admin/articles_xsell.php. There have been various other posts referring to this exact problem, however no answer has been posted...

 

When selecting "Cross-Sell Articles" from the Article Manager on the Admin Panel, I get the following error:

 Parse error: parse error, unexpected '}' in C:\Program Files\Apache Group\Apache2\htdocs\catalog\mky\articles_xsell.php on line 258

Once I remove the bracket in question:

	}// end of foreach.

I get the following error:

Parse error: parse error, unexpected '}' in C:\Program Files\Apache Group\Apache2\htdocs\catalog\mky\articles_xsell.php on line 302

Once I remove the bracket in question:

	<?php }?>

The Cross-Sell Admin page loads, but with errors:

help.jpg

 

Anyone have any ideas?

Share this post


Link to post
Share on other sites

Dont know should I get mad or cry :angry: . but still I haven't got this thing working. However now I installed Contrib Installer mod to mycommerce and then I installed article manager again but still I get this same error(under the author box which is working):

 

1054 - Unknown column 'a.authors_id' in 'on clause'

 

select a.articles_id from articles a, articles_to_topics a2t left join topics_description td on a2t.topics_id = td.topics_id left join authors au on a.authors_id = au.authors_id, articles_description ad where (a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '1' and td.language_id = '1' and a.articles_date_added > SUBDATE(now( ), INTERVAL '30' DAY)

 

[TEP STOP]

 

 

 

This is my query, I tried to change as is said previous messages but without result.

<?php
 $articles_all_array = array();
 $articles_all_query_raw = "select a.articles_id, a.articles_date_added, ad.articles_name, ad.articles_head_desc_tag, au.authors_id, au.authors_name, td.topics_id, td.topics_name from " . TABLE_ARTICLES . " a, " . TABLE_ARTICLES_TO_TOPICS . " a2t left join " . TABLE_TOPICS_DESCRIPTION . " td on a2t.topics_id = td.topics_id left join " . TABLE_AUTHORS . " au on a.authors_id = au.authors_id, " . TABLE_ARTICLES_DESCRIPTION . " ad where (a.articles_date_available IS NULL or to_days(a.articles_date_available) <= to_days(now())) and a.articles_id = a2t.articles_id and a.articles_status = '1' and a.articles_id = ad.articles_id and ad.language_id = '" . (int)$languages_id . "' and td.language_id = '" . (int)$languages_id . "' order by a.articles_date_added desc, ad.articles_name";

 $articles_all_split = new splitPageResults($articles_all_query_raw, MAX_ARTICLES_PER_PAGE);

 

I installed Contrib installer and Article manager to pure osCommerce (I mean I havent changed anything). Any ideas, please.

Edited by aapinen

Share this post


Link to post
Share on other sites

Update to my problem:

 

I HAD apache2triad version 1.5.4

 

And I changed it to older version 1.4.4.

 

And now it works smoothly :thumbsup:

 

So I think this contribution and specially that query line has a problem with MySQL 5.0.18?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×