Jump to content
Sign in to follow this  
dontera

Products Attributes Sort v1.0

Recommended Posts

hello guys, thankx for the great contributions , i have installed it and it working fine. The problem is i haave so many products already added in my store and it will be impossbile to add the sort value for all the sizes manually.

like for eg:

red t-shirt

sizes available

s

m

L

xL

 

is there a way to add the sort order at one place and it will work for all the products

like this is how i wana sort it:

s - sort 1

m - sort 2

L - sort 3

XL - sort 4

 

 

 

any help is greatly appreciated

 

thankx

Share this post


Link to post
Share on other sites
hello guys, thankx for the great contributions , i have installed it and it working fine. The problem is i haave so many products already added in my store  and it will be impossbile to add the sort value for all the sizes manually.

like for eg:

red t-shirt

sizes available

s

m

L

xL

 

is there a way to add the sort order at one place and it will work for all the products

like this is how i wana sort it:

s - sort 1

m - sort 2

L - sort 3

XL - sort 4

any help is greatly appreciated

 

thankx

 

 

ANY ONE ?? :(

Share this post


Link to post
Share on other sites

Hello

Maybe I don't understand how to install the contribution.

I have fallowed all the instruccions, but I have been geting some troubles:

 

In my first attempt I got the fallowing error:

 

1054 - Unknown column 'attribute_sort' in 'field list'

 

select attribute_sort from products_attributes where products_attributes_id = '36'

 

[TEP STOP]

 

Ok

Maybe I should try firs in a clean store

 

I did so

 

At this try everything works well in administration module

But in the real store I have gotten the fallowing;

 

Warning: main(includes/html_title.php): failed to open stream:

No such file or directory in /home2/conocera/public_html/stores/product_info.php on line 24

 

Fatal error: main(): Failed opening required

'includes/html_title.php' (include_path='.:/home2/conocera/public_html:/usr/local/lib/php')

in /home2/conocera/public_html/stores/product_info.php on line 24

 

Looking for the file html_title.php that was mentioned in

product_info.php line 24

 

<?php require(DIR_WS_INCLUDES . 'html_title.php'); ?>

 

I could not find it. SIMPLY SUCH FILE , html_title.php, does exist in a clean store.

 

well

Can somebody help me or light me.

Share this post


Link to post
Share on other sites
Hello

Maybe I don't understand how to install the contribution.

I have fallowed all the instruccions, but I have been geting some troubles:

 

In my first attempt I got the fallowing error:

 

1054 - Unknown column 'attribute_sort' in 'field list'

 

select attribute_sort from products_attributes where products_attributes_id = '36'

 

[TEP STOP]

 

Ok

Maybe I should try firs in a clean store

 

I did so

 

At this try everything works well in administration module

But in the real store I have gotten the fallowing;

 

Warning: main(includes/html_title.php): failed to open stream:

No such file or directory in /home2/conocera/public_html/stores/product_info.php on line 24

 

Fatal error: main(): Failed opening required

'includes/html_title.php' (include_path='.:/home2/conocera/public_html:/usr/local/lib/php')

in /home2/conocera/public_html/stores/product_info.php on line 24

 

Looking for the file html_title.php that was mentioned in

product_info.php line 24

 

<?php require(DIR_WS_INCLUDES . 'html_title.php'); ?>

 

I could not find it. SIMPLY SUCH FILE , html_title.php, does exist in a clean store.

 

well

Can somebody help me or light me.

Share this post


Link to post
Share on other sites
sinryder,

 

You can probably write some custom SQL code:

 

update option_sort, 1 where option value="S"

update option_sort, 2 where option value="M"

 

or something like that.

 

ed

 

 

hey i tried it and didnt work :(

 

can any one please help me out with it.

Share this post


Link to post
Share on other sites

sinryder,

 

Do you mean you pasted what I wrote and it didn't work? Or, you wrote the CORRECT SQL syntax, based on what I wrote, and it didn't work.

 

I'm not a SQL person so I'm not surprised if you got a SQL error if you simply pasted it as-is.

 

ed


Answers to osCommerce's most persistent questions! Tips & Tricks | Configuration | Common Problems.

Seek and ye shall find Contributions.

My Contributions

My Blog

Share this post


Link to post
Share on other sites
hey same here , i am not good in this at all :( .

i hope some one else can write the correct code

 

I am not a code person at all I am a visual designer but even we have to think every now and then. (SMILE)

 

I would suggest setting up your sorting as instructed... you know?

 

s (sort 1)

m (sort 2)

L (sort 3)

XL(sort 4)

 

and in order to not do this for all the products you have? You need to download this contribution which I use.

 

http://www.oscommerce.com/community/contributions,1664/

 

hope this helps ..... THIS COPIES THE PRODUCT Attributes to other products you choose. it takes a little to install it but if you take your time and do not be impatient it should work for you...

Share this post


Link to post
Share on other sites

Ok... now I am about to install THIS contribution. Before I do can someone tell me if it is a needed thing to have the "Weight Mod installed?" My siituation will never use this feature (WEIGHT).

 

 

 

Graphicpoet

Share this post


Link to post
Share on other sites
I am not a code person at all I am a visual designer but even we have to think every now and then.  (SMILE)

 

I would suggest setting up your sorting as instructed... you know?

 

s (sort 1)

m (sort 2)

L (sort 3)

XL(sort 4)

 

and in order to not do this for all the products you have? You need to download this contribution which I use.

 

http://www.oscommerce.com/community/contributions,1664/

 

hope this helps ..... THIS COPIES THE PRODUCT Attributes to other products you choose. it takes a little to install it but if you take your time and do not be impatient it should work for you...

 

hey Marsaisa this only copies the attribute options but its not copying the sort order

the problem is i already have around 700 attributes options set and it will take for ever to add the sort number to them :(

Share this post


Link to post
Share on other sites

I am running osC 2.2 MS2

 

I have Products Attributes Sort v1.0 installed

 

Everything seems to be working on the Admin side, but in the shopping cart, all the product Attributes/Options are still being sorted alphabetically instead of by the sort order I have set in Admin.

 

To see examples of what I mean, go to:

http://www.popthetop.com/catalog/product_i...products_id=157

 

The sort order SHOULD be:

ODHW Carrying Case (+ $39.95):

ODHW Water Hose connector (+ $24.95):

ODHW Shower Attachment (+ $14.95):

 

But it is being listed and saved in your cart as:

ODHW Carrying Case (+ $39.95):

ODHW Shower Attachment (+ $14.95):

ODHW Water Hose connector (+ $24.95):

 

Anyone know how to fix this?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

I checked and everything is fine.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Heya's, im a complete novice when it comes to PHP.

 

I installed this mod and get the following on the products_attributes.php page

 

Fatal error: Call to undefined function: tep_attributes_sort() in /home/infos811/public_html/catalog/admin/products_attributes.php on line 702

 

This appears where you would normally set the Product Attributes.

 

Here is the block of code that this refers to:

 

<?php

$next_id = 1;

$attributes = tep_db_query($attributes);

while ($attributes_values = tep_db_fetch_array($attributes)) {

$products_name_only = tep_get_products_name($attributes_values['products_id']);

$options_name = tep_options_name($attributes_values['options_id']);

$values_name = tep_values_name($attributes_values['options_values_id']);

$attributes_sort = tep_attributes_sort($attributes_values['products_attributes_id']);

$rows++;

?>

 

Ive highlighted line 702

 

any ideas?

Share this post


Link to post
Share on other sites

How do I edit the files to sort in a descending order? A to Z instead of Z to A; 1 to 31 instead of 31 to 1?

 

Thank you

Share this post


Link to post
Share on other sites

I installed this-and am getting no errors-but it's not functioning as designed. The extra field shows up in product_attributes.php, but when I edit it, enter the value and select Update-it reverts back to zero.

 

I've checked and rechecked the install and everything looks the same...

 

Pretty Please...


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites

Hi,

 

I have the same problems as mentioned above. Have they ever been solved? and why is there not a good version out there for download. As this seems to be a must have contribution.

 

I have the same problem as akmac, I see a new row with 'Atrib sort' but when i change the value it resets to 0 every time

 

And when i want to add a new atribute i get this:

 

1136 - Column count doesn't match value count at row 1

 

insert into products_attributes values ('', '90', '6', '17', '0', '+')

 

[TEP STOP]

 

Help would be more then welcome. Somebody has to have this contrib running right???


Even in this dark place, yes, I am afraid of my own shadow.

 

 

 

Contributions | KnowledgeBase | osCommerce 2.2 pdf

Share this post


Link to post
Share on other sites

Hi Some how this contribution has ended up on the bottom of my new products page and not in product attributes. Even so it does work on the admin side, and does add data to the data base. But it does not work on the site. Does anyone know what file could be the problem? I already had the attributes manager contribution installed. Also a mutiple image contribution. This made the admin/catagories rather complex. Any ideas?


Cheers,

Pete.

 

(DON'T PANIC)

Share this post


Link to post
Share on other sites

Hello

 

excuse me for my english is bad because I'm french men :P

 

I want first to congratulate you for the contrib and It's work nice :thumbsup:

 

BUT Can i make you a sugestion ?

 

- why not put 2 more "sort_order" in your contribution :blush:

 

I needed to work fast :D

 

I ave try to make it but I dont known how to make it the final action...

can you help me please :-"

 

If you understand french Sugestion Amelioration for your contributionmy explication and screen view

 

thank' s for your help

:rolleyes:

Share this post


Link to post
Share on other sites

Hi, I need to sort the attributes in admin/catgeories.php to make it faster to update a product. Now it is difficult to see if an attribute even exists. I would like to sort the attributes by name. Thanks!

Share this post


Link to post
Share on other sites
Warning: implode(): Bad arguments. in /home/blessed/public_html/trial2/admin/includes/application_top.php on line 172

 

I'm getting this error. I did a clean install of the osc, simply to test the contribution out. The first time I looked at the catalog this morning, it was showing everything in order.

 

Now it isn't not in order. And I now realize that i can't click on any of my categories in admin or I get the above error. The only way I can enter new stock is by adding it as soon as you click on categories and products and then move them. I can create no categories, just can't go into them to add stock there.

 

I did nothing to application_top.php so I don't want to mess with it. Any ideas?

Share this post


Link to post
Share on other sites

I sorted the attributes by name in admin/catgeories.php but then the products got another attribute since attributes ID was on the same row as usual.

 

How can I sort the table properly, by name and with the right ID?

Updating and inserting products would be a lot easier then..

Share this post


Link to post
Share on other sites

any idea what this error means?

 

1054 - Unknown column 'attribute_sort' in 'field list'

 

select attribute_sort from products_attributes where products_attributes_id = '29'

 

[TEP STOP]

 

It prevents me from adding a new product and from doing anything with the attributes, I really want to get this to work


"I must admit that I personally measure success in terms of the contributions an individual makes to her or his fellow human beings."

---Margaret Mead---

 

"The answer is never the answer. What's really interesting is the mystery. If you seek the mystery instead of the answer, you'll always be seeking. I've never seen anybody really find the answer -- they think they have, so they stop thinking. But the job is to seek mystery, evoke mystery, plant a garden in which strange plants grow and mysteries bloom. The need for mystery is greater than the need for an answer.

--Ken Kesey"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×