Jump to content
Met00

Recover Cart Sales

Recommended Posts

Hi,

Help! No carts being found and one question.

Question : Will this contribution allow the manual transformation of an already paid-for customer basket (cart) into an order? (This is implied by several discussions on the French oscommerce forum, e.g.http://www.oscommerce-fr.info/forum/index.php?s=&showtopic=21568&view=findpost&p=114379)

However I see no mention of this functionality in the Install.html. Only description of sending emails.

Ideally in this particular case the email that should go out is the standard one that an order has been placed. (Goal is to address the known incident of the "customer did not return to store after payment" and/or "payment processor did not notify store.")

 

Hey,

 

With your question here, this contrib will definately NOT take a cart and turn it into an order, even if the customer did intend it to be an order (and may have already paid).

Unfortunately I can't read french so I can't check out that forum.

 

Maybe there is another contrib that will do that. I haven't found one, but I haven't really looked either.

 

Cheers,

Chris

Share this post


Link to post
Share on other sites
Try setting this to false, it could be finding an earlier or later order.

Thanks for the quick response. Still finds no carts.

Where and what echos should I put or other debugging tips ?

 

Here is a picture of the table customer_baskets:

customers_basket.jpg

 

and customers with baskets:

customers_with_baskets.jpg

 

Thanks in advance,

(Don't hesitate to state the obvious. I'm still a beginner here...)

i.


*** Je suis plus souvent sur le forum français ***

ms2fr, Header Tags 2.5.5b, Order logging before payment, Better PayPal Description perso, Free shipping per product, Must agree to terms, Country State Selector, World Zones, Visible countries, Store Pick Up, several shipping modules, Personal Invoice Number, 'On the Fly' Auto Thumbnailer using GD Library, More_Pics_6 for 2.2 ms2, Ultimate SEO URLs 2-2.1d/e,Virement Bancaire, Estimated Shipping 1.5, xml_guide, SP+,Step By Step 1.8, Order Editor 2.6.3, Google Analytics, Dynamic Sitemap 2.0, OSC-Expeditor, Recover Cart Sales, Links Manager 1.15

local : linux 2.6 Fedora Core 3, server : APACHE 2.0.54, MySQL 4.1.18, php : 4.4.0 (on strike refuse to update)

remote : IcoOpenBSD 4.x, server : IcodiaSecureHttpd, MySQL 4.1.24, php : 4.4.9

 

You never get a second chance to make a first impression.

Share this post


Link to post
Share on other sites

p.s. I posted on our French forum that this was useful for sending emails thus 'turning carts into orders' but did not have a function that turned a cart into an order in the database. (http://www.oscommerce-fr.info/forum/index.php?s=&showtopic=32475&view=findpost&p=167195)


*** Je suis plus souvent sur le forum français ***

ms2fr, Header Tags 2.5.5b, Order logging before payment, Better PayPal Description perso, Free shipping per product, Must agree to terms, Country State Selector, World Zones, Visible countries, Store Pick Up, several shipping modules, Personal Invoice Number, 'On the Fly' Auto Thumbnailer using GD Library, More_Pics_6 for 2.2 ms2, Ultimate SEO URLs 2-2.1d/e,Virement Bancaire, Estimated Shipping 1.5, xml_guide, SP+,Step By Step 1.8, Order Editor 2.6.3, Google Analytics, Dynamic Sitemap 2.0, OSC-Expeditor, Recover Cart Sales, Links Manager 1.15

local : linux 2.6 Fedora Core 3, server : APACHE 2.0.54, MySQL 4.1.18, php : 4.4.0 (on strike refuse to update)

remote : IcoOpenBSD 4.x, server : IcodiaSecureHttpd, MySQL 4.1.24, php : 4.4.9

 

You never get a second chance to make a first impression.

Share this post


Link to post
Share on other sites

i think im the only one with this problem so far, but when i try to send the email to tell the customer about their cart contents, they dont get the email. I have all my email settings right because i send and reveice orders through my site fine, its just when i try to send it through RCS it doesnt work.. please help! THANKS!

Share this post


Link to post
Share on other sites
i think im the only one with this problem so far, but when i try to send the email to tell the customer about their cart contents, they dont get the email. I have all my email settings right because i send and reveice orders through my site fine, its just when i try to send it through RCS it doesnt work.. please help! THANKS!

RCS uses the same code as the rest of osC, so that' part is very unlikely to be the problem. Usually it's in the configuration, as in using an incorrect email address, etc.

 

Check your logs, they will tell you why your SMTP server is rejecting the connection/user/etc.

Share this post


Link to post
Share on other sites

I recently installed the lastest version of this mod. I am excited to start using it, but I've run into a big problem. Everything seems to be working fine. I see all the abandoned carts, etc. However, when I click to send the e-mail, it shows the e-mail sent report, but it does not actually send the e-mail.

 

I am able to send e-mails through all other parts of my store, the send-mail function, newsletters, and and receive e-mails when orders are placed. However, this mod is not sending the e-mails. I created a dummy account, added stuff to the cart, abandoned the cart, and sent the e-mail ...when I check my e-mail, there is NOTHING.

 

I would love for the mod to work, but the most important part (sending the e-mail) is not working.

 

Any suggestions would be greatly appreciated.

 

John

Share this post


Link to post
Share on other sites
I recently installed the lastest version of this mod. I am excited to start using it, but I've run into a big problem. Everything seems to be working fine. I see all the abandoned carts, etc. However, when I click to send the e-mail, it shows the e-mail sent report, but it does not actually send the e-mail.

 

I am able to send e-mails through all other parts of my store, the send-mail function, newsletters, and and receive e-mails when orders are placed. However, this mod is not sending the e-mails. I created a dummy account, added stuff to the cart, abandoned the cart, and sent the e-mail ...when I check my e-mail, there is NOTHING.

 

I would love for the mod to work, but the most important part (sending the e-mail) is not working.

 

Any suggestions would be greatly appreciated.

 

John

See previous; RCS uses the same code as the rest of the system to send emails so the usual culprit is a bad email address (like an invisible char, etc).

 

The best way to find the problem is look at your logs; they will nearly always show the exact cause.

 

PS: I use the latest version of this mod on my site and it is working fine, so at least to some degree it is tested :)

Edited by lane

Share this post


Link to post
Share on other sites

As an update to my previous post:

 

The 2.22 version did not send out the e-mails. I then tried an earlier verison 1.3, and that one did send out the e-mails. So, I'm definitely sure that it is not my system but rather something with the mod itself. I will test other versions to see what results I get.

 

John.

Share this post


Link to post
Share on other sites
See previous; RCS uses the same code as the rest of the system to send emails so the usual culprit is a bad email address (like an invisible char, etc).

 

The best way to find the problem is look at your logs; they will nearly always show the exact cause.

 

PS: I use the latest version of this mod on my site and it is working fine, so at least to some degree it is tested :)

 

See previous what??? Could you please explain to me why when I use an earlier version (v1.3) the mail sends just fine and when I use the latest version (v2.22), it doesn't work. Obviously there is something wrong with the latest version of the mod. Maybe instead of telling people over and over again to look through logs, it would help to do some linear troubleshooting.

 

John

Share this post


Link to post
Share on other sites
See previous what??? Could you please explain to me why when I use an earlier version (v1.3) the mail sends just fine and when I use the latest version (v2.22), it doesn't work. Obviously there is something wrong with the latest version of the mod. Maybe instead of telling people over and over again to look through logs, it would help to do some linear troubleshooting.

 

John

<delete initial response>

 

My first response was a bit irate; I mean this is something I do for free, so I'd ask just a bit of help here. This is going to be a little bit blunt, but I'm not trying to be offensive (really!).

 

How am I supposed to know you had used 1.3 before and only had problems since installing 2.2 if you don't say so? Why am I expected do linear troubleshooting on your installation but you shouldn't be bothered to look at your logs to try and help locate the problem?

 

As I stated in my response to the post just before (ie, previous to) you question; this mod continues to work fine on my installation so how do I troubleshoot it here? Is it obvious that there is something wrong with the latest version of the mod? Maybe, but out of all the people using it only 2 have posted an issue. It's working on my server. Thus, in order to isolate the issue with the latest version of the mod I need to get some information that can only come from the people experiencing the issue... and we're back to my suggestion on looking into the logs.

 

I do this part time, which right now is very part as I am working 14-17 hours per day, 7 days a week. I'm simply asking that if you have a problem please be willing to help me help you. (Of course, if this was an issue with software for which you had paid, or had paid to get support with then things would be different, but being pro-active in solving issues is part of what open source entails, at least in my mind.)

 

I don't mind helping, but please remember that I can't read minds, don't have access to your server, and it's very unlikely that I know the history of your use of this mod, the set of mods used on your store, how you use the mod, you configuration settings, etc.

 

So, I don't mind doing some linear debugging as long as you don't mind the wait since I can get to about one question a day. My first question is, when you say "it doesn't send the email" what do you mean? (ie, does it give an error during processing? Report that everything went OK but the email doesn't arrive? Other? How did you test? (real customer? created a test account? Exact process worked under 1.3 or was there some slight variation, and if so what?)

Share this post


Link to post
Share on other sites

I think that this contribution is a great concept, but is there a way to automate it so that you wouldn't have to check everyday to see if there is an abandoned cart? Such as, after a set amount of time (say 3 days), they automatically receive the e-mail telling them about their cart.

Share this post


Link to post
Share on other sites
I think that this contribution is a great concept, but is there a way to automate it so that you wouldn't have to check everyday to see if there is an abandoned cart? Such as, after a set amount of time (say 3 days), they automatically receive the e-mail telling them about their cart.

I'm sure there is... but I'm not sure how you would do such a thing.

 

Well... maybe... I run a modified version of HelpDesk as well, and it automatically checks a pop3 server every hour. However, it's VERY non-intuitive to setup and also very prone to problems. I already regret trying to support getting special pricing with how much time in support it has brought.

 

If I can figure out a way to make it automate but involve no end user setup I will put it in, but otherwise I've dedided that I much prefer the simplicity of the original design (copy some files and be done). :)

Share this post


Link to post
Share on other sites
I'm sure there is... but I'm not sure how you would do such a thing.

 

Well... maybe... I run a modified version of HelpDesk as well, and it automatically checks a pop3 server every hour. However, it's VERY non-intuitive to setup and also very prone to problems. I already regret trying to support getting special pricing with how much time in support it has brought.

 

If I can figure out a way to make it automate but involve no end user setup I will put it in, but otherwise I've dedided that I much prefer the simplicity of the original design (copy some files and be done). :)

 

Hey,

 

Couldnt this be set up using a CRON Job and passing some options to it such as how old a cart needs to be before an email is sent?

I wouldn't bother trying to get the script to automatically do it every few days or so. CRONS are much better and easier (and less prone to breaking).

 

Cheers,

Chris :)

Share this post


Link to post
Share on other sites
Couldnt this be set up using a CRON Job and passing some options to it such as how old a cart needs to be before an email is sent?

I wouldn't bother trying to get the script to automatically do it every few days or so. CRONS are much better and easier (and less prone to breaking).

I'm not sure, but it would seem like it should be possible. Add a parm to the list, use lynx to call it? Hmm... I'll give it some thought.

Share this post


Link to post
Share on other sites

Hi there,

 

I'm currently using version 1.3.6 how do I go about updating as instructions start at version 1.6?

 

Also, does the latest version record any product options the customer might have selected, e.g. size?

 

Thanks

 

Dave

Edited by stubbsy

Share this post


Link to post
Share on other sites
Hey,

 

Couldnt this be set up using a CRON Job and passing some options to it such as how old a cart needs to be before an email is sent?

I wouldn't bother trying to get the script to automatically do it every few days or so. CRONS are much better and easier (and less prone to breaking).

 

Cheers,

Chris :)

 

Why this is a BAD idea...

 

1) a number of people create accounts to get shipping costs and totals (for those sites that don't run shipping in cart modules). So you get accounts created with e-mail addresses like xxx@xxx.com - do you really want to send them an e-mail?

2) you have loss leaders in the store, the person has 1 item in their cart and it's a loss leader. Do you really want to send them an e-mail?

3) you have a cart with a great deal in it, and you want to add a PS message to personalize the e-mail and get them back to the store

 

If I can think of at least three reasons why this shouldn't be automatted, then I'm sure there are 10 or 20 that releate to any shops personal set up beyond these three. It's not like running this every few days takes all that much time. I do it nightly (I have found that after three days the sale is a gonner even with a reminder, they bought elsewhere). It takes me 2 minutes. I have a 15% recovery rate. It's the lowest amount of time I spend for the greatest amount of sales. YMMV


The king of kluge...

? Do you really know what is and isn't working in your store? ≡ ?

Share this post


Link to post
Share on other sites

guys

 

I have read through this thread and can't sem to find the answer..

 

I have installed the contribution and it all works well..

 

however i don't seem to have any abandonded carts showing when i run the tool...

 

there are orders in the tables that are pending and I have checkedand double checked the setting with the help of this thread but still no abandoned carts are showing

 

Anyone know why this is not working

 

thanks

 

Mark


Regards

 

Mark A Reynolds

Share this post


Link to post
Share on other sites
guys

 

I have read through this thread and can't sem to find the answer..

 

I have installed the contribution and it all works well..

 

however i don't seem to have any abandonded carts showing when i run the tool...

 

there are orders in the tables that are pending and I have checkedand double checked the setting with the help of this thread but still no abandoned carts are showing

 

Anyone know why this is not working

 

thanks

 

Mark

 

ok cancel

 

it seems a day has to pass at least before things show up - it works ok for me now i have left it for 24 hrs

 

thansk for this

 

regards

 

mark


Regards

 

Mark A Reynolds

Share this post


Link to post
Share on other sites

i cant get the emails to send either. i tried toggleing all my email options but still no luck..

and this site seems to have an automated recovery thing cause i got one right after i ditched a cart

www.beachbums.com


Check out my fully customized oscommerce site by viewing my profile.

Share this post


Link to post
Share on other sites
i cant get the emails to send either. i tried toggleing all my email options but still no luck..

and this site seems to have an automated recovery thing cause i got one right after i ditched a cart

www.beachbums.com

 

 

I was having problems with my email too. For me the problem was that i installed the SQL from the notepad instead of the SQL from the install instructions. *install the SQL that is the install instructions*

Share this post


Link to post
Share on other sites

hello,

 

i installed new RCS version. but its not working or i'm dont know how to use.

 

i made test purchase with test account. after it i went into tools > recover cart sales. days interval was 30- 30 i pressed go but nothing show. This is problem with script or i'm doing something wrong ?

 

Thank you.

Share this post


Link to post
Share on other sites
hello,

 

i installed new RCS version. but its not working or i'm dont know how to use.

 

i made test purchase with test account. after it i went into tools > recover cart sales. days interval was 30- 30 i pressed go but nothing show. This is problem with script or i'm doing something wrong ?

 

Thank you.

 

Make it "0 - 30" days, if that doesnt work, try making a fake account on your site and add sumthing to the cart, then try "0 - 30" days. If that doesnt work, make sure you installed the SQL from the install instructions, not the SQL that was sitting in the folder by itself. Ifffff that doesnt work make sure you adding the code in all the right places.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×