Jump to content
Met00

Recover Cart Sales

Recommended Posts

1. Have you tried using the Unsold Cart Report contribution available at http://www.oscommerce.com/community/contributions,1598 ? If you also have problems with this contrib there should be something wrong at your site. Maybe you should try to reinstall the contribution and make sure you did follow the install instructions properly.

 

2. Do you get any errors when launching recover_cart_sales.php, e.g. parse errors? If yes, the problem liest probably in a forgotten parenthesis or hyphen in the code or something like this.

1. Have you tried using the Unsold Cart Report contribution available at http://www.oscommerce.com/community/contributions,1598 ? If you also have problems with this contrib there should be something wrong at your site. Maybe you should try to reinstall the contribution and make sure you did follow the install instructions properly.

 

2. Do you get any errors when launching recover_cart_sales.php, e.g. parse errors? If yes, the problem liest probably in a forgotten parenthesis or hyphen in the code or something like this.

1. I will try the other contribution.

 

2. No, everything looks ok, except that it doesn't work. After "executing" search nothing is found.

 

Thanks.

 

Kind regards,

Raul

I have the same problem with recover sales 1.2 displays nothing after long search

 

unsold carts worked fine for me...

 

recover sales> no errors just nothing displayed on page after search ie blank page after it goes to recover_cart_sales.php

Make sure you are using the TOOL page and not the REPORT page of RCS Tool. The Report Page will show nothing untill you have started using the Tool Page and have actually recovered some sales.

Share this post


Link to post
Share on other sites

that is what i am using it only displays on a setting of 0 days and anything large than that takes forever to run then displays blank page

Share this post


Link to post
Share on other sites
that is what i am using it only displays on a setting of 0 days and anything large than that takes forever to run then displays blank page

Then that is most likely related to the performance issue for the Attributes, that has hopifully been fixed with the version 1.3 that will be out within the next 30 minutes, me and Met00 are finializing a few last minute issues as I type.

 

You either have a slow server, or short timeouts on your SQL server, or both. The attribute code has been optimized, and the attributes can be disabled now as well.

 

When 1.3 is released please try it and see if it fixes the problem.

Share this post


Link to post
Share on other sites

Recover Cart Sales v1.3

 

You can download it from here:

 

Recover Cart Sales v1.3

 

or go to the Contribution Page.

 

CHANGES

  • Fixed error in Readme where I forgot a define.
  • Optimized attribute code to speed up script
  • Added SHOW_ATTRIBUTES configuration variable
  • Added German Language files, provided by
    Matthias F.(webmaster@bodyfeelings.de)
  • Added Spanish Language files, provided by
    Aalst(aalst@aalst.com), no promises on my
    Latin American Spanish translations.

KNOWN ISSUES

  • None at this time

FUTURE PLANS

  • Have item price reflect active attribute pricing
  • Have item price reflect active specials
  • Ability to sort by column headings
  • Fix 'possible' bugs in report file
  • Updating report to provide more information

If you are having performance issues, please try this release. The attributes being displayed is turned off by default, if you are using attributes then please go into the Configuration area of recover_cart_sales.php and set SHOW_ATTRIBUTES to TRUE.

 

As always please post any problems with 1.3 in this topic.

 

-Aalst

Share this post


Link to post
Share on other sites

FUTURE PLANS

  • Have item price reflect active attribute pricing
  • Have item price reflect active specials
  • Ability to sort by column headings
  • Fix 'possible' bugs in report file
  • Updating report to provide more information

I'm looking into the "report" tool. I want to do a rewrite of it, so expect a new version in a few days that has additional functionality.


The king of kluge...

? Do you really know what is and isn't working in your store? ≡ ?

Share this post


Link to post
Share on other sites

I've just installed v. 1.3 over the 1.01 and I don't have products names nor prices.

 

Kind regards,

Raul

Share this post


Link to post
Share on other sites
I've just installed v. 1.3 over the 1.01 and I don't have products names nor prices.

Can you provide a screen shot and/or explain in more details?

 

What version of OSC are you running, and what is your default language?

 

Are you getting the Item numbers, dates, customer names, email address', phone numbers, or quanities?

 

-Aalst

Edited by Aalst

Share this post


Link to post
Share on other sites
that is what i am using it only displays on a setting of 0 days and anything large than that takes forever to run then displays blank page

Then that is most likely related to the performance issue for the Attributes, that has hopifully been fixed with the version 1.3 that will be out within the next 30 minutes, me and Met00 are finializing a few last minute issues as I type.

 

You either have a slow server, or short timeouts on your SQL server, or both. The attribute code has been optimized, and the attributes can be disabled now as well.

 

When 1.3 is released please try it and see if it fixes the problem.

same thing with 1.3 any ideas?

 

thank you,

 

kevin

Share this post


Link to post
Share on other sites

Klugeboy (that's a me) has been at it again. If you are interested in "cart recovery" you may also be interested in making stats_customers.php a useful report. Since I think this is a part of the standard deliverable in OSC I didn't want to make it a contribution - so I made the mods a "tip" at:

http://forums.oscommerce.com/index.php?showtopic=68185

 

What does this have to do with cart recovery? If you are looking for tools that help you with sales, turning the "best customer" report into something useful seems to be something you may want to try.

 

[it also interrupted me from doing the reporting on this since I'm trying to figure out a way to make the reporting portion to determine how well you convert more usable... I'm working on it... :P ]


The king of kluge...

? Do you really know what is and isn't working in your store? ≡ ?

Share this post


Link to post
Share on other sites
same thing with 1.3 any ideas?

What version of OSC are you using? Have you used version 1.0 before of RCS Tool? If 1.2 is your first try with this tool then try 1.0 and see if you have the same problems or if it is only with 1.2 and 1.3?

 

Do you have the SHOW_ATTRIBUTES set to TRUE or FALSE? Also do you use Attributes with your products?

Share this post


Link to post
Share on other sites
same thing with 1.3 any ideas?

What version of OSC are you using? Have you used version 1.0 before of RCS Tool? If 1.2 is your first try with this tool then try 1.0 and see if you have the same problems or if it is only with 1.2 and 1.3?

 

Do you have the SHOW_ATTRIBUTES set to TRUE or FALSE? Also do you use Attributes with your products?

Hallo,

 

I also have still the same problem.

If I set $BASE_DAYS = 5 than it works... but also very slow.

I also set SHOW_ATTRIBUTES to FALSE

 

The unsold_cart version 1.7 works very fine for more than 356 days... no speedproblems

 

I'm using Osc2.2MS2

 

I have no idea ! Please help :(


Thanks Matthias

Share this post


Link to post
Share on other sites
same thing with 1.3 any ideas?

What version of OSC are you using? Have you used version 1.0 before of RCS Tool? If 1.2 is your first try with this tool then try 1.0 and see if you have the same problems or if it is only with 1.2 and 1.3?

 

Do you have the SHOW_ATTRIBUTES set to TRUE or FALSE? Also do you use Attributes with your products?

osc ms2

 

lots of attributes

attributes set to false

Share this post


Link to post
Share on other sites
osc ms2

lots of attributes

attributes set to false

What about the other questions? Have you used version 1.0 of this tool? or did you come in at version 1.2 and if so then try version 1.0 to see if the problem is in the orignal code or code that I have introduced? I need to know where to look.

 

Especially if you are having the problem with SHOW_ATTRIBUTES set to false, then it is by-passing all of the attribute code, which is the big DB code changes that can cause performance issues.

 

If you used 1.0 or 1.01 with out problems and it is new to 1.2/1.3 then I can narrow my search. If you have this problem with 1.0/1.01 then I can also narrow my search.

 

Also do you know what type of server you are running on? How much memory it has, what processors it has, are you on a dedicated server or a shared server? Is your SQL server a localhost or do you have to point to a specfic server or web address?

 

I would like to hear answers to all the questions here and the quoted message who are experience this performance issue with the report. The performance issue as I understand it is that you get a TIME OUT message at the default 10 days, and you have to keep reducing the days until it runs, and sometimes that is even 0 days being TODAY only.

 

I will start looking at my changes, then move on to the tool as a whole, until I hear from someone about this with more details to help narrow my search.

 

FYI .. I can't replicate this, and I have attributes for some of my products, but not alot. With attributes turned off in the tool I still have over 2200 products, and I have a large amount of abandoned carts.

Share this post


Link to post
Share on other sites

Are FILENAMES.PHP and DATABASE_TABLES.PHP new to MS2 and where not in MS1?

Share this post


Link to post
Share on other sites

Hallo Aalst,

 

I will try to answer all your questions:

 

I'm using Osc2.2-MS2

The problem came up with version 1.2 (1.0 was fine)

I call my database with localhost on a shared server of my provider rns24.de

 

The Servicer info reports the following:

- Linux server02 2.4.21

- Server API Apache

- Apache Version Apache/1.3.27

- PHP Version 4.3.2

- APACHE

- Max Requests Per Child: 100 - Keep Alive: on - Max Per Connection: 100

- Timeouts Connection: 300 - Keep-Alive: 15

- Server Root /usr/local/apache

 

 

I have perhaps 20 MB webspace left

 

Hmmm anything else you need ?!


Thanks Matthias

Share this post


Link to post
Share on other sites
Can you provide a screen shot and/or explain in more details?

OSC MS 2.2 , default language polish (I changed the translation from 1.01 to use new defined text).

I used the recover sales tool 1.01. After upgrading there is all info except product names and prices and total value in the cart.

When I copied the recover_cart_sales.php from earlier version everything is ok (but of corse not Base Day as it's not in language file).

 

Are you getting the Item numbers, dates, customer names, email address', phone numbers, or quanities?

Yes, all this is in place.

 

Kind regards,

Raul

Edited by raul

Share this post


Link to post
Share on other sites
I also have still the same problem.

If I set $BASE_DAYS = 5 than it works... but also very slow.

I also set SHOW_ATTRIBUTES to FALSE

 

The unsold_cart version 1.7 works very fine for more than 356 days... no speedproblems

 

I'm using Osc2.2MS2

Did you upgrade from 1.0/1.01 or did you just migrate from Unsold Cart to version 1.2/1.3 of this tool?

Share this post


Link to post
Share on other sites
Are FILENAMES.PHP and DATABASE_TABLES.PHP new to MS2 and where not in MS1?

YES B)

Thanks, I didn't know that... I will make the chagnes for MS1 and MS2 installs. Are there any other MS1 and MS2 differences that effect the installation of this tool?

Share this post


Link to post
Share on other sites
I'm using Osc2.2-MS2

The problem came up with version 1.2 (1.0 was fine)

I call my database with localhost on a shared server of my provider rns24.de

 

The Servicer info reports the following:

- Linux server02 2.4.21

- Server API Apache

- Apache Version Apache/1.3.27

- PHP Version 4.3.2

- APACHE

- Max Requests Per Child: 100 - Keep Alive: on - Max Per Connection: 100

- Timeouts Connection: 300 - Keep-Alive: 15

- Server Root /usr/local/apache

Have you tried with SHOW_ATTRIBUTES set to TRUE and FALSE with the same results?

Share this post


Link to post
Share on other sites

Having Performance Issues?

 

Try this...

 

recover_cart_sales.zip

 

This is only recover_cart_sales.php, and should be placed over your existing one in your ADMIN directory, make sure you have 1.2 or 1.3 installed before doing this.

 

Please let me know if it is BETTER, SAME, or WORSE.

 

-Aalst

Share this post


Link to post
Share on other sites

This version shows everything, with products and prices. Thank you :)

 

Kind regards,

Raul

PS.I don't see any preformance issues.

Share this post


Link to post
Share on other sites
This version shows everything, with products and prices. Thank you :)

 

Kind regards,

Raul

PS.I don't see any preformance issues.

GREAT...

 

Thats one, now if I hear from bodyfeelings in an hour or so, and he has the same results then I will release it in a full package, with updated installation insturctions for MS1 and MS2.

 

Thanks...

 

-Aalst

Share this post


Link to post
Share on other sites
Thats one, now if I hear from bodyfeelings in an hour or so, and he has the same results then I will release it in a full package, with updated installation insturctions for MS1 and MS2.

 

Aalst :)

very good job !!!!

 

It works

 

Thank you very much


Thanks Matthias

Share this post


Link to post
Share on other sites

Hmmm.....

 

now I've testet the report stats_recover_cart_sales.php

Why dose the report only shows 1 in examination.

I've sent 41 mails on the 26. of november ??

 

The scart tabel is also filled with 41 records !


Thanks Matthias

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×