Jump to content
Met00

Recover Cart Sales

Recommended Posts

I just installed the latest version, and I believe it will be a great tool to help boost my sales. If that is, I can get it working. I'm having the following error message displayed at the top of recover_cart_sales.php. Everthing else works just fine.

 

1054 - Unknown column 'customers_group_id' in 'field list'

select customers_group_id from customers where customers_id = ''

[TEP STOP]

 

Any help would be appreciated!

 

Thanks,

 

Kel Jackson

CEO / President

RCM RC Products

www.rcm-rc.com


No Great Man ever complains of want of opportunity... sieze the day.

Share this post


Link to post
Share on other sites
I just installed the latest version, and I believe it will be a great tool to help boost my sales.  If that is, I can get it working.  I'm having the following error message displayed at the top of recover_cart_sales.php.  Everthing else works just fine.

 

1054 - Unknown column 'customers_group_id' in 'field list'

select customers_group_id from customers where customers_id = ''

Hmmm... I wonder if we're not relying on / requiring a contribution? Can you tell me more about your setup? (ie, version of osC running and mods).

Share this post


Link to post
Share on other sites

I'm having some trouble with people I've already contacted showing up as "uncontacted." I read that I could fix this by flushing the "scart" table; but when I try that I get a message saying I can't do that because I need reload permission. No idea why that would be, but there it is.

 

So, is there another way to keep the contacted/uncontacted info accurate?

Share this post


Link to post
Share on other sites
Hmmm... I wonder if we're not relying on / requiring a contribution? Can you tell me more about your setup? (ie, version of osC running and mods).

 

I'm running osCommerce 2.2-MS2. I have quite a few mods, I'm sure i can't remember then all, so just to name a few:

 

Account Balance (Gift Certificate Redemption)

Wishlist

Admin Order Create

Admin Account Creat

Customer Order Comments

Unsold Carts Report

Monthly Sales Tax Report

Printable Catalog

Sort Customers asc/desc by first name, last name, or join date

Several Custom Information Pages

Custom Template Application

 

Here are some system stats:

 

Operating system Linux

Kernel version: 2.4.21-4.0.1.ELsmp

Apache version 1.3.33 (Unix)

PERL version 5.8.1

PHP version 4.3.10

MySQL version 4.0.24-standard

 

Any suggestions?

 

Thanks,

 

-Kel


No Great Man ever complains of want of opportunity... sieze the day.

Share this post


Link to post
Share on other sites
I'm running osCommerce 2.2-MS2.  I have quite a few mods, I'm sure i can't remember then all, so just to name a few:

...

Aha...figured it out:

 

You were a very baaad boy and didn't follow directions :) The problem is that you copied the tep_get_products_special_price function from my installation directions, which specifically state that you can not do that.

 

You have to copy the tep_get_products_special_price from your /catalog/includes/functions/general.php file.

 

That will solve your problem :)

 

(unless, of course, you don't have tep_get_products_special_price in your general.php file... but I haven't found an install yet that didn't have it.)

Share this post


Link to post
Share on other sites
I'm having some trouble with people I've already contacted showing up as "uncontacted."  I read that I could fix this by flushing the "scart" table; but when I try that I get a message saying I can't do that because I need reload permission.  No idea why that would be, but there it is.

 

So, is there another way to keep the contacted/uncontacted info accurate?

If you have phpMyAdmin, 'empty' the scart table. This should clear it out.

 

BTW; what version are you running? Is this an upgrade? If so what was the first version you ran?

Share this post


Link to post
Share on other sites
I have tried to install this contrib and I could not get it to work completely and do not feel too comfortable messing with  it but I need it so is anyone willing to install this correctly for me for $40?

 

I am a disabled vet and my only income comes from my site and I need this to improve my sales and profits. Those VA nebefits seems to get smaller every darn year.

 

Any help is appreciated.

Installed & tested.

Share this post


Link to post
Share on other sites
If you have phpMyAdmin, 'empty' the scart table. This should clear it out.

 

BTW; what version are you running? Is this an upgrade? If so what was the first version you ran?

 

When I couldn't "flush" the table, I emptied it instead. That made everyone show up as "uncontacted." (Whereas before, I was looking at a "frozen" version of the contacted/uncontacted info.)

 

It was working fine for 3 months or so, until it stopped updating the contacted/uncontacted info. I don't want to start over... I want it to continue working fine. :)

 

I've got RCS v1.4. (I tried to install the latest version the other day, but I think I've hacked my OSC install a bit too heavily, gave me all sorts of errors.)

Share this post


Link to post
Share on other sites
Aha...figured it out:

 

You were a very baaad boy and didn't follow directions :) The problem is that you copied the  tep_get_products_special_price function from my installation directions, which specifically state that you can not do that.

 

You have to copy the  tep_get_products_special_price from your /catalog/includes/functions/general.php file.

 

That will solve your problem :)

 

(unless, of course, you don't have  tep_get_products_special_price in your general.php file... but I haven't found an install yet that didn't have it.)

 

Eureka! Thanks for everything. Somehow I missed that part in the installation instructions.

 

Thanks,

 

-Kel :)


No Great Man ever complains of want of opportunity... sieze the day.

Share this post


Link to post
Share on other sites
When I couldn't "flush" the table, I emptied it instead.  That made everyone show up as "uncontacted."  (Whereas before, I was looking at a "frozen" version of the contacted/uncontacted info.)

 

It was working fine for 3 months or so, until it stopped updating the contacted/uncontacted info.  I don't want to start over... I want it to continue working fine. :)

 

I've got RCS v1.4.  (I tried to install the latest version the other day, but I think I've hacked my OSC install a bit too heavily, gave me all sorts of errors.)

yea, 1.4 does not have the fix for the scart table bug that the latest one does. With the latest you should never have to flush or empty the scart table. (crossing fingers!)

 

Your hacking of your OSC install should not effect anything for the latest version; what has changed are only on the Admin side of the cart and are very simple:

 

1. Added some items to the "Configuration" table so that you can configure RCS via the admin panel instead of having to edit the PHP file. Plus added a bunch of nice options :)

 

2. You have to modify the ADMIN general.php file (ie, /catalog/admin/includes/functions/general.php) by copying one function from YOUR catalog general.php file. (ie, /catalog/includes/functions/general.php).

 

#2 would not be a problem if the original designers hadn't duplicated so much of the code in the Admin area; still can't figure that decision out :)

Share this post


Link to post
Share on other sites

How does everyone handle this contribution with orders that were declined? This contrib is great! However i'm curious if there are people with setups that tell them an order was attempted to be checked out with, and was declined, or like this contrib does already just shows that someone came, had a cart w/ products signed up and left.

 

I'd just like to know the differences on who was declined on an processing attempt, versus what its doing right now, only together.

 

Thanks!

Share this post


Link to post
Share on other sites
How does everyone handle this contribution with orders that were declined?  This contrib is great! However i'm curious if there are people with setups that tell them an order was attempted to be checked out with, and was declined, or like this contrib does already just shows that someone came, had a cart w/ products signed up and left.

 

I'd just like to know the differences on who was declined on an processing attempt, versus what its doing right now, only together.

 

Thanks!

Actually, that's a good question! I'd like to be able to send out a seperate type of email, one that specifically targets "declined" orders. Heck, also one that targets "pending" orders (ie, paypal where they don't complete the payment, etc.)

 

Pending should be fairly easy, it's only a slight mod ... if I get the time :)

 

The declined issue would be harder, as I don't think any information is stored for looking this information up. I'll give it some thought, but if anyone else has thoughts or ideas please speak up!

Share this post


Link to post
Share on other sites

Hi there, I been using this contrib for months and it works really great, but a few days ago one of my customers added a lot of products to his cart but he didn?t finished the checkout process, so as you all know that order went directly to "Recover Cart Sales" list.

 

The thing is that he decided to pay me today via paypal, but in an external way, he just remebered the amount of money he owed me and my paypal account, so he send the money without finishing the checkout process.

 

Now I want to transfer that order from the Recover Cart Sales List to my Shipped Orders List, but if I ask the customer to finish the checkout process he will be charged again.

 

How can I do this without disturbing the customer? I mean, I want to do this in an internal way, I dont want to ask the customer for his time and cooperation.

 

Thanks in advance!

Juan Ugarte

PS Sorry for my bad english :blush:


Truth? You can?t handle the truth!!

Share this post


Link to post
Share on other sites
Hi there, I been using this contrib for months and it works really great, but a few days ago one of my customers added a lot of products to his cart but he didn?t finished the checkout process, so as you all know that order went directly to "Recover Cart Sales" list.

 

The thing is that he decided to pay me today via paypal, but in an external way, he just remebered the amount of money he owed me and my paypal account, so he send the money without finishing the checkout process.

 

Now I want to transfer that order from the Recover Cart Sales List to my Shipped Orders List, but if I ask the customer to finish the checkout process he will be charged again.

 

How can I do this without disturbing the customer? I mean, I want to do this in an internal way, I dont want to ask the customer for his time and cooperation.

RCS never actually changes any of the order status information. The only thing it modifies is the SCART table, which is simply a tag for whether or not a customer was sent an email about an order via RCS.

 

I should note that this is assuming that you never use the "Delete" buttons, which will of course modify other tables in the process of removing the shopping cart attached to the delete button pressed. :)

 

I can only think of two options for your situation; either delete the cart via RCS or you could manually "complete" the order yourself. To do this, login as that customer and checkout using PayPal for payment. Once at the paypal site for payment, go into your store's admin area and view the order (in Customers:Orders). There you can modify the status of the order, on my site it would change from "Pending" to "Shipped"; you can also notify the customer or not (your choice) about the change.

 

Hope that helps!

 

PS: Your English is fine :)

Share this post


Link to post
Share on other sites

Thank you Lane for your fast replay, It would be great if I can finish the trasnaction as if I was the customer, but how do I login into his account if I dont have his password, mysql only provides me an encrypted password, is there any contribution that allows me to login as any customer?

 

Thanks!

Juan Ugarte


Truth? You can?t handle the truth!!

Share this post


Link to post
Share on other sites
Thank you Lane for your fast replay, It would be great if I can finish the trasnaction as if I was the customer, but how do I login into his account if I dont have his password, mysql only provides me an encrypted password, is there any contribution that allows me to login as any customer?

 

Thanks!

Juan Ugarte

PM'd

Share this post


Link to post
Share on other sites

ok. I must be going crazy. I have searched through this entire post and can't seem to find the answer. I can't get scart to be populated. I have abondoned carts (test carts) and I am not getting any error while executing. The links to the new reports are there. The only thing I am missing is data in scart to pull from. I am using MS2.

 

Any advice?

 

Dan Sampson

Share this post


Link to post
Share on other sites

Very nice work!

 

Just sent out the emails (only three) and have already received a positive reply. I have two small issues related to the urls listed in the email to customers. The first issue is that in the link to the product, it is listing the url in this format:

 

(http://mysite.com/product_info.php?products_id=753{1}3)

 

The section of the url that causes it to break is the "{1}3" on the end. So when the customer clicks the link, they get an error.

 

The second issue is that both the product link and the site link at the bottom of the message do not use the www subdomain-which I try to use for everything. This is not critical, as the url resolves-but I'd like to list my url with the www for the sake of continuity.

 

Thanks !


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites

Disregard my previous post (except the part about this contribution being excellent work)

 

The error was due to one of my settings in admin/includes/configure.php remaining without the www in the url-now fixed. This corrected both issues.

 

Thank you for the easy to install, and supremely u$eful contribution!


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites
ok.  I must be going crazy.  I have searched through this entire post and can't seem to find the answer.  I can't get scart to be populated.  I have abondoned carts (test carts) and I am not getting any error while executing.  The links to the new reports are there.  The only thing I am missing is data in scart to pull from.  I am using MS2.

 

Any advice?

 

Dan Sampson

The SCART table is only populated when you send out emails via the RCS tool.

Share this post


Link to post
Share on other sites

Hmm I had this contribution working perfectly first time when I installed it on a test cart but this time round after installation my admin control panel is spitting out things like this:

 

BOX_HEADING_CONFIGURATION

BOX_HEADING_CATALOG

BOX_HEADING_MODULES

BOX_HEADING_CUSTOMERS

etc etc

 

Even after copying over the files from my first cart with the working recover cart contribution it still won't work What on earth have I done?

 

Sarah

Share this post


Link to post
Share on other sites
Hmm I had this contribution working perfectly first time when I installed it on a test cart but this time round after installation my admin control panel is spitting out things like this:

 

BOX_HEADING_CONFIGURATION

BOX_HEADING_CATALOG

BOX_HEADING_MODULES

BOX_HEADING_CUSTOMERS

etc etc

 

Even after copying over the files from my first cart with the working recover cart contribution it still won't work What on earth have I done?

 

Sarah

Okay, premature posting there - I actually just figured it out. Something wrong with the english file. I just went back to the old version and then implemented the amendments to the file again and it worked.

Share this post


Link to post
Share on other sites

Hi! I love it! I love it! I love it! But I guess I did something wrong, because the links in the email the customer gets (login, product info, site url) don't work. I mean they work, but "The page cannot be displayed". What am I missing? I hope you can help me...Thanks a lot!


My Tiny Contribution - Romanian Buttons

Share this post


Link to post
Share on other sites

Hi, This is such a great contrib!! I sent out my first emails today. 3 out of 4 people got the email just fine, however, an AOL user received a blank email. The subject was correct, but the email itself was totally blank. Any idea why this is happening?

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×