Jump to content
Met00

Recover Cart Sales

Recommended Posts

I have been trying to install this great contr into my site - until now without succes.

 

The problem lies in the admin general.php where I am supposed to copy/paste a section of the code from catalog general.php.

 

When I try to go into the admin part, I get the following error:

 

Fatal error: Cannot redeclare tep_get_products_name() (previously declared in /var/www/html/admin/includes/functions/general.php:590) in /var/www/html/admin/includes/functions/general.php on line 845

 

As I am not a coder, I hope somebody out there can help me.

 

All inputs are appreciated  :D

Sounds like you copy and pasted the function tep_get_products_name as well as the special price function. You are only supposed to copy / paste the special price function since the tep_get_products_name function already exists in the admin file (ie, that is the function you paste the special price function after).

Share this post


Link to post
Share on other sites
Lane, Just a reminder to uncheck by default "Uncontacted", it is getting to be somwhat of a hassel.

Also include the attribute fix.

I'm out of town for a while, so I can't get to this right away. However, you can do a quick fix on your code by looking for $checked and changing any = 1 occurances to = 0.

 

I will get to a new official release with both issues addressed asap when I get back.

Share this post


Link to post
Share on other sites

I have not updated to the latest version yet, but I was wondering if this has been fixed yet or not in the latest version...

 

When you send an e-mail to anyone in the list of Recover Cart Sales page, it will save and show the date that you sent the e-mail.

 

But when you send a second e-mail, like a week later or something, it does not update the date. It stays the original e-mails contact date.

 

Can this be changed to update the contact date on EACH e-mail sent to the current date of that e-mail?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
I have not updated to the latest version yet, but I was wondering if this has been fixed yet or not in the latest version...

 

When you send an e-mail to anyone in the list of Recover Cart Sales page, it will save and show the date that you sent the e-mail.

 

But when you send a second e-mail, like a week later or something, it does not update the date. It stays the original e-mails contact date.

 

Can this be changed to update the contact date on EACH e-mail sent to the current date of that e-mail?

It has not been changed; I've never sent more than one email so I've never noticed it and no one has mentioned it before.

 

I'll add this to the ToDo list for the next version. Thanks for the report!

Share this post


Link to post
Share on other sites

New topic!!!

 

1. I have had revover cart for some time now which was working fine, great contribute. I installed the latest version last week 2.1. I made a mistake on installation by running 1 of the sql update files twice and got repeat entries into the database for the configuration varaible in admin, given dulpicate entries. Does any anyone knwo how to remove these double entries as I can not find which table they are in????? otherwiser contribute was working fine!!!

 

2. Yesterday, I starting to get 2 errors in the recover carts area in admin. see below:

 

Warning: fopen(/tmp/mysql.sock): failed to open stream: Operation not supported in /home/zenasxxxtoys/www/zenasxxxtoys.com/admin/recover_cart_sales.php on line 115

 

Warning: fread(): Length parameter must be greater than 0. in /home/zenasxxxtoys/www/zenasxxxtoys.com/admin/recover_cart_sales.php on line 117

 

I understand that recover carts is trying to open a file /tmp/mysql.sock, but I look in this directory and nothing exists in this directory.

 

Can someone please advise, what I should do now??????

 

Many Thanks

 

Julian

 

http://www.zenastoys.co.uk

Take a peak its Naughty - Zenas Toys

Share this post


Link to post
Share on other sites
Sounds like you copy and pasted the function tep_get_products_name as well as the special price function. You are only supposed to copy / paste the special price function since the tep_get_products_name function already exists in the admin file (ie, that is the function you paste the special price function after).

 

Hi Lane

 

Just back in town - thats why the late reply.

 

Great spottet - I think I had missunderstood your very good install file.

 

Everything works now.

 

Thank you

 

Peer

Share this post


Link to post
Share on other sites

I just have a quick question...

 

To get this working, its enough installing the contribution of 1st of June?

 

Or do I have to get all of the rest of them?

 

Dumb question, i know

 

thanks

Share this post


Link to post
Share on other sites
I just have a quick question...

 

To get this working, its enough installing the contribution of 1st of June?

 

Or do I have to get all of the rest of them?

 

Dumb question, i know

 

thanks

Just the latest, and use the "Install.html" file instructions.

Share this post


Link to post
Share on other sites
New topic!!!

 

1. I have had revover cart for some time now which was working fine, great contribute. I installed the latest version last week 2.1. I made a mistake on installation by running 1 of the sql update files twice and got repeat entries into the database for the configuration varaible in admin, given dulpicate entries. Does any anyone knwo how to remove these double entries as I can not find which table they are in????? otherwiser contribute was working fine!!!

Yes, search the table "configuration" for entries like %RCS% and delete any duplicates found. (ie, using phpMyAdmin, etc.)
2. Yesterday, I starting to get 2 errors in the recover carts area in admin. see below:

 

Warning: fopen(/tmp/mysql.sock): failed to open stream: Operation not supported in /home/zenasxxxtoys/www/zenasxxxtoys.com/admin/recover_cart_sales.php on line 115

 

Warning: fread(): Length parameter must be greater than 0. in /home/zenasxxxtoys/www/zenasxxxtoys.com/admin/recover_cart_sales.php on line 117

 

I understand that recover carts is trying to open a file /tmp/mysql.sock, but I look in this directory and nothing exists in this directory.

Most likely you lost permission to the /tmp folder. That's the only thing I can think of anyway.

Share this post


Link to post
Share on other sites
I have not updated to the latest version yet, but I was wondering if this has been fixed yet or not in the latest version...

 

When you send an e-mail to anyone in the list of Recover Cart Sales page, it will save and show the date that you sent the e-mail.

 

But when you send a second e-mail, like a week later or something, it does not update the date. It stays the original e-mails contact date.

 

Can this be changed to update the contact date on EACH e-mail sent to the current date of that e-mail?

This feature has been added to v2.10, just released.

 

In order to do this, I added a new field to the scart table, datemodified, which is updated upon a new record or when another email is sent to a customer. Since all previous entries will be empty, I default to using the dateadded if datemodified is empty.

 

I also found when doing this that the scart table usage was allowing duplicate entries for customers. These duplicate records were being created whenever a customer abandoned more than one cart or the admin emailed the customer more than one time. This turned out to be the source of several problems. The table now requies unique customer entries (ie, 1 entry per customer) and new abandonded carts or multiple email contacts simply update the modified date field.

Share this post


Link to post
Share on other sites
Is it possible to be able to get a copy of the email automatically sent to Admin as well as the customer?  Does anyone know what code I would need to add / amend ?

 

(I get the extra Order emails and would like to do the same for all customer correspondence)

 

Thanks again !

This feature is also in v2.10 ... you just need to enter the email address you want to get copied with each email in the RCS configuration area. I did it this way instead of using the admin or sales or other existing email address because this is pretty specialized and I figured many would want these going to a unique email address.

 

To have the contribution only send emails to the customer, leave the email field blank.

Share this post


Link to post
Share on other sites

Lane , Thanks for the upgrades I had a problem with the SQL update, I think th only differemce from 2.01 to 2.11 is

 

INSERT INTO `configuration` ( `configuration_id` , `configuration_title` , `configuration_key` , `configuration_value` , `configuration_description` , `configuration_group_id` , `sort_order` , `last_modified` , `date_added` , `use_function` , `set_function` )
? VALUES ('', 'E-Mail Copies to', 'RCS_EMAIL_COPIES_TO', '', "If you want copies of emails that are sent to customers by this contribution, enter the email address here. If empty no copies are sent", 6501, 35, NULL, NOW(), '', '');
INSERT INTO `configuration` ( `configuration_id` , `configuration_title` , `configuration_key` , `configuration_value` , `configuration_description` , `configuration_group_id` , `sort_order` , `last_modified` , `date_added` , `use_function` , `set_function` )
? VALUES ('', 'Autocheck "safe" carts to email', 'RCS_AUTO_CHECK', 'true', "To check entries which are most likely safe to email (ie, not existing customers, not previously emailed, etc.) set this to <b>true</b>.<br><br>Setting this to <b>false</b> will leave all entries unchecked (you will have to check each entry you want to send an email for).", 6501, 82, NULL, NOW(), '', "tep_cfg_select_option(array('true', 'false'),");
INSERT INTO `configuration` ( `configuration_id` , `configuration_title` , `configuration_key` , `configuration_value` , `configuration_description` , `configuration_group_id` , `sort_order` , `last_modified` , `date_added` , `use_function` , `set_function` )
? VALUES ('', "Match orders from any date", 'RCS_CARTS_MATCH_ALL_DATES', 'true', "If <b>true</b> then any order found with a matching item will be considered a matched order.<br><br>If <b>false</b> only orders placed after the abandoned cart are considered.", 6501, 84, NULL, NOW(), '', "tep_cfg_select_option(array('true', 'false'),");

 

 

Before I did the above sql update I was getting return mail directed to

 

RCS_EMAIL_COPIES_TO@orbit.xxxx-xxxxx.net

 

I have also updated the files from 2.01 to 2.11

 

Jimmy

Edited by RI Downlink

I'm not a coder just a splicer.

Share this post


Link to post
Share on other sites

Hi,

I have just installed this contribution v2.11 from new.

I am getting an error when I try and run tools> Recover Cart Sales

1054 - Unknown column 'customers_group_id' in 'field list'

 

select customers_group_id from customers where customers_id = ''

 

What could this be?

How do i fix this?

 

Aprreciate your expert help.

Thanks in advance.

Kunal

Share this post


Link to post
Share on other sites

Hello, I have just installed Recover Cart Sales 2.11 to my store andget this error message:

 

1054 - Unknown column 'customers_group_id' in 'field list'
select customers_group_id from customers where customers_id = ''
TEP STOP

 

Error message seems similar to this:

 

Hi,

I have just installed this contribution v2.11 from new.

I am getting an error when I try and run  tools> Recover Cart Sales

What could this be?

How do i fix this?

 

Aprreciate your expert help.

Thanks in advance.

Kunal

Share this post


Link to post
Share on other sites
Hi,

I have just installed this contribution v2.11 from new.

I am getting an error when I try and run  tools> Recover Cart Sales

What could this be?

How do i fix this?

 

Aprreciate your expert help.

Thanks in advance.

Kunal

Any fix to this problem will be great!!

Kunal

Share this post


Link to post
Share on other sites

Following up on

1054 - Unknown column 'customers_group_id' in 'field list'
select customers_group_id from customers where customers_id = ''
TEP STOP

 

I noticed that customers_group_id does not exist in my customers table, I went back to the code I put on general.php and commented most of the bs it contained, and it worked; I bet this is a discusting hack so, why does customers_group_id NOT exist in my store? where does it come from? how may I add it? can I? WTF? hehehe

 

  function tep_get_products_special_price($product_id) {

// global $customer_id;

// $customer_group_query = tep_db_query("select customers_group_id from " . TABLE_CUSTOMERS . " where customers_id =  '" . $customer_id . "'");

// $customer_group = tep_db_fetch_array($customer_group_query);

// $product_query = tep_db_query("select specials_new_products_price from " . TABLE_SPECIALS . " where products_id = '" . (int)$product_id . "' and status and customers_group_id = ". (int)$customer_group['customers_group_id']);

// $product = tep_db_fetch_array($product_query);

return $product['specials_new_products_price'];

  }

 

 

One more thing, I see no product attributes displayed on recover_cart_sales.php, must I contact the customer each and every time I need to know what they really ordered? or is there a way to display them?

 

 

thanks! :)

Share this post


Link to post
Share on other sites
Following up on

1054 - Unknown column 'customers_group_id' in 'field list'
select customers_group_id from customers where customers_id = ''
TEP STOP

 

I noticed that customers_group_id does not exist in my customers table, I went back to the code I put on general.php and commented most of the bs it contained, and it worked; I bet this is a discusting hack so, why does customers_group_id NOT exist in my store? where does it come from? how may I add it? can I? WTF? hehehe

One more thing, I see no product attributes displayed on recover_cart_sales.php, must I contact the customer each and every time I need to know what they really ordered? or is there a way to display them?

thanks! :)

I did not add the customer_id part of the code as it is not required to paste that in the genral.php of the catalog folder but still getting the error:

1054 - Unknown column 'customers_group_id' in 'field list'
select customers_group_id from customers where customers_id = ''

 

What else can it be?

Kunal

Share this post


Link to post
Share on other sites

Hey,

 

Fantastic contribution. Just installed it and it is great.

 

I have one problem with it though.

 

When I go to recover_cart_sales.php I have some customers with listings of $0.00.

I know that it is probably for products that are nolonger available, but is there any way to remove those items out of it and not list them? And if a customer only had items in their cart which none of them are available anymore, then it should either not display the customer in recover_cart_sales.php or it should just delete their cart (probably deleting their cart would be the best).

 

Any thoughts on how to make this happen?

 

Cheers,

Chris :)

Share this post


Link to post
Share on other sites
I did not add the customer_id part of the code as it is not required to paste that in the genral.php of the catalog folder but still getting the error:

1054 - Unknown column 'customers_group_id' in 'field list'
select customers_group_id from customers where customers_id = ''

 

What else can it be?

Kunal

Any help at all!!! as it is not working for me.

 

Kunal

Share this post


Link to post
Share on other sites
Following up on

1054 - Unknown column 'customers_group_id' in 'field list'
select customers_group_id from customers where customers_id = ''
TEP STOP

I noticed that customers_group_id does not exist in my customers table, I went back to the code I put on general.php and commented most of the bs it contained, and it worked; I bet this is a discusting hack so, why does customers_group_id NOT exist in my store? where does it come from? how may I add it? can I? WTF? hehehe

Not sure; you didn't copy the code from the install directions did you? You have to copy it from YOUR general.php file! If you did copy it from your file, then your install had only a partial setup for pricing by groups/customers and you should really double check all operations to make sure pricing is working as you expect.
One more thing, I see no product attributes displayed on recover_cart_sales.php, must I contact the customer each and every time I need to know what they really ordered? or is there a way to display them?

thanks! :)

Did you go to the configuration options and turn on the display of attributes?

Share this post


Link to post
Share on other sites
Hey,

 

Fantastic contribution. Just installed it and it is great.

 

I have one problem with it though.

 

When I go to recover_cart_sales.php I have some customers with listings of $0.00.

I know that it is probably for products that are nolonger available, but is there any way to remove those items out of it and not list them? And if a customer only had items in their cart which none of them are available anymore, then it should either not display the customer in recover_cart_sales.php or it should just delete their cart (probably deleting their cart would be the best).

 

Any thoughts on how to make this happen?

 

Cheers,

Chris :)

You are probably correct about why this is happening... you would have to add logic to the code to check for this condition and skip that customer. I'll look into adding this for the next release (which will be a while as I am away from the office with very limited access to the internet).

Share this post


Link to post
Share on other sites
Hi,

I have just installed this contribution v2.11 from new.

I am getting an error when I try and run  tools> Recover Cart Sales

What could this be?

How do i fix this?

 

Aprreciate your expert help.

Thanks in advance.

Kunal

What file is this happening in? General.php? Did you copy the function from your catalog's general.php file or from the install file?

 

Sorry for the long delays in replying, but I'm out of the office for an unknown time and have extremely limited internet access.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×