Jump to content
defender39

Wishlist 2.0 Support Thread

Recommended Posts

Is it possible to have the Admin page view a customer's wish list? That would be ideal for me.


Onnig

Share this post


Link to post
Share on other sites

Hi

I have installed STSv1.8 and now just added wishlistv2.0. It does not work. I installed a cleaned osC 2 MS2 with STSv1.8 and Wishlist 2. Can anyone care to share your experience. Please!! :rolleyes:

Share this post


Link to post
Share on other sites

Hi akkinmore,

 

Whatever problems that may have occurred will probably, most likely be resolved through this thread. Please read through this entire thread for your problem. I did and it fixed all of my problems with wishlist 2.0. :)


Onnig

Share this post


Link to post
Share on other sites

I've read this entire thread and I don't see a solution to a problem I am having!

I am using MS2 with Wishlist 2.0.1'

When I am signed into my site the area where the whishlist box is supposed to be is replaced with the following errors:

 

Warning: main(includes/modules/wishlist/FILENAME_WISHLIST): failed to open stream: No such file or directory in /home/dragonwi/public_html/catalog/includes/boxes/wishlist.php on line 14

 

Warning: main(): Failed opening 'includes/modules/wishlist/FILENAME_WISHLIST' for inclusion (include_path='') in /home/dragonwi/public_html/catalog/includes/boxes/wishlist.php on line 14

 

I do have the includes/modules/wishlist/wishlist.php in place -the original from the downloaded contrib.

My catalog/includes/boxes/wishlist.php looks like this:

<?php

/*

  $Id: wishlist.php,v 1.0 2002/05/08 10:00:00 hpdl Exp $

 

  osCommerce, Open Source E-Commerce Solutions

  http://www.oscommerce.com

*/

 

?>

<!-- wishlist //-->

          <tr>

            <td>

<?php

  include(DIR_WS_MODULES. 'wishlist/' . FILENAME_WISHLIST);

?>

            </td>

          </tr>

<!-- wishlist_eof //-->

 

I am only using the English lanquage.

I'm lost here.

Thanks!

Share this post


Link to post
Share on other sites

Millyramsey,

 

You may have forgotten to do step #3 in the readme.txt file:

 

3. in /catalog/includes/application_top.php add the next set of lines:

 

//Wishlist

  define('FILENAME_WISHLIST', 'wishlist.php');

  define('FILENAME_WISHLIST_HELP', 'wishlist_help.php');

//Wishlist

  define('TABLE_WISHLIST', 'customers_wishlist');

 

I had skipped over some steps as well, easy to miss. :)


Onnig

Share this post


Link to post
Share on other sites

millyramsey,

 

Are you getting the same error message? If so, place the code I mentioned toward the top of the application_top.php page.

 

This is where I placed mine:

<?php

/*

  $Id: application_top.php,v 1.280 2003/07/12 09:38:07 hpdl Exp $

 

  osCommerce, Open Source E-Commerce Solutions

  http://www.oscommerce.com

 

  Copyright © 2003 osCommerce

 

  Released under the GNU General Public License

*/

 

// start the timer for the page parse time log

  define('PAGE_PARSE_START_TIME', microtime());

 

//Wishlist

  define('FILENAME_WISHLIST', 'wishlist.php');

  define('FILENAME_WISHLIST_HELP', 'wishlist_help.php');

//Wishlist

  define('TABLE_WISHLIST', 'customers_wishlist');


Onnig

Share this post


Link to post
Share on other sites

Ok, now it's saying this:

 

Warning: main(includes/modules/wishlist/wishlist.php): failed to open stream: No such file or directory in /home/dragonwi/public_html/catalog/includes/boxes/wishlist.php on line 14

 

Warning: main(): Failed opening 'includes/modules/wishlist/wishlist.php' for inclusion (include_path='') in /home/dragonwi/public_html/catalog/includes/boxes/wishlist.php on line 14

 

I checked the spelling of both my wishlist.php filenames (one in includes/modules/wishlist/ and the other in includes/boxes/) that I uploaded, they are fine, and so is the /wishlist/ directory in /modules/

 

???

Share this post


Link to post
Share on other sites

MILLYRAMSEY,

 

Did you upload all the necessary files that came with the wish list contribution? It seems to be missing. Please go through the readme.txt file again.


Onnig

Share this post


Link to post
Share on other sites

Ok, I just uninstalled everything, and reinstalled it. Thanks Onnig for telling me something I needed to hear but just didn't want to.

 

Then, after reading this thread two or three more times, I got it to work! Even the email is working with the links! Yay! Is someone willing to wade through everything and re-release this mod?

 

I was having the problem with the email-to-friend option not showing up at all, but this post by 1quicksi helped me:

Anyways my solution was to move the entire tell_a_friend section just above:

 

<?php

if ($wishlist_numrows > 0 && (PREV_NEXT_BAR_LOCATION == '2' || PREV_NEXT_BAR_LOCATION == '3')) {

?>

 

My clue was from someone who posted that they thought this was the code stopping the tell_a_friend from working.

 

Hopefully this will help someone else down the road.

 

Then the links in the email weren't finding products (directing to file not found pages), but a post by funkyfermin helped solve that problem. In wishlist_email.php:

 

Find and replace with the one below

$wishliststring .= $resultarray[1]."\n" . HTTP_SERVER ."/catalog/product_info.php/products_id=".$resultarray[0] . "\n\n";

 

 

TRY THIS

 

$wishliststring .= $resultarray[1]."\n" . HTTP_SERVER . DIR_WS_CATALOG ."product_info.php?products_id=" . $resultarray[0] . "\n\n";

 

Thank you to everyone for all your hard work!

Edited by millyramsey

Share this post


Link to post
Share on other sites

Hello everybody,

I have search this thread with no luck or I might have missed it. So, I post it again. Anyone care to share whether STS v1.8 can coexist with Wishlist2.0 ? I still could not make it work. Please!! :rolleyes:

Share this post


Link to post
Share on other sites
Hello everybody,

I have search this thread with no luck or I might have missed it. So, I post it again. Anyone care to share whether STS v1.8 can coexist with Wishlist2.0 ? I still could not make it work. Please!! :rolleyes:

i just installed this with mine and I have sts installed...

 

it took me a couple hours but I finally got it...

 

what issues are you having?

 

http://www.atmotorsports.com is where I have it...

 

the only thing I dont have that I still need to do is getting the box added

Edited by higabyte

Share this post


Link to post
Share on other sites

ok i thought i had it working..

 

the problem im running into is when a someone is not logged in and try to visit the site they get a sql error because its pulling from "customer_id="... so basically it just needs an if statement in there somewhere I would think, just gotta figure out where...

 

im more of an asp guy so im just learning php, give me a break, hehe...

 

*edit*

ahh hell, its cause of this:

 

if (tep_session_is_registered('customer_id')) include (DIR_WS_BOXES . 'wishlist.php');

 

once I add that it should fix my problem...

Edited by higabyte

Share this post


Link to post
Share on other sites

ok got it working now...

 

steps 1-6 are the same as the readme file, for step 7 do the below... this will get it working with the STS hack...

 

 

add

 

   $sts_block_name = 'wishlist';
  require(STS_START_CAPTURE);
  if (tep_session_is_registered('customer_id')) require(DIR_WS_BOXES . 'wishlist.php');
  require(STS_STOP_CAPTURE);
  $template['wishlist'] = strip_unwanted_tags($sts_block['wishlist'], 'wishlist');

 

to your sts_user_code.php file and then on your sts_template.html add $wishlist where you want the box to appear

Share this post


Link to post
Share on other sites

will there be a proper update to this contrib to support MS2? I managed to get it somewhat working.. however my templates don't work with the wishlist.php page...

 

thxs

-Jean

Share this post


Link to post
Share on other sites

Hi.

 

I'm still having trouble with the negative four wishlist pages when there's nothing in the wishlist. Very strange.

 

Anybody know how to fix that one?

 

shris

Share this post


Link to post
Share on other sites

Hi,

 

I am not sure if I missed a thread, but there is something strange happening:

 

When I click "add to wishlist", everything works perfect. When I choose "add to basket", my products are transferred to the wishlist as well. And I am unable to get them out of there, the only thing I can do is adding to the wishlist.

 

Can anybody please tell me how to get this solved?

 

Greetings, Michael


Not because it is difficult we don't dare to do it, but because we don't dare to do it, it is difficult. (Seneca)

Share this post


Link to post
Share on other sites

i had the same problem with the "buy now" buttons and didn't have time to dig into it. i had to return my application_top.php to its original form and dump the wishlist stuff till i have more time to work on it (i'm still pre-launch and can't hold up the launch for imperfected wishlist technology!!).

 

my guess is that the wishlist authors don't use buy now and simply commadeered that functionality for wishlist instead -- which makes it 100% incompatible for anyone using "buy now". if you want to poke around your application_top file, i think the changes in there are probably the place to start to get your real shopping cart back. good luck!!!

Share this post


Link to post
Share on other sites

how interresting!

 

I never noticed that! LOL !

 

Well I don't think it is a big deal 'cause the buy now button and the buy button are working on the same principle... Did anyone allready fix this?

Share this post


Link to post
Share on other sites
Of course there is an issue with the links as they are incorrect and appear listed 8 times? :(?  I am sure I will get through this yet.? Time to go read the thread again for clues...

hi

 

well with the language I might can help those who run MS1. Go to wishlist_email.php around line 44 - 46 and find this

 

$wishliststring = "My Wishlist is: \n\n";

$wishlist_query_raw = "select tab2.products_id, tab1.products_name from " . TABLE_WISHLIST . " as tab2, products_description as tab1 WHERE tab2.customers_id=$customer_id and tab1.products_id = tab2.products_id order by products_name";

$wishlist_query = tep_db_query($wishlist_query_raw);

 

 

past the following line

 

and tab1.language_id = '" . $languages_id . "'

 

between "tab2.products_id" and "order by" to have the following:

 

$wishliststring = "My Wishlist is: \n\n";

$wishlist_query_raw = "select tab2.products_id, tab1.products_name from " . TABLE_WISHLIST . " as tab2, products_description as tab1 WHERE tab2.customers_id=$customer_id and tab1.products_id = tab2.products_id and tab1.language_id = '" . $languages_id . "' order by products_name";

$wishlist_query = tep_db_query($wishlist_query_raw);

 

At least this seams to work with me.

 

Now I have a totally different problem. I can not add any products to the wishlist 2.0 nor can I delete any. Moving from the wishlist to the cart is not a problem.

Adding and delete cause the following problem:

 

1146 - Table 'catalog.table_wishlist' doesn't exist

 

delete from TABLE_WISHLIST where products_id = '79' and customers_id = '2'

 

[TEP STOP]

 

but I do not see where and how I can fix this. Because I do not have a clue where to look for and I do not find why and how he is producing this error.

 

Can someone help me here?

 

Cheers

 

Jens

Thanks the email now comes out to 1 instead of 3 for languages.

Share this post


Link to post
Share on other sites
Then the links in the email weren't finding products (directing to file not found pages), but a post by funkyfermin helped solve that problem. In wishlist_email.php:

 

Find and replace with the one below

$wishliststring .= $resultarray[1]."\n" . HTTP_SERVER ."/catalog/product_info.php/products_id=".$resultarray[0] . "\n\n";

 

 

TRY THIS

 

$wishliststring .= $resultarray[1]."\n" . HTTP_SERVER . DIR_WS_CATALOG ."product_info.php?products_id=" . $resultarray[0] . "\n\n";

 

Thank you to everyone for all your hard work!

Another solution you could use is

 

 

 

$wishliststring .= $resultarray[1]."\n" . HTTP_SERVER . DIR_WS_HTTP_CATALOG ."product_info.php?products_id=".$resultarray[0] . "\n\n";

 

What this does is the same as theirs only instead of adding /catalog/ I inputed DIR_WS_HTTP_CATALOG which follows the osC structure so that it'll match what you inputed in configure.php so you can always change your folder name and it'll follow.

Share this post


Link to post
Share on other sites

My prayers were answered !!!

 

The following solved my problem. I had troubles adding to my wishlist. Products were added to the shopping cart instead of the wishlist when clicking on wishlist.

 

Brilliant guys, thanx to everybody that helped me ...

 

QUOTE (beardeddone @ Nov 25 2003, 11:05 PM)

 

 

It needs to be changed to

 

CODE 

 

</form>

 

<td align="right" class="main"><?php echo tep_draw_form('wishlist_quantity', tep_href_link(FILENAME_WISHLIST, tep_get_all_get_params(array('action')) . 'action=add_wishlist')); ?>

          <?php if (tep_session_is_registered('customer_id')) echo tep_draw_hidden_field('products_id', $product_info_values['products_id']) . tep_image_submit('button_wishlist.gif', IMAGE_BUTTON_ADD_WISHLIST); ?></td>

</table></td>

 

 

 

 

This is what I did and its working fine for me and shows wishlist button on the same line

 

PART ONE in product_info.php

 

<tr class="infoBoxContents">

<td ><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

<td class="main"><?php echo '<a href="' . tep_href_link(FILENAME_PRODUCT_REVIEWS, tep_get_all_get_params()) . '">' . tep_image_button('button_reviews.gif', IMAGE_BUTTON_REVIEWS) . '</a>'; ?></td>

<td class="main" align="right"><?php echo tep_draw_hidden_field('products_id', $product_info['products_id']) . tep_image_submit('button_in_cart.gif', IMAGE_BUTTON_IN_CART); ?></td>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td></form>

<td align="right" class="main">

<?php echo tep_draw_form('wishlist_quantity', tep_href_link(FILENAME_WISHLIST, tep_get_all_get_params(array('action')) . 'action=add_wishlist')); ?>

<?php if (tep_session_is_registered('customer_id'))

echo tep_draw_hidden_field('products_id', $product_info_values['products_id']) . tep_image_submit('button_wishlist.gif', IMAGE_BUTTON_ADD_WISHLIST); ?>

 

</td></form>

</tr>

</table></td>

</tr>

 

PART TWO in product_info.php

 

<!-- body_eof //-->

</td></tr>

<!-- footer //-->

 

Let me know if I am wrong.

:D :D :D


From all the things I lost, I miss my mind the most - Ozzy Ozborne

Share this post


Link to post
Share on other sites

After a long day I've got most of the things working now, just a few things to fix...

 

When I add more than 7 items the 8th+ item/s don't get shown, any ideas on how to fix this where should I be looking?

 

Also when I put more than 3 itmes in my wish list the total in the "my wishlist" box are wrong. It shows 6 when I have 4?

 

For now I've changed it so that it now shows "You currently have more than 3 items in your Wishlist." when I put more than three items in there.

 

How can I fix this?

 

 

 

... and where is the link for the help file in the pages?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×