Jump to content
defender39

Wishlist 2.0 Support Thread

Recommended Posts

I have been attempting to include seperate pricing per customer into my wishlist. I have looked around for help, but I can't find it. I'm sure I just don't know enough to realize where the help is.

 

I just installed version 2.4b. Could someone help me with the code to allow for SPPC? I would greatly appreciate it.

Share this post


Link to post
Share on other sites

I have been poking around the wishlist support threads for ages, and all I can find is other people who have the same problem as I do...

 

I have Master Products installed, and when I try to add a slave product to my wish list the MASTER product is added instead. :(

 

In a perfect world, the qty would also be passed, so one could add multiple slaves (with different qtys) to the wishlist.

 

Any ideas would be most appreciated -- I'm at the point where I'd consider paying someone to do the mod (and giving it back to the osC community, of course).

Share this post


Link to post
Share on other sites

Well I'm writing in this thread because its the contribution I used, as it seems wishlist 3.0 was taken off contributions. Didn't realise this hasn't been active since last December.

 

Ok, so I installed wishlist 2.0. All the files are in place, and i ran the sql.. Problem is, Wishlist box does not show in column, and adding to the wishlist, just adds to shopping cart as normal. Ive triple checked file edits, and seems fine. Ive also gone through all 41 pages in here, but can't seem to find an answer?

 

Anyone be of help? It seems like it could be something within database causing the problem maybe?

Share this post


Link to post
Share on other sites
Well I'm writing in this thread because its the contribution I used, as it seems wishlist 3.0 was taken off contributions. Didn't realise this hasn't been active since last December.

 

Ok, so I installed wishlist 2.0. All the files are in place, and i ran the sql.. Problem is, Wishlist box does not show in column, and adding to the wishlist, just adds to shopping cart as normal. Ive triple checked file edits, and seems fine. Ive also gone through all 41 pages in here, but can't seem to find an answer?

 

Anyone be of help? It seems like it could be something within database causing the problem maybe?

 

I don't suppport wishlist 2.0, but if you installed the latest file under the wishlist 2.0 contribution, then thats wishlist 3.5d. Do you use CSS buttons contribution? That will cause the wishlist to act as you are suggesting. Or the missing on the file edits in application top, or when you added the edits to application top, you didn't put them before the shopping cart actions like it says.

 

If you are using 3.5d then look over that thread as I have said this same thing before.

 

-Dennis

Share this post


Link to post
Share on other sites
I don't suppport wishlist 2.0, but if you installed the latest file under the wishlist 2.0 contribution, then thats wishlist 3.5d. Do you use CSS buttons contribution? That will cause the wishlist to act as you are suggesting. Or the missing on the file edits in application top, or when you added the edits to application top, you didn't put them before the shopping cart actions like it says.

 

If you are using 3.5d then look over that thread as I have said this same thing before.

 

-Dennis

 

Thanks, went through edits 5 times checking each character, also someone else gave it a go, still no luck.

 

I just went through 28 pages of 3.5d (sorry didnt know that forum existed), and the only guy that had a problem like this pm'd you url for a look and he never came back to post what was causing it.

 

I have got Basic design pack added, and has css buttons you mention, have you advice on how i can get this running with css buttons? Even the wishlist box doesn't show in column?

Share this post


Link to post
Share on other sites
I don't suppport wishlist 2.0, but if you installed the latest file under the wishlist 2.0 contribution, then thats wishlist 3.5d. Do you use CSS buttons contribution? That will cause the wishlist to act as you are suggesting. Or the missing on the file edits in application top, or when you added the edits to application top, you didn't put them before the shopping cart actions like it says.

 

If you are using 3.5d then look over that thread as I have said this same thing before.

 

-Dennis

 

Thanks, went through edits 5 times checking each character, also someone else gave it a go, still no luck.

 

I just went through 28 pages of 3.5d (sorry didnt know that forum existed), and the only guy that had a problem like this pm'd you url for a look and he never came back to post what was causing it.

 

I have got Basic design pack added, and has css buttons you mention, have you advice on how i can get this running with css buttons? Even the wishlist box doesn't show in column?

Edited by modulate

Share this post


Link to post
Share on other sites

The wishlist box doesn't show unless something is added to your wishlist. Now for the css buttons, That modification messes up the code required to perform the operations for the wishlist to function correctly. What you need to do is change the wishlist button on the product_info.php to a regular submit button. Right now it is running through the tep_image_submit() function and the css buttons modifies that function and drops the "name" attribute. Which is required for the wishlist to work.

Share this post


Link to post
Share on other sites

Hello,

 

I installed wishlist 3.5d and have the following error:

 

Fatal error: Cannot instantiate non-existent class: messagestack in /hsphere/local/home/rodrico/eratoys.com/catalog/includes/application_top.php on line 521

 

 

This is the line of code that draws the error:

 

// initialize the message stack for output messages

require(DIR_WS_CLASSES . 'message_stack.php');

$messageStack = new messageStack;

 

I didn't add to this line of code and there is no related adjustment in the wishlist contribution. I have looked over my adjustsments and don't see where my error is. Any help?? Any ideas??

 

Thanks,

Rod

Share this post


Link to post
Share on other sites

I too have the issue where the wishlist button redirects to the shopping cart, how do we change the code of the button in product_info.tpl.php to compensate for the name requirement ?

Share this post


Link to post
Share on other sites
The wishlist box doesn't show unless something is added to your wishlist. Now for the css buttons, That modification messes up the code required to perform the operations for the wishlist to function correctly. What you need to do is change the wishlist button on the product_info.php to a regular submit button. Right now it is running through the tep_image_submit() function and the css buttons modifies that function and drops the "name" attribute. Which is required for the wishlist to work.

Share this post


Link to post
Share on other sites

Just install Wishlist

and added the Admin "stats_wishlists.php"

But when run I get

Parse error: syntax error, unexpected T_REQUIRE in /home/hiro/public_html/catalog/admin/stats_wishlists.php on line 1

 

This is the "stats_wishlists.php" file contents.

 

<?php
/*
 $Id: stats_wishlists.php,v 1.00 2005/06/15

 Aaron Hiatt aaron@scaredrabbit.com
 http://www.scaredrabbit.com

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

define('HEADING_TITLE', 'Customer Wishlists');

define('TABLE_HEADING_NUMBER', 'Rank');
define('TABLE_HEADING_CUSTOMERS', 'Customers');
define('TABLE_HEADING_CUSTOMERS_COMPANY', 'Company');
define('TABLE_HEADING_CUSTOMERS_WISHLIST', 'Wishlist Products');
define('TABLE_HEADING_CUSTOMERS_GROUP_NAME', 'Price Level');
?>

 

I can't see what is wrong, any help would be great

Thanks

Share this post


Link to post
Share on other sites

After installing Wishlist 2.0 I am receiving this error, from what I have read on the forums this maybe a mysql issue, I am running 5.0.24 version, is there a fix for this with this contribution?

 

 

1054 - Unknown column 'p.products_id' in 'on clause'

 

select pd.products_id, pd.products_name, pd.products_description, p.products_image, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price from products p, products_description pd left join specials s on p.products_id = s.products_id where pd.products_id = '28' and p.products_id = pd.products_id and pd.language_id = '1' order by products_name

 

[TEP STOP]

 

 

Thanks

Wendy

Share this post


Link to post
Share on other sites

select pd.products_id, pd.products_name, ....

 

Just add in like so

 

select p.products_id, pd.products_id, pd.products_name, ...

Share this post


Link to post
Share on other sites

Just change to

 

specials s on pd.products_id = s.products_id

Edited by dblake

Share this post


Link to post
Share on other sites

I have installed wishlist 3.5d on my site and really dig it. I was testing the email friends and family feature, followed the link in the automatic email, came to the public wishlist page, added the item on the wishlist to my cart and recieved the following error:

 

Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/bradyswe/twohandsworldshop.com/catalog/includes/application_top.php:569) in /hsphere/local/home/bradyswe/twohandsworldshop.com/catalog/includes/functions/general.php on line 29

 

I found similar problems in the forums using google search and got rid of all trailing whitespace in both files mentioned in the error. Anyone have an idea as to what may be causing this error?

 

twohandsworldshop.com/catalog/ is the location of my osC install.

 

Thanks for any help! :D

Share this post


Link to post
Share on other sites
Just install Wishlist

and added the Admin "stats_wishlists.php"

But when run I get

Parse error: syntax error, unexpected T_REQUIRE in /home/hiro/public_html/catalog/admin/stats_wishlists.php on line 1

 

This is the "stats_wishlists.php" file contents.

 

<?php
/*
 $Id: stats_wishlists.php,v 1.00 2005/06/15

 Aaron Hiatt aaron@scaredrabbit.com
 http://www.scaredrabbit.com

 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

define('HEADING_TITLE', 'Customer Wishlists');

define('TABLE_HEADING_NUMBER', 'Rank');
define('TABLE_HEADING_CUSTOMERS', 'Customers');
define('TABLE_HEADING_CUSTOMERS_COMPANY', 'Company');
define('TABLE_HEADING_CUSTOMERS_WISHLIST', 'Wishlist Products');
define('TABLE_HEADING_CUSTOMERS_GROUP_NAME', 'Price Level');
?>

 

I can't see what is wrong, any help would be great

Thanks

 

 

Anyone ?

Share this post


Link to post
Share on other sites

Dear All,

 

what I like about Wishlist is that once you click "Add to Wishlist", you get a message displayed that the article has been added but the page stays focused on the product rather than jumping to the wishlist.

 

QUESTION: What changes do I need to make to get the same functionality on my shopping cart? Currently when putting products in the shopping cart, OSC jumps to the cart, however I want it to stay on the product and just display a message that the article has been added to the shopping cart.

 

I realize I may be in the wrong forum but as the functionality is so similar, I thought someone here might be able to help me - my OSC skills are not (yet) advanced enough to figure it out myself... :rolleyes:

 

Many thanks

BB

Share this post


Link to post
Share on other sites

After having problems with Wishlist 3.5 (newest version - just got a blank page every time I tried to go to the wishlist), I installed Wishlist 2.4b instead. I can now view the wishlist, but I have 2 problems:

 

1. The items added to the wishlist are not being displayed, but it says they're there. I looked in the database, and they do get added into customers_wishlist, but as product_id 0. customers_id is correct, but there is nothing for products_model and products_name, and the 3 last fields say 0.00 and 0. How can I get the right info added? When I edit one of the fields and just write in a product_id, it's displayed in the wishlist.

 

2. When e-mailing the wishlist, the URLs aren't displayed, as they should be as far as I can tell from wishlist_email.php. Only the product titles are displayed in the e-mail.

 

Any advice? My knowledge of php code is still a bit limited, and I would really like to get this up and running. TIA!

:)

Share this post


Link to post
Share on other sites

I dont support 2.0 and suggest going back to 3.x and your blank page prob I would turn on your php/apache error checking or have your server company turn it on as it seems it's turned off if you getting blank pages. Also have you viewed the page source? Maybe your redirects aren't working propery? I'm pretty sure I uses super globals so if register globals is off, it should still work propery, something to check anyway. Installation error? Could be any number of things...

 

-Dennis

Share this post


Link to post
Share on other sites
I dont support 2.0 and suggest going back to 3.x and your blank page prob I would turn on your php/apache error checking or have your server company turn it on as it seems it's turned off if you getting blank pages. Also have you viewed the page source? Maybe your redirects aren't working propery? I'm pretty sure I uses super globals so if register globals is off, it should still work propery, something to check anyway. Installation error? Could be any number of things...

 

-Dennis

Thanks for the tips!

 

I did install 3.5 3 more times, just to see if I had made some syntax error during the install, but the same thing happened every time. The wishlist.php just comes up blank. This is the only page on my entire site that comes up blank, so that's why I was wondering about the register_globals issue. But I'll try the other things, too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×