Jump to content
Johnson

Master Products - MS2

Recommended Posts

Hi,

 

I need some help, been reading in this thread without any luck about my request so here it comes.

 

I want to replace the default table for slaves with a pulldown menu that only showes "Model" names for the slaves.

and i want the model names to lead to the slaves page.

 

i hope someone can help me with this.

thanks

Share this post


Link to post
Share on other sites

I am having a problem with the images if someone could help out here....

 

http://www.totallygirly.com/bobby-jack-gro...1895-p-960.html

 

Now, let me start by saying that I have the size in product_info.php for the main image to be set at 250px width

 

Slave images is set at 90px wide

 

I turn on the images and this is what I get..some are the correct size, some are not. The images that are the right size are the images that I uploaded to the website AFTER turning on the images.

 

Also, wanting to sort the slaves by price, highest to lowest...how do I do this?? Can I also remove the + beside price so that can not be manually sorted?

 

Any ideas???

Edited by swtnhpy

Share this post


Link to post
Share on other sites
I am having a problem with the images if someone could help out here....

 

http://www.totallygirly.com/bobby-jack-gro...1895-p-960.html

 

Now, let me start by saying that I have the size in product_info.php for the main image to be set at 250px width

 

Slave images is set at 90px wide

 

I turn on the images and this is what I get..some are the correct size, some are not. The images that are the right size are the images that I uploaded to the website AFTER turning on the images.

 

Also, wanting to sort the slaves by price, highest to lowest...how do I do this?? Can I also remove the + beside price so that can not be manually sorted?

 

Any ideas???

 

You already pm'd me on this, and I stated that you appear to have problem with a) the image contribution (unknown) that you are using, or B) have a problem with the java script calls you are making for pop-up windows and image replacement in your product_info.php.

 

If you can enlighten someone here with what contributions you are using, we might be able to provide an answer.


GEOTEX from Houston, TX

 

(George)

Share this post


Link to post
Share on other sites

Yes, but I thought I'd come here to see if someone else could help. I have removed the code (pop up window code from the images from you) and still have the same issue. The only other contributions that I am using that would have anything to do with images would be extra images (checked the code and doesn't interfere), and lightbox.

Share this post


Link to post
Share on other sites
Yes, but I thought I'd come here to see if someone else could help. I have removed the code (pop up window code from the images from you) and still have the same issue. The only other contributions that I am using that would have anything to do with images would be extra images (checked the code and doesn't interfere), and lightbox.

 

I understand. All I suggested was give us a clue. since, as you found, the pop up window for master products has nothing to do with your image problem.

 

One of the image programs you specify is indirectly causing the problem. Check your code to be sure you are calling the correct functions in all areas. The contributions would give you changes for product_info.php or product_listing.php, but would not give you the code you need to insert in other modules like master_products.php or master_listing.php.

 

If you are using any specials listing or catalog printing contributions, you will need to check them also for image errors and code changes that may need to be made.

 

hth.

 

George

 

btw. I notice you have whislist installed on your site. Does it work properly with Master-Slave? I have been unable to get it working properly passing both items and attributes from the M-S contribution. If you have it working properly, this would solve an issue for several of us.

Edited by Geotex

GEOTEX from Houston, TX

 

(George)

Share this post


Link to post
Share on other sites

Please ignore the comment on using Wishlist. I checked your wishlist and see it doesn't work properly with Master-Slave either.

 

George


GEOTEX from Houston, TX

 

(George)

Share this post


Link to post
Share on other sites
I understand. All I suggested was give us a clue. since, as you found, the pop up window for master products has nothing to do with your image problem.

 

One of the image programs you specify is indirectly causing the problem. Check your code to be sure you are calling the correct functions in all areas. The contributions would give you changes for product_info.php or product_listing.php, but would not give you the code you need to insert in other modules like master_products.php or master_listing.php.

 

If you are using any specials listing or catalog printing contributions, you will need to check them also for image errors and code changes that may need to be made.

 

hth.

 

George

 

btw. I notice you have whislist installed on your site. Does it work properly with Master-Slave? I have been unable to get it working properly passing both items and attributes from the M-S contribution. If you have it working properly, this would solve an issue for several of us.

 

 

OH WOW....I know I have over 30 contributions in this store. :( I know it has something to do with images that were already in the store and images added recently as I have added new masters and slaves and the image size is working perfectly. Short of going through each and every product and renaming and re-uploading all the images..I'm unsure what to do as I have check the other files with a fine tooth comb and every piece of image code is using small_image_width and height. :(

 

And yes, my wishlist doesn't work right with masters/slaves but I haven't had time to figure out why.

Share this post


Link to post
Share on other sites

hello all

 

the products_listing_status tinyint(2) I change it to varchar(50) I need to find out where in the code it says to insert the data with tinyint(2)

 

thanks

Share this post


Link to post
Share on other sites

Hi, I just installed this contribution and I just have a quick question.

 

So when I assign a slave to a master, the slave shows up under the master product_info page. However, when I click on the slave, it still redirects me to the master product_info page.

 

Is it possible to make it so that the slave has its own product_info page?

 

-Simon

Share this post


Link to post
Share on other sites
Hi, I just installed this contribution and I just have a quick question.

 

So when I assign a slave to a master, the slave shows up under the master product_info page. However, when I click on the slave, it still redirects me to the master product_info page.

 

Is it possible to make it so that the slave has its own product_info page?

 

-Simon

 

go back and check the contribution http://addons.oscommerce.com/info/1681 you will find a pop-up contribution I added that will do what you want.


GEOTEX from Houston, TX

 

(George)

Share this post


Link to post
Share on other sites

Does this contribution have a dedicacated site where I can see screenshots of the admin-side cotrol panel? If not, does anyone have screenshots that they share with me?

 

I am asking because I am paying someone to install this contribution, and I have a feeling they have not done that. I am being told that things are controlled via the Product Attributes page. Does that sound right? Below is the mage of how I am being told the contribution works.

 

Thanks in advance for any clarificaton you can give me on this.

 

admin-setup.JPG

Share this post


Link to post
Share on other sites

I'm not sure what you are displaying to us. If the products have attributes, then it could be part of the display setup.

 

I did a custom rework of Master/Slave, and here are the instructions I wrote. All except the specific parts about a selling a set only would pertain to a normal installation of M/S.

 

Master-Slave doc


GEOTEX from Houston, TX

 

(George)

Share this post


Link to post
Share on other sites

Hello everyone,

 

It took me quite a while to install Master Products contribution, but it seems to work now. I have two questions and look for help:

1. For products without master or slave feature, in product description page, under the "select quantity" box, default number is 0. Can this be changed into 1?

2. I set Master product with price of 0. I also Hide Slave products. It seems if I search Slave product's model number, I can't find it. How can I enable the shopping cart to Find it by searching slave product's model number?

 

Thank you for your time. Any help is appreciated.

 

Best Regards,

 

Grant

Share this post


Link to post
Share on other sites

The products I had Master Products installed for do NOT have attributes. This is how the guys is telling me Master Products works. Looking at your image, I see where the Master and Slaves come into play. That does not appear in my instalation. Thanks so much for your help and your images.

 

I'm not sure what you are displaying to us. If the products have attributes, then it could be part of the display setup.

 

I did a custom rework of Master/Slave, and here are the instructions I wrote. All except the specific parts about a selling a set only would pertain to a normal installation of M/S.

 

Master-Slave doc

Share this post


Link to post
Share on other sites
Hello everyone,

 

It took me quite a while to install Master Products contribution, but it seems to work now. I have two questions and look for help:

1. For products without master or slave feature, in product description page, under the "select quantity" box, default number is 0. Can this be changed into 1?

2. I set Master product with price of 0. I also Hide Slave products. It seems if I search Slave product's model number, I can't find it. How can I enable the shopping cart to Find it by searching slave product's model number?

 

Thank you for your time. Any help is appreciated.

 

Best Regards,

 

Grant

 

Yes, it does take quite awhile to install this contribution. Takes even longer when you have a heavily modified cart.

 

If you did an install of a routine to hide products, look at the search,php and advanced_search.php pages. You will find a database call that you can undo to find hidden items. Just be careful how you word the filters, or you will also find a lot of stuff you may not want to show.

 

If you "hid" your products by using the catalog/admin/categories.php status feature to make a product inactive, you need to add a hide products contribution.


GEOTEX from Houston, TX

 

(George)

Share this post


Link to post
Share on other sites
Yes, it does take quite awhile to install this contribution. Takes even longer when you have a heavily modified cart.

 

If you did an install of a routine to hide products, look at the search,php and advanced_search.php pages. You will find a database call that you can undo to find hidden items. Just be careful how you word the filters, or you will also find a lot of stuff you may not want to show.

 

If you "hid" your products by using the catalog/admin/categories.php status feature to make a product inactive, you need to add a hide products contribution.

 

Hi, George,

 

Thank you note. I "hide" products in admin, slave products only show under master product page. Can you tell me the exact "hide products contribution"? I am still new to oscommerce and tried searching in contributions but found none.

 

Grant

Share this post


Link to post
Share on other sites

This was from post of 1608. It seems no one has answered it yet. Now I am having the same problem as well. Does anyone know?

 

*********************************************

HELPPPPPP!! Master Products And Easy Populate. I have setup the EP 2.76c module that has Master Products support.

 

My question is, do I need to setup the master products through my admin first and only use EP to setup the slaves?

 

I ask because in the v_products_master column for slaves you must specify the master products id. And the only way to get this is to setup the master in the admin and use a test slave product to view the drop down selection menu of available master products so it spits out that master products id in the box next to it. Then you take this number and copy it into EP v_products_maste field to make the slave match up with the master.

 

Is that the only way to do it? Isn't there a way I can just put in Master and Slaves in easy populate and have it work?

 

**help**

Share this post


Link to post
Share on other sites
This was from post of 1608. It seems no one has answered it yet. Now I am having the same problem as well. Does anyone know?

 

*********************************************

HELPPPPPP!! Master Products And Easy Populate. I have setup the EP 2.76c module that has Master Products support.

 

My question is, do I need to setup the master products through my admin first and only use EP to setup the slaves?

 

I ask because in the v_products_master column for slaves you must specify the master products id. And the only way to get this is to setup the master in the admin and use a test slave product to view the drop down selection menu of available master products so it spits out that master products id in the box next to it. Then you take this number and copy it into EP v_products_maste field to make the slave match up with the master.

 

Is that the only way to do it? Isn't there a way I can just put in Master and Slaves in easy populate and have it work?

 

**help**

 

Take a look at the newest release of easy populate. It is supposed to allow fields to be defined as needed in for existing fields in products and products_descriptions. I am not an ep expert, but know that a lot of security issues have been addressed in the updates, and can't imagine using the old release you mention for anything other than a template to make your changes in a new version.


GEOTEX from Houston, TX

 

(George)

Share this post


Link to post
Share on other sites
Take a look at the newest release of easy populate. It is supposed to allow fields to be defined as needed in for existing fields in products and products_descriptions. I am not an ep expert, but know that a lot of security issues have been addressed in the updates, and can't imagine using the old release you mention for anything other than a template to make your changes in a new version.

Again, thank you for your help. It seems the most updated one supporting Master Products is 2.76C, which is what I am using right now. I will try newer version one by one. I am sure the 2.76G didn't work at all.

Share this post


Link to post
Share on other sites
Again, thank you for your help. It seems the most updated one supporting Master Products is 2.76C, which is what I am using right now. I will try newer version one by one. I am sure the 2.76G didn't work at all.

 

I went looking for that one after I posted, couldn't find that specific version. Can you post the link to it, or pm the file to me.

 

Thanks,

 

Never mind, Found it.

Edited by Geotex

GEOTEX from Houston, TX

 

(George)

Share this post


Link to post
Share on other sites

Hi, I have MS2 installed already and it's running fine. However, right now I am trying to add over like a 100 master to a single slave. (i.e a screen protector that applies too all phone models). I realized that the number of master allowed for a single slave is limited?

 

Is there anyway to increase this number to infinite?

 

Any help would be appreciated.

 

-Simon

Share this post


Link to post
Share on other sites

I need to find a way to customize the includes/modules/product_listing.php to show this:

 

Master | Master Name

Image | Master Description

-----------------------------------------

Slave Item # | Slave Description | Slave Price | Qty box | Add to Cart

 

So the Master Image is covering two rows, and the next column has the Master Product Name in the top row and the Master Product Description in the 2nd row.

 

Then a new table underneath each Master showing the Slave's information (one row per slave)

 

I'm having a bugger of a time figuring this out - was hoping someone else here might have some ideas :blush:


~Tracy
 

Share this post


Link to post
Share on other sites

Does anyone have any idea how to fix the problem where if I make the non purchased slave products 0 or blank it still comes through as 1 in the cart?

 

Its driving me nuts, I think I have searched everywhere and tried everything.

 

thanks

Rod

Share this post


Link to post
Share on other sites
Does anyone have any idea how to fix the problem where if I make the non purchased slave products 0 or blank it still comes through as 1 in the cart?

 

Its driving me nuts, I think I have searched everywhere and tried everything.

 

thanks

Rod

 

Kind of lost you on this. Do you mean set all listed products to 0, then let the customer increase the quantity? If so, catalog/includes/modules/master_listing.php has 2 lines to change, approx 191 & 200, look for

 

$lc_text = tep_draw_input_field('Qty_ProdId_' . $listing['products_id'], '1', 'size="4"');

 

change to:

 

$lc_text = tep_draw_input_field('Qty_ProdId_' . $listing['products_id'], '0', 'size="4"');

 

If you mean when you change an item from 1 to 0 it is still added to the cart, look for a coding error that happened somewhere while you were installing. Probably in application_top.php.


GEOTEX from Houston, TX

 

(George)

Share this post


Link to post
Share on other sites

I have been using Master Products for a long time and it has worked fine. Recently my web host updated the PHP version on my server to V5.2.6 and now I have a problem with master products:

 

Adding to the cart from the master listing does not work. i.e when you view a master product, enter quantities and add to the cart, the cart remains empty.

 

My products are still added to the cart from a normal product listing.

 

Has anyone else had this problem with a php upgrade, or does anyone know what changes in php may have caused it?

 

Thanks in advance for any help.

 

Tim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×