Jump to content
Sign in to follow this  
adrian##

fixes to PhpBB contribution

Recommended Posts

Hi,

 

I have installed chaveiro's PHPBB 2.0.8a Contribution. I got everything to work, except that I cannot go into admin.

 

When I type:

http://localhost/catalog/admin/bb_default.php in my browser, I get the following error:

 

Fatal error: Failed opening required 'includes/configure.php' (include_path='.;c:\php4\pear') in C:\FoxServ\www\catalog\includes\application_top.php on line 29

 

My line 29 in application_top.php looks like this:

require('includes/configure.php');

 

Any Ideas?

 

Thanks,

David

Share this post


Link to post
Share on other sites

Hi there,

 

Nevermind, I found the fix for this:

 

In catalog/includes/application_top.php FIND:

require('includes/configure.php');

 

CHANGE TO:

 

if(defined('ADMIN')){
require('../../includes/configure.php');
}else if(defined('IN_PHPBB')){
require('../includes/configure.php');
}else{
require('includes/configure.php');
}

 

ALSO In catalog/includes/configure.php

DELETE

define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_INCLUDES', 'includes/');

 

FIND

 

define('DIR_WS_HTTPS_CATALOG', '');

 

ADD

 

if(defined('ADMIN')){  
  define('DIR_WS_IMAGES', '../../images/');
  define('DIR_WS_INCLUDES', '../../includes/');
}else if(defined('IN_PHPBB')){
  define('DIR_WS_IMAGES', '../images/');
  define('DIR_WS_INCLUDES', '../includes/');
}else{
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
}

 

The above fix was taken from oldpa's phpbb contribution, so all credits goes to him.

 

That should do it!

StrictlyPC

Share this post


Link to post
Share on other sites

Thanks Swisschris for you solution its about the first thread I've read where it actually has a solution. It worked great on my site!

Share this post


Link to post
Share on other sites

Hi.

 

I wonder if anyone can help with this...

 

I have installed the PhpBB contribution. Everything seems OK, but I get the following problem:

 

When I log-in and then Post 'anything', i.e. a reply, I get the dreaded

 

Warning: Cannot add header information - headers already sent by

(output started at c:\apache\htdocs\catalog\modules.php:28)

in

c:\apache\htdocs\catalog\includes\modules\phpbb2\posting.php on line 591

 

The post is successful, but I am then showing as 'logged out', and must log-in again.

 

Any help at all would be gratefully received.

 

:(

 

Regards

 

Steve

Share this post


Link to post
Share on other sites

Hi,

 

there is an answer either on this thread or another phpBB thread... it took me a hile to find, but from memory, there are some lines of code in posting.php which relate to cookies that need to be commented out.... (I think that they also exist in general.php too)

 

cheers

 

 

andy


with ten thousand dollars we'll all be millionaires

Share this post


Link to post
Share on other sites

im installing the phpbb contrib posted on osc's site and im stuck at this point in the install. Im hosted on a windows server and not sure what to do with this.

 

###########################################################
Perform the folowing command at .\catalog if on a unix shell :

ln -s includes/modules/phpbb2/templates/ templates

This creates a virtual folder to where templates are really and is important as allow to install other templates without any modifications.
If you dont have access to unix, it should be possible to implement using a the modwrite engine at .htaccess. Or just replicate the folder includes/modules/phpbb2/templates/ to /catalog/.
###########################################################

 

check my site at www.fatkap.net i just pput osc in yesterday.


FatKap.Net

Contributions:

adminlogin_md5

Guest Account

Advanced Search Infobox

autologin_secure

catalog_products_with_images

Coppermine gallery

Loginbox

paypal accept

phpbb208a

and my very own links box

Share this post


Link to post
Share on other sites

i finished the install skipping that step and the forum works with some miscelaneous errors.

 

Warning: Cannot add header information - headers already sent by (output started at path\modules.php:28) in path\includes\modules\phpbb2\viewtopic.php on line 55


FatKap.Net

Contributions:

adminlogin_md5

Guest Account

Advanced Search Infobox

autologin_secure

catalog_products_with_images

Coppermine gallery

Loginbox

paypal accept

phpbb208a

and my very own links box

Share this post


Link to post
Share on other sites

From much searching of the forums i fixed all my errors and my forums seem to be running fine. Now i know i saw somewhere how to turn the side blocks on and i cant seem to find that again. Does anybody know how?


FatKap.Net

Contributions:

adminlogin_md5

Guest Account

Advanced Search Infobox

autologin_secure

catalog_products_with_images

Coppermine gallery

Loginbox

paypal accept

phpbb208a

and my very own links box

Share this post


Link to post
Share on other sites

hay thanks for the quick reply ppl

:P


FatKap.Net

Contributions:

adminlogin_md5

Guest Account

Advanced Search Infobox

autologin_secure

catalog_products_with_images

Coppermine gallery

Loginbox

paypal accept

phpbb208a

and my very own links box

Share this post


Link to post
Share on other sites

i added this forum contribution successfully.. but there's a strange slash problem

 

When adding or editing the post,

 

For example,

How's things

becomes

How\'s things

 

Any ideas how to fix this?

Edited by kennlee

Share this post


Link to post
Share on other sites

What is wrong with me I am the only one that cant get this mod to work.

I have problems in login.php, logoff.php, account_edit.php and Create account.php

 

I followed the instructions exactly and the bug fixes

 

in login.php it wont login it just brings me back to the login page. i cant log in at all.

in create_account.php i get this error

 

1146 - Table 'compunee_John77.TABLE_PHPBB_USERS' doesn't exist

insert into TABLE_PHPBB_USERS (user_id, user_active, username, user_password, user_session_time, user_session_page, user_lastvisit, user_regdate, user_level, user_posts, user_timezone, user_style, user_lang, user_dateformat, user_new_privmsg, user_unread_privmsg, user_last_privmsg, user_emailtime, user_viewemail, user_attachsig, user_allowhtml, user_allowbbcode, user_allowsmile, user_allowavatar, user_allow_pm, user_allow_viewonline, user_notify, user_notify_pm, user_popup_pm, user_rank, user_avatar, user_avatar_type, user_email, user_icq, user_website, user_sig, user_sig_bbcode_uid, user_aim, user_yim, user_msnm, user_occ, user_interests, user_actkey, user_newpasswd) values ('78', '1', 'KLkjl;kj', 'f05bed2c1c56a15ba32acf6430bf24a3', '1094420320', '0', '', '1094420320', '0', '0', '0', '1', 'english', 'D M d, Y g:i a', '0', '0', '0', '', '0', '1', '0', '1', '1', '1', '1', '1', '0', '1', '1', '0', '', '0', 'jo@compuneeds.net', '', '', '', '', '', '', '', '', '', '', '')

[TEP STOP]

 

but i looked in my DB and it is there as clear as day

and the line is there in database_tables.php

 

why wont it work please help

Share this post


Link to post
Share on other sites

I've read some and scanned all of the phpBB discussion on this forum that I can find. It seems that the contribution for using phpBB and oscommerce together don't really connect the two. I've signed up on a few sites using it and have to register twice to join the forums and attempt to order something.

 

After some more investigation I might attempt to merge the two in a way. In other words, having the customer/forum member database be one. Has anyone tried this? I think it would be nice to have one login for both. Most of the sites I maintain don't have a need for just an ecommerce system but more or less a forum with the ability to allow members to purchase things via an ecommerce system.

Share this post


Link to post
Share on other sites

I've had it working fine on my website previously, but un-integrated it (following instructions for converting a nuked-phpbb2 back to standalone) so that I could integrate phpbb2 with a coppermine gallery. That integration was more important to me, and I didn't see the point in making my users enter in as much customer info as osC requires just to use the forums.

 

My $.02.

 

-jared

Share this post


Link to post
Share on other sites

im a lost noob, do i install the base phpbb app to includes/modules/phpbb2/ of the oscommerce site? if i do this, will i need to run the phpbb install? if so, how? (i pointed to includes/modules/phpbb2/install/index.php and the server says im not auth to view file...

 

 

is there a rewrite of the install instructions, I cannot fully understand the english in the current install text. I can get phpbb to run as a seperate script, but when making the two (osc and phpbb) work as a team thats where all hell breaks loose

Share this post


Link to post
Share on other sites

also, im really into SEO, and for some reason, when I "disable" search engine friendly urls my catalog doesnt work, (clicks just recycle to the index page) but the forum does?, i dunno...

Share this post


Link to post
Share on other sites

Well all, I have re-installed my phpbb, and it is working to my taste, should I then move that dir to the /includes/modules/phpbb dir, and then try the contrib from there..

Share this post


Link to post
Share on other sites

WEll searching high and low for fixes and such and got the admin side working (I think, the admin panel comes up at least) But if I click on the link on the main page I get:

 

http://www.MyDomain.com/location-to-store/catalog/modules.php?op=modload&name=phpbb2&file=index.php

 

The browser then gives me the page can not be found. I turned off search engine safe URLS but still get the same. Ideas?

Edited by 1quicksi

Share this post


Link to post
Share on other sites
So it is possible to have 1 universal login for both osc and phpbb using this contrib???

 

 

on my site it is working form first try, visit HERE

 

you can test it .. we're going live on 1st of January .. we will delete everything before 1st.

 

also i have following two questions for developers of this contribution;

 

- Have you heard of latest hacks on phpbb .. they recommned upgrade to 2.11 .. what cen WE do

 

- Have you try to make any INFOBOX for latest topics or something .. i have tried several mods within phpbb but they seems not to work, because i guess there are some differences in paths or urls

 

thanx

Share this post


Link to post
Share on other sites

I'm seriously wanting to combine my phpBB forum with osC. The above site mentioned I could not even find his Forum?

 

Does anybody have this working with the osC shell (I still want the L&R boxes). I also could not decript the zip file: PHPBB 2.0.8a implementation in oscommerce ms2

 

I use WinZip and it say there is a problem with the zipped file?

 

With all the formentioned problems, any input would be appreciated.

 

Thanks, KJ


define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites

go back and take another look at:

 

Aussiehealthandfitness

 

If you look at the top of the page you will see a tab that says forum try clicking that.... if thats no good there is also a link under the information box. it says Forum. Its still under development but now its mainly the look of the site we're working with.

Share this post


Link to post
Share on other sites

Hi top_speed

 

as i remember the zip file has two extensions .. just remove the last one .. it is like contriv.rar.zip .. or reverse .. .zip.rar .. just remove last extension ...

 

but there is other thing .. i strongly recommend NOT to install this contribution, because at PhpBB forum they strongly advice upgrading to 2.11 version, since in older version are bugs found, and already some sites went down because of hacking, with little help form this bug :blink:

 

i have posted few questions about upgrading here on this forum but no answer .. so untill fix my phpbb forum is down :thumbsup: :(

Share this post


Link to post
Share on other sites

if you read this thread and the other couple that are around you will find the fixes for all your questions... there all here you just have to look for them... I personally dont have the time to go looking for you but there all here.

Share this post


Link to post
Share on other sites

maybe i wasn't clear enough .. i was talking about security risks and critical update .. mentioned on phpbb site .. a month ago .. where they say that everybody should upgrade to 2.11 version ... SECURITY RISK

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×