Jump to content
Sign in to follow this  
adrian##

fixes to PhpBB contribution

Recommended Posts

Don't forget to edit profile.php and privmsg.php the same way.

 

1x profile.php

5x privmsg.php

 

From:

 

 $navigation->set_snapshot();
tep_redirect(tep_href_link(FILENAME_LOGIN, '', 'SSL'));

 

 

To:

 

?>
<script LANGUAGE="JavaScript">
<!-- Begin
if (navigator.javaEnabled()) 
window.location = "login.php";
else 
window.location = "login.php";
//  End -->
</script>
<?php

Share this post


Link to post
Share on other sites

Jcall,

We are using the latest phpbb2 contribution from oscommerce which is PHPBB 2.0.8a implementation by Chaverio. The other forums that i have seen are discussing an earlier version of the contribution.

 

SwissChris,

I'm currently using a template i downloaded from PHPBB which is not the default. All the fixes we have applied have worked correctly. I also applied the changes to profile.php and privmsg.php, which i must say worked great again. Thanks.

 

But when i try to change the forum with the Jump To: drop down box i get:

Sorry File Doesn't Exist!

 

Is that the same thing your talking about ?(jumping to another forum by choosing it from the drop down box).

Share this post


Link to post
Share on other sites

Yes, exactly right! I have not read into the code to much yet, but I am sure there is an easy solution. Maybe the creator of the mod could give us a hint...?

 

I just got done rewriting the subSilver to my needs. Adapted it to bcInvert a simple, yet nice looking theme. At this stage, it's easier for me to get them together this way.

Edited by SwissChris

Share this post


Link to post
Share on other sites

Question:

 

Were you able to control users via the phpbb admin. Like ban them etc. Just wondering because my username search windows appears to be an error. Works on the user front though?

Edited by SwissChris

Share this post


Link to post
Share on other sites

Ok. Here's a nice one!!!!

 

When users sign up it ads the date when they joined the forum to the members list. Now, if one of your users enters his profile and posts his email or does any other change in the profile, the date when the user supposedly joined, changes to 01. January 1970. What do you think the problem is located?

 

By the way... It does it in the Contrib Distributors Forum as well! :D

Edited by SwissChris

Share this post


Link to post
Share on other sites

Ignor the last post. It only happened to users during unfinished setup of forum. After, I ran a database fix on configuration, it works flawless!

Edited by SwissChris

Share this post


Link to post
Share on other sites

SwissChriss,

Are you using my system. LOL. Looks like we have the same issues and yes i get a page cannot be displayed we i try to ban, delete, etc. a user through the phpadmin panel. The page that it refers to is bb_modules.php but there is no such page in the contribution or anywhere else. I have been looking for this page all day. Still working on it, if anything is discovered i'll give you a heads up.

 

I'm gonna try to change a profile within the forum to see if i also need to run the a database fix. Thanks.

Share this post


Link to post
Share on other sites

Question:

 

Did you ever get the upmysql.php to work on your forum? I would love to import the data, but it only returns db error. Would you mind posting the code? Thanks!

Share this post


Link to post
Share on other sites

SwissChris,

Ok, i got the search under the admin panel to search for users under ban control, management, and permissions. To make this work you have to edit three files. They are under /catalog/admin:

The first one is admin_user_ban.php. Change line around 445.

Change This:

'U_SEARCH_USER' => append_sid("./../bb_search.$phpEx?mode=searchuser"),

To this:

'U_SEARCH_USER' => append_sid("./../search.$phpEx?mode=searchuser"),

 

In admin_users.php change line around 1124.

Change This:

'U_SEARCH_USER' => append_sid("./../bb_search.$phpEx?mode=searchuser"),

To This:

'U_SEARCH_USER' => append_sid("./../search.$phpEx?mode=searchuser"),

 

In admin_ug_auth.php change line around 899.

Change This:

'U_SEARCH_USER' => append_sid("../bb_search.$phpEx?mode=searchuser"))

To This:

'U_SEARCH_USER' => append_sid("../search.$phpEx?mode=searchuser"))

I just made these changes and the admin panels search for user works fine. Also if you want to change the width of the username look up window that pops up, you can edit these files: user_ban_body.tpl, auth_ug_body.tpl and change the width where it says onclick="window.open

 

I'll post that upmysql.php in a few. Hope this helps.

Share this post


Link to post
Share on other sites

Here is the upmysql.php that i used. Hopefully it will work for you.

 

<?php
// ------------------------------------------------------------------------- //
//  GNU General Public License for more details.                             //
//                                                                           //
//  You should have received a copy of the GNU General Public License        //
//  along with this program; if not, write to the Free Software              //
//   author:  Oldpa                                                    //
//  web site:  http://oldpa.adsldns.org  http://www.oldpa.com.tw        //
// ------------------------------------------------------------------------- //
function install_header(){

?>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title>OSC User Converter to PHPBB</title>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo _CHARSET;?>">
<meta name="AUTHOR" content="osCommerce">
<meta name="GENERATOR" content="oldpa-- http://www.oldpa.com.tw/">
</head>
<body>
<div style='text-align:center'><img src='http://www.oldpa.com.tw/images/s_poweredby.gif' /><h3>CONVERT LINE 1</h3><br />
<?php
}

function install_footer(){
?>
<br /><br /><a href='http://www.oldpa.com.tw/' target='_blank'><img src='images/logo1.gif' alt='www.oldpa.com.tw' border='0' /></a></div>
</body>
</html>
<?php
}

if ( !isset($action) || $action == "" ) {
$action = "message";
}

if ( $action == "message" ) {
install_header();
echo "
<table width='90%' border='0'><tr><td colspan='2'>CONVERT LINE 2</td></tr><br>
<tr><td>-</td><td>XXXXX | YYYYY | ZZZZZ</b></td></tr>
<tr><td>-</td><td>CONVERT LINE 4</b></td></tr>
<tr><td>-</td><td><span style='color:#ff0000;font-weight:bold;'>CONVERT LINE 5</span></td></tr>
</table>
";
echo "<p>CONVERT LINE 6</p>";
echo "<form action='".$PHP_SELF."' method='post'><input type='submit' value='submit' /><input type='hidden' value='upgrade' name='action' /></form>";
install_footer();
exit();
}

if ( $action == "upgrade" ) {
require('includes/application_top.php');
install_header();
echo "<h4>CONVERT LINE 7</h4>\n";
$error = array();

/*tep_db_query("insert into " . TABLE_PHPBB_USERS . " (user_id , user_active, username, user_password ,user_session_time , user_session_page ,
                                                    user_lastvisit , user_regdate , user_level , user_posts , user_timezone , user_style ,
                                                 user_lang , user_dateformat , user_new_privmsg , user_unread_privmsg , user_last_privmsg ,
             user_emailtime , user_viewemail , user_attachsig , user_allowhtml , user_allowbbcode ,
             user_allowsmile ,user_allowavatar ,user_allow_pm , user_allow_viewonline ,user_notify ,
             user_notify_pm ,user_popup_pm , user_rank , user_avatar ,user_avatar_type ,user_email ,
             user_icq ,user_website ,user_from ,user_sig , user_sig_bbcode_uid , user_aim , user_yim ,
             user_msnm ,user_occ , user_interests , user_actkey , user_newpasswd)
             SELECT customers_id , '1', concat(ucase(left(customers_firstname,1)), ' ' , customers_lastname) , customers_password , '', '',
             'time()', 'time()', '0','0','0.00','1',
             'english','D M d, Y g:i a', '0','0','0',
             '0','0','1','0','1',
             '1','1','1','1','0',
             '1','1','0','','0',customers_email_address,
             '','','','','','','','','','','',''
              FROM ".TABLE_CUSTOMERS." WHERE customers_id");
*/
echo "insert into " . TABLE_PHPBB_USERS . " (user_id , user_active, username, user_password ,user_session_time , user_session_page ,
                                                    user_lastvisit , user_regdate , user_level , user_posts , user_timezone , user_style ,
                                                 user_lang , user_dateformat , user_new_privmsg , user_unread_privmsg , user_last_privmsg ,
             user_emailtime , user_viewemail , user_attachsig , user_allowhtml , user_allowbbcode ,
             user_allowsmile ,user_allowavatar ,user_allow_pm , user_allow_viewonline ,user_notify ,
             user_notify_pm ,user_popup_pm , user_rank , user_avatar ,user_avatar_type ,user_email ,
             user_icq ,user_website ,user_from ,user_sig , user_sig_bbcode_uid , user_aim , user_yim ,
             user_msnm ,user_occ , user_interests , user_actkey , user_newpasswd)
             SELECT customers_id , '1', concat(ucase(left(customers_firstname,1)), ' ' , customers_lastname) , customers_password , '', '',
             'time()', 'time()', '0','0','0.00','1',
             'english','D M d, Y g:i a', '0','0','0',
             '0','0','1','0','1',
             '1','1','1','1','0',
             '1','1','0','','0',customers_email_address,
             '','','','','','','','','','','',''
              FROM ".TABLE_CUSTOMERS." WHERE customers_id";

tep_db_query("insert into " . TABLE_PHPBB_GROUPS . " (group_id , group_type, group_name , group_description  ,group_moderator  , group_single_user)
                                                         SELECT customers_id+1,'1','','Personal User','0','1' FROM ".TABLE_CUSTOMERS." WHERE customers_id <> 1");

tep_db_query("insert into " . TABLE_PHPBB_USER_GROUPS . " (group_id , user_id , user_pending)
                                                               SELECT g.group_id ,u.user_id ,g.group_moderator FROM ".TABLE_PHPBB_GROUPS." AS g , ".TABLE_PHPBB_USERS ." AS u WHERE g.group_id = u.user_id+1");

}
echo "<div style='text-align:center;'><h4>CONVERT LINE 8</h4>\n";
echo "<table width='70%' border='0'><tr><td>";
echo "</td></tr></table><br /><br /><a href='".HTTP_SERVER."/'>HOME</a>";

install_footer();

?>

 

Hope it helps. I'm gonna see the next issue we are having which is the drop down box to jump to another forum. I hope this one is easy. Let me know if you find anything, even a hint, maybe it will point me in the right direction. Thanks.

Share this post


Link to post
Share on other sites

Hmm, I tried that as well and I still get the following error message:

 

insert into phpbb_users (user_id , user_active, username, user_password ,user_session_time , user_session_page , user_lastvisit , user_regdate , user_level , user_posts , user_timezone , user_style , user_lang , user_dateformat , user_new_privmsg , user_unread_privmsg , user_last_privmsg , user_emailtime , user_viewemail , user_attachsig , user_allowhtml , user_allowbbcode , user_allowsmile ,user_allowavatar ,user_allow_pm , user_allow_viewonline ,user_notify , user_notify_pm ,user_popup_pm , user_rank , user_avatar ,user_avatar_type ,user_email , user_icq ,user_website ,user_from ,user_sig , user_sig_bbcode_uid , user_aim , user_yim , user_msnm ,user_occ , user_interests , user_actkey , user_newpasswd) SELECT customers_id , '1', concat(ucase(left(customers_firstname,1)), ' ' , customers_lastname) , customers_password , '', '', 'time()', 'time()', '0','0','0.00','1', 'german','D M d, Y g:i a', '0','0','0', '0','0','1','0','1', '1','1','1','1','0', '1','1','0','','0',customers_email_address, '','','','','','','','','','','','' FROM customers WHERE customers_id1062 - Duplicate entry '55' for key 1

 

insert into phpbb_groups (group_id , group_type, group_name , group_description ,group_moderator , group_single_user) SELECT customers_id+1,'1','','Personal User','0','1' FROM customers WHERE customers_id <> 1

 

[TEP STOP]

 

Question:

 

Is it not an issue with the entries already made for users signed up, I mean since the installation of the phpbb of course, since they are added to the memberlist as soon as current members login the first time upon installation?

Edited by SwissChris

Share this post


Link to post
Share on other sites

Warning!!!!!!

 

There is a major flaw and I could not solve it with str_replace its the sign \\&\\ in Emails upon post notification. Any link won't work, it's only working if it were an html email. Any solutions are welcome!!

Share this post


Link to post
Share on other sites

Not sure exactly what you mean. Are you talking about receiving an email when their is a post?

Share this post


Link to post
Share on other sites

Does anyone have an Idea where this could come from when starting

 

/catalog/admin/bb_default.php

 

 

Fatal error: Cannot instantiate non-existent class: sql_db in /home/www/geizpreis_at/catalog/includes/modules/phpbb2/includes/db.php on line 60

 

Thanks for your possible help,

Ernst

:huh:

Share this post


Link to post
Share on other sites

Answer to Ernst Steiniger:

 

You asked:

 

Does anyone have an Idea where this could come from when starting

 

/catalog/admin/bb_default.php

 

Fatal error: Cannot instantiate non-existent class: sql_db in /home/www/geizpreis_at/catalog/includes/modules/phpbb2/includes/db.php on line 60

 

Answer:

 

You have a chmod issue. Solve it by using for example WS_FTP or any other FTP Program and CHMOD your phpbb2 directory, the following includes directory and finally the db directory to 777. You can do that with all boxes marked.

 

Security Issue:

 

Ok, here is a good one!!! In order for the admin to have access to the phpbb administration, one can not secure phpbb, the includes folder or the db folder with .htaccess, which according to phpbb experts needs to be secured from hackers. You try to secure them with an .htaccess file and you get the above issue!

Well, I can certainly confirm the warnings from the phpbb experts!!!! Only, after having the forum online for a few days, my forum got hacked today for the first time and I suddenly found the strangest user names!!!

 

Well, I believe this is not a security issue to the osc database, or how do you see it? However the hacker did not distroy any data, nor did he make entries, since I tried to log back in with his username and after changeing the password in phpmyadmin to somehting familiar, the login was still not possible, since if there is no entry in the osc user db, it won't let him log back in. He tried twice with different names. Yet, the possibility of having a guy try to hack all of the db isn't really charming. This is reason enough to take down the script from the site!!!

 

Do you know how we can otherwise resolve this issue. Another issue is the amp; in the emails sent via email. If you open a topic and other users are replying you are being informed and in that mail is a link to the topic or post you made. To back the amp; in the url causes an error page rather than the topic. If you delete the amp; manually from the url they than work again. Can't expect all of your users to do that! Well, I tried to str_replace the amp; which it wouldn't let me.

 

Remarks:

 

Ok, you guys probably figured out in the meantime, that this phpbb is basically the phpbb mod for phpnuke! No wonder, we can get so little support from the "contributor" of this mod! Is it possible that you don't know your code well enough? I don't think I am going to spend much more time on this... since no real support is provided. The "contributor" still runs version 2.0.6 on his site which is totally disfunctional! Won't even let you log in after you open an account!

Edited by SwissChris

Share this post


Link to post
Share on other sites

Hi there I got the mod working fine, but I can not figure out how to get the side bars on it. The top template and bottom work fine.

 

thanks,

 

scott

Share this post


Link to post
Share on other sites

Since adding the boards, is anyone getting reports from customers that items are being mysteriously added/removed from their carts?

 

-jared

Share this post


Link to post
Share on other sites
Hi there I got the mod working fine, but I can not figure out how to get the side bars on it. The top template and bottom work fine.

 

The code is there, but commented out by default. I had symbol problems with the right column, so I just took them back off.

 

The left column code to uncomment is in catalog/modules.php .

The right column code to uncomment is in catalog/includes/modules/phpbb2/includes/page_tail.php .

 

Just search for BOX_WIDTH and you'll find them.

 

-jared

Share this post


Link to post
Share on other sites

Jcall can you be more specific about your last post. Left Column missing. Sorry, newbie here!

 

Thanks,

Bragg

Share this post


Link to post
Share on other sites

in catalog/modules.php, change this:

<!-- body //-->
<table border="0" width="100%" cellspacing="3" cellpadding="3">
 <tr>

<!--
<td width="//<?php echo BOX_WIDTH_LEFT; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH_LEFT; ?>" cellspacing="0" cellpadding="2"> 
-->
<!-- left_navigation //-->

<!-- left_navigation_eof //-->

 

to this:

<!-- body //-->
<table border="0" width="100%" cellspacing="3" cellpadding="3">
 <tr>


<td width="//<?php echo BOX_WIDTH_LEFT; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH_LEFT; ?>" cellspacing="0" cellpadding="2"> 

<!-- left_navigation //-->

<!-- left_navigation_eof //-->

 

in catalog/includes/modules/phpbb2/includes/page_tail.php, change this:

<!-- body_text_eof //-->
<? /*
<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->
   </table></td>
*/ ?>
 </tr>
</table>
<!-- body_eof //-->

 

to this:

 

<!-- body_text_eof //-->
<? 
<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">
<!-- right_navigation //-->
<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>
<!-- right_navigation_eof //-->
   </table></td>
?>
 </tr>
</table>
<!-- body_eof //-->

 

-jared

Share this post


Link to post
Share on other sites

Jcall,

Thanks for the help on that one! My next question, Is there anyway to get rid of the background of the page? Basically I just want to have the board. The stock background color is taking over my site (messing up my header, side bar, etc...)

 

Thanks

Share this post


Link to post
Share on other sites

yes - - it's in the stylesheet (style.css, if I remember correctly) for the Subsilver profile. You can edit it with phpbb's admin page.

 

-jared

Share this post


Link to post
Share on other sites
is there any where to go to get an installer of tis contibution that works?

Not that I know. I'd go through and clean it up if I had the time, but I don't right now.

 

As it is, I'm probably going to dis-integrate the board with osCommerce, because I'd rather have an integrated userbase in my gallery and board than an integrated userbase in the board and osCommerce.

 

-jared

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×