Jump to content
Sign in to follow this  
frankl

[Contribution] Step-By-Step Manual Order

Recommended Posts

When I use this it records order totals in the following format "349) it should be "$349.99". Anyone know how to fix this...?

Share this post


Link to post
Share on other sites

I have installed the contrib and when I click on select customer or confirm it leaves out a my main domain part of my https address. It looks like this..

 

https://ssl.perfora.net/catalog/admin/create_order.php instead of https://ssl.perfora.net/eyetechdigital.net/...g/catalog/admin

 

If I manually type it in it works. It does it throughout all of the editing pages. What is configured incorrectly..also when I go to edit_orders and click update I'm getting this parse error..

 

Warning: Invalid argument supplied for foreach() in /homepages/12/d95204434/htdocs/catalog/admin/edit_orders.php on line 222

 

Warning: Cannot modify header information - headers already sent by (output started at /homepages/12/d95204434/htdocs/catalog/admin/edit_orders.php:222) in /homepages/12/d95204434/htdocs/catalog/admin/includes/functions/general.php on line 18

 

is there a certain line section the code that came with contrib needs to be entered at in the general.php file.

 

Any help would be great.

 

Running MS2

Share this post


Link to post
Share on other sites

I just installed the beta order editor and it works great except on my admin side when it shows the customers orders on admin/orders.php it only shows the first 2 numbers of their total (ie 31) not $31.26

 

how can i fix this??

 

 

jeff

Share this post


Link to post
Share on other sites
ok...went through a few tests for creating orders and two things stand out. First one is easy to fix (I think & hope) but the 2nd might not be....

 

1- The total amount for the order is not saved in currency. so if you view an order you create manually, the total will show up like 15 instead of $15.00. I will look at the code but I think we need to use the currency function...

To Fix the $$ problem go to line 43 or so and find

$temp_amount = number_format($currency, 2, '.', '');
 $currency = "GHB";
 $currency_value = "1";
 

 

and replace with

 

$temp_amount = number_format($temp_amount, 2, '.', '');
 $currency = "USD";
 $currency_value = "1";
 

 

that will fix that problem.

I tried this but I still get only a 31 under ORDER TOTAL on orders.php page

 

any ideas??

Share this post


Link to post
Share on other sites

Just wondering if anyone has ever got this working with payment gateways?

I would like to be able to manually enter credit card numbers over the phone...

 

Thanks

Kyle

Share this post


Link to post
Share on other sites
Any one else having the problem that when you manually add items to an order that are on special that it does not calculate the price correctly. It lists it as the regular price.

 

If this has already been addressed let me know and I'll read through the thread.

 

Thanks

Hello,

 

could the problem be solved? I have the same Problem.

Share this post


Link to post
Share on other sites
..also when I go to edit_orders and click update I'm getting this parse error..

 

Warning: Invalid argument supplied for foreach() in /homepages/12/d95204434/htdocs/catalog/admin/edit_orders.php on line 222

 

Warning: Cannot modify header information - headers already sent by (output started at /homepages/12/d95204434/htdocs/catalog/admin/edit_orders.php:222) in /homepages/12/d95204434/htdocs/catalog/admin/includes/functions/general.php on line 18

 

is there a certain line section the code that came with contrib needs to be entered at in the general.php file.

 

Any help would be great.

 

Running MS2

Same problem here...

 

It was asked about 6 times in the last year still no answer...

 

Anybody has a solution for this ?

 

Any help appreciated!

Edited by goyo

Share this post


Link to post
Share on other sites

Hello-I'd like to install and use this module but after spending all last night following the install instructions and it fails to operate-

 

The box appears in the admin-Create order and create account but when i click-I get page cannot be displayed "/admin/FILENAME_CREATE_ORDER.

 

Anyone have any ideas? or does anyone want some Paypal cash to sort this out for me?

 

Let me know.

 

PS.My shop is a fresh install and is not live

 

There are also some other modules I want to install but as I am not a proggrammer even the simple tasks are difficult.

:unsure:

Share this post


Link to post
Share on other sites

I've looked through the thread and I can't find any mention of it, but in the main OSC configuaration there is a setting for 'Subtract product in stock by product orders' which can be set to 'true' or 'false'. It appears that the Manual Order contrib ignores this setting and will subtract stock quantities regardless of this setting.

 

Was anybody aware of this? And anybody have any suggestions for stopping it from doing so?

 

Cheers

Matt

Share this post


Link to post
Share on other sites

After reading every response here, I'm convinced that while this mod has potential, it's rather lacking.

 

All I wanted was something that would allow me to take orders manually. Seemed simple enough - create an account, then use the same order process that's already built into the system, with shipping and credit card, etc. options that we've already enabled (our gateways).

 

Instead, I get something that really only creates accounts. The shipping defaults to FedEx for Canada, for some bizarre reason - I don't even use FedEx. Secondly, it doesn't do the credit cards at all, I don't even have a choice for that.

 

Anyway, I'll be happy to try again when this has been flushed out, but right now, it's just easier for me to create an account for the user with a standard password they can change when they login. At least this way, I get real time shipping quotes (and correct shipping options) as well as correct prices, and the ability to enter in payment options through our gateway.

 

Oh well.

Share this post


Link to post
Share on other sites

the shipping to canada, etc is just in the files, you can change them to what you want. piece of cake to do that.

this does work well. it does not only create accounts. you can create an order, modify an order . . . .

 

it just takes reading.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Just to confirm what John sais, this contribution rocks, I have this running and I am able to add an order with credit card features, faxback form paypal and any payment module I like.

 

If you select credit card in the payment method field then click the update button next to that it should refresh the page with the fileds for the credit card number, start, finish and cvv number, I have included a few extra fields for credit card so you may not have all the above.

 

Shipping options also show in the edit orders as a dropdown selection of 5 different methods so I cant see what any problem with the contribution, this is a clean install of the contribution out of the box and all these features work fine, all I can think is you have not setup you shipping module 100%.

 

Regards


Always seeking & Desperate to find a solution!

Share this post


Link to post
Share on other sites

While editing the order in Admin, it seems the only time it sends an email to the customer is if the order status has changed, regardless if I appended comments or not. Is there a way to have an email sent to the customer any time the checkbox for "Notify Customer" is checked, regardless of status? Is this a bug or the way it was designed?

Share this post


Link to post
Share on other sites

i Get the following error when i click on either creat order, or creat customer:

 

Fatal error: Cannot redeclare tep_db_connect() (previously declared in /home/carbolyt/public_html/admin123/includes/functions/database.php:13) in /home/carbolyt/public_html/admin123/includes/functions/database.php on line 13.

 

What is the problem.

 

Thanks

Share this post


Link to post
Share on other sites
Same problem here...

 

It was asked about 6 times in the last year still no answer...

 

Anybody has a solution for this ?

 

Any help appreciated!

 

Make this number 7. Anyone know what is causing this?

I got this error when I tried to select Credit Card as a payment

method. It now no longer shows the credit card as an option.

 

Warning: Invalid argument supplied for foreach() in
/usr/home/routerbitworld/www/htdocs/admin/edit_orders.php on line 222

Warning: Cannot modify header information - headers already sent by
(output started at
/usr/home/routerbitworld/www/htdocs/admin/edit_orders.php:222) in
/usr/home/routerbitworld/www/htdocs/admin/includes/functions/general.php
on line 18

 

Thanks,

Jonathan Duncan


Jonathan Duncan

JKD Web Magic

Web Site Hosting and Design

http://www.jkdwebmagic.com/

Share this post


Link to post
Share on other sites

hi!

i just installed this and somehow my create orders page shows up blank. I noticed that my create_orders.php IS blank. any help would be much appreciated. thanks!

Share this post


Link to post
Share on other sites

I was wondering I just downloaded this does it work the way it is? or will I be getting minor errors and such...Im not the greatest at this php code and all and I would not like to get over my head...Mark


The Hobby Undergound..."For The Pure Hobbyist"

Share this post


Link to post
Share on other sites

There are 4 occurances of the following line of code in edit_orders.php:

if(IsSet($add_product_options))

but where does the variable $add_product_options get set?

Share this post


Link to post
Share on other sites

I see now, it's the selection box name. I'm adding the option of using checkboxes instead, so each checkbox id or value will need adding to the $add_product_options variable.

Share this post


Link to post
Share on other sites

Hi guys,

 

I am testing this mod on my local server right now. However, I've encountered a small issue. When attempting to add the product in step 2 I am seeing some products with text while others are blank.

 

When attempting to add a product that is blank... and the next page is displayed with the text properly.

 

The same issue is happening with the attributes step 3. I find this very unusual and was hoping that someone could help me out.

 

Thanks,

 

M

Share this post


Link to post
Share on other sites
Hi guys,

 

I am testing this mod on my local server right now. However, I've encountered a small issue. When attempting to add the product in step 2 I am seeing some products with text while others are blank.

 

When attempting to add a product that is blank... and the next page is displayed with the text properly.

 

The same issue is happening with the attributes step 3. I find this very unusual and was hoping that someone could help me out.

 

Thanks,

 

M

 

After further testing, I found my problem. I removed the languages that I dont use and it appeared to solve my problem. I guess my question is different now. Is there a setting for language to use with this mod? (Just in case I do support other languages... at the moment it's no biggie)

 

Thanks,

 

M

Share this post


Link to post
Share on other sites
Make this number 7.  Anyone know what is causing this?

I got this error when I tried to select Credit Card as a payment

method.  It now no longer shows the credit card as an option.

 

Warning: Invalid argument supplied for foreach() in
/usr/home/routerbitworld/www/htdocs/admin/edit_orders.php on line 222

Warning: Cannot modify header information - headers already sent by
(output started at
/usr/home/routerbitworld/www/htdocs/admin/edit_orders.php:222) in
/usr/home/routerbitworld/www/htdocs/admin/includes/functions/general.php
on line 18

 

Thanks,

Jonathan Duncan

 

 

Hello Gentlemen,

 

I was just searching the forum and found that you guys are getting the same error that I was.. I'm not sure about you guys but I only get the error when I attempt to change the Payment Method when I haven't added any items to the order. I'm looking around the code to see if I can fix it so that the error wont happen when the order is empty. In the meantime, just make sure you add products before you change the Paymetn Method and you should be cool..

 

Good Luck!

 

Rich Morgan

DB Microfiber

Premium Grade Microfiber for Your Home or Car

www.dbmicrofiber.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×