Jump to content
Sign in to follow this  
frankl

[Contribution] Step-By-Step Manual Order

Recommended Posts

OK I logged into PHPMYadmin on my webhost and went to the database admin.

 

once you access the database for your oscommerce store, click on customers.

 

Under the structure tab there should be a button or link for Add. I added the field at the end of the table.

 

The settings were:

Field : member_flag

Type : char

length/value : 1

attributes :

Null : null

Extra :

Share this post


Link to post
Share on other sites
This time, I have downloaded v1.8. The install.txt file mentions "changes_to_original_files.txt; but does not contain that file. v1.7 does not contain it.

 

Searching the forums (e.g. at Google: site:forums.oscommerce.com changes_to_original_files.txt) shows only someone else who looked but never found the file.

 

Does anyone know where it is?

 

I also would like to know where the file changes_to_original_files.txt, which was eluded to in the install.txt file of v1.8, is located?

Edited by studio-owens

Share this post


Link to post
Share on other sites

Hi all;

 

This is a great contrib that I am much in need of. I think I have everything installed correctly and

am testing the program by creating an order. I noticed in the product field that it is not multipleing

the quantities, just leaving as a single. Also when I click the Update button to save changes, I am

getting this:

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 476

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 476

 

Warning: Cannot modify header information - headers already sent by (output started at /home/ladykd54/public_html/wholesale/admin/edit_orders.php:371) in /home/ladykd54/public_html/wholesale/admin/includes/functions/general.php on line 35

 

 

Can anyone help?

 

Thank,

Karen

Share this post


Link to post
Share on other sites
Hi all;

 

This is a great contrib that I am much in need of. I think I have everything installed correctly and

am testing the program by creating an order. I noticed in the product field that it is not multipleing

the quantities, just leaving as a single. Also when I click the Update button to save changes, I am

getting this:

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 371

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 476

 

Warning: Division by zero in /home/ladykd54/public_html/wholesale/admin/edit_orders.php on line 476

 

Warning: Cannot modify header information - headers already sent by (output started at /home/ladykd54/public_html/wholesale/admin/edit_orders.php:371) in /home/ladykd54/public_html/wholesale/admin/includes/functions/general.php on line 35

Can anyone help?

 

Thank,

Karen

 

 

 

 

Never mind ..... I fixed it

Share this post


Link to post
Share on other sites

I have this installed with Protx direct, but when I change an order, or create a new order, I cannot enter credit card details - any suggestions?

 

Thanks

Share this post


Link to post
Share on other sites

SQL Error when adding products to new order.

 

So when i go to create a new order, i choose the customer fine, click next, the edit order page comes up.

Here's my problem. When i click "Add a Product", the page that comes up gives me this error:

 

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'JOIN categories_description x ON x.categories_id=ptc.categories_id ORDER' at line 1

 

SELECT products_name, p.products_id, p.products_model, x.categories_name, ptc.categories_id FROM products p LEFT JOIN products_description pd ON pd.products_id=p.products_id LEFT JOIN products_to_categories ptc ON ptc.products_id=p.products_id LEFT JOIN categories_description cd ON cd.categories_id=ptc.categories_id LEFT JOIN categories_description x ON x.categories_id=ptc.categories_id ORDER BY categories_id

 

This only started happening recently.

 

I've tried a few things but i can't figure it out. Any help would be greatly appreciated!

 

Thanks

Share this post


Link to post
Share on other sites

Anyone able to post a small hack which takes out the extra step of hittin the confirm button after selecting the customer... would be easier if it fills the fields after you select a customer from the pull down menu automatically without hitting the button...

Share this post


Link to post
Share on other sites

WHat happened to the install instructions? They're missing from the bottom of the 'install.txt' file on the latest release.

 

Does anyone have the most recent set of instructions?

Edited by goodwinpro

Share this post


Link to post
Share on other sites

OK, I found the install instructions by downloading a earlier version (much earlier unfortunately). I'm not sure if it actually is accurate anymore.

 

So, I get to step 3 and it says...

 

3) Upload this file to catalog/admin/includes/boxes/

manual_order.php

 

However, I can't find the file "manual_order.php" anywhere in the download files. I even downloaded earlier versions and can't find it there. The only file in 'boxes' is 'customers.php'.

 

Anybody know what's going on with this? What am I missing?

Share this post


Link to post
Share on other sites
Download from here:

 

osCommerce Step-By-Step Manual Order Entry

 

Don't forget to donate to the Core Team

 

Cheers from Down Under

 

 

This looks great and very useful. :thumbsup: However, I am looking at the install.txt for the 1.8 version and it does not have any steps to follow. The install directions from 24 Mar - 2004 are there, but are these the ones to use? I appreciate all your help.

Share this post


Link to post
Share on other sites
This looks great and very useful. :thumbsup: However, I am looking at the install.txt for the 1.8 version and it does not have any steps to follow. The install directions from 24 Mar - 2004 are there, but are these the ones to use? I appreciate all your help.

 

 

Even I need the same help.. Since I have installed order editor and SPPC i cant directly install them.. So I need step by step help..

 

Thanks,

Share this post


Link to post
Share on other sites

Has anyone used the Attribute Sets module with this contribution. I can't get it to work with it. It just shows a blank drop down menu for Attributes when you are trying to add an order.

 

Any help would be greatly appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

Hi all,

 

I had posted this earlier today in the general support section... but as is the norm... it's always AFTER you say, I can't find it that you find it... lol... so here I am on the proper thread:

 

my question:

 

I've been searching the forum left and right but can't seem to find something that has to do with my issue. The "displayed" discount amount in admin is wrong when I edit or create an order using a different currency then the default currency.

 

I had installed many years ago Step-By-Step Manual Order Entry http://www.oscommerce.com/community/contri...ual+Order+Entry to manually create accounts and orders.

 

This is what's happening...

 

on the customer side, if an order is placed in a different currency then the default currency, the order is processed corretly and when viewing the order on the admin side... everything is perfect.

 

When I create an order manually or edit an order on the admin side, if I try to add a discount then I have issues.

 

For instance, let's say my default currency is US and my chosen currency for this order is CAD with a 1.10 difference with the US.

 

On the order created on the customer's side... it will show like this:

 

subtotal: 100.00$

discount: -20.00$

Total: 80.00$

 

 

when I create the order on the admin side, meaning using the Step-by-step Manual Order Entry, it will show like this:

 

subtotal: 100.00$

discount: -22.00$

total: 80.00$

 

the system still counts it right so my total is accurate but the discount amount that appears in admin shows with the currency exchange rate applied to it although it shouldn't.

 

I know it's just cosmetic since my total is still accurate but it creates a lot of annoyances with the customers. Is there a way to fix this?

 

 

I've searched all previous posts in this thread regarding currency issues. I also saw in the edit_orders file where this is mentionned but it doesn't appear as if anyone that found a solution posted it.

 

I've found a temporary fix by editing the info in the database directly by going to orders_total table and editing the proper field for said order but surely there has to be something that could be done to the code to make this an automatic?

 

Thanks in advance

Share this post


Link to post
Share on other sites

So I posted this in the forum for the complete order editing tool but I the problem may be related to the step by step manual order as well.

 

If anyone has an idea what is going on here, PLEASE HELP. I am desperate to get this fixed.

 

See message below:

 

 

 

So I know that there are others that asked this before but I am still struggling to find a solution to the discount/tax/total calculations.

 

These are some serious flaws to this contribution and I would like to see if anyone had luck fixing these problems.

 

I AM WILLING TO PAY SOMEONE IF THEY CAN FIND A SOLUTION. DJmonkey, or anyone else, I will give you a generous donation if you can help me.

 

1. When you enter a discount amount, and click update, the tax does not calculate correctly.

Example:

 

(If tax rate is 5.6%)

Sub-total: 100.00

discount: - 10.00

Tax: 5.60 (THis should be 5.04)

Total: 95.60

 

So it is calculating the tax on the subtotal and not including the discount.

 

2. I use discount coupons contribution. If the customer creates an order and uses a coupon, it works just fine but if you update the order, it completely ignores the discount amount.

 

Examples:

 

(This is how it looks before you click update, completely correct!)

Sub-Total: 100.00

Discount coupon: -10.00

Tax: 5.04

Total: 95.04

 

(THis is what happens after you click update)

Sub-Total: 100.00

Discount Coupon: -10.00

Tax: 5.60

Total: 105.60

 

I have read just about every post and there are some fixes that people found. Unfortunatly, I am using the latest build of order editor and every fix that I found does not apply to the current build. The code seems to be completely different and I cannot adapt it to work correctly.

I think these problems are both related to each other so hopefully there is an easy way to get them both to work correctly.

 

I am using step by step manual order also. I did notice something wierd that order editor is doing. Maybe it is related to the problem. When the step by step manual order creates a new order, it automatically adds a "Discount" line item called "OT_discount" in the orders_total Table in MYSQL. If you edit the order at all, it actually changes this field to OT_custom_1 for some reason.

 

So any help that you can offer will be appreciated and generously rewarded. Thanks in advance!

Share this post


Link to post
Share on other sites
I AM WILLING TO PAY SOMEONE IF THEY CAN FIND A SOLUTION. DJmonkey, or anyone else,

 

I've reached that point as well. I've been trying to figure out a solution for months and I'm stuck with editing my database manually which although not complex still wastes an incredible amount of time.

 

Any help would be appreciated.

 

TIA

Share this post


Link to post
Share on other sites

Hi and greetz from the german oscommerce forum.. i'm a active member there..

I have a little question to this contrib, because it will not run... What is meaned with "IMPORTANT: If you choose to install these files be sure to complete installation steps 10 - 14 before using."

 

where are these steps ? can't found a description for that..

 

thanks for help..

Share this post


Link to post
Share on other sites

So I posted this in the forum for the complete order editing tool but I the problem may be related to the step by step manual order as well.

 

If anyone has an idea what is going on here, PLEASE HELP. I am desperate to get this fixed.

 

See message below:

 

 

 

So I know that there are others that asked this before but I am still struggling to find a solution to the discount/tax/total calculations.

 

These are some serious flaws to this contribution and I would like to see if anyone had luck fixing these problems.

 

I AM WILLING TO PAY SOMEONE IF THEY CAN FIND A SOLUTION. DJmonkey, or anyone else, I will give you a generous donation if you can help me.

 

1. When you enter a discount amount, and click update, the tax does not calculate correctly.

Example:

 

(If tax rate is 5.6%)

Sub-total: 100.00

discount: - 10.00

Tax: 5.60 (THis should be 5.04)

Total: 95.60

 

So it is calculating the tax on the subtotal and not including the discount.

 

2. I use discount coupons contribution. If the customer creates an order and uses a coupon, it works just fine but if you update the order, it completely ignores the discount amount.

 

Examples:

 

(This is how it looks before you click update, completely correct!)

Sub-Total: 100.00

Discount coupon: -10.00

Tax: 5.04

Total: 95.04

 

(THis is what happens after you click update)

Sub-Total: 100.00

Discount Coupon: -10.00

Tax: 5.60

Total: 105.60

 

I have read just about every post and there are some fixes that people found. Unfortunatly, I am using the latest build of order editor and every fix that I found does not apply to the current build. The code seems to be completely different and I cannot adapt it to work correctly.

I think these problems are both related to each other so hopefully there is an easy way to get them both to work correctly.

 

I am using step by step manual order also. I did notice something wierd that order editor is doing. Maybe it is related to the problem. When the step by step manual order creates a new order, it automatically adds a "Discount" line item called "OT_discount" in the orders_total Table in MYSQL. If you edit the order at all, it actually changes this field to OT_custom_1 for some reason.

 

So any help that you can offer will be appreciated and generously rewarded. Thanks in advance!

 

I'm not sure what version you're using and I don't remember what version I installed but mine does not do this. Does your admin/edit_orders.php file have verbage around line 333 from a Michel Haase on 2/18/2005, dealing with $RunningSubTotal and $RunningTax fields? He had code in there for calculating totals either with or without tax. (You comment out one or the other.) Could this be your problem area? If you don't have that code or you have it set to calculate with tax, that could explain it.


Add-Ons personally installed:

Step by Step Manual Order -- Request Reviews -- Reviews in Product Listing -- Reviews in Product Display -- Review Approval System -- Leverage Browser Cache --
Header Tag Controller -- Multilayer SEO Pop Out Menu -- Follow Us Box -- View All Products -- USPS Shipping Labels -- UPS Shipping Labels -- Monthly Sales/Tax Report --
htacess Optimisation -- Remove Unused Images -- Master Password -- Admin Change Customer Password -- Database Backup Manager -- Zero Stock Report --
Searchbox Search In Descriptions -- Easy Populate 2.76i -- Barcode Rendering -- Admin Sort By Model -- Products Purchased Report

Add-Ons personally developed:

Search for email address, etc in Orders -- Discontinue Product

Add-Ons installed by others:

View Counter -- Site Monitor -- Image Thumbnailer -- Database Optimizer -- Recaptcha -- Discount Coupons -- Add More Fields

Share this post


Link to post
Share on other sites

For those having problems with it calculating tax on shipping, I may have found the solution. If it's really this easy, I can't believe someone didn't find it sooner. (Makes me feel like I'm not seeing the big picture and I'm overlooking some hidden problem with my solution...)

 

Anyway, in admin/edit_orders.php around line 376 (in our file anyway), you should hopefully find:

 

if ($ot_class == "ot_shipping" || $ot_class == "ot_lev_discount" || $ot_class == "ot_customer_discount" || $ot_class == "ot_custom" || $ot_class ==

"ot_cod_fee") {

 

Try changing it to:

 

if ($ot_class == "ot_lev_discount" || $ot_class == "ot_customer_discount" || $ot_class == "ot_custom" || $ot_class ==

"ot_cod_fee") {

 

This serves to remove ot_shipping (order total shipping) from the $RunningTax calculation which is evidently what ultimately gets used in the Total field on both the Manual Order Entry screen and the invoice. I have performed basic testing and it appears to have solved the problem. I will post an update if it causes other, unforseen issues.

 

For what it's worth, I appear to have installed version 1.5 of this contrib. Older versions (and perhaps even some newer versions) may not have the same coding in the edit_orders file.

Edited by kru

Add-Ons personally installed:

Step by Step Manual Order -- Request Reviews -- Reviews in Product Listing -- Reviews in Product Display -- Review Approval System -- Leverage Browser Cache --
Header Tag Controller -- Multilayer SEO Pop Out Menu -- Follow Us Box -- View All Products -- USPS Shipping Labels -- UPS Shipping Labels -- Monthly Sales/Tax Report --
htacess Optimisation -- Remove Unused Images -- Master Password -- Admin Change Customer Password -- Database Backup Manager -- Zero Stock Report --
Searchbox Search In Descriptions -- Easy Populate 2.76i -- Barcode Rendering -- Admin Sort By Model -- Products Purchased Report

Add-Ons personally developed:

Search for email address, etc in Orders -- Discontinue Product

Add-Ons installed by others:

View Counter -- Site Monitor -- Image Thumbnailer -- Database Optimizer -- Recaptcha -- Discount Coupons -- Add More Fields

Share this post


Link to post
Share on other sites

Let me add...

 

From what I can tell, different states/countries have different ways of calculating tax. For some locations, it may be appropriate to charge tax on shipping. So the way this contrib is coded is not necessarily 'wrong' or a 'problem'. Code that one person might introduce to suit his/her needs may not be appropriate for a large percentage of those who download it. In a perfect world, there would be an Admin feature that allows you to set taxation on shipping to either Yes or No. As you can see, however, this contrib doesn't have the greatest on-going user support, despite being a fantastic addition... once up and running. So those of us who know just enough php to be dangerous simply resort to hacking up the code...


Add-Ons personally installed:

Step by Step Manual Order -- Request Reviews -- Reviews in Product Listing -- Reviews in Product Display -- Review Approval System -- Leverage Browser Cache --
Header Tag Controller -- Multilayer SEO Pop Out Menu -- Follow Us Box -- View All Products -- USPS Shipping Labels -- UPS Shipping Labels -- Monthly Sales/Tax Report --
htacess Optimisation -- Remove Unused Images -- Master Password -- Admin Change Customer Password -- Database Backup Manager -- Zero Stock Report --
Searchbox Search In Descriptions -- Easy Populate 2.76i -- Barcode Rendering -- Admin Sort By Model -- Products Purchased Report

Add-Ons personally developed:

Search for email address, etc in Orders -- Discontinue Product

Add-Ons installed by others:

View Counter -- Site Monitor -- Image Thumbnailer -- Database Optimizer -- Recaptcha -- Discount Coupons -- Add More Fields

Share this post


Link to post
Share on other sites

I added this contrib today and I amexciting to start using it but having some problems:

 

My first concern. In the 14 step install, there was no file includes/boxes/manual_orders.php included with the contrib. I have a customers.php file and merged that with my current customers.php file. I also removed the define for manual_orders.php because I did not have a file to add. So it may be half-working...if I need this file, where can i find it? If I am using the wrong install file, where can I find it?

 

Issue#2

 

I am receiving multiple syntax / parse errors in regards to this section of code in create_account_process.php

 

 

such as

Fatal error: Call to undefined function tep_encrypt_password() in create_account_process.php on line 360

 

 

I comment out that line to see if the error clears and I am receiving more error messages where it is expecting a ')'. I have been fiddling back and forth trying to sort it out. Is the problem apparent to anyone?

 

 

lines 352-379 code:

 

 

<?php

} else {

$sql_data_array = array('customers_firstname' => $firstname,

'customers_lastname' => $lastname,

'customers_email_address' => $email_address,

'customers_telephone' => $telephone,

'customers_fax' => $fax,

'customers_newsletter' => $newsletter,

'customers_password' => tep_encrypt_password($password));

//'customers_password' => $password,

//'customers_default_address_id' => 1);

 

 

if (ACCOUNT_GENDER == 'true') $sql_data_array['customers_gender'] = $gender;

if (ACCOUNT_DOB == 'true') $sql_data_array['customers_dob'] = tep_date_raw($dob);

 

 

tep_db_perform(TABLE_CUSTOMERS, $sql_data_array);

 

 

$customer_id = tep_db_insert_id();

 

 

$sql_data_array = array('customers_id' => $customer_id,

//change line below to suit your version

'address_book_id' => 1, //pre MS2

'entry_firstname' => $firstname,

'entry_lastname' => $lastname,

'entry_street_address' => $street_address,

'entry_postcode' => $postcode,

'entry_city' => $city,

'entry_country_id' => $country);

Last issue...

create_order.php

I select the customer I want to create an ordre for and click confirm. It logs me out of admin, I re login and it adds my customer info in, I select products to add, click "add product" and it logs me out of admin again.

 

 

What do I need to do to correct this problem?

 

Thanks for any and all help!

Share this post


Link to post
Share on other sites

A few helpful hints for stores based in the US:

 

You might want to change the order of the address fields in the Manual Order account creation process. (Post Code is before City and State, as delivered. I guess that's how they do it overseas...) Anyway, the file you want to move the Post Code code around in is admin\includes\modules\account_details.php

 

If you want to move the fields around on the verification page that appears during the next step of the Manual Order process, that's in admin\includes\modules\create_order.php

 

If you're like me and want to change the field names to something more applicable to the US, you'll find them in admin\includes\languages\english.php. For instance, I changed ENTRY_POST_CODE from 'Post Code:' to 'ZIP/Post Code:'. I also changed ENTRY_CITY from 'Suburb:' to 'City:' Please be aware that these values appeared twice in my english.php file. Be sure to change them in both locations to avoid any problems.

Edited by kru

Add-Ons personally installed:

Step by Step Manual Order -- Request Reviews -- Reviews in Product Listing -- Reviews in Product Display -- Review Approval System -- Leverage Browser Cache --
Header Tag Controller -- Multilayer SEO Pop Out Menu -- Follow Us Box -- View All Products -- USPS Shipping Labels -- UPS Shipping Labels -- Monthly Sales/Tax Report --
htacess Optimisation -- Remove Unused Images -- Master Password -- Admin Change Customer Password -- Database Backup Manager -- Zero Stock Report --
Searchbox Search In Descriptions -- Easy Populate 2.76i -- Barcode Rendering -- Admin Sort By Model -- Products Purchased Report

Add-Ons personally developed:

Search for email address, etc in Orders -- Discontinue Product

Add-Ons installed by others:

View Counter -- Site Monitor -- Image Thumbnailer -- Database Optimizer -- Recaptcha -- Discount Coupons -- Add More Fields

Share this post


Link to post
Share on other sites

I will repeat it again, because it seems some people aren't reading through this thread (it is pretty long, but that's no excuse), so they don't see how many people are commenting that the newer versions are missing some files and/or instructions. I believe I used version 1.5 when I installed. While it's not quick or easy, I was able to get it to work without too many stumbling blocks...

 

So try an older version! You don't always need the latest and greatest. Many of the newer versions add functionality that isn't necessarily needed or is geared towards different countries, etc. Start with something that works and then you can make changes individually, as you need them...


Add-Ons personally installed:

Step by Step Manual Order -- Request Reviews -- Reviews in Product Listing -- Reviews in Product Display -- Review Approval System -- Leverage Browser Cache --
Header Tag Controller -- Multilayer SEO Pop Out Menu -- Follow Us Box -- View All Products -- USPS Shipping Labels -- UPS Shipping Labels -- Monthly Sales/Tax Report --
htacess Optimisation -- Remove Unused Images -- Master Password -- Admin Change Customer Password -- Database Backup Manager -- Zero Stock Report --
Searchbox Search In Descriptions -- Easy Populate 2.76i -- Barcode Rendering -- Admin Sort By Model -- Products Purchased Report

Add-Ons personally developed:

Search for email address, etc in Orders -- Discontinue Product

Add-Ons installed by others:

View Counter -- Site Monitor -- Image Thumbnailer -- Database Optimizer -- Recaptcha -- Discount Coupons -- Add More Fields

Share this post


Link to post
Share on other sites

To change the EDIT button (at the top right of the Admin page for Orders) to point to the new order entry page for ALL orders, whether they are website generated or manually generated, find the following code in admin\orders.php:

 

$contents[] = array('align' => 'center', 'text' => '<a href="' . tep_href_link(FILENAME_ORDERS, tep_get_all_get_params(array('oID', 'action')) . 'oID=' . $oInfo->orders_id . '&action=edit') . '">' . tep_image_button('button_edit.gif', IMAGE_EDIT) . '</a> <a href="' . tep_href_link(FILENAME_ORDERS, tep_get_all_get_params(array('oID', 'action')) . 'oID=' . $oInfo->orders_id . '&action=delete') . '">' . tep_image_button('button_delete.gif', IMAGE_DELETE) . '</a>');

 

And change the first FILENAME_ORDERS to FILENAME_EDIT_ORDERS

 

To change the Order ID search box above it to go to the new order entry page as well, find the following code in admin\orders.php:

 

<tr><?php echo tep_draw_form('orders', FILENAME_ORDERS, '', 'get'); ?>

<td class="smallText" align="right"><?php echo HEADING_TITLE_SEARCH . ' ' . tep_draw_input_field('oID', '', 'size="12"') . tep_draw_hidden_field('action', 'edit'); ?></td>

</form></tr>

<tr><?php echo tep_draw_form('status', FILENAME_ORDERS, '', 'get'); ?>

<td class="smallText" align="right"><?php echo HEADING_TITLE_STATUS . ' ' . tep_draw_pull_down_menu('status', array_merge(array(array('id' => '', 'text' => TEXT_ALL_ORDERS)), $orders_statuses), '', 'onChange="this.form.submit();"'); ?></td>

</form></tr>

 

And change the first FILENAME_ORDERS to FILENAME_EDIT_ORDERS

 

Why would you want to do this? To make the order entry and updating processes consistent. Your data entry person will see the same view all the time instead of bouncing back and forth. Trust me, we didn't have it set up this way for quite a while and it was a pain in the butt to change order details if someone requested a change after an order was created. We would go to the address line and enter edit_ in front of orders.php so it went to the manual entry view just so we could change something.


Add-Ons personally installed:

Step by Step Manual Order -- Request Reviews -- Reviews in Product Listing -- Reviews in Product Display -- Review Approval System -- Leverage Browser Cache --
Header Tag Controller -- Multilayer SEO Pop Out Menu -- Follow Us Box -- View All Products -- USPS Shipping Labels -- UPS Shipping Labels -- Monthly Sales/Tax Report --
htacess Optimisation -- Remove Unused Images -- Master Password -- Admin Change Customer Password -- Database Backup Manager -- Zero Stock Report --
Searchbox Search In Descriptions -- Easy Populate 2.76i -- Barcode Rendering -- Admin Sort By Model -- Products Purchased Report

Add-Ons personally developed:

Search for email address, etc in Orders -- Discontinue Product

Add-Ons installed by others:

View Counter -- Site Monitor -- Image Thumbnailer -- Database Optimizer -- Recaptcha -- Discount Coupons -- Add More Fields

Share this post


Link to post
Share on other sites

I will repeat it again, because it seems some people aren't reading through this thread (it is pretty long, but that's no excuse), so they don't see how many people are commenting that the newer versions are missing some files and/or instructions. I believe I used version 1.5 when I installed. While it's not quick or easy, I was able to get it to work without too many stumbling blocks...

 

So try an older version! You don't always need the latest and greatest. Many of the newer versions add functionality that isn't necessarily needed or is geared towards different countries, etc. Start with something that works and then you can make changes individually, as you need them...

 

OK. Well...I just checked all of the available versions on the osCommerce website (including Beta) and the Instructions 10-14 do not exist in any of the packages. Some of the earlier packages include instructions 1-10 with Additional Notes. So, I'm with the above poster who asked what "IMPORTANT: If you choose to install these files be sure to complete installation steps 10 - 14 before using." refers to in the install.txt file that is contained in all packages after 1.1. Also, in that same file is included this line under ---INSTALLATION--- "You have just to compare the files which are based on a version MS2. It is indicated to interior the modifications carried out for the files of origin with the MS2." Which further confuses the matter to me.

 

Basically, I can read and understand instructions 1-10 included in version 1.1. But, I have reservations about following those instructions while applying the latest updated files (ie someone posted the instruction 10-14 comment for a reason). Reasons for not going with version 1.1 and following instructions seem to be all the fixes and updates and changes that have been made to accomodate real world difficulties. So, I don't feel entirely ignorant or foolish to ask this question once again with all due respect to your above stated opinion. Just basically, where are instructions 10-14, and what additional changes are necessitated to accomodate an osCommerce 2.2-MS2 build, if any, in light of the ""You have just to compare the files which are based on a version MS2. It is indicated to interior the modifications carried out for the files of origin with the MS2." comment under installation?

 

Chris

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×