Jump to content
Sign in to follow this  
frankl

[Contribution] Step-By-Step Manual Order

Recommended Posts

This might be a step by step manual order, but it sure isn't a step by step install :(

 

I have a heavily modified store and a comparrison file install is a right royal pain in the ass.

 

Has anyone a standard format install text for the modified files.

 

i.e find

blah blah

 

replace with blah blah blah.

 

Contributions done this way also make the development and bug fixing easier.

Share this post


Link to post
Share on other sites
This might be a step by step manual order, but it sure isn't a step by step install :(

 

I have a heavily modified store and a comparrison file install is a right royal pain in the ass.

 

Has anyone a standard format install text for the modified files.

 

i.e find

blah blah

 

replace with blah blah blah.

 

Contributions done this way also make the development and bug fixing easier.

 

tell me about it!......

 

anyways, my problems are critical.....

 

When I click "Add Product" all I get a a blank list with a blank drop down menu that has "TOP" as it's only option.

 

When I click update anywhere on the page I get "Cannot re-declare" error for the general.php (as mentioned earlier in the thread, without answer!).

 

I think it's actually updateing though, its just a big pain! and not something I can hand over to a client.

 

lastly, there are NO shipping options, or payment option drop downs. judging by the instructions as well as this thread, I guess there should be these things....they just must not be working for me. The only things that are there are blank text fields for Payment (no CC # and expire entry fields, just 1 blank field) and shipping is in the order total field (as 'delivery') with a blank text field as well.

 

can someone please help!?

Share this post


Link to post
Share on other sites
tell me about it!......

 

anyways, my problems are critical.....

 

When I click "Add Product" all I get a a blank list with a blank drop down menu that has "TOP" as it's only option.

 

When I click update anywhere on the page I get "Cannot re-declare" error for the general.php (as mentioned earlier in the thread, without answer!).

 

I think it's actually updateing though, its just a big pain! and not something I can hand over to a client.

 

lastly, there are NO shipping options, or payment option drop downs.  judging by the instructions as well as this thread, I guess there should be these things....they just must not be working for me.  The only things that are there are blank text fields for Payment (no CC # and expire entry fields, just 1 blank field) and shipping is in the order total field (as 'delivery') with a blank text field as well.

 

can someone please help!?

 

for my first problem, you have to have the items within categories to make it work.

Share this post


Link to post
Share on other sites

i have the problem previously stated by a few of the State not being passed to the next stage in the create an account process, although it is actually being placed into the DB, any ideas on tracing this as it also doesnt reflect on the Invoice / packing slip either !!!

Share this post


Link to post
Share on other sites

step-by-step.jpg

 

Hi. Anyone have an idea why I'm not getting the text for the product attributes in the drop down menus? After having worked on this awhile I think it has something to do with the variable in red (below) not having a value from edit_orders.php, but I can't figure out what the fix is:

 

foreach($ProductOptionValues as $OptionID => $OptionValues)

{

$OptionOption = "<b>" . $Options[$OptionID] . "</b> - <select name='add_product_options[$OptionID]'>";

foreach($OptionValues as $OptionValueID => $OptionValueName))

{

$OptionOption .= "<option value='$OptionValueID'> $OptionValueName\n";

}

$OptionOption .= "</select><br>\n";

 

if(IsSet($add_product_options))

$OptionOption = str_replace("value='" . $add_product_options[$OptionID] . "'", "value='" . $add_product_options[$OptionID] . "' selected", $OptionOption);

 

print $OptionOption;

}

Share this post


Link to post
Share on other sites

Hmm, I am wondering if I am just a fool, i have tried installing this mod but kept getting lost. Seems I am the only one, so apparently, I better ask.

 

I tried using the Beyond Compare, but my pages have so much stuff changed, it is near impossible.

 

Now, am i suppose to use a file compare or follow the file changes doc? Do i start at the first written contribution and work my way through them all until i get to 1.6?

http://www.oscommerce.com/community/contributions,1589

 

In the install doc, it says to "IMPORTANT: If you choose to install these files be sure to complete installation steps 10 - 14 before using."

 

steps 10-14 from where?

Share this post


Link to post
Share on other sites

After uploading the step_by_step_orders_v1.6 contribution, I get the following error message when I click 'Orders' in my Customers menu item:

 

1054 - Unknown column 'o.is_so' in 'field list'

 

select o.orders_id, o.is_so, o.customers_name, o.payment_method, o.date_purchased, o.last_modified, o.currency, o.currency_value, s.orders_status_name, ot.text as order_total from orders o left join orders_total ot on (o.orders_id = ot.orders_id), orders_status s where o.orders_status = s.orders_status_id and s.language_id = '1' and ot.class = 'ot_total' order by o.orders_id DESC limit 0, 12

 

[TEP STOP]

 

Any ideas? The rest of the contribution seems to work fine.

Share this post


Link to post
Share on other sites
After uploading the step_by_step_orders_v1.6 contribution, I get the following error message when I click 'Orders' in my Customers menu item:

 

1054 - Unknown column 'o.is_so' in 'field list'

 

select o.orders_id, o.is_so, o.customers_name, o.payment_method, o.date_purchased, o.last_modified, o.currency, o.currency_value, s.orders_status_name, ot.text as order_total from orders o left join orders_total ot on (o.orders_id = ot.orders_id), orders_status s where o.orders_status = s.orders_status_id and s.language_id = '1' and ot.class = 'ot_total' order by o.orders_id DESC limit 0, 12

 

[TEP STOP]

 

Any ideas? The rest of the contribution seems to work fine.

 

I'm having the same problem!! Don't know yet what to do. I'm testing and evaluating this contribution.

Share this post


Link to post
Share on other sites

Hi i have just installed this, and it is ok, but when i come to delet a customer i get this

 

1054 - Unknown column 'c.member_flag' in 'field list'

 

select c.customers_id, c.customers_gender, c.customers_firstname, c.customers_lastname, c.customers_dob, c.customers_email_address, a.entry_company, a.entry_street_address, a.entry_suburb, a.entry_postcode, a.entry_city, a.entry_state, a.entry_zone_id, a.entry_country_id, c.customers_telephone, c.customers_fax, c.customers_newsletter, c.member_flag, c.customers_default_address_id from customers c left join address_book a on c.customers_default_address_id = a.address_book_id where a.customers_id = c.customers_id and c.customers_id = '16'

 

[TEP STOP]

 

any help please! this is urgent!

Share this post


Link to post
Share on other sites

Hi everybody ! Great mod :D

 

All most everything works great but I have one small problem :-" after I have created new account and customer goes in to first time to check in, this error comes :

 

Warning: Missing argument 3 for tep_get_zone_name() in /home/tronica/public_html/testi/includes/functions/general.php on line 318

 

Warning: Cannot modify header information - headers already sent by (output started at /home/tronica/public_html/testi/includes/functions/general.php:318) in /home/tronica/public_html/testi/includes/functions/general.php on line 53

 

The error goes away when you push refresh button and after that everything goes like they should be.

 

How can I fix this ? :thumbsup:

Share this post


Link to post
Share on other sites

Whenever I click Update on the page that allows you to add items I get these Error

 

Warning: Invalid argument supplied for foreach() in /home/~Path~/edit_orders.php on line 286

Warning: Invalid argument supplied for foreach() in /home/~Path~/edit_orders.php on line 295

Warning: Invalid argument supplied for foreach() in /home/~Path~/edit_orders.php on line 356

Warning: Invalid argument supplied for foreach() in /home/~Path~/edit_orders.php on line 377

Warning: Invalid argument supplied for foreach() in /home/~Path~/edit_orders.php on line 387

Warning: Cannot modify header information - headers already sent by (output started at /home/animehou/public_html/NerGAL/edit_orders.php:286) in /home/~Path~/includes/functions/general.php on line 36

 

It then proceeds to add the order to the database, but I can't see it in the Orders Page.

 

I then get this Error: on the Order Page with no orders listed.

1054 - Unknown column 'o.is_so' in 'field list'

select o.orders_id, o.is_so, o.customers_name, o.payment_method, o.date_purchased, o.last_modified, o.currency, o.currency_value, s.orders_status_name, ot.text as order_total from orders o left join orders_total ot on (o.orders_id = ot.orders_id), orders_status s where o.orders_status = s.orders_status_id and s.language_id = '1' and ot.class = 'ot_total' order by o.orders_id DESC limit 0, 20

[TEP STOP]

 

 

Also if I try to add Items and select a cat from the drop down box it does nothing.

Share this post


Link to post
Share on other sites
step-by-step.jpg

 

Hi. Anyone have an idea why I'm not getting the text for the product attributes in the drop down menus? After having worked on this awhile I think it has something to do with the variable in red (below) not having a value from edit_orders.php, but I can't figure out what the fix is:

 

foreach($ProductOptionValues as $OptionID => $OptionValues)

{

$OptionOption = "<b>" . $Options[$OptionID] . "</b> - <select name='add_product_options[$OptionID]'>";

foreach($OptionValues as $OptionValueID => $OptionValueName))

{

$OptionOption .= "<option value='$OptionValueID'> $OptionValueName\n";

}

$OptionOption .= "</select><br>\n";

 

if(IsSet($add_product_options))

$OptionOption = str_replace("value='" . $add_product_options[$OptionID] . "'", "value='" . $add_product_options[$OptionID] . "' selected", $OptionOption);

 

print $OptionOption;

}

 

HI,

 

For those of you that have the same problem, you must add that pov.language_id=po.language_id in the db query for the options and it should solve your problems

 

 

Bye

 

 

 

Pl_dtm


PL DTM

-----------------------------------------

Sur un malentendu, ... ?a pourrait marcher

Share this post


Link to post
Share on other sites

Hi. I need to know if this contribution works fine with CCGV (gift vouchers and coupons) and tax rates.

Share this post


Link to post
Share on other sites

Hi Fredrik

Good question so I tested it on my site. I added an order via the contribution in the admin, adding the product. there are fields where there is the cost, the shipping and a couple blank fields where you are able to imput anything you want, example any extra charge. I know that part works well. I never tried to add a coupon so I added a coupon code and in the cost column added a -15.00. it did work, I looked in my order history and it showed the coupon and value subtracting the coupon value from the total. hope this helps.

 

Elizabeth

 

 

I have the margin reports contribution installed. within this contribution is margin_reports2 which shows a report with all the items purchased along with the cost of the item. The problem is if I add an order via the step by step the cost of the item does not cary over to the margin_reports2. are there any fixes for this.

 

Thanks

Elizabeth

Share this post


Link to post
Share on other sites

Hi Elizabeth,

 

Thank you very much for testing! :) I'll give it a try then.

Edited by Fredrik.r

Share this post


Link to post
Share on other sites

HELP NEEDED

 

Igot this error when trying to see client details and order details.

Does anyone have any idea what this is it comes up after installing this mod.

 

CLIENTS

 

1054 - Unknown column 'c.member_flag' in 'field list'

 

select c.customers_id, c.customers_gender, c.customers_firstname, c.customers_lastname, c.customers_dob, c.customers_email_address, a.entry_company, a.entry_street_address, a.entry_suburb, a.entry_postcode, a.entry_city, a.entry_state, a.entry_zone_id, a.entry_country_id, c.customers_telephone, c.customers_fax, c.customers_newsletter, c.member_flag, c.customers_default_address_id from customers c left join address_book a on c.customers_default_address_id = a.address_book_id where a.customers_id = c.customers_id and c.customers_id = '18'

 

[TEP STOP]

 

 

ORDERS

 

Orders Order ID:

Status: All OrdersKanselertDellevertSendtRegistrertI behandlingPlukklisteEndret til forskuddsbetalingEndret til kredttkortbetalingEndret til fakturabetalingSendt i returLevert?penEndret til postoppkravAvventer svar fra kunden

 

 

Customers Order ID IS Order Order Total Date Purchased Status Action

1054 - Unknown column 'o.is_so' in 'field list'

 

select o.orders_id, o.is_so, o.customers_name, o.payment_method, o.date_purchased, o.last_modified, o.currency, o.currency_value, s.orders_status_name, ot.text as order_total from orders o left join orders_total ot on (o.orders_id = ot.orders_id), orders_status s where o.orders_status = s.orders_status_id and s.language_id = '4' and ot.class = 'ot_total' order by o.orders_id DESC limit 0, 20

 

[TEP STOP]

Share this post


Link to post
Share on other sites

I got the same "1054 - Unknown column 'o.is_so' in 'field list'" on my site,

 

Can someone please help?

 

Thank you,

Matt

 

HELP NEEDED

 

Igot this error when trying to see client details and order details.

Does anyone have any idea what this is it comes up after installing this mod.

 

CLIENTS

 

1054 - Unknown column 'c.member_flag' in 'field list'

 

select c.customers_id, c.customers_gender, c.customers_firstname, c.customers_lastname, c.customers_dob, c.customers_email_address, a.entry_company, a.entry_street_address, a.entry_suburb, a.entry_postcode, a.entry_city, a.entry_state, a.entry_zone_id, a.entry_country_id, c.customers_telephone, c.customers_fax, c.customers_newsletter, c.member_flag, c.customers_default_address_id from customers c left join address_book a on c.customers_default_address_id = a.address_book_id where a.customers_id = c.customers_id and c.customers_id = '18'

 

[TEP STOP]

ORDERS

 

Orders Order ID:

Status: All OrdersKanselertDellevertSendtRegistrertI behandlingPlukklisteEndret til forskuddsbetalingEndret til kredttkortbetalingEndret til fakturabetalingSendt i returLevert?penEndret til postoppkravAvventer svar fra kunden

 

 

Customers Order ID IS Order Order Total Date Purchased Status Action

1054 - Unknown column 'o.is_so' in 'field list'

 

select o.orders_id, o.is_so, o.customers_name, o.payment_method, o.date_purchased, o.last_modified, o.currency, o.currency_value, s.orders_status_name, ot.text as order_total from orders o left join orders_total ot on (o.orders_id = ot.orders_id), orders_status s where o.orders_status = s.orders_status_id and s.language_id = '4' and ot.class = 'ot_total' order by o.orders_id DESC limit 0, 20

 

[TEP STOP]

Share this post


Link to post
Share on other sites
I got the same "1054 - Unknown column 'o.is_so' in 'field list'" on my site,

 

I just deleted the reference from the 3 sql strings in admin/orders.php referencing this field and now orders display again. But, if you try to click on Edit on an order it blows up.

 

But, that is just the beginning of the problems with this contrib and the INSTRUCTIONS SUCK.

 

Also, there should not be things coming up in French and then English in other places.

 

This contrib has the potential for being an awesome contrib, but the contributors need to create thorough instructions and jump in on this thread.

 

v1.6 is a disaster!

 

Please help!!!!

 

P.S. I will gladly donate for this contrib once it doesn't wreck my store. Luckily I did BACKUP!!!

Edited by zelf

Share this post


Link to post
Share on other sites

Sorry for the 1.6 contribution, I created a new package with the modification. I test on simple ms2 and it work fine.



Regards
-----------------------------------------
Loïc

Contact me by skype for business
Contact me @gyakutsuki for an answer on the forum

 

Share this post


Link to post
Share on other sites

Hello All,

 

I don't know whether this has been fixed, or not. But when you have a negative number for a product's option, this contrib adds the corresponding positive amount. For example, with a selection of a product's option, $4 is DEDUCTED, but this contrib adds $4.00. Negative value options work fine in the normal ordering process.

 

It's not a big deal because I'm using this contrib for auctions, so I'm changing the pricing anyway.

 

Also, after I've created the account and get a default Payment Method, when I update the Payment Method, I get:

 

Warning: Invalid argument supplied for foreach() in /home/catalog/xxAdmin/edit_orders.php on line 222

 

Warning: Cannot modify header information - headers already sent by (output started at /home/catalog/xxAdmin/edit_orders.php:222) in /home/catalog/xxAdmin/includes/functions/general.php on line 18

 

The Payment Method IS updated when I click the back button, but it's just the "unpolished" effect. No big deal either.

 

I think this is an important contrib, providing essential functionality. This is a diamond, but still "in the rough."

 

Thanks.

Share this post


Link to post
Share on other sites

Everything seem to work fine on 1.7 except in the attributes

 

Adding a product. ex.

 

1 x Winegard 76 cm Satellite Dish with Invacom .3 LNBF

- Dish Mover: GS120 (+$62.95)

- LNB Upgrades: Invacom TWH-031 (+$37.00)

 

is ok but when ever you hit the update button it becomes

 

1 x Winegard 76 cm Satellite Dish with Invacom .3 LNBF

- Dish Mover: GS120 (+$62.95) (+$62.95)

- LNB Upgrades: Invacom TWH-031 (+$37.00) (+$37.00)

 

update again

 

1 x Winegard 76 cm Satellite Dish with Invacom .3 LNBF

- Dish Mover: GS120 (+$62.95) (+$62.95) (+$62.95)

- LNB Upgrades: Invacom TWH-031 (+$37.00) (+$37.00) (+$37.00)

 

The totals are adding correctly, but the attribute price listing keeps adding for each time you hit the update.

 

Jimmy

 

www.dvbhardware.com


I'm not a coder just a splicer.

Share this post


Link to post
Share on other sites

Hello,

 

How can I sort my products by model instead of by name when selecting a new product from drop-down list? Any ideas?

 

Thanks,

Irina.

Share this post


Link to post
Share on other sites

Hi

 

is there a demo of this that contribution? i really would to see it as i cannot get my orders and customers files to work (even though i am using text diff files)

 

i think this is exactly what i need but need some help.. can anyone advise oif they have a demo of this script, or if they have access admin levels then could they temporarily set me up on restricted to customers box only... just so i can see wht the script does)

 

many thanks


Upon receiving fixes and advice, too many people don't bother to post updates informing the forum of how it went. Until of course they need help again on other issues and they come running back!

 

Why receive the information you require in good faith for free, only to then have the attitude to ignore the people who gave it to you?

 

There's no harm in saying, 'Thanks, it worked'. On the contrary, it creates a better atmosphere.

 

CHOOCH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×