Jump to content
Sign in to follow this  
Met00

Abandoned Carts

Recommended Posts

Oh yeah I need someone to test something in the NEW 1.4.1.

 

If anyone who has a multi-language site, and has a default language other than english or can set it to something other than english for a test. Please check that the product descriptions come up in that default language.

 

I would be greateful... Thanks...

 

-Aalst

Share this post


Link to post
Share on other sites
I apologize for uploading a zip with the wrong files, and I apologize for use a non-cross-platform function I know better than that.  That latter is unforgivable and I should be flogged.

 

The new file can be downloaded from:

 

http://www.oscommerce.com/contributions/Un...port_1.4.1a.zip

 

In the next release I will not be using the money_format function.  I will have to write a new function that uses number_format to archive the same results, or at least good enough. :)

 

That function is a really nice one, I wasn't aware that it wasn't Windows Friendly, but then again who really is. :rolleyes:

 

-Aalst

That's better, it moved the error down a couple of lines :-)

 

Fatal error: Call to undefined function: money_format() in xxxxxxxx\catalog\admin\stats_unsold_carts.php on line 131

Edited by beardeddone

Best Regards

Share this post


Link to post
Share on other sites

Beardeddone,

 

Yeah that is the famous error.

 

That could mean that you are not running PHP 4.3.0 or higher, or that you are on a Windows Server which wouldn't matter what version of PHP you have.

 

If you are not on a windows server, if you upgrade your PHP it should fix it. If you are on Windows, then you will have to wait for the next version. I hope to have it out later tonight. Until then if you need the report you can use version 1.3, you can get it from the contrib page:

 

http://www.oscommerce.com/community/contributions,1598

 

It has a few bugs in it, that have been fixed in 1.4.1. In case you want to know what they are:

  • Last cart or only cart doesn't display a Final Price
  • Total only show the second to the last carts Final Price or
    shows zero if only a single cart is displayed

Adios...

 

-Aalst

Share this post


Link to post
Share on other sites
Beardeddone,

 

Yeah that is the famous error.

 

That could mean that you are not running PHP 4.3.0 or higher, or that you are on a Windows Server which wouldn't matter what version of PHP you have.

 

If you are not on a windows server, if you upgrade your PHP it should fix it.  If you are on Windows, then you will have to wait for the next version.  I hope to have it out later tonight.  Until then if  you need the report you can use version 1.3, you can get it from the contrib page:

 

http://www.oscommerce.com/community/contributions,1598

 

It has a few bugs in it, that have been fixed in 1.4.1.  In case you want to know what they are:

  • Last cart or only cart doesn't display a Final Price
     
  • Total only show the second to the last carts Final Price or
    shows zero if only a single cart is displayed

Adios...

 

-Aalst

Oh yes I am as posted in a prevous post upgraded to PHP 4.3.4 yesterday, still getting the error as posted.

SNAG-0022.jpg

Edited by beardeddone

Best Regards

Share this post


Link to post
Share on other sites

i also seem to having this problem. only the error is coming across on line 175. i am on a linux server and am using php 4.3.4

 

i just installed this contribution and i have a feeling that i am going to love it. i just need it to work. any suggestions?

Share this post


Link to post
Share on other sites

Hmm, well I am not familiar with the strfmon on Linux, but you need to make sure you have these capabilities active or installed on Linux.

 

The next version will not require strfmon from Linux, therefore I hope it will be crossplat-form after all this is done.

Share this post


Link to post
Share on other sites

I tested the version:

 

10/26/2003 - Unsold Carts addon Author: Jacob Schlottke

 

This one works "almost" perfekt for MS1

 

The total is not working (who cares ;-) )

 

 

11/10/2003 - Unsold Carts Report v1.4.1

This version brings in MS1 the failure with the currency

 

Fatal error: Call to undefined function: money_format() in xxxxxxxx\catalog\admin\stats_unsold_carts.php on line 131

 

HTH

 

Stefan Fritsche

Share this post


Link to post
Share on other sites

Uploaded version 1.5 of Unsold Carts Report

 

The fix everyone everywhere has been waiting for (drum roll) . . . :blink:

Posted well with in the time frame I stated. (*nudge* Noobish-n-stuff) :D

 

You can download it from here:

 

http://www.oscommerce.com/contributions/Un..._Report_1.5.zip

 

Changes for version 1.5:

  • Removed use of money_format function and replaced with standard
    OSC supplied functions
  • This *should* now be cross-platform again (sorry)
  • Only the /admin/stats_unsold_carts.php was updated
  • Works on OSC MS2 if you have OSC MS1 you will need to use v1.1:
    http://www.oscommerce.com/contributions/unsold_carts1.1.zip

From Mile Stone to Mile Stone there it is not always possible to keep add-ons back-words compatible, and with MS3 on the way it looks like some add-ons will have to be changed to work only with MS3. :huh: Oh well that is the way the code crumbles.

 

-Aalst

Share this post


Link to post
Share on other sites
Uploaded version 1.5 of Unsold Carts Report

 

The fix everyone everywhere has been waiting for (drum roll) . . . :blink:

Posted well with in the time frame I stated. (*nudge* Noobish-n-stuff) :D

 

You can download it from here:

 

http://www.oscommerce.com/contributions/Un..._Report_1.5.zip

 

Changes for version 1.5:

  • Removed use of money_format function and replaced with standard
    OSC supplied functions
  • This *should* now be cross-platform again (sorry)
  • Only the /admin/stats_unsold_carts.php was updated
  • Works on OSC MS2 if you have OSC MS1 you will need to use v1.1:
    http://www.oscommerce.com/contributions/unsold_carts1.1.zip

From Mile Stone to Mile Stone there it is not always possible to keep add-ons back-words compatible, and with MS3 on the way it looks like some add-ons will have to be changed to work only with MS3. :huh: Oh well that is the way the code crumbles.

 

-Aalst

Very good, this one works, no errors.

 

Thanks


Best Regards

Share this post


Link to post
Share on other sites

I fixed a couple errors in the 1.5... was just missing some text in the language file. Fixed and uploaded as version 1.6...

Share this post


Link to post
Share on other sites

Jacob,

 

Not to be a pain, but you do not increment the version numbers if a file that was in version 1.4.1a ended up missing or the wrong version in 1.5. I have included the correct version that was in 1.4.1a and reverted the version back to 1.5 with a letter to allow the upload.

 

Also if I make a mistake I would like the chance to fix it, before someone else does so, I typically respond very quickly to requests, as shown in the last 24 hours.

 

-Aalst

Share this post


Link to post
Share on other sites

Its done so whats the big deal? I apologize, but I wasn't trying to out do you, just trying to have it fixed so people wouldn't have to reinstall it.

 

In the future I'll give you time to fix it, my apologies.

Share this post


Link to post
Share on other sites

It just common curtsy, it is not about out doing, it just about respect. If you look at the posts for the last 24 hours and several uploads, I have been very responsive, because I am waiting for feedback on problems, so I get it solid. With that said...

 

Sometimes I am just in a hurry or just plain stupid in my rush to get a new release, and I forget something with the ZIP, I typically try to double check it and unzip and do the install, however, I have 3 times with this release failed to do this step, and I know better, and it has bitten me in the rear.

 

So... I apologize also for getting upset about it, I am more upset at myself about being an idiot and upload a bad release.

 

BTW...

 

I am still looking for feed back from multi language sites with a default language other than English to test the report, to make sure the multi language features work correctly for the product descriptions.

 

-Aalst

Share this post


Link to post
Share on other sites
It just common curtsy, it is not about out doing, it just about respect.  If you look at the posts for the last 24 hours and several uploads, I have been very responsive, because I am waiting for feedback on problems, so I get it solid.  With that said...

 

Sometimes I am just in a hurry or just plain stupid in my rush to get a new release, and I forget something with the ZIP, I typically try to double check it and unzip and do the install, however, I have 3 times with this release failed to do this step, and I know better, and it has bitten me in the rear.

 

So... I apologize also for getting upset about it, I am more upset at myself about being an idiot and upload a bad release.

 

BTW...

 

I am still looking for feed back from multi language sites with a default language other than English to test the report, to make sure the multi language features work correctly for the product descriptions.

 

-Aalst

Your not an idiot by no means, thanks for getting this working, no more fixes need for me, mines working and I ain't fixing it anymore :-)


Best Regards

Share this post


Link to post
Share on other sites

Yea, you added a lot of nice features to this, its very powerful, and an exceptional tool. With the addons, I have found that it brought 60% of my empty carts to sales. (In the past 2 weeks, I had 24 abandoned cards and 16 resulted in sales with calls.)

 

Thanks again on this release aalst, pleasure working with you on this.

Share this post


Link to post
Share on other sites

well i m planing to upgrade to ms2 but isnt it possible to have a newer version of abandoned cart compatible wit hms 1 ?

:(


MS2

Share this post


Link to post
Share on other sites

Aalst!!! You rock! I can't believe you have done all that work in such a short period of time. (do you ever sleep?) 8P

 

everything looks good in MS2. the only thing i saw was the grand total says table_cart_grandtotal$22.37 rather than Grand Total: $22.37. But i can fix that myself.

 

Thanks again

Share this post


Link to post
Share on other sites
Uploaded version 1.5 of Unsold Carts Report

 

The fix everyone everywhere has been waiting for (drum roll) . . .  :blink:

Posted well with in the time frame I stated.  (*nudge* Noobish-n-stuff) :D

 

You can download it from here:

 

http://www.oscommerce.com/contributions/Un..._Report_1.5.zip

 

Changes for version 1.5:

  • Removed use of money_format function and replaced with standard
    OSC supplied functions
     
  • This *should* now be cross-platform again (sorry)
     
  • Only the /admin/stats_unsold_carts.php was updated
     
  • Works on OSC MS2 if you have OSC MS1 you will need to use v1.1:
    http://www.oscommerce.com/contributions/unsold_carts1.1.zip

From Mile Stone to Mile Stone there it is not always possible to keep add-ons back-words compatible, and with MS3 on the way it looks like some add-ons will have to be changed to work only with MS3.  :huh:  Oh well that is the way the code crumbles.

 

-Aalst

Thanks for your contribution, yes I know you can't follow the MS.

That was the reason I wrote down which version was working with MS1 and which gave a failure with MS1 so everybody else can check which version he has.

 

That was also the reason why I stay with my very good working MS1 and about 50 or 80 add ons :-).

 

No way I will wait to MS9 and use the already tested and working stuff of the "Old" 2.2 MS1.

 

Thanks again for that very nice contribution.

 

Although I will not call my customers yet, because I personally think they won't like it. But it is for me a good hint, at which point the gave up and why. So it is useful for me and them, too.

 

 

Stefan Fritsche

www.klosterbrauerei.com

Share this post


Link to post
Share on other sites

Out of curiosity, why does everyone think this version doesn't work on MS1?? I have a heavily modded MS1 and this version works right out of the box....

 

B)

Share this post


Link to post
Share on other sites

Noobish-n-stuff,

Aalst!!!  You rock! I can't believe you have done all that work in such a short period of time. (do you ever sleep?) 8P

Yes I sleep, go to school, run a business, raise two kids, etc. etc. :) To be honest the changes and fixes where rather simple.

 

everything looks good in MS2. the only thing i saw was the grand total says table_cart_grandtotal$22.37 rather than Grand Total: $22.37. But i can fix that myself.

As for the problem with the defined variable showing up instead of the replacement variable, that would mean you downloaded 1.5a instead of 1.5b or you didn't replace the newer english language file.

 

Kooyan,

That was the reason I wrote down which version was working with MS1 and which gave a failure with MS1 so everybody else can check which version he has.

 

That was also the reason why I stay with my very good working MS1 and about 50 or 80 add ons :-).

 

No way I will wait to MS9 and use the already tested and working stuff of the "Old" 2.2 MS1.

MS3 is supposed to have "many" of the popular contribs built-in to it, you may want to check out which ones are once it release and see if it has most or all of the ones you use, maybe it will be worth it once they have almost all or all of them built-in for you. :)

 

Carrerarod,

Out of curiosity, why does everyone think this version doesn't work on MS1?? I have a heavily modded MS1 and this version works right out of the box....

A few people said that 1.3 - 1.5 don't work for them but 1.1 does, so I added that comment to help people. MS2 supposiedly handles the currency differntly or something like that so some of the function calls have changed possible. I didn't get into OSC until MS2 so I do not know anything about previous versions.

 

If yours works, maybe one of your other mods/add-ons have updated your currencies or general function files with the MS2 functions, making yours more compatible with MS2 mods/add-ons.

 

Azer,

well i m planing to upgrade to ms2 but isnt it possible to have a newer version of abandoned cart compatible wit hms 1 ?

1.5b works for some MS1 installs and not on others, all I can say is try it and find out. If it doesn't maybe you can make a MS1 version branch or just upgrade to MS2 if it is a difficult process.

 

JrWrestling

With the addons, I have found that it brought 60% of my empty carts to sales. (In the past 2 weeks, I had 24 abandoned cards and 16 resulted in sales with calls.)

I am currious how you handle the phone call, what type of things do you say to start of, and to close the sale? Have you tried e-mails and phone calls? Did you find phone calls more effective? I really want to use this report to improve sales, but I am not sure how to handle a phone call without being coming off like a discourteous phone solicitor.

 

Wow, now that's a message :D

 

-Aalst

Share this post


Link to post
Share on other sites
1.5b works for some MS1 installs and not on others

 

it would be interresting to understand why it work with some and not with other !


MS2

Share this post


Link to post
Share on other sites

the v 1.5b works well with my ms1 ian loaded 5 !

 

as you see i use a french shop and so the date format is not as you can read for now

 

1 x Shuttle SN41G2 @ 331.1000 (20031110)

 

it should be :

 

1 x Shuttle SN41G2 @ 331.1000 (10/11/2003)

 

so is there a way to check the date format used in the shop and to use the same in the contrib ?


MS2

Share this post


Link to post
Share on other sites

2.:REQ : having the price with only 2 decimal not : 25.0830 but 25.08 ...

 

3.REQ : customer in bold ...


MS2

Share this post


Link to post
Share on other sites

for the bold customer :

 

remplace

<tr>
                   <td class='dataTableContent' valign=top> <a href='" . tep_href_link(FILENAME_CUSTOMERS, 'search=' . $inrec['lname'], 'NONSSL') . "'>" . $inrec['fname'] . " " . $inrec['lname'] . "</a><br>
                                                            <a href='" . tep_href_link('mail.php', 'selected_box=tools&customer=' . $inrec['email']) . "'>" . $inrec['email'] . "</a><br> " . $inrec['phone'] . "</td>
                 <td>

by

 

<tr>
                   <td class='dataTableContent' valign=top> <a href='" . tep_href_link(FILENAME_CUSTOMERS, 'search=' . $inrec['lname'], 'NONSSL') . "'>[COLOR=red]<b>[/COLOR]" . $inrec['fname'] . " " . $inrec['lname'] . "[COLOR=red]</b>[/COLOR]</a><br>
                                                            <a href='" . tep_href_link('mail.php', 'selected_box=tools&customer=' . $inrec['email']) . "'>" . $inrec['email'] . "</a><br> " . $inrec['phone'] . "</td>
                 <td>

 

but didnt figure how to palce the blue color !

<hr size=1 color=000080>


MS2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×