Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Guest

RMA Returns error for 2.2 MS2

Recommended Posts

Guest
In return_product.php, find the line that says:

tep_redirect(tep_href_link(FILENAME_RETURN . '?action=sent&rma_value='. $rma_value . '&return_id=' . $ticket_id));

 

and change to:

 tep_redirect(tep_href_link(FILENAME_RETURN . urlencode('?action=sent&rma_value='. $rma_value . '&return_id=' . $ticket_id)));

 

This will prevent the & in the url from getting converted to & which is what the problem is. If you take the url you used above, and simply change the 2 places it says & to just & (deleting amp;) you'll find it will work. This code change prevents this from happening.

 

Dan

 

I found one reason, why the rma number is not shown up: ==> Ultimate SEO URL (in my case 2.1)!

 

This contribution changes the the HTML href link wrapper function "function tep_href_link" in catalog/includes/functions/html_output.php

 

If you disable Ultimate SEO URL 2.1 and use the "old" html_output.php they RMA-Number will be shown. The new functions seemst to wrap the links the way, that you always have this ugly "&" instead of "&". Even if you use urlencode.

 

If you replace the "&" manually in the Browser and refresh, the RMA-Number will appear!

 

Hopefully anyone knows a solution, to get Ultimate SEO and RMA 2.55 work together. Because it are both great contribs!.

 

Greetzs

 

function tep_href_link

Edited by erdm?nnchen

Share this post


Link to post
Share on other sites

This doesnt seem to work with any SEO URLS contrib , it connot translate the urls for the product the customer wants to return when clicking the "Return this item" from the customers account page.

 

If anyone has found a solution for this problem, please feel free to PM or Email me.

Share this post


Link to post
Share on other sites

Hi,

I am getting an error in the store section at: https://www.dysfunktionaljewelry.com/store/....php?order_id=5

 

I also get them in any of the new files I have in there.

 

here is the error:

 

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/httpd/vhosts/dysfunktionaljewelry.com/httpdocs/store/includes/functions/database.php on line 99

 

Any ideas?

 

Thanks,

Philip

Share this post


Link to post
Share on other sites

Hello,

 

I am installing this contribution right now, and noticed that the following files are missing from the contribution zip file, yet they are stated as "New files that must be copied over"

 

admin/password_forgotten.php -- NOT INCLUDED

admin/restore_order.php -- NOT INCLUDED

 

I tried searching this board, and read through the included documentation and can't find any reason why they shouldn't be there.

 

The file is:

ReadMe(RMA_SYSTEM_2.5c).txt

RMA Returns System Documentation (Older doc files contained in "docs" folder)

2.5-2.5c, submitted on 6-26-2005 by Keith W

2.5d by Infobroker

2.4.1, submitted on 11-11-2004 by Justin Mayer

Original author: David Howarth

 

I'd really appreciate it if someone could let me know if this is how it is supposed to be before I continue installing.

 

Thank you!

Share this post


Link to post
Share on other sites
Guest

Hi All,

 

I used this contrib a few years ago now... and also assisted in trying to solve issues with it (albeit unsuccessfully), and am very glad to see that it is running very smoothly now.

 

However, does it now support attributes? If not, is it something that others would want? I may try to get it to work (I tried in the past and failed - hopefully improved php/sql skills since then) but wouldn't mind pointers/advice.

 

Thanks

Share this post


Link to post
Share on other sites
Hi All,

 

I used this contrib a few years ago now... and also assisted in trying to solve issues with it (albeit unsuccessfully), and am very glad to see that it is running very smoothly now.

 

However, does it now support attributes? If not, is it something that others would want? I may try to get it to work (I tried in the past and failed - hopefully improved php/sql skills since then) but wouldn't mind pointers/advice.

 

Thanks

 

I would realy like it to work .... I'm not enough a PHP programmer to do so..... If anyone can get RMA + attributes to work, she/he would make me a very happy person ;)

Share this post


Link to post
Share on other sites

Sorry, I'm not sure. Maybe you deleted something by accident... I would try overwriting return_products.php with the original install file and making the changes again.

Share this post


Link to post
Share on other sites
Sorry, I'm not sure. Maybe you deleted something by accident... I would try overwriting return_products.php with the original install file and making the changes again.

Thank, I will do that and keep my fingers crossed.

 

Denice

Share this post


Link to post
Share on other sites

I really like the RMA system and it seems to be the only one. Is there a way to make it so it doesnt automaticly give an RMA number when a customers fills outs an RMA request. That way I can reject invalid RMAs. The way it is now customers thing they get an automatic RMA.

Share this post


Link to post
Share on other sites

I installed RMA and there are some errors.

The last Full Release 2.5h does not contain all files! I downloaded 2.5 when I noticed that files are missing. When I've finished my installation, I will create a new complete package.

 

Opening the returns.php in the administration tool the following error comes up:

 

RMA Methode

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select refund_method_id, refund_method_name from refund_method where language_id = '2' order by refund_method_id limit -20, 20

 

[TEP STOP]

 

I don't know what to do because I imported the included database file and phpmyadmin said everything is correct,..

 

 

I would be really glad if you help me! :)

Edited by cleefor

Share this post


Link to post
Share on other sites

Ok I solved this problem by changing the language ids in the database manually.

 

Now the next one :D

 

Produkt RMA

RMA Nummer:

Status:

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1

 

select o.returns_id, o.returns_status, o.customers_name, o.contact_user_name, o.rma_value, o.payment_method, o.date_purchased, o.last_modified, o.currency, o.currency_value, s.return_reason_name, op.final_price, o.returns_date_finished, rs.returns_status_name from returned_products o left join returns_products_data op on (o.returns_id = op.returns_id), return_reasons s , returns_status rs where o.returns_reason = s.return_reason_id and s.language_id = '2' and o.returns_status = rs.returns_status_id order by o.returns_id DESC limit -20, 20

 

[TEP STOP]

 

this error is at the returns.php page....what to do??

Share this post


Link to post
Share on other sites
I installed RMA and there are some errors.

The last Full Release 2.5h does not contain all files! I downloaded 2.5 when I noticed that files are missing. When I've finished my installation, I will create a new complete package.

 

Opening the returns.php in the administration tool the following error comes up:

I don't know what to do because I imported the included database file and phpmyadmin said everything is correct,..

I would be really glad if you help me! :)

 

 

2.5H Does contain all the files, what files are you talking about? Regarding your other error, that file (returns.php) really hasn't been messed with in a long time if it is the catalog file you are talking about, except one change I made but that change uses a command built into osCommerce so I doubt it is the file, your version of SQL is probably different then most people. What version of SQL are you using?


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites

From README:

 

New files that must be copied over:

...

admin/includes/boxes/returns.php

admin/includes/classes/returns.php

...

 

And in .zip, there is no such files. Shall I assume that "admin/returns.php" is the same file? And if so, should I symlink or copy? If that's the solution, I have another problem instead... I get errors about the declaration of tep_db_connect, in admin/includes/functions/database.php.

Share this post


Link to post
Share on other sites
2.5H Does contain all the files, what files are you talking about? Regarding your other error, that file (returns.php) really hasn't been messed with in a long time if it is the catalog file you are talking about, except one change I made but that change uses a command built into osCommerce so I doubt it is the file, your version of SQL is probably different then most people. What version of SQL are you using?

 

Ok, it's an old version of SQL. (I had other problems with it due to the old version)

 

Deedook already named the missing files.

Share this post


Link to post
Share on other sites
cleefor:

Version 2.5h contains the missing files, use them.

 

homewetbar:

A repack is needed.

 

 

Sorry must have nuked them by accident when I was cleaning up the installation directories and directions. I've posted the repackaged version for those who requested it now.


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites

Hi there,

Can anyone help me out just installed the newest version - the customer side working perfectly combined with the fancier invoice and packing slip addon looks very professional but on the admin side

on the page that says Product Exchange / Return click on a customers name link to edit the returns page and its blank only shows the boxes to the left.

 

Whats the problem here? can anyone help me out?

 

plus the invoice and packing slip don't show? click on buttons popup comes up but blank?

 

Everything else seems to be working fine on all the tests i've done.

Share this post


Link to post
Share on other sites
2.5H Does contain all the files, what files are you talking about? Regarding your other error, that file (returns.php) really hasn't been messed with in a long time if it is the catalog file you are talking about, except one change I made but that change uses a command built into osCommerce so I doubt it is the file, your version of SQL is probably different then most people. What version of SQL are you using?

 

 

This two files are missing and i've done what you said and added them from the version previous and all is working now. No problems here - RMA working correctly....

Share this post


Link to post
Share on other sites

one thing i've noticed you get to lines the same?

 

Default charge for restocking a non-faulty item 15

 

Default charge for restocking a non-faulty item 15

 

Check stock level true

 

Subtract stock true

 

Allow Checkout true

 

Mark product out of stock ***Out Of Stock***

 

Stock Re-order level 5

 

Default charge for restocking a non-faulty item

 

 

What file is this in? what line does what? as it seems they change different figures but wording doesn't help

Share this post


Link to post
Share on other sites

2.5H works great. Under the admin section of return_products.php, where the check boxes are to notify customer, append comments, complete return, etc. When I uncheck the append comments it still adds them to the comments list, how can I fix this? The email we send to the customer to return his product is quite long and it takes up a page and messes up the interface.

Share this post


Link to post
Share on other sites
Guest

I do hope you can help i've just installed RMA Returns system 2.5h all seams to work untill i get my rma number i go to my site click on track a return type this number in and i am greated by login page it will not allow me passed this page. If i place a test order on my site i login and i can complete a test order.

 

I do hope you can help me.

Share this post


Link to post
Share on other sites

Hey wassup everyone. Can anyone help me with the situation that I have:

**ADMIN RETURN SECTION**

I have RMA System installed. Admin/Return.php isnt showing that 'final_price' of product with attributes. Only shows original 'product_price' w/ tax. Can anyone help me please. Thanks.

 

F Dot Element

Share this post


Link to post
Share on other sites

Does anyone have the same problem, when i check the voucher, the customer dont get the mail, whit the credit code, or do you have to got another controbution installed.

 

thanks, BartP

Share this post


Link to post
Share on other sites
Hey wassup everyone. Can anyone help me with the situation that I have:

**ADMIN RETURN SECTION**

I have RMA System installed. Admin/Return.php isnt showing that 'final_price' of product with attributes. Only shows original 'product_price' w/ tax. Can anyone help me please. Thanks.

 

F Dot Element

 

 

Someone needs to update the code so it pulls the price data from the order instead of the current prices that would fix that problem. Sorry but you guys are going to have to help, I don't have time to do it right now.


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×