Jump to content
Golden Boy

RMA Returns error for 2.2 MS2

Recommended Posts

Can the RMA Returns admin part of the script, be put at the bottem of the order overview page for example:

When the user choses to return an item, its the same as it is now, but in the admin side, rather than compleated (in the orders page) it will say ither part returned or returned.

The admin clicks on the order (like he would when processing an order) and at the bottem of the order overview/order edit are the details the user submited for the return, then the admin can compleate it from there.

The admin can change the status to compleate if he denies the return or just return it and it will still display the part returned or returned status.

The config should be under the admin config menu, and there should be an option to turn off the restocking cost, and the voucher.

What i mean can be seen at www.x-cart.com/demo/admin/

login, click on orders, all order dates, then click on any order and you can see at the bottem of the order page the return system.

Share this post


Link to post
Share on other sites
This forum kicks you out of the posting notification function if you have not been here for a couple of days (weeks?) and I haven't - I am terribly busy

Sebastian

 

I hear that! If it wasn't for Cat PMing I would not have come back to check. None of these notifications showed up in my email :'(

 

So, let me catch up and re-read some of these problems and maybe doing and I can come up with something.

 

As for the GV stuff, that's his ballgame! I don't use GV's so unable to help in that area.

 

When i return a product & click the request button to complete the return & get an RMA number, the page gets redirected to the login screen. The user then has to login to get the RMA number. Does this happen to your stores or has anyone made a fix to skip the login page?

 

Some people still have this problem occasionally and I don't know why, as every time I have uploaded the contribution this does not happen. The only time I see a login screen is when I click on Track A Return, and if the customer isn't already signed in, it will take you there. And if a customer is going to return a product and goes to their order history, clicks on Return, fills out the information, and clicks on the button to get the RMA number, like Cat's, it goes directly to the section of showing them the RMA number with my instructions and sends and email.

 

 

Mett:

 

It looks like toward the very bottom something on this line got messed up:

 

<td width=100% colspan=3 align=right><input type=submit name="submit" value="Find Return ->">   </td>

</tr>

 

Change it to this and see what happens:

 

<td width=100% colspan=3 align=right><input type=submit name="submit" value=Track Return<? echo TEXT_FIND_RETURN; ?>   </td>

</tr>

 

 

kingdonk: Don't know :rolleyes:

Share this post


Link to post
Share on other sites

Mett: This block of code near the bottom you are missing some parts:

 

                            <td width=100% colspan=3 align=right><input type=submit name="submit" value="Find Return ->">   </td>

                            </tr>

                            ';

 

Replace with this and try it:

 

<td width=100% colspan=3 align=right><input type=submit name="submit" value=Track Return<? echo TEXT_FIND_RETURN; ?>   </td>

</tr>

</form>

 

 

';

Share this post


Link to post
Share on other sites
First, in Admin, when I click on 'Returned Products' I get:

Secondly, in the main catalog, I get the following at the top of the page:

Finally, in the catalog, if I click on the 'Account' button I get the following error:

 

I don't have a line 908, stops at line 907. See if your last 3 lines look like that (with the numbers in front).

 

905 </body>

906 </html>

907 <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

 

As for the other two, open up each file and at the very end after the final ?> put your cursor right after the > and hold your delete button down. Those errors are usually caused from "extra white space" at the bottom of the files.

Share this post


Link to post
Share on other sites
Mett:? This block of code near the bottom you are missing some parts:

Replace with this and try it:

 

<td width=100% colspan=3 align=right><input type=submit name="submit" value=Track Return<? echo TEXT_FIND_RETURN; ?>   </td>

? ? ? ? ? ? ? ? ? ? ? ? ? ?  </tr>

? ? ? ? ? ? ? ? ? ? ? ? ? ?  </form>

? ? ? ? ? ? ? ? ? ? ? ? ? ?  ';

 

Thanks, but same thing happend, I mean nothing :-" :D ;as long i can see in contributions list some improvments was added to original; can you tell me wich one it's the good one? i made some modifications to original files: RMA_return_2.3.zip becouse first logged me out when i try to find a RMA number...and now this problem....

Edited by Mett

Carpe Diem

Share this post


Link to post
Share on other sites
Thanks, but same thing happend, I mean nothing  :-"  :D  ;as long i can see in contributions list some improvments was added to original; can you tell me wich one it's the good one? i made some modifications to original files: RMA_return_2.3.zip becouse first logged me out when i try to find a RMA number...and now this problem....

 

 

Finally, I solve this problem. In my case, post method doesn't work for me, so i use get method. Also, i need to be multilanguage so...see below

 

$returns = tep_draw_form('rma_find', tep_href_link('returns_track.php', '', 'NONSSL'), 'get'); // i use get method, it's work for me

$returns .= tep_draw_hidden_field('action', 'returns_show');

$returns .= tep_hide_session_id();

$returns .= '<tr>

<td colspan=3 class=main>' .TEXT_INSERT_RMA.'</td>

</tr>

<tr>

<td width=100& colspan=3 class=main> </td>

</tr>

<tr>

<td width="25%" height="30" align="left" class="main">'.TEXT_YOUR_RMA.'</td>

<td width="5%" height="30" align="center" class="main"> </td>

<td width="75%" height="30" align="left" class="main"><font color=red><input type=text name="rma" value="" size=20></font></td>

</tr>

<tr>

<td width=100& colspan=3 class=main> </td>

</tr>

<tr>

<td width=100% colspan=3 align=right><input type=submit name="submit" value="'.TEXT_FIND_RETURN.'"</td>

</tr>

</form>

';

 

in catalog/includes/languages/english/return_product.php add:

 

define('TEXT_INSERT_RMA','Insert return number: ');

define('TEXT_YOUR_RMA','Your <b><i>RMA</i></b> Number');

define('TEXT_FIND_RETURN','Find return');


Carpe Diem

Share this post


Link to post
Share on other sites

I've got a problem with this contrib that I haven't seen addressed in this thread. I'm on OSC MS2.2 with a ton of other contributions installed already, and I'm trying to install RMA_return_2.3.

 

First problem was with FILENAME_RETURN not being defined in filenames.php - figured that out on my own.

 

Now, whenever a customer clicks on 'Return' from account_history_info.php, it goes to the return_product.php page, but without any styling, CSS or otherwise (as in, I lose my header, sideboxes, pretty much everything) - it's just a white page with black text. It shows my addresses for billing & shipping, my email, and then for 'Please indicate why you are returning this product' I get this info:

 

1146 - Table 'abc_osc1.TABLE_RETURN_REASONS' doesn't exist

select return_reason_id, return_reason_name from TABLE_RETURN_REASONS where language_id = '1' order by return_reason_id desc

TEP STOP

 

I've checked my tables in phpMyAdmin, and there is definitely a 'return_reasons' table at my database root. It's got a language_id '1' (actually, 4 entries have a language_id of 1, which I'm assuming means English). Past that, my PHP skills vanish into thin air and I am lost.

 

Can anybody help me get this straightened out? Thanks.

 

Jacob

Share this post


Link to post
Share on other sites

<sigh> - I figured it out - not including the application_top_refund.php file DOES tend to cause problems :blush:

 

jacob

 

I've got a problem with this contrib that I haven't seen addressed in this thread. I'm on OSC MS2.2 with a ton of other contributions installed already, and I'm trying to install RMA_return_2.3.

 

Now, whenever a customer clicks on 'Return' from account_history_info.php, it goes to the return_product.php page, but without any styling, CSS or otherwise (as in, I lose my header, sideboxes, pretty much everything) - it's just a white page with black text. It shows my addresses for billing & shipping, my email, and then for 'Please indicate why you are returning this product' I get this info:

 

1146 - Table 'abc_osc1.TABLE_RETURN_REASONS' doesn't exist

select return_reason_id, return_reason_name from TABLE_RETURN_REASONS where language_id = '1' order by return_reason_id desc

TEP STOP

 

Jacob

Share this post


Link to post
Share on other sites

Has anybody fixed the tax not being added in issue? I've got the contrib up and running, but it isn't including tax in to the refund amount. I've read the whole thread, but never saw a fix.

 

Anybody? Thanks!

 

Jacob

Share this post


Link to post
Share on other sites

Yo-

 

I found this tel. no. in when a user is refused an RMA....

 

337-229-9292

 

Where the hell can i change this?? I went through the language files to no avail...

 

Thanks!

Share this post


Link to post
Share on other sites
Has anybody fixed the tax not being added in issue? I've got the contrib up and running, but it isn't including tax in to the refund amount. I've read the whole thread, but never saw a fix.

 

Anybody? Thanks!

 

Jacob

Look at my thread near the top of the last page, that will show you how to amend the contri to add your tax rate!

Edited by martinmacca

Share this post


Link to post
Share on other sites
Look at my thread near the top of the last page, that will show you how to amend the contri to add your tax rate!

 

martinmacca,

 

I saw your post, but I'm looking for a solution that will recognize if tax has been applied on the order, and if so, refund it. It seems like your solution will just refund the additional percentage regardless if the sale was taxed or not. (I only tax when the ship-to address is within a state I have a physical presence.)

 

Am I correct here?

 

Thanks for the help.

 

Jacob

Share this post


Link to post
Share on other sites

No one else found this?! Rather embarrassing...

 

Your return request has been declined.

Please contact us at (337) 229-9292 for more information.

 

Did a search on the database and the includes, nothing...

Share this post


Link to post
Share on other sites

3 Problems.

 

1. How do you change the subject and from fields in the email that gets sent when the refund is a gift voucher (to be more specific the redeem gift voucher email)? The email that gets sent has (no subject) in the subject field?

 

2. How do you change the restocking fee from a % to a $ value. I want to charge $12 not 12%?

 

3. johnnymke problem... How do you change the phone number???

Your return request has been declined.

Please contact us at (337) 229-9292 for more information.

 

If anyone can offer any suggestions or help I would greatly appreciate it.

 

Thanks,

Andrew

Edited by andyy15

Andrew Yuen

osCommerce, Community Team

Share this post


Link to post
Share on other sites

Hello Andrew and Johnny:

 

Your return request has been declined.

Please contact us at (337) 229-9292 for more information.

 

Edit the "comment_bar_return.html" under the admin directory and you should be all set.

 

That will take care of the default phone number. I hope this helps. PM me if you got questions. :thumbsup:

 

Regards,

Arpesh Patel

Edited by OnlineSoon

Regards,

Arpesh Patel (Senior Developer)

Share this post


Link to post
Share on other sites

Released 2.3a (forgot to add that to the title in the contributions though). This is all that I did:

 

Update to Version 2.3 only. Added #7 notes text on where to change return text information (admin/comment_bar_return.html) and changed the phone number to generic x's.

 

Once this is uploaded, if you want you can add IceTheNet (RMA Box Fix) and Chris Martin (RMA Returns Address Enhancer) updates. 2.3a MUST be installed first as noted.

 

Cathy

Share this post


Link to post
Share on other sites

:'( ok i have just installed this contributation, have 2 errors in different sections

 

when i log in as a test customer and make a dummy purchase all goes well, i then go to make a return request, and i see this

 

3 x Gift Certtificate TEXT_RMA # 70652062407

 

but being that i have already asked for a rma you see that but if i have not asked for rma this is what i see

 

1 x Flying Dragond 1 TEXT_RETURN_PRODUCT

 

and on top of that i see

 

HEADING_ORDER_NUMBER (Pending)

HEADING_ORDER_DATE Monday 29 January, 2001

and this

Top ? Catalog ? NAVBAR_TITLE_1 ? NAVBAR_TITLE_2 ? NAVBAR_TITLE_3

HEADING_ORDER_DATE Monday 29 January, 2001

HEADING_ORDER_TOTAL $106.72

 

i see the text of the script, any help here woudl be greatly appreciated, and then for the second issue is this

 

when i go to the admin section i see the rma section but when i click on the link i get the TEXT_IN_THE_URL kind of thing, any help ..please


Adrian Padilla

Share this post


Link to post
Share on other sites

Your corresponding language file is not being included. You should see

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_ACCOUNT_HISTORY_INFO);

around line 30 of your account_history_info.php file. If you find that line, then your language file is missing.

 

 

HTH

 

Tim

Share this post


Link to post
Share on other sites

i got it fixed thanks ..sorry for not responding sooner, but fyi.......that as it.........i skipped that step completely ....over zealous to get it going


Adrian Padilla

Share this post


Link to post
Share on other sites

Non-Defective products are subject to a 12.5% restocking fee. All returned products are inspected for the reason of return before a final decision is made.

 

 

Where do I change the amount for a restocking fee? :blush:

Share this post


Link to post
Share on other sites
Where do I change the amount for a restocking fee?

Admin > Configuration > Stock > Default Charge for Restocking a Non-Faulty Item

 

I've added this to the instructions, along with a bunch of other enhancements. I will upload a new version of this contribution shortly.

 

If anyone has any idea what the "Restore Order" function does, please post a note to this thread describing what it is for and how it works, in as much detail as you can. I will add then add that to the documentation in the next version of this contribution.

 

Also, an explanation as to why an alternate version of admin/password_forgotten.php is included in this contribution would be most helpful. It's not at all clear why the contribution's version should be used in place of the stock MS2 version of this file.

 

Hopefully someone will post info on these two topics soon, so I can include this information in the next version of the contribution that will be uploaded shortly.

 

Thanks!

 

Justin

Share this post


Link to post
Share on other sites
If anyone has any idea what the "Restore Order" function does, please post a note to this thread describing what it is for and how it works, in as much detail as you can. I will add then add that to the documentation in the next version of this contribution.

 

Also, an explanation as to why an alternate version of admin/password_forgotten.php is included in this contribution would be most helpful. It's not at all clear why the contribution's version should be used in place of the stock MS2 version of this file.

 

Hopefully someone will post info on these two topics soon, so I can include this information in the next version of the contribution that will be uploaded shortly.

 

Thanks!

 

Justin

 

 

As far as the Restore Order feature, I have no idea. That was included in the contribution from the actual creator. The password forgotten in the admin section is different than the other.

 

The original one is for customers that forget their password can click on the "Forgot Password" from the login page. The other one, also by the creator is if say you get a phone call from a customer saying their password isn't working (if they don't use the one from the login), you can go to your Customers database, find their name and send them a new password from your admin (you will see "Send Password" under the buttons). Comes in handy when they call instead of using the feature in login.

 

HTH

Edited by only2empires

Share this post


Link to post
Share on other sites

I have posted version 2.4 of the RMA Returns System, including a few new features and a lot of bug fixes:

 

New Features

* Customers will not see restocking fee notice if restocking fee is set to zero

* Product return link not shown to customers for Pending or Processing orders

* Order number added to Returns detail page

 

Fixes

* Returned products are now properly added back to stock

* Refund now properly includes any tax that was added to the order

* Return status now properly defaults to Pending

* Much improved Customer Returns box navigation in admin

* Voucher refund email routines improved

* Better integration with MS2 filename/tablename definition structure

* Unneeded gv_tracking table deleted

* Many English improvements

* Enhanced documentation and version history

 

A more detailed version history can be found at the end of the ReadMe file included in the archive. This version history will be useful for those upgrading from 2.3 to 2.4.

 

In order to eliminate the need for multiple downloads, version 2.4 includes the RMA infobox and Address Enhancer extras contributed previously. With the possible exception of the Credit Class / Gift Voucher contribution, no other patches or files should be required.

 

And now, a few general comments about this contribution.

 

It's difficult to run a store efficiently without a mechanism for accepting, tracking, and processing returns. Mr. Howarth -- the original author of this contribution -- has done us all a service by contributing the original RMA Returns System code to the osCommerce community, and we all owe him our gratitude. This contribution has since been improved upon by a number of helpful folks, including Sebastian Krupp, Cathy, and IceTheNet.

 

Nonetheless, it would be irresponsible not to point out several important observations. There were a few problems with this contribution that were show-stoppers for us (tax not being included, product not being added back to inventory, etc.), so I spent a decent amount of time looking through the code. Having pored over the code for a few hours, I can say without exaggeration that the RMA Returns System is the most haphazardly written contribution I have ever seen. It is utterly overflowing with cruft. There are numerous database fields that are added but not used. Large chunks of abandoned, commented-out code are scattered across numerous PHP files. OSC's multilingual framework is honored in some places and ignored in other places as evidenced by several hard-coded English text strings. Other unrelated contributions (or worse, fragments of other contributions) are also included in this kipplefest. It's a complete mess, held together with twine and bubble gum. While I have made over a dozen fixes and enhancements in order to make this contribution usable for our needs, most of the cruft remains. I simply don't have the time or skills at my disposal to clean everything up. (I am not a programmer and know nothing about PHP -- my changes were made purely on instinct and trial/error.)

 

To be fair, this is a very ambitious project, one that has been modified by many different people. That being the case, the unsightly underbelly is perhaps unavoidable.

 

That disclaimer aside, the RMA Returns System does work... quite admirably, as a matter of fact. Where there are undoubtably countless bugs, annoyances, and other shortcomings left to be addressed, even in its current state this contribution does a remarkable job at keeping returns in order and saving time in the process. Once again, the efforts of the original author and all the subsequent contributors deserve great praise and commendation.

 

I'll do my best to provide support here for any problems that crop up with this new release, but please read the ReadMe thoroughly before posting. Of course, there are bound to be tons of additional bugs that have yet to be discovered, so 2.4.1, 2.4.2, and their brethren are probably not too far off. ;)

 

--Justin

Share this post


Link to post
Share on other sites

Super! As I've said before, I have NO IDEA about recoding things, little changes I can muddle through. :-" What I will do is take your revision and create a new fresh oscommerce on my server and see how it goes. This way anyone new coming into the program will be able to see from here on out using a CLEAN oscommerce if anything needs fixed to better guide you (or others) from here on out.

 

I'm glad you stepped up to bat on this, because frankly I could have never done the things you have done and some questions I just couldn't answer because I simply didn't know.

 

So, this weekend I will attempt a clean install and report back!!!

 

Thanks Justin,

 

Cathy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×