Jump to content
Sign in to follow this  
VJ

[Contribution] Links Manager for osC v1.00

Recommended Posts

Marianna - It looks OK. I can't think of anything else to suggest other than to look at the tables in the database using phpmyadmin.

 

Steve - Notice the items you are missing (compared to Marianna's). You should run back through the instructions to see where it went wrong.

 

Jack

 

 

Jack I checked and the tables weren't there. I did install everything again. When I run links_setup I get the following error.

 

 

 

SQL query:

 

 

MySQL said:

 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<?php

 

require('includes/application_top.php')' at line 1

 

These are the first lines from catalog/includes/application_top.php

 

 

<?php

/*

$Id: application_top.php,v 1.280 2003/07/12 09:38:07 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

Share this post


Link to post
Share on other sites
Jack I checked and the tables weren't there. I did install everything again. When I run links_setup I get the following error.

SQL query:

MySQL said:

 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<?php

 

require('includes/application_top.php')' at line 1

 

These are the first lines from catalog/includes/application_top.php

<?php

/*

$Id: application_top.php,v 1.280 2003/07/12 09:38:07 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright ? 2003 osCommerce

 

 

 

 

 

 

 

Sorry here is the whole SQL error:

 

 

 

Server: localhost

Error

There seems to be an error in your SQL query. The MySQL server error output below, if there is any, may also help you in diagnosing the problem

 

ERROR: Unknown Punctuation String @ 1

STR: <?

SQL: <?php

/*

$Id: links_setup.php,v 1.00 2003/10/02 Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application_top.php');

 

 

SQL query:

 

 

MySQL said:

 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<?php

 

require('includes/application_top.php')' at line 1

 

[ Back ]

 

 

and here is the first lines from links_setup.php

 

 

<?php

/*

$Id: links_setup.php,v 1.00 2003/10/02 Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application_top.php');

Share this post


Link to post
Share on other sites

Are you running links_setup.php from a browser or with phpmyadmin?

 

Jack

Share this post


Link to post
Share on other sites

From the instruction file

Step 3: Fire up your browser and run /catalog/links_setup.php, to update your

database. Note that catalog refers to the directory your shop is in.

You don't use phpmyadmin.

 

Jack

Share this post


Link to post
Share on other sites
From the instruction fileYou don't use phpmyadmin.

 

Jack

 

 

I'm going to sound silly Jack but how do I do that. Sorry, but I'm new.

Share this post


Link to post
Share on other sites
I'm going to sound silly Jack but how do I do that. Sorry, but I'm new.

 

 

 

 

Ooops ok I got it.

 

But when I click submit I get the following

error

 

 

Parse error: syntax error, unexpected T_STRING in /home/hotling3/public_html/includes/languages/english/links_submit.php on line 46

Share this post


Link to post
Share on other sites
Ooops ok I got it.

 

But when I click submit I get the following

error

Parse error: syntax error, unexpected T_STRING in /home/hotling3/public_html/includes/languages/english/links_submit.php on line 46

 

 

 

 

line 46 47

 

 

define('EMAIL_SUBJECT', 'Welcome to ' . www.xxxxxx.net . ' link exchange.');

Share this post


Link to post
Share on other sites
line 46 47

define('EMAIL_SUBJECT', 'Welcome to ' . www.xxxxxx.net . ' link exchange.');

 

 

 

changed the line to just the name instead of www.xxxxxx.net and still getting an error when clicking sumbit a link

Share this post


Link to post
Share on other sites

Try using links_setup.php, not links_submit.php. So if your domain name is mysite.com, you would type in

 

Jack

Share this post


Link to post
Share on other sites
Try using links_setup.php, not links_submit.php. So if your domain name is mysite.com, you would type in

 

Jack

 

 

 

Thank you Jack for all your help .....all working now

 

this is a great contribution

 

Thank you

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

j

Share this post


Link to post
Share on other sites

Download the latest Ultimate SEO contribution and update your .htaccess file.

 

Jack

Share this post


Link to post
Share on other sites
hmmmm mine too!!! the table exists but it says it doesn't other than that it works fine :)

 

1146 - Table 'paddockstandshop.table_links_status' doesn't exist

 

select links_status_id, links_status_name from table_links_status where language_id = '1'

 

[TEP STOP]

 

You have to define the database in your includes/database_tables.php ... it appears you didn't.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
You have to define the database in your includes/database_tables.php ... it appears you didn't.

 

Thanks Jacks_mcs

 

I have reinstalled the contribution again and (touch wood) it all appears to be working again :o)

 

Thanks for your time

 

Regards

 

Steve


Regards

 

Steve

Share this post


Link to post
Share on other sites

I have managed Links Manager and Ultimate_SEO_URL worked together. However, some weird things happened. The links Manager version is 1.14 and the SEO version is the version posted by yesudo on 31 Oct 2006 at http://www.oscommerce.com/community/contri...,all/search,seo plust some code merge Nventa's 2.2 version to make this enabled on LinksManager.

 

The problem you can check at my lab website: http://perfectillusion.net/catalog/links.php. The big problem is that under the links category page, there is shown no links! Although you can see the links count on the category page, but after you click a category, there are no links there, it says "There are no links to list in this category". I have checked my install process, and seems no any messed up in the code. So what's the problem? By the way, in admin, the link is checked and approved.

 

The other one is that, on that page, that is http://perfectillusion.net/catalog/jewelry-links-1.html, the url at the end of the breadcrumb. The url is link to the same link category page, in this case, jewelry, but, it show as http://perfectillusion.net/catalog/links.php?lPath=1, not a SEO url format!

 

 

Is any of you have the same problems as I have?

Share this post


Link to post
Share on other sites

Hi Everybody,

 

Just change in all the files:

 

TABLE_LINKS to links

TABLE_LINKS_DESCRIPTION to link_description

etc....

 

do not alter the define stuff

define('TABLE_LINK_CATEGORIES', 'link_categories');

This is where the mistake was made.

 

just change in all files exept the .sql file the name af the tables to:

TABLE_LINKS to links

etc.....

 

When this has been done this link exchanger works mighty fine!!!!!

 

Greetz,

 

drumidiot

Edited by drumidiot

Share this post


Link to post
Share on other sites
I have managed Links Manager and Ultimate_SEO_URL worked together. However, some weird things happened. The links Manager version is 1.14 and the SEO version is the version posted by yesudo on 31 Oct 2006 at http://www.oscommerce.com/community/contri...,all/search,seo plust some code merge Nventa's 2.2 version to make this enabled on LinksManager.

 

The problem you can check at my lab website: http://perfectillusion.net/catalog/links.php. The big problem is that under the links category page, there is shown no links! Although you can see the links count on the category page, but after you click a category, there are no links there, it says "There are no links to list in this category". I have checked my install process, and seems no any messed up in the code. So what's the problem? By the way, in admin, the link is checked and approved.

 

The other one is that, on that page, that is http://perfectillusion.net/catalog/jewelry-links-1.html, the url at the end of the breadcrumb. The url is link to the same link category page, in this case, jewelry, but, it show as http://perfectillusion.net/catalog/links.php?lPath=1, not a SEO url format!

Is any of you have the same problems as I have?

Maybe the language option is not set correctly?

 

Jack

Share this post


Link to post
Share on other sites
Hi Everybody,

 

Just change in all the files:

 

TABLE_LINKS to links

TABLE_LINKS_DESCRIPTION to link_description

etc....

 

do not alter the define stuff

define('TABLE_LINK_CATEGORIES', 'link_categories');

This is where the mistake was made.

 

just change in all files exept the .sql file the name af the tables to:

TABLE_LINKS to links

etc.....

 

When this has been done this link exchanger works mighty fine!!!!!

 

Greetz,

 

drumidiot

 

Hi, what are you talking about? I am using LinksManager V 1.14. Everything seems correct.

 

Hi, Jack, thanks for reply my post. But I don't seem that in the admin, under links manager, there seems no languages select option. If you refer to under the edit link page, and yes, I set the language to English. which language option you refer to?

Share this post


Link to post
Share on other sites

In admin->Configuration->Links. Also, if the order of your languages have been changed in admin->Localization->Languages, it might cause a problem.

 

Jack

Share this post


Link to post
Share on other sites
In admin->Configuration->Links. Also, if the order of your languages have been changed in admin->Localization->Languages, it might cause a problem.

 

Jack

 

Wow! Thanks, it worked! I changed the order of my languages in admin->Localization->Languages. I have set it back, the links showed up!

 

So I think now just leave the following:

1. How to make the link at the end of the breadcrumb on the http://perfectillusion.net/catalog/jewelry-links-1.html to be the same?

 

2. If I have added another language, in this case Chinese for example, how can I make show this language's links in admin->Configuration->Links?

 

Thanks alot!

Share this post


Link to post
Share on other sites

1 - Are you saying you want html to be included in the breadcrumb?

 

2 - For a new langauge, you have to add the code to links.php to see that language. You can just copy the section of code for one of the other languages (they are marked) and change the names to match the other language.

 

Jack

Share this post


Link to post
Share on other sites
1 - Are you saying you want html to be included in the breadcrumb?

 

2 - For a new langauge, you have to add the code to links.php to see that language. You can just copy the section of code for one of the other languages (they are marked) and change the names to match the other language.

 

Jack

 

Thanks Jack! Even though I haven't check to see if that is the way to add a new language, but I thought, at least at this moment, do this will add an option to the admin->Configuration->Links? You mean the links.php under the admin folder, right?

 

And the breadcrumb: If you go to that page on my lab site: http://perfectillusion.net/catalog/jewelry-links-1.htm, hove the mouse over the "jewelry" at the end of the breadcrumb, and watch the status bar of your browser, you will see the url is: http://perfectillusion.net/catalog/links.php?lPath=1. This link should link to the same page you are on right now, I thought since the SEO urls enabled, why it is at non-seo-url format? Maybe this is a problem of the Ultimate_SEO_URLS contribution?

 

Thank you very much for your input!

Edited by NerioDavid

Share this post


Link to post
Share on other sites

For the language, the code is in the links.php file in the root.

 

As for the breadcrumb, thanks for pointing that out. I never noticed it before. Here is the fix. In links.php and links_submit.php, find

 $breadcrumb->add($link_categories_value['link_categories_name'], FILENAME_LINKS . '?lPath=' . $lPath);

and change it to

$breadcrumb->add($link_categories_value['link_categories_name'], tep_href_link(FILENAME_LINKS, 'lPath=' . $lPath));

 

Jack

Share this post


Link to post
Share on other sites
For the language, the code is in the links.php file in the root.

 

As for the breadcrumb, thanks for pointing that out. I never noticed it before. Here is the fix. In links.php and links_submit.php, find

 $breadcrumb->add($link_categories_value['link_categories_name'], FILENAME_LINKS . '?lPath=' . $lPath);

and change it to

$breadcrumb->add($link_categories_value['link_categories_name'], tep_href_link(FILENAME_LINKS, 'lPath=' . $lPath));

 

Jack

 

 

Thanks. it works beautifully! :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×