Jump to content
Sign in to follow this  
VJ

[Contribution] Links Manager for osC v1.00

Recommended Posts

It's still pointing to a problem with your database. You will need to check and see why you don't have the table. I wonder if you ran an update script instead of the full database install?

 

Jack

 

 

 

Jack I'm fearly new to this. I don't know exacly where to beggin. I installed a full package (LinksManager_V_1.14). Should I start over? If I do, I still have to run links_setup.php again?

 

Thank you

Share this post


Link to post
Share on other sites

Unfortunately, there is no way to answer your question since I don't know what has gone on. If you only installed a partial database update, then it will be difficult for you to fix that, due to lack of experience with the database. Or maybe a mistake has been made in the files? Maybe both. The best way to go would be to restore it all and start over, but if you made the changes to a live shop, that would be difficult to do with your database. You could create a second shop in a sub-directory and test it there. But that might not be something you can do, based on being new. If I knew what to tell you, I would, but I don't.

 

Jack

Share this post


Link to post
Share on other sites

Hi Jack, all. I installed Jack's 1.14 on my site, and I really like the idea. My personal feeling is that it could be very good for SEO if used properly. I'm not interested, however, in having dozens if not hundreds of reciprocal links. I'd like perhaps 15-20 solid links with others in my industry.

 

That said, I don't want to have categories. I'd like them to be not required, but really, I'd just like them gone, completely, not required to fill out, and not even on the submission form. You can see my page here: http://www.thevisiondepot.com/links.php ... as you can see, I don't even have any categories -- I don't know how to put one in.

 

I've looked at the code, but I have no idea how to take categories out -- or, at the very least, not make 'em a requirement. Could anyone assist me here?

 

Thanks a bunch,


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites

Quite a few people have mentioned this and it is planned for a future release, but I've no idea when that might be. it is not a simple change since the code was written assuming there would be categories. You can setup a links on your page to go to just one category though. To anyone looking at it, it would appear that there are no categories. It is not difficult to do that. Just setup your links in one category and then add a link on the shop to that page. You should remove the Categories button in the code too.

 

Jack

Share this post


Link to post
Share on other sites

Thanks Jack. Per your advice, I worked it out with categories, and I kinda like the way it looks. I didn't realize that the admin interface gave you so many options. Great contribution (as always) Jack ... I think I'm gonna have fun with this one and put it to good use.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
Everyone who's been having that "1064 - You have an error in your SQL syntax near 'xor ld.language_id = '99')' at line 1..." error, here's the solution:

 

I've got PHP 4.3.2 installed.

"xor" is I believe some older binary operator. I changed it to "or" and it got rid of the error.

 

ciraklizer

 

 

What do I have to do to make that change?

 

Many thanks.

Share this post


Link to post
Share on other sites

Just wondering if it's possible to list all of the links on the links.php page instead of having to choose a category? I like having categories, but it'd be nice to view all of the links at once and then have the option to narrow them down by categories if needed. Let me know if this is possible. Thanks!

Share this post


Link to post
Share on other sites

The fix mentioned may not make the code function properly but the code is located in link.php if you want to try it. Just search for xor.

 

Jack

Share this post


Link to post
Share on other sites

Greetings,

 

I installed the link exchange script succesfully but How do I add or make a link categorie?

 

Thank you,

 

Peter Kroon

Share this post


Link to post
Share on other sites

Greetings,

 

I figured it out, the problem is that the script uses different table names for the same table, example: TABLE_LINKS also seen as just "links".

 

I will upload the correct files so everbody can use them.

This will happen after I corrected all files.

 

Thanks,

 

Peter Kroon

Edited by drumidiot

Share this post


Link to post
Share on other sites

Please don't upload individual files. Also, can you point out where the problem is at (file name)?

 

Jack

Share this post


Link to post
Share on other sites

Hi

 

Please Jack I need help with Links manager. Keep getting the same messege even after starting over again

 

 

1146 - Table 'xxxxxx_ecom.links_status' doesn't exist

 

select links_status_id, links_status_name from links_status where language_id = '1'

 

Thank you

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

hmmmm mine too!!! the table exists but it says it doesn't other than that it works fine :)

 

1146 - Table 'paddockstandshop.table_links_status' doesn't exist

 

select links_status_id, links_status_name from table_links_status where language_id = '1'

 

[TEP STOP]


Regards

 

Steve

Share this post


Link to post
Share on other sites
It's saying the table doesn't exist. Did you run the sql file?

 

Jack

 

 

 

I did run the SQL file Jack. Is there anything else I can do. The contribution worked for a while like half a day or so.

Edited by katiallo

Share this post


Link to post
Share on other sites

If the code is setup correctly and the table really can't be found, the error should say something like TABLE_LINK_STATUS doesn't exist. Since yours is displaying in lower case, it looks like the definition for the table name is incorrect. Take a look at the admin/includes/database_tables.php file and find this code

define('TABLE_LINKS_STATUS',

and post the full line here.

 

Jack

Share this post


Link to post
Share on other sites
If the code is setup correctly and the table really can't be found, the error should say something like TABLE_LINK_STATUS doesn't exist. Since yours is displaying in lower case, it looks like the definition for the table name is incorrect. Take a look at the admin/includes/database_tables.php file and find this code
define('TABLE_LINKS_STATUS',

and post the full line here.

 

Jack

 

 

 

Here it is Jack:

 

 

// VJ Links Manager v1.00 begin

define('TABLE_LINK_CATEGORIES', 'link_categories');

define('TABLE_LINK_CATEGORIES_DESCRIPTION', 'link_categories_description');

define('TABLE_LINKS', 'links');

define('TABLE_LINKS_DESCRIPTION', 'links_description');

define('TABLE_LINKS_TO_LINK_CATEGORIES', 'links_to_link_categories');

define('TABLE_LINKS_STATUS', 'links_status');

define('TABLE_LINKS_CHECK', 'links_check');

define('TABLE_LINKS_FEATURED', 'links_featured');

// VJ Links Manager v1.00 end

Share this post


Link to post
Share on other sites

// VJ Links Manager v1.00 begin

define('TABLE_LINK_CATEGORIES', 'link_categories');

define('TABLE_LINK_CATEGORIES_DESCRIPTION', 'link_categories_description');

define('TABLE_LINKS', 'links');

define('TABLE_LINKS_DESCRIPTION', 'links_description');

define('TABLE_LINKS_TO_LINK_CATEGORIES', 'links_to_link_categories');

define('TABLE_LINKS_FEATURED', 'links_featured');

// VJ Links Manager v1.00 end


Regards

 

Steve

Share this post


Link to post
Share on other sites

Marianna - It looks OK. I can't think of anything else to suggest other than to look at the tables in the database using phpmyadmin.

 

Steve - Notice the items you are missing (compared to Marianna's). You should run back through the instructions to see where it went wrong.

 

Jack

Share this post


Link to post
Share on other sites
Marianna - It looks OK. I can't think of anything else to suggest other than to look at the tables in the database using phpmyadmin.

 

Steve - Notice the items you are missing (compared to Marianna's). You should run back through the instructions to see where it went wrong.

 

Jack

Copied and pasted missing defines into mine but when I get a little more time I might reinstall the contribution. The worrying thing for me is, it all worked fine and dandy for a day or two the bang....


Regards

 

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×