Jump to content
Sign in to follow this  
iiinetworks

[CONTRIBUTION] File uploads as an Option Feature

Recommended Posts

Hey guys got this to work!!! YEAH!!!

 

ok on the enhancement part...for the admin to click a view here linnk...its not working at all....can anyone help?

 

Thanks

 

Hi justin,

 

Just wondering if you could help me out with the database modifications in part A of the upload .7. I saw that you got this to work and i cant seem to get the settings to work in myphpadmin. If you have anytime could you show me wehat you did for part A in the readme.html??? It would be a huge help.

 

Thanks

Jeremy

Share this post


Link to post
Share on other sites

Hi

 

when will be a update release ? And May be the new Update with not only the Files! Please with a Description of How we hve to Update a.s.o.

 

 

thx

Share this post


Link to post
Share on other sites
Hi everybody!

 

Now I am trying to install the v8 version.

 

I went to phpmyadmin, clicked on "SQL" and ran the "option_type_feature.sql".

 

But I keep getting this error:

Can anybody tell me what I am doing wrong here??????

 

I had character set on "utf8" and compression "autodetect".

 

Do I have to go to the "products_options" and than run the sql file or what????

 

I appreciate any help/hint! :'(

 

THANKS!

 

 

Hi, i got the same error, i am wondering what you did to fix this when you were entering in that "option_type_feature.sql". That's the only one i am having trouble with. For some reason its not adding the table "Product_options_type", and i got the same error as you. Any help would be appreciated.

 

Thank you!

Share this post


Link to post
Share on other sites
1146 - Table 'commerce.TABLE_PRODUCTS_OPTIONS_TYPES' doesn't exist

select products_options_types_id, products_options_types_name from TABLE_PRODUCTS_OPTIONS_TYPES where language_id='1' order by products_options_types_id

[TEP STOP]

This is the error I got when I try to add �new prod attributes. What shall I do? The table does exist.

 

Thanks in advance

Ellinor

 

 

Hi there, ive ran into this problem along the way too, what did you end up doing to fix this?

 

Thanks,

Share this post


Link to post
Share on other sites
Hey guys got this to work!!! YEAH!!!

 

ok on the enhancement part...for the admin to click a view here linnk...its not working at all....can anyone help?

 

Thanks

 

Could you help me out and letting me know how you got the file upload to work? I get the same "Error: destination does not exist." everytime. ive installed it 3 separate times and i get the same result. My database entries worked perfect, i have all the files from a clean install replaced and added, and double checked everything. Can someone PLLLEASSSEEEE put up a new version that actually works without having to change anything. I really really need this!!

 

Thanks for your much needed help ahead of time!!!

Share this post


Link to post
Share on other sites
I get the same "Error: destination does not exist." everytime.

 

check this:

 

in your catalog

you should have images/uploads

directory

make sure that directory called uploads is CHMOD 777

inside it you should have that .htaccess file that came with the distribution

 

I am in process of installing this mod on a clean 2.2Rc2a and so far I was able to get it working but have not done testing yet.


Genie Livingstone

thanks for not spamming the forums

Share this post


Link to post
Share on other sites

Hello,

 

I really like osCommerce and I was able to set it up, configure it to my liking and it all seams well. However I am in need to allow my customers to upload their images and so I thought I would install Upload.7. It all went down hill from there, I started getting database errors, script errors and every other error. I uninstalled it and reinstalled it and then tried to install the Product Attributes Option addin thinking that the Upload.7 feature addin needed it to function and still nothing but errors. I have restored my osCommerce and it works very well but I still can not install the feature or features to add the option for my customers to upload their pic's. I searched the this forum and the web and see that some people were able to get the feature working for them but allot other people still were unable to get it to work.

 

Do the features like

Product Attributes - Option Type Feature

File Upload.7

 

work with "osCommerce Online Merchant v2.2 Release Candidate 2a", or only the earlier versions?

 

Is there a complete download that contains all of the corrected files and everything needed to either install the whole osCommerce package (including the addin features "Product Attributes - Option Type & File Upload.7") or

 

A complete download with all the corrected files and everything needed to add just the upload feature to my current version of osCommerce (osCommerce Online Merchant v2.2 Release Candidate 2a) with out having to fix errors and or bugs?

 

I really appreciate all your help with this

Share this post


Link to post
Share on other sites

Hey everyone,

 

I added an add on. File Feature v8. when i try and up load an image i get this

 

Error: destination does not exist.

 

but i can't find anywhere on osC how to fix. can someone please help me out

 

this is where i have the website

 

http://smogunlimited.com/NSCreativeSolutio...?products_id=28

 

 

thanks for the help


"Knowing others is intelligence; knowing yourself is true wisdom. Mastering others is strength, mastering yourself is true power." Lao-Tzu (6th century B.C.), Chinese philosopher

Share this post


Link to post
Share on other sites

I feel you...I have been asking for help for over 1 year and have had no luck. sucks :'(

 

 

Does anyone have this contribution working with the "OPTIONS TYPE" contribution? I'm running into a problem when trying to display the textarea box.

 

i've been posting my updates on the general forum but haven't had any luck. Please let me know if anyone can help me....

 

http://forums.oscommerce.com/index.php?showtopic=300439


"Knowing others is intelligence; knowing yourself is true wisdom. Mastering others is strength, mastering yourself is true power." Lao-Tzu (6th century B.C.), Chinese philosopher

Share this post


Link to post
Share on other sites
Does anyone have this contribution working with the "OPTIONS TYPE" contribution? I'm running into a problem when trying to display the textarea box.

 

i've been posting my updates on the general forum but haven't had any luck. Please let me know if anyone can help me....

 

http://forums.oscommerce.com/index.php?showtopic=300439

use v.8, .7 wouldnt work for me. Also make sure you manually configure your configure.php. it is not in the import files.

 

// CLR 020605 defines needed for Product Option Type feature.

define('PRODUCTS_OPTIONS_TYPE_SELECT', 0);

define('PRODUCTS_OPTIONS_TYPE_TEXT', 1);

define('PRODUCTS_OPTIONS_TYPE_RADIO', 2);

define('PRODUCTS_OPTIONS_TYPE_CHECKBOX', 3);

// iii 030813 added: File Uploading: FILE type and UPLOAD_PREFIX

define('PRODUCTS_OPTIONS_TYPE_FILE', 4);

define('UPLOAD_PREFIX', 'upload_');

define('TEXT_PREFIX', 'txt_');

define('PRODUCTS_OPTIONS_VALUE_TEXT_ID', 0); //Must match id for user defined "Text" value in db table TABLE_PRODUCTS_OPTIONS_VALUES

 

define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');

define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);

?>

 

 

 

 

I have it up and running. i need to fix my text shifter to the side, but anyone know of a product that will let the user see the item they uploaded before they buy it?

Share this post


Link to post
Share on other sites
check this:

 

in your catalog

you should have images/uploads

directory

make sure that directory called uploads is CHMOD 777

inside it you should have that .htaccess file that came with the distribution

 

I am in process of installing this mod on a clean 2.2Rc2a and so far I was able to get it working but have not done testing yet.

 

Any luck with your test as I get this same error and have already tried everything you have listed plus a hundred other things

Share this post


Link to post
Share on other sites

I'm also working on getting File_Feature_v.8 working with

product_attributes_option_type_3.0

 

One area of conflict is that I want to use both textarea and file upload,

so I needed to change configure.php (both in catalog/includes and catalog/includes/local)

 

from:

define('PRODUCTS_OPTIONS_TYPE_TEXTAREA', 4);

define('PRODUCTS_OPTIONS_TYPE_FILE', 4);

 

to:

define('PRODUCTS_OPTIONS_TYPE_TEXTAREA', 4);

define('PRODUCTS_OPTIONS_TYPE_FILE', 5);

 

also I changed the database table `products_options_types`

INSERT INTO `products_options_types` (`products_options_types_id`, `products_options_types_name`, `language_id`) VALUES (4, 'Textarea', 1);

INSERT INTO `products_options_types` (`products_options_types_id`, `products_options_types_name`, `language_id`) VALUES (5, 'File', 1);

 

I also changed database_table.php to include

define('TABLE_ADMINISTRATORS', 'administrators');

 

Hope this helps.

Share this post


Link to post
Share on other sites

I've been using this contribution for a couple months and it works PART of the time. My problem is that the customers_id does not always fill in the files_uploaded table and I don't know which files belong to which customer. Sometimes it works, some times it doesn't. I don't see how customers could be using it in a way that doesn't get a match for the id.

 

Can anyone offer a suggestion on where to look to make sure I get this field filled 100% of the time? Also, is there a way to also record the order number and product item number with each uploaded file?

 

Thanks!!!

Share this post


Link to post
Share on other sites
Could you help me out and letting me know how you got the file upload to work? I get the same "Error: destination does not exist." everytime. ive installed it 3 separate times and i get the same result. My database entries worked perfect, i have all the files from a clean install replaced and added, and double checked everything. Can someone PLLLEASSSEEEE put up a new version that actually works without having to change anything. I really really need this!!

 

Thanks for your much needed help ahead of time!!!

 

After trying to install today I noticed the problem of an error "Error: destination does not exist." After trying all the suggestions for a fix in this forum I was still out of luck. I noticed that the destination that the script was trying to write to was /catalogimages/uploads instead of /catalog/images/uploads. Not knowing how to modify the script I created the directory catalogimages and put the uploads directory in there...and success!!!

 

I hope this helps some of you that have had similar problems recently.

Share this post


Link to post
Share on other sites

I'm still having a problem installing the contrib, hopefully this will take someone 6 seconds to write a sentence to point me in the right direction... anyway, i've edited all 3 of the sql files as instructed, then it says:

"STEP 1. Use the admin tool to create a new Products Option. (In upper left table)"

 

Where is this? I cannot find it anywhere?

 

thanks a bunch guys...

Share this post


Link to post
Share on other sites

never mind, installed an older version of oscommerce an the options are there, gettin some error messages but i have something to work with now

Share this post


Link to post
Share on other sites

ok here's my problem, I've done what i think it tells me to in the instructions, but in the product info page, i have a text option, and an image upload option, both have empty drop down boxes next to them,, no upload/browse for files button, and no box for text input... here is a picture of my attributes page:

http://i195.photobucket.com/albums/z177/ch...ill/problem.jpg

 

Also, it says to add EXACTLY ONE attribute,,, but i used a template which already had 5 on it, i had to delete these first, would this make a difference?

 

thanks guys

Share this post


Link to post
Share on other sites

I know this thread is old but I have just found the contribution and am thinking of installing it. However, could anyone please confirm what, actually, happens to the file once it is uploaded. For example, is it attached to the order and displayed in Admin against the Customer order? Also, is this a modification to the following contribution?

 

http://addons.oscommerce.com/info/160/v,22

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Hi,

 

Sorry for my english language, but I'm from Belgium and I speak French.

 

I have this contribution ( File Upload .8 (for PA - Option Type Feature) instead on my site, but, always, I have this message :

 

Fatal error: Call to a member function add() on a non-object in /home2/.../includes/classes/upload.php on line 119

 

on line 119, I have this :

 

$messageStack->add('upload', SUCCESS_FILE_SAVED_SUCCESSFULLY, 'success');

 

My files (images) are ok uploaded, but I have this message and nothing others in my site !!!

 

Another member from another forum has the same problem :

 

http://forums.oscommerce.com/lofiversion/i...hp?t290296.html

 

Please help me, and many thanks,

Edited by pottepei

Share this post


Link to post
Share on other sites

Hi everyone,

 

I finally got this thing to work, took me all day.

Only have 1 little thing I can't figure out;

 

When I add a product to the cart with the file attached, it goes to the cart and displays

2 of the same products. 1 with the file attached and the other without.

So it also doubles the price and all.

 

Any ideas?

 

Thanks a bunch!

 

Patrick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×