Jump to content
Sign in to follow this  
iiinetworks

[CONTRIBUTION] File uploads as an Option Feature

Recommended Posts

Hi everyone ,

 

I installed file_feature-.77 today and I can’t seem to get it working. I see nothing. My site is working good. you can still see my website. but when I go to the admin and try to see the Contribution that I installed it not ther.

 

U am running RC1

 

PHP Version 4.4.6

 

Server OS: Linux

 

Apache/1.3.37

 

MySQL 4.1.22

 

And my site is

 

http://nscreativesolutions.smogunlimited.com/

 

Can someone help me out.

 

Thanks

Edited by flyhighsounds

"Knowing others is intelligence; knowing yourself is true wisdom. Mastering others is strength, mastering yourself is true power." Lao-Tzu (6th century B.C.), Chinese philosopher

Share this post


Link to post
Share on other sites

I've been trying to get this to work for a couple weeks and am now getting desperate. I've files being uploaded, but they are with the 1,2,3, naming pattern. I tried the code to get the full file name, but it's not working. I also don't have the files showing on the customer orders to know which customer uploaded which file. I don't know what to try next.

 

I am new to OSC and dont' know PHP. Is there anyone willing, and qualified, to help me with this if I provide them FTP access?

 

Any help is GREATLY appreciated!!!!

Share this post


Link to post
Share on other sites
I've been trying to get this to work for a couple weeks and am now getting desperate. I've files being uploaded, but they are with the 1,2,3, naming pattern. I tried the code to get the full file name, but it's not working. I also don't have the files showing on the customer orders to know which customer uploaded which file. I don't know what to try next.

 

I am new to OSC and dont' know PHP. Is there anyone willing, and qualified, to help me with this if I provide them FTP access?

 

Any help is GREATLY appreciated!!!!

 

 

I got it working! Thanks anyway.

Share this post


Link to post
Share on other sites
Hi everyone ,

 

I installed file_feature-.77 today and I can’t seem to get it working. I see nothing. My site is working good. you can still see my website. but when I go to the admin and try to see the Contribution that I installed it not ther.

 

U am running RC1

 

PHP Version 4.4.6

 

Server OS: Linux

 

Apache/1.3.37

 

MySQL 4.1.22

 

And my site is

 

http://nscreativesolutions.smogunlimited.com/

 

Can someone help me out.

 

Thanks

 

I could assist you with your osCommerce installation along with this mod, but I'll have to charge you a few bucks for my time. :) Let me know if you're interested; you can PM me.

Share this post


Link to post
Share on other sites
I've been trying to get this to work for a couple weeks and am now getting desperate. I've files being uploaded, but they are with the 1,2,3, naming pattern. I tried the code to get the full file name, but it's not working. I also don't have the files showing on the customer orders to know which customer uploaded which file. I don't know what to try next.

 

I am new to OSC and dont' know PHP. Is there anyone willing, and qualified, to help me with this if I provide them FTP access?

 

Any help is GREATLY appreciated!!!!

This is my piece of code in the page where you want to upload the files (I have it my checkout_shipping page).

if ($customer_id) 
			  {
				tep_db_query("insert into " . TABLE_FILES_UPLOADED . " (sesskey, customers_id, files_uploaded_name) values('" . tep_session_id() . "', '" . $customer_id . "', '" . tep_db_input($products_file->filename) . "')");
			  } else {
				tep_db_query("insert into " . TABLE_FILES_UPLOADED . " (sesskey, files_uploaded_name) values('" . tep_session_id() . "', '" . tep_db_input($products_file->filename) . "')");
			  }
			  $insert_id = tep_db_insert_id();
			// create filename : unique id + filename
			$products_file->set_filename("$insert_id" . '_' . $products_file->filename);

 

The last line gives you almost a unique filename : ID_filename. The customer can upload two different files with the same name...

 

For the admin side I do not know as I'm not using the product attributes to upload files but extra options in the checkout process. I have used this contribution as a basis for my development.

Share this post


Link to post
Share on other sites
This is my piece of code in the page where you want to upload the files (I have it my checkout_shipping page).

if ($customer_id) 
			  {
				tep_db_query("insert into " . TABLE_FILES_UPLOADED . " (sesskey, customers_id, files_uploaded_name) values('" . tep_session_id() . "', '" . $customer_id . "', '" . tep_db_input($products_file->filename) . "')");
			  } else {
				tep_db_query("insert into " . TABLE_FILES_UPLOADED . " (sesskey, files_uploaded_name) values('" . tep_session_id() . "', '" . tep_db_input($products_file->filename) . "')");
			  }
			  $insert_id = tep_db_insert_id();
			// create filename : unique id + filename
			$products_file->set_filename("$insert_id" . '_' . $products_file->filename);

 

The last line gives you almost a unique filename : ID_filename. The customer can upload two different files with the same name...

 

For the admin side I do not know as I'm not using the product attributes to upload files but extra options in the checkout process. I have used this contribution as a basis for my development.

 

Thanks! I did get it working, but I like how you inserted the underscore in the name. I didn't know enough about PHP to know how to do that. Still never got the admin side working to show who uploaded files, but found out how to set up an ODBC to MySQL and link it to MS Access (that's the technology I do know) and made an application there to deal with all the matching.

 

I appreciate your help! Thanks again!!!

Share this post


Link to post
Share on other sites
Your included database_tables.php file in version 8 is missing several important tables

 

Use a diff program like Winmerge to compare this contrib files with your files. Much better than copying files from a distribution package to your folders.

 

You are of course encouraged to fix this database_tables.php file and publish a new version of this contribution.

Share this post


Link to post
Share on other sites

I have used version .8. I have tried every suggestion that I have found on this contribution but I cannot see a file being uploaded. On my order form I see the browse and I can pick a file. I have a box so that I can add text. I have a select color. I click to checkout and I get the color displayed. I get the text from the text box added on my screen but I do not see the file listed. I do not get the file in the uploads folder.

 

I think that I have tried every version but it is still not working...anyone have suggestion. I have the uploads directory set to 777. I do not get any type of error message.

 

Help...please

Share this post


Link to post
Share on other sites

Hello all,

 

Like most here, got the file upload, added the enhancement, checked application_top and in the SQL, should all now be using #.filename.ext instead of missing the "." or having a space after the "."

 

But, still don't have "click to view" on the admin order page, and would like a recommendation for adding a preview onto the cart for the user, maybe for the admin too.

 

Has anyone got this part working and can post the code?

 

Thanks

Share this post


Link to post
Share on other sites

For some reason everytime I select anything except the select option, like radio, check box, text, file, they all default to the select option. Is there a specific place for me to look and check the code or is there a line I need to change.

I added the changes to an existing application and have included it in a fresh install with the same result.

Any help would be appreciated.

Thanks.

Share this post


Link to post
Share on other sites

Hi all,

 

After read all this thread, i decide me to write in because i cannot find help that i need.

 

I'm trying to use this contrib on my website and it don't run.

 

I tried with all version and now, i'm trying with the v.8.

 

Nothing is uploaded and i haven't description in my shopping cart.

No errors appears.

In the folder there are nothing, but the right is '777' on the folder uploads on my server.

 

Can anyone help me to solve this problem.

 

You can try by yourself to this url : http://www.ptitcado.fr/product_info.php?cP...;products_id=43

 

Thanks in advance for your help and excuse me for my English.

 

Jeff

Share this post


Link to post
Share on other sites
Hi all,

 

After read all this thread, i decide me to write in because i cannot find help that i need.

 

I'm trying to use this contrib on my website and it don't run.

 

I tried with all version and now, i'm trying with the v.8.

 

Nothing is uploaded and i haven't description in my shopping cart.

No errors appears.

In the folder there are nothing, but the right is '777' on the folder uploads on my server.

 

Can anyone help me to solve this problem.

 

You can try by yourself to this url : http://www.ptitcado.fr/product_info.php?cP...;products_id=43

 

Thanks in advance for your help and excuse me for my English.

 

Jeff

 

Hi,

 

I find by myself where it was the problem after 2 days.

 

Thanks all

 

Jeff

Share this post


Link to post
Share on other sites
I am releasing a file uploading contribution. This will be the support thread for the contribution. More details will follow after I finish uploading to the contribution area.

 

Thanks,

Matt

 

Hi Everyone,

 

I have a question if someone can answer it for me. We have an existing store and are looking at the file upload feature. We have read the posts and intend to use file upload .8 posted by riwi Oct 07. The instructions indicate we should run the sql from myphp or similar.

 

1) Will this cause a problem for an existing store with mods or should we manually insert the db fields as indicated in the instructions included with .77?

2) If we manually update the db fields, are there any changes or additions in the fields when using .8 rather than .77?

 

Thank You

Share this post


Link to post
Share on other sites

Hi all, I've tried to install this amazing contrib, but I get the message that registers globals are OFF and didn't work.

 

Any ideas to make it run on a RC1 with RG OFF?

 

Thx in advance ;)

Share this post


Link to post
Share on other sites

Hi People!

 

I am just about to install "File_Feature_v.8" and have 1 problem and 2 questions! :)

 

1)

 

I tried to run the first "option_type_feature.sql" query in phpmyadmin.....but since I am a total rookie in phpmyadmin I keep getting errors!!!!

Can someone tell me how I can do that? Or is there any instruction on that somewhere on the net????

 

2)

 

Does File Feature v8 attaches the uploaded files to a perticular order, so I can see who had uploaded the file or not?

 

3)

 

Is it possible to put the upload option after login for example after setting the shipping/payment options?

 

 

I appreciate any HELP or HINT......please! :'(

 

THANKS :blush:


IT?s ALL good!!!

Share this post


Link to post
Share on other sites

I'm also getting errors galore on installing this feature. The first step of the readme.html doesn't make much sense to me which I'm sure where most of my confusion surrounds. Would anyone be willing to explain step 1 in a more clear manner?

Share this post


Link to post
Share on other sites
I could assist you with your osCommerce installation along with this mod, but I'll have to charge you a few bucks for my time. :) Let me know if you're interested; you can PM me.

 

 

I am willing to pay for it (a few bucks), I am testing it right now with the last version oscommerce have oscommerce-2.2rc2.zip in my own computer, and I runned the sql statements with no issue, however, in the step 2 where I have to merge each of the files is where my problem begins, I can pay by paypal if you can do it in a production environments at with hostgator.com (I believed we have to update the version they carry). give me a call if you are in the USA 786-493-7181 or send me an email ivanrojas@gmail.com, i do apologize if this kind of negociation is illegal in this forum, but thanks for this contribution, i used oscommerce before and I thank to you all guys working in the anonymity, I know sql but i dont understand much of php, thanks

Share this post


Link to post
Share on other sites

Hi everybody!

 

Now I am trying to install the v8 version.

 

I went to phpmyadmin, clicked on "SQL" and ran the "option_type_feature.sql".

 

But I keep getting this error:

SQL query:

 

INSERT INTO `configuration` ( `configuration_id` , `configuration_title` , `configuration_key` , `configuration_value` , `configuration_description` , `configuration_group_id` , `sort_order` , `last_modified` , `date_added` , `use_function` , `set_function` )

VALUES ( 169, 'Product option type Select', 'PRODUCTS_OPTIONS_TYPE_SELECT', '0', 'The number representing the Select type of product option.', 0, NULL , NOW( ) , NOW( ) , NULL , NULL )

 

 

MySQL said:

 

#1062 - Duplicate entry '169' for key 1

 

Warning: Invalid argument supplied for foreach() in /usr/share/phpmyadmin/libraries/common.lib.php on line 683

 

Can anybody tell me what I am doing wrong here??????

 

I had character set on "utf8" and compression "autodetect".

 

Do I have to go to the "products_options" and than run the sql file or what????

 

I appreciate any help/hint! :'(

 

THANKS!


IT?s ALL good!!!

Share this post


Link to post
Share on other sites

Anybody out there willing to setup this module (file feature .8) I'm willing to pay. I can do Paypal. I am a basic user of the Os system and do not understand how to do the SQL.

 

Thanks

Bob

Share this post


Link to post
Share on other sites

Hi Guys.

I really need help, I hope someone has the solution. :'(

 

I’ve got other contributions installed, in this case been “Options as Images for MS2” and it works beautifully no problem at all.

 

I came across this wonderful contribution “Option Type Feature”.

I’ve installed it and it works fine but there is an issue.

 

Unfortunately my PHP knowledge it not enough to figure out the solution to get these contributions to work in harmony on the “product_info.php” page. That’s the only problem I have.

 

The issue is that they interfere with hitch other.

Does someone have both of these contributions installed and working? Or does someone know that are the changes that need to be done on “product_info.php” for this page to work properly?

 

I do not know where to place the code for Option Type Feature product_info.php without messing up the Option Type Feature and vice versa. I have tried but I only get one working at a time, not both in conjunction with hitch other.

 

Thank you in advance.

:thumbsup:

Share this post


Link to post
Share on other sites

hi

i need help

i have installed the upload contrib, and it works.

The Problem is i need the Options for Text and Files and this Options are disabled. how can i enble it?

 

Sorry for the bad english....

 

Thanks for help

Share this post


Link to post
Share on other sites

hello there,

 

For some reason i cannot get this to work. I dont have any experience with Databases and i think all i need is a clearer description on how to add the field, record, and table in part A. I have copied the files over and thats no problem so if anyone can just give me some specifics on the phpmyadmin part that would be a huge help.

 

Thanks

Share this post


Link to post
Share on other sites
Success!!! I Finally I got everything working but.........

 

My only issue is, and I've seen this question posted throughout this thread but I have not seen the answer. After a file has been uploaded to me, when I go to the uploads folder where the files are located, the files are renamed as "1", "2", "3" and so on. Now if I download them and add the extension (which I can see what they originally name in the order section of the admin panel) I can open them fine. No biggy right now since my volume is low, but I can see this becoming a major hassle if I get busy.

 

How do I retain the file names of the images people are sending me? I'm guessing this is why the update that involves check the file names on the order page is not letting click to download them?

 

Thanks in advance and sorry if this has already been answered (I missed it)

 

Hi there,

 

I was wondering if you could help me with getting upload .7 up and running. I cant seem to be able to get the database part through my head. When i set certain fields to not null, i save it, and it shows up as null again. Its really driving me crazy and i was wondering if you can share any tips on how to get all the database configurations set up correctly.

 

The entire part A in the readme.html file is all i need. I can upload the files into the correct folders no problem.

 

Thanks!!!

 

ps - your site is awesome

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×