Jump to content
Sign in to follow this  
HTD

All Products and Site Map

Recommended Posts

Yes, this is the right place !

 

Unfortunately, I did not try this version!

 

Good luck!

Share this post


Link to post
Share on other sites

Hello,

I think that this is a great contrib!

however, in my site_map_12.php file when I click the link the popup window does not have scroll bars, so you can't view the whole page. those anyone know where in the code should I add the scroll bars? those anyone else have this problem?

thank you,

Amitai

Share this post


Link to post
Share on other sites

I'm having problems with this contribution. Check out my site www.dreamwayonline.com for some reason i cant find this in this file

 

3. Open catalog/includes/application_top.php:

 

find the code: define('FILENAME_UPCOMING_PRODUCTS', 'upcoming_products.php');

 

under it, add:

 

define('FILENAME_ALL_PRODUCTS', 'all_products.php');

define('FILENAME_SITE_MAP', 'site_map.php');

 

or use this file if you prefer it (v1.2 TexaStar.com):

define('FILENAME_SITE_MAP', 'site_map_12.php');

 

 

Can you give me any help? Also, I do not like my site map where they suggest it. I want it just in my info box like i have it. Is there a reason for all of that other code to for when its supposed to be at the top? how can i get the engines to see my all products page..and is this legal by google?


Brayden Jessen

Share this post


Link to post
Share on other sites

im having the same problem!! i cannot find the string of text that i am supposed to place the new code under

 

can anyone help us??

Share this post


Link to post
Share on other sites

I'm having the same problem with this contribution. I can't find this text in my application_top.php.

 

3. Open catalog/includes/application_top.php:

 

find the code: define('FILENAME_UPCOMING_PRODUCTS', 'upcoming_products.php');

 

under it, add:

 

define('FILENAME_ALL_PRODUCTS', 'all_products.php');

define('FILENAME_SITE_MAP', 'site_map.php');

 

or use this file if you prefer it (v1.2 TexaStar.com):

define('FILENAME_SITE_MAP', 'site_map_12.php');

Share this post


Link to post
Share on other sites
I'm having the same problem with this contribution.  I can't find this text in my application_top.php.

 

3. Open catalog/includes/application_top.php:

 

find the code: define('FILENAME_UPCOMING_PRODUCTS', 'upcoming_products.php');

 

under it, add:

 

define('FILENAME_ALL_PRODUCTS', 'all_products.php');

define('FILENAME_SITE_MAP', 'site_map.php');

 

or use this file if you prefer it (v1.2 TexaStar.com):

define('FILENAME_SITE_MAP', 'site_map_12.php');

 

At least I now know that I am not the only one who can't find this. Now how can this work if this can't be found? Am I missing something somewhere? I read and re read the thread about this and I can not get it to work. I have the exact same problem. Any help out there for this?


"Wasn't me..I was dead at the time"~~~~ Dress To Kill

Share this post


Link to post
Share on other sites

Hi.

 

I'm setting up a new store & just installed this contribution.

 

I don't understand the reasoning behind the hidden links & all that..

 

So, I changed the code that shows the links in the header to this:

 

 

 

<td align="right" class="headerNavigation" width="125">

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td align="right" class="headerNavigation"><?php echo '<a href="' . tep_href_link(FILENAME_SITE_MAP, '', 'NONSSL', true) . '">' . 'Site Map</a>'; ?>   </td>

</tr>

</table>

 

You can see it in action here

 

Any comments good or bad as far as effectiveness & SEO?

Share this post


Link to post
Share on other sites

Hi

 

Not sure if this thread is still "live" as no replys to the last few problems. Anyway, i started to install all products contribution a few days ago. Ran into a problem but got no reply's to it on the forum so just undid my last step to keep my site working. I am posting here because i notice sitemap contib has some files with the same name as all products. Do i need to completly undo installing all products before adding site map? I the error happened after the step that add the all products link to the catagories box. The error is as follows......

 

http://forums.oscommerce.com/index.php?sho...ic=39737&st=100

 

thanks for your help

Paul


Regards

Paul

Share this post


Link to post
Share on other sites

The file you are looking for is includes/filenames.php

 

I'm hoping this thread starts up again because although I have this partially installed I'm so confused. (great contribution) I'm hoping I can get it to work the way its supposed to.

 

I have all the files installed. My all products page works good all products

I put a link (html) link in my header code hoping that this would still work (please let me know if it will not work that way)

 

now I have to get it to redirect for visitors. what am I missing?

I also noticed that my header_tag page is very different. where should I add the code?

 

Thanks

 

Hi

 

Not sure if this thread is still "live" as no replys to the last few problems. Anyway, i started to install all products contribution a few days ago. Ran into a problem but got no reply's to it on the forum so just undid my last step to keep my site working. I am posting here because i notice sitemap contib has some files with the same name as all products. Do i need to completly undo installing all products before adding site map? I the error happened after the step that add the all products link to the catagories box. The error is as follows......

 

http://forums.oscommerce.com/index.php?sho...ic=39737&st=100

 

thanks for your help

Paul

Share this post


Link to post
Share on other sites

Hi Terry,

 

and anyone who can assist on this,

 

I have installed and set uo the sitemap with no problems, but i would like to make an addition and not sure how to go about... As it stands the only clickable link is the products , i would like to me that category and sub category to have links too, so that if you click on a category you will go to that category,... any ideas...

 

thanks

Share this post


Link to post
Share on other sites
Hi Terry,

 

and anyone who can assist on this,

 

I have installed and set uo the sitemap with no problems, but i would like to make an addition and not sure how to go about... As it stands the only clickable link is the products , i would like to me that category and sub category to have links too, so that if you click on a category you will go to that category,... any ideas...

 

thanks

 

 

I have just hit another problem... i have a sub category in a sub category and that does not show... any help

Share this post


Link to post
Share on other sites
I have just hit another problem... i have a sub category in a sub category and that does not show... any help

 

I just installed this contrib and I love it so far! I may be able to help some:

 

As for making the categories and subcategories links, I'm not sure if this is the right way to do it, but this is what I did (if you know of a better way so the URL looks more like it does from my categories box (dynamenu) where instead of saying cPath=1&categoriesID=17 it would say cPath=1_17 - please let me know as I will be working on that shortly)

 

Look for the part of the code that gets the main categories, and then under that you will see the comment //get and display their names. Look for the "echo" section. Where you want the text link put:

 

\n<a href=\"" . tep_href_link(FILENAME_DEFAULT, 'cPath=' .str_replace("/", "/", rawurlencode($categories['categories_id'])). '&categories_id=' . $categories_desc['categories_name'] . '&language=' . $this_language_code, 'NONSSL', true) . "\">" . $categories_desc['categories_name'] . "</a>

 

Then look for the part of the code that gets the sub categories, again underneath you will find a commented line that says //get and display their names. Look for the "echo" section underneath of this, and where you want the text link put:

 

\n<a href=\"" . tep_href_link(FILENAME_DEFAULT, 'cPath=' .str_replace("/", "/", rawurlencode($categories['categories_id'])). '&categories_id=' .$parents['categories_id'] . '&language=' .$this_language_code, 'NONSSL', true) . "\">" . $sub_cat_desc['categories_name'] . "</a>

 

This will create working links with the SessionID in tact - but again I'm not sure if it's best to have the &categories_id=17 in the URL rather than just the cPath=1_17

 

 

Now - I have the same question as you regarding categories in the subcategories. Some of my categories have 3 levels rather than two - so if anyone out there knows how to create the "while" statement, or whatever it is we need in order to pull another level that would be great! I will be studying various other bits of code to see if I can figure it out - if I can I will post it here :) If anybody else knows how - a post would be greatly appreciated :thumbsup:

 

Tracy


~Tracy
 

Share this post


Link to post
Share on other sites

I only skimmed this thread and have not tried the contribution but I thought it important to note that the technique of sending the search engines to one page and your visitors to another is considered against the rules and the SE's will ban your site if they find you doing it.

 

Jack

Share this post


Link to post
Share on other sites
I only skimmed this thread and have not tried the contribution but I thought it important to note that the technique of sending the search engines to one page and your visitors to another is considered against the rules and the SE's will ban your site if they find you doing it.

 

Jack

 

I don't think that's what I'm doing. The URL just gets setup differently for some reason. Is there a big difference between cPath=1_17 and cPath=1&category_id=17 - does that cause the search engine to feel it's being sent somewhere other than where the vistors are being sent to?

 

Tracy


~Tracy
 

Share this post


Link to post
Share on other sites
I don't think that's what I'm doing. The URL just gets setup differently for some reason. Is there a big difference between cPath=1_17 and cPath=1&category_id=17 - does that cause the search engine to feel it's being sent somewhere other than where the vistors are being sent to?

 

Tracy

As I said, I didn't look into what was being done. I was only saying that based on the statement
I send Google to a (modified) allprods page thru some text and a 1 x 1 pixel transparent gif link
From googles guidelines
Make pages for users, not for search engines. Don't deceive your users or present different content to search engines than you display to users, which is commonly referred to as "cloaking."
I don't think what you are doing fits the intent of what they are talking about. However, if they found such a link, which is probably not likely, it could result in a ban. It is just something to consider.

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×