Jump to content
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

This contrib is just great, but I just have one problem. I tried to find it in this thread but I couldn't. Now when I have installed STS I get like borders around everything, have I missed doing something?

 

You have successfuly installed the contribution, now you have to modify the html default template and create your own to personalize your shop. There is a file named sts_default.html somewhere in catalog or catalog/includes folder, try to change something on it.

 

- Rigadin


STS PLUS, a variation of STS, is now available.

ACA 2.0 is also out!

Share this post


Link to post
Share on other sites

Hi,

 

If anyone else is using the product_info.php.html templates and miss the Click to Enlarge function of the images I have just uploaded a solution to this in the STS contribution section.

 

Cya

Stot

Share this post


Link to post
Share on other sites

Hi,

 

I also created and uploaded a mod to add a $masterproducts tag for product_info.php.html

 

Hope someone finds this useful.

 

Cya

Stot

Share this post


Link to post
Share on other sites

Hello i need your help about popup

I have read the 113 pages and i ve done everything is written about resolving popup problem but i didn;t succed.

I installed sts template in a clean version of oscommerce.

I put the script

<script language="javascript"><!--

function popupWindow(url) {

window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res

izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le

ft=150')

}

//--></script>

between <head> </head> in sts_template.html

i also installed the sts template version fo 02/04/2004 (fix about popup)

and the version 25/08/2004 (fix bug of 02/04/2004 version)

but no result. The popup image in product_info.php doesn' t work when i click on the phrase " click to enlarge"

Can someon please help me?

Share this post


Link to post
Share on other sites

Hi,

 

This is from a site where STS is used and the popup works. The code is between the "<body>" tags of course, not the "<head>" tags ...........

 

<td align="center" class="smallText">
<script language="javascript"><!--
document.write('<a href="javascript:popupWindow(\'http://example.com/popup_image.php?pID=49\')"><img src="images/imagecache/imagefilename.jpg" border="0" alt="Alt text" title=" Title text " width="100" height="72" hspace="5" vspace="5"><br>Click to enlarge</a>');
//--></script>

<noscript>
<a href="http://example.com/images/imagefilename.jpg" target="_blank"><img src="images/imagecache/imagefilename.jpg" border="0" alt="Alt  text" title=" Title text " width="100" height="72" hspace="5" vspace="5"><br>Click to enlarge</a>
</noscript>
</td>

 

HTH

 

Peter

Share this post


Link to post
Share on other sites
Hello i need your help about popup

I have read the 113 pages and i ve done everything is written about resolving popup problem but i didn;t succed.

I installed sts template in a clean version of oscommerce.

I put the script

<script language="javascript"><!--

function popupWindow(url) {

? window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res

izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le

ft=150')

}

//--></script>

between <head> </head> in sts_template.html

i also installed the sts template version fo 02/04/2004 (fix about popup)

and the version 25/08/2004 (fix bug of 02/04/2004 version)

but no result. The popup image in product_info.php doesn' t work when i click on the phrase " click to enlarge"

Can someon please help me?

 

Are you using a product_info.php.html file? If so you need to add that script to the header in that file also.

Edited by Stot

Share this post


Link to post
Share on other sites

Thank you all for your reply

I found the solution I don't need if it is the right solution but it works.

To the sts_display_output .php i made some changes the code in line 33

 

must look like this:

////////////////////////////////////////////

// SELECT HOW TO DISPLAY THE OUTPUT

/////////////////////////////////////////////

$display_template_output = 1;

$display_normal_output = 1;

$display_debugging_output = 0;

$display_version_output = 0;

 

 

and the line 329 must look like

 

/////////////////////////////////////////////

////// Display HTML

/////////////////////////////////////////////

if ($display_normal_output == 0) {

 

 

It works for me

and in the sts_template.html you don' t have to put the script

Share this post


Link to post
Share on other sites

Is there a way to include PHP code inside an sts_template.html file? I tried but it just typed the code like this: index.php?<? echo "osCsid=".session_id(); ?> istead of actually executing it... I search the forum but didn't find something, so please go easy on me :)


There's a diference between living & BEING ALIVE!

Share this post


Link to post
Share on other sites

Hey guys.. I need some help here.

 

I want to be able to setup a different product_info for my DVD products only.

 

On this product_info page, i want to be able to show like:

 

Pic, Name

 

Running Time:

Starring:

Rating:

 

But i dont want this to be shown for any other categories/products, Just the DVD's.

 

Anyone have an idea ? I need to be able to put the info in when i add the product, and for the product info to display this special information.

 

Can i setup a special product_info for just the DVD's

 

Please help :(

 

Steve

Share this post


Link to post
Share on other sites

i was just wondering, and i know everyone is having this problem and i have been to several of the pages linked from this site and still see the issue, it is with the popups, now im not using product_info.php.html just straight product info, and i have got mo pics 6 installed aswell, but the problem is with any popup window in the whole of OSC, is there a fix for this anywhere, because i dont know if it is just me not understanding but i can't get anything to work still..any help would be great

Share this post


Link to post
Share on other sites

I get this result:

Could you tell me what to do next?:

 

:'(

 

 

PHP Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in E:\hshome\goldenbi\testes.goldenbit.net\catalog\includes\application_top.php on line 511 PHP Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in E:\hshome\goldenbi\testes.goldenbit.net\catalog\includes\application_top.php on line 511 PHP Fatal error: main(): Failed opening required 'STS_START_CAPTURE' (include_path='.;C:\PHP\pear') in E:\hshome\goldenbi\testes.goldenbit.net\catalog\includes\application_top.php on line 511

Share this post


Link to post
Share on other sites
Hi,

 

If anyone else is using the product_info.php.html templates and miss the Click to Enlarge function of the images I have just uploaded a solution to this in the STS contribution section.

 

Cya

Stot

 

 

Hi Stot,

 

I am having trouble with the click to enlarge on STS and don't know what to look for - i get a java script error on the page and no popup window.

 

Any ideas ? http://www.bhitradeframes.com/osc is the site

 

cheers

martin

Share this post


Link to post
Share on other sites

hello i have used the latest phpBB contribution for my site www.e-mallz.com. i am using the STS template system and i have used the following contribution for the oscommerce phpbb integrations

http://www.oscommerce.com/community/contri...,3/search,phpBB

BUt it is not showing up in the site however when i used it without STS in my local server it is working just fine now . tell me what shoud i do to worked it out i need some help urgently

Share this post


Link to post
Share on other sites
Is there a way to include PHP code inside an sts_template.html file? I tried but it just typed the code like this: index.php?<? echo "osCsid=".session_id(); ?> istead of actually executing it... I search the forum but didn't find something, so please go easy on me :)

 

The goal of sts is to separate the html design from the php scripts. If you have something special to do in php, create a new sts tag in sts_user_code.php and use this tag in the template. See sts_user_code.php for an example.

 

-Rigadin

Edited by 241

STS PLUS, a variation of STS, is now available.

ACA 2.0 is also out!

Share this post


Link to post
Share on other sites
Hey guys.. I need some help here.

 

I want to be able to setup a different product_info for my DVD products only.

 

On this product_info page, i want to be able to show like:

 

Pic, Name

 

Running Time:

Starring:

Rating:

 

But i dont want this to be shown for any other categories/products, Just the DVD's.

 

Anyone have an idea ? I need to be able to put the info in when i add the product,  and for the product info to display this special information.

 

Can i setup a special product_info for just the DVD's

 

Please help  :(

 

Steve

 

 

What you need is Products Extra Fields, contribution number 2202.

 

- Rigadin


STS PLUS, a variation of STS, is now available.

ACA 2.0 is also out!

Share this post


Link to post
Share on other sites
I get this result:

Could you tell me what to do next?:

 

:'(

PHP Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in E:\hshome\goldenbi\testes.goldenbit.net\catalog\includes\application_top.php on line 511 PHP Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in E:\hshome\goldenbi\testes.goldenbit.net\catalog\includes\application_top.php on line 511 PHP Fatal error: main(): Failed opening required 'STS_START_CAPTURE' (include_path='.;C:\PHP\pear') in E:\hshome\goldenbi\testes.goldenbit.net\catalog\includes\application_top.php on line 511

You have not installed the contribution completely. There are definitions to add in the file includes/configure.php, I guess you don't have them.

 

- Rigadin


STS PLUS, a variation of STS, is now available.

ACA 2.0 is also out!

Share this post


Link to post
Share on other sites
You have not installed the contribution completely. There are definitions to add in the file includes/configure.php, I guess you don't have them.

 

- Rigadin

 

 

Rigardin:

 

I do not have words to express my gratitude to you. After 3 days of many hours trying everything, you show me where the simple mistake was. Now it is working.

 

THANK! YOU THANK! YOU THANK YOU! God bless you! :rolleyes: :lol: :) :thumbsup:

 

cmpessoa

Share this post


Link to post
Share on other sites

So can anyone give any help of the popup issue that it taunting everyone...? It is a very strange problem..

Share this post


Link to post
Share on other sites

Hello STS people ...

 

I'm relatively new to OsCommerce, and recently installed STS. Its pretty much what I expected, and am relatively satisfied.

 

Let me get to my point.

 

As far as I know, STS doesn't support customizing the actual $contents "element". Only where you can place it. Your still at the mercy of OsC's default way of displaying the categories and products. I'm familiar with the product_listing Mod, displaying in columns instead of in a Row, but I'm trying to take a step further.

 

I'd like the ability to customize the actual product listing themselves, placing each product within its own set of container images. I don't want to make it sound difficult. I'd simply like the ability to place my image on the left, with my more info/buy button, price and short description on the right. Simply have the freedom to place a set of "product_listing elements", within there respective graphic placeholders. Notice on the following site I have the price within a "price tag". Id like freedom similar to STS of dragging and dropping product_listing elements.

 

The following website is a site were migrating to OsC. Its currently written in ASP/MsSQL and runs under Lagarde's StoreFront 5.2:

 

http://plainmodels.com/xresults.asp?txtFro...rchParamVen=ALL

 

<><><><>

 

Has anyone started a Mod for this? Is anyone willing to start a Mod for this?

 

Can anyone point me in the right direction? Which files control the display of products? (not talking about product_info). I think its includes/modules/product_listings.php .. but I'm not positive.

 

If anyone is willing to help, and needs to be compensated, I can offer a barter. I'm a graphic designer/ web designer. We can trade man-hours. (portfolio furnished upon request).

 

I'm very much in need of this and is the key feature I need to be able to use OsC in the future.

 

Any and all help will be greatly appreciated.

 

Thank You

 

Respectfully,

 

Chris

Share this post


Link to post
Share on other sites

Quick question... is there any preparation that has to be done to a template that you'll be integrating with OSC using STS (ex. slicing, etc.) ? Thanks

Share this post


Link to post
Share on other sites
Quick question... is there any preparation that has to be done to a template that you'll be integrating with OSC using STS (ex. slicing, etc.) ? Thanks

 

Whats up danno ...

 

In my case, yes. Im slicing out a Fireworks/Photoshop template (mhvacsew.com/mhvacsew-gradientOrange1b.html).

 

Im currently (actually as we speak) adding the STS elements into there sliced placholders. Im trying to find the right contribs to emulate the look I have going on in my template. If you take a look at the site im working on refacing, youll see its content is large, and i have lots of work ;).

 

I've actually hard coded the tables into product_listing.php, using only my desired elements, and am pretty much content. In the future I foresee a pain customizing on a per site basis, the code that controls $contents. This is the feature I'm looking to aquire. The "freedom" of drag and dropping elements for $content.

 

Keep me posted.

 

Thanks for your time.

 

Respectfully,

 

Chris

Share this post


Link to post
Share on other sites
You have not installed the contribution completely. There are definitions to add in the file includes/configure.php, I guess you don't have them.

 

- Rigadin

 

 

I have the same problem

 

I added the definitions into the configure.php

 

http://www.pcwired.com


Spend money to earn money!!!

Share this post


Link to post
Share on other sites
I have the same problem

 

I added the definitions into the configure.php

 

http://www.pcwired.com

 

Are you saying you're still having the problem?

 

Make sure you've added them in your catalog/includes/configure.php file and not the admin one.

Edited by Fourbit

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×