Jump to content
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

I don't use the STS myself and I haven't read this thread. But it looks like the STS has a bug/problem with sid's.

 

It seems to me that, if you add $sid to your STS links (and if you don't you will certainly have problems), the sid is allways shown, so also to spiders !

Edited by PandA.nl

Please do not PM me for support, I will not respond anyway.

Share this post


Link to post
Share on other sites

I have STS installed and running well - it's a great contribution! I hope this is the right place to post as I think the solution lies in STS.

 

I'm trying to configure the Wishlist2 contribution but there's a problem with the way the product info page is being built. The new 'add to wishlist' button is being placed to the left of the 'add to cart button'. As best I can tell from a day of searching the boards the problem is the 'add to wishlist' button is inside the same form tag as 'add to cart', so both buttons are acting as 'add to cart' buttons. Is anyone familiar with Wishlist2 or able to help with how to add a new form to the page so the two buttons can function separately?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

My product info pages are not showing parts of the STS Template. (k tried to do that for the outline title).

 

Anyways, I've been working on an OsC site, and am almost done with it. I've been installing contributions and doing some configuration myself. Well just recently after I rolled back from some changes that didn't work, my site is dropping part of the template.

 

http://69.20.52.85/ is the link.

 

If you click on the test product the "what's hot" (best sellers) box will disappear.

 

I had configured STS to only use one template file, so I don't think it's now trying to use multiple STS templates.

 

How can I fix this issue? I really don't want to reinstall / setup OsC.

 

Thank you,

-Nick

Share this post


Link to post
Share on other sites

I'm trying to add more images underneath the tag for "$imagesmall"! How can I define my other images that I'm using from UltraImage contributions in my custom product_info pages?

 

Any has any ideas?


-----------------------------------------------------------------------

 

Sincerely,

Dr. DK

Share this post


Link to post
Share on other sites

Thanks for the great job..

 

I have a question.. Can I remove your copyright in the page ?

 

how much do I have to pay if I want to remove it..

 

Tuesday 08 March, 2005 33 requests since Wednesday 02 February, 2005

 

Copyright © 2003 Simple Template System by DiamondSea.com

Share this post


Link to post
Share on other sites
I'm trying to add more images underneath the tag for "$imagesmall"! How can I define my other images that I'm using from UltraImage contributions in my custom product_info pages?

 

Any has any ideas?

 

I just went in manually and changed the product_info page! Thanks.


-----------------------------------------------------------------------

 

Sincerely,

Dr. DK

Share this post


Link to post
Share on other sites

STS is indeed a grand ol peice of work. I am thrilled by its abilities. However, I am a bit unclear as to the actual use of the template tags.

 

In the readme file it says...

 

Starting with version 2.00 you can now use multiple template files that will

change according to the category selected in index.php.

 

You can now create custom templates for any or each category.  Here is how

the appropriate template file is selected:

 

1) You can have a default site template by creating

 

  /catalog/includes/sts_template.html

 

2) You can have a default category template by creating

 

  /catalog/includes/sts_templates/index.php.html

 

3) You can have a different template for the Main Catalog Page (cPath=0) by

creating

 

  /catalog/includes/sts_templates/index.php_0.html

 

4) You can have a different template for the other Catalog pages (cPath=XX_YY)

by creating

 

  /catalog/includes/sts_templates/index.php_XX-YY.html

 

(where XX_YY is the cPath=XX_YY value you see in the categories URL.)

OK this makes sense to some degree. But can I use the tags like they were used in the sample "product_info.php.html-SAMPLE" page in:

 

/catalog/includes/sts_templates/index.php.html

/catalog/includes/sts_templates/index.php_0.html

/catalog/includes/sts_templates/index.php_XX-YY.html

(files in bold indicate template files)

 

I do not want to just display the default tags like in the main sts_template.html

eg:

$cartlogo

$urlcartlogo

$checkoutlogo

$urlcheckoutlogo

ect...

 

But rather the tags that are displayed in product_info.php.html where the main content goes. Such as:

$productdesc

$imagesmall

$imagelarge

I wish to use these tags in index.php_XX-YY.html, index.php_0.html ect... But am having no luck calling them to display. They display nothing.

?

I ask this question simply because the readme.txt says:

-----------------------------------------------------------------------------

USING PRODUCT_INFO CONTENT TEMPLATES:

-----------------------------------------------------------------------------

Starting with version 2.00 you can now use PRODUCT_INFO TEMPLATES to customize

the $CONTENT section of your product information pages by creating:

 

  /catalog/includes/sts_templates/product_info.php.html

 

and using the product_info template variables (listed below) to layout

your product_info pages.

 

A very ugly but functional sample of a product_info.php.html file is provided

in the STS distribution.  This file is called:

 

  product_info.php.html-SAMPLE

 

To use this file on your site, you would copy it into your

 

  /catalog/includes/sts_templates/

 

directory and rename it to be

 

  product_info.php.html

I guess where the confusioin is where it says:

you can now use PRODUCT_INFO TEMPLATES to customize

the $CONTENT section of your product information pages by creating:......

This statement above leads me to beleive that I can display the content tags such as $productdesc, $imagesmall, $imagelargein in the other templates just like they are displayed in the product_info.php.html.

 

What I am trying to do is display a buy now button, the product picture, and a short product description on the index.php_XX-YY.html page. But I do not see any tags that allow me to display a buy now button and the actual correct link to add the item to the cart.

 

Anybody care to enlighten my lack on understanding here? :blink:

Thanks in advance!

Kind Regards,

Keven J

Share this post


Link to post
Share on other sites

The problem has gotten even worse!

 

Now the "what's hot" (aka best sellers box) is completely gone.

 

I was tinkering with my install of OsC some more, what i was changing I thought was un related to STS, but apparently it is? Now the best sellers box has completely disappeared. I dont' understand what is going on with this.

 

I can't think of what to do, and I've tweaked so much of this setup that I can't really "start from scratch" anymore.

 

Can someone please help me! This is unfortunately pretty urgent too :(

 

Thank you.

Share this post


Link to post
Share on other sites

Ha! i'm an idiot.

 

I "fixed" the problem. I had wiped all my previous test purchases so the box wasn't showing up.

 

The previous problem as well is fixed because i was not aware that the best sellers box is dependent to what category you are in.

 

So... problem fixed. sorry to cause unneeded clutter in the thread.

Share this post


Link to post
Share on other sites

I have still not been able to use product_info.php.html which I am starting to need to use.

 

Anybody have a list of step by step on what to change , delete & modify from the using the standard sts_template.html ? I read through the post and info seem to be all over the place on this subject while nothing seem to work for me.

 

I have all the contrib fixes installed a seem to be working properly below.

 

www.DVBHardware.com

 

Thanks,

 

Jimmy


I'm not a coder just a splicer.

Share this post


Link to post
Share on other sites

I'm putting together a site for my wifes jewelry business and I need some help getting the right and left colums fixed. Her site is Christina J's Jewelry.

 

1. On the left column, how do I make all of the info boxes the same width?

 

2. On the right column, why am I getting info boxes showing up multiple times and why are they inside of the "Tell A Friend" box?

 

Thanx, Dave.

Share this post


Link to post
Share on other sites

I'm confused as to what defines which column an info box is to appear in.

 

Is it the sts_template.html, sts_display_output.php, or the column_left.php / column_right.php file?

 

Thanx, Dave.

Share this post


Link to post
Share on other sites
I dont think anybody reads this thread. :(

 

I am afraid you are right. I would love to help,

but I am only a beginner myself. Where are

the helpful experts? Maybe we are just too

many people trying to learn and too few

that already know and are tired of answering

questions. I suggest you try to write pm`s to

the people who wrote the contributions, it

helped me once already,

 

Ken

Share this post


Link to post
Share on other sites

dsatchell:

 

Go through your edits again, looks like you made double entries.

 

I have not got into the guts of this contrib for a while & I do not code at all, just a splicer.

 

 

Jimmy


I'm not a coder just a splicer.

Share this post


Link to post
Share on other sites

I am trying to remove the STS template from wpcallback.php (WorldPay) but my template still shows after adding the code below in sts_display_output.php and wpcallback.php. I've tried several solutions I've found here on the forum but none of them works.. just an empty template and no order showing up in admin. Isn't that strange? How do I turn off template for a specific file?

 

 

In sts_display_output.php

 

if(isset($notemplate) && $notemplate == "YES") {

$display_template_output = 0;

$display_normal_output = 1;

}

 

 

In wpcallback.php

 

$notemplate = "YES";

Share this post


Link to post
Share on other sites
Thanks, your suggestion helped my sort the problem on the home page, however when in the catagories, HEADING_TITLE appears again, looking at the code it looks like I cannot find the language definitions and is therefore just displaying the tag text. However I'm not a good enough programmer to figure out a way around it.

 

 

Hi,

 

again, sorry to push this but my boss is getting impatient! :'(

Share this post


Link to post
Share on other sites

I have a large site, that uses three php pages, that are included using a php include on every page. Is there anyway to include these in the STS template system?

 

<?php include 'url-to-file';

?>

Share this post


Link to post
Share on other sites
I have a large site, that uses three php pages, that are included using a php include on every page. Is there anyway to include these in the STS template system?

 

<?php include 'url-to-file';

?>

 

try this if your on an apache webserver that allows you to parse php in html pages.

 

in the root directory of the site make a file called .htaccess and then put these 2 lines of code inside the file. And put it inside the root directory of the site on the webserver.

 

RemoveHandler .html .htm
AddType application/x-httpd-php .php .htm .html

 

let me know if that works for you. :thumbsup:

 

Kind Regards,

Keven J

www.kevenvision.com

Edited by kevenvision

Share this post


Link to post
Share on other sites

Thanks Keven, what would I use as the code of the actual include?

 

-Zach

 

try this if your on an apache webserver that allows you to parse php in html pages.

 

in the root directory of the site make a file called .htaccess and then put these 2 lines of code inside the file. And put it inside the root directory of the site on the webserver.

 

RemoveHandler .html .htm
AddType application/x-httpd-php .php .htm .html

 

let me know if that works for you.  :thumbsup:

 

Kind Regards,

Keven J

www.kevenvision.com

Share this post


Link to post
Share on other sites
Give this a shot.

 

<?php include("the_file_name");?>

 

Kind Regards,

Keven J

www.kevenvision.com

 

 

I put that in sts_template.html. It doesn't seem to be working. The file does not get included. I tried both the full path, and the relative and absolute URL.

 

Zach

Share this post


Link to post
Share on other sites

think in terms of though the sts_template is in the root directory of the site.

 

Does it produce an error log for you? usualy when you do a php call it will put an error log in the directory where the file is called from.. open that and see what it says. :)

Share this post


Link to post
Share on other sites

I do not see any errors in the error log. I viewed the source of the page that is output. And the include ends up unchanged, in the actual source.

 

<?php include ('/header.php'); ?>

 

Should sts_template.html be changed to a php page?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×