Jump to content
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

Can someone please help me with this..... When I type in $reviewsbutton in the sts_product_info.php.html file, it shows the button, but the button does not link to anything. Any ideas why? My site is www.mp3shop4u.com. Also, I already know how to add extra commands such as $content, etc in the html_display_output file for the normal sts template site, but how do I add things like that in the sts_product_info.php? I have a wishlist button I need to add to the file so that in sts_product_info.php.html I can type in something like $addtowishlistbutton.

 

ANY HELP IS APPRECIATED, THANKS IN ADVANCE!

 

-Daniel

Share this post


Link to post
Share on other sites
Can someone kind enff to put your link here and see how is the image look like after installation this contribution.

 

Tks

 

This contribution isn't one template, it's a template system. It allows you to quickly change the layout simply by changing one html-file. Some examples can be found at http://www.diamondsea.com/sts/sites.html

 

By the way, some of those aren't very good examples IMO. It's very easy to change the layout, as long as you know some basic html. Actually, if you're just looking to change small parts of the layout, you could even manage by a little cut'n'paste :D

Share this post


Link to post
Share on other sites

And another thing I almost forgot;

the "HOW TO INSTALL (EASY)" part of the readme-file, doesn't mention sts_product_info.php. It too should (obviously) be copied to the includes-folder. It actually took me several minutes to find out. (I like to follow the instructions in README and INSTALL files to the point.)

Share this post


Link to post
Share on other sites

I'm having issues with getting STS up and running. I've been all over the boards trying to find a solution but I'm come up empty.

 

I did a fresh install of osC2.2 and then did the easy install of STS 2.0

 

But when I visit my catalog, I get this:

 

>>

Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in /home/adorable/public_html/catalog/includes/application_top.php on line 511

 

Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in /home/adorable/public_html/catalog/includes/application_top.php on line 511

 

Fatal error: main(): Failed opening required 'STS_START_CAPTURE' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/adorable/public_html/catalog/includes/application_top.php on line 511

<<

 

Here is what my configure.php looks like in /includes

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.adorablecards.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.adorablecards.com');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/adorable/public_html/catalog/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'adorablecards.com'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', '*****');

define('DB_SERVER_PASSWORD', '*****');

define('DB_DATABASE', 'adorable_shop');

define('USE_PCONNECT', 'true'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

 

// STS: ADD: Define Simple Template System files

define('STS_START_CAPTURE', DIR_WS_INCLUDES . 'sts_start_capture.php');

define('STS_STOP_CAPTURE', DIR_WS_INCLUDES . 'sts_stop_capture.php');

define('STS_RESTART_CAPTURE', DIR_WS_INCLUDES . 'sts_restart_capture.php');

define('STS_TEMPLATE_DIR', DIR_WS_INCLUDES . 'sts_templates/');

define('STS_DEFAULT_TEMPLATE', DIR_WS_INCLUDES . 'sts_template.html');

define('STS_DISPLAY_OUTPUT', DIR_WS_INCLUDES . 'sts_display_output.php');

define('STS_USER_CODE', DIR_WS_INCLUDES . 'sts_user_code.php');

define('STS_PRODUCT_INFO', DIR_WS_INCLUDES . 'sts_product_info.php');

// STS: EOADD

?>

 

 

Anyone got some help to offer?

Thanks,

 

ZAch

Share this post


Link to post
Share on other sites

Hi, Great Contrib!!!

 

 

I do not use header tag controller, I am using "Search Engine Optimization for osCommerce Web Store - SEO PHP Functions"

 

which retrives its meta tag info from the following variables in includes/functions/seo_fns.php.

 

$html_contents_title = seo_create_title('' . TITLE);

$html_contents_description = seo_create_meta_description('' . TITLE);

$html_contents_keywords = seo_create_meta_keywords('' . TITLE);

 

 

How can I implement this to work with sts??

 

greatly appreciated.

Share this post


Link to post
Share on other sites

Hi there,

 

Just wondering if anyone could help me with one small question?

First of all can I just say a massive thanks to the creator of this contribution as it is absolutely fantastic. If anyone would like to see a work in action then they can take a look at http://www.helitorque.com/clients/bsr/store/ It isn't finished quite yet but hopefully people will think it is quite nice??

 

Anyway on to the question. I was just wondering if it is possible to link to images in the main sts_template.html and other STS Templates via relative URL links instead of absolute URL links? At the moment I am having to code all of the image source URL's so that they look like http://www.helitorque.com/clients/bsr/stor.../bsr_header.jpg etc...

 

What I would like to be able to do is have the image source URL as sts_templates/images/layout/image1.jpg instead so that I don't have to code the whole URL in. This would make it much quicker and easier and also I could test on my localhost (own computer) much easier by just dropping in the same template from FTP.

 

I tried changing the link to one of the images but it wouldn't work.

 

If anyone understands any of what I am asking and can help with this in any way then I would be exceptionally greatful.

 

Regards,

 

Mark Bowen

Edited by Mark Bowen

Share this post


Link to post
Share on other sites

Mark,

 

As far as I can see, you should be able to use urls such as includes/sts_templates/images/layout/image1.jpg.

 

This is the same as the URL you suggested just with th includes/ at the begining.

 

I have all my images in the standard images folder so I just use images/image1.jpg but you should be able to use the path to your chosen folder as I suggested above.

 

I'm no expert in these things so for my curiosity and everyone elses sake, please post back whether or not this workd.

 

Thanks

 

Peter

 

Hi there,

 

Just wondering if anyone could help me with one small question?

First of all can I just say a massive thanks to the creator of this contribution as it is absolutely fantastic. If anyone would like to see a work in action then they can take a look at http://www.helitorque.com/clients/bsr/store/ It isn't finished quite yet but hopefully people will think it is quite nice??

 

Anyway on to the question. I was just wondering if it is possible to link to images in the main sts_template.html and other STS Templates via relative URL links instead of absolute URL links? At the moment I am having to code all of the image source URL's so that they look like http://www.helitorque.com/clients/bsr/stor.../bsr_header.jpg etc...

 

What I would like to be able to do is have the image source URL as sts_templates/images/layout/image1.jpg instead so that I don't have to code the whole URL in. This would make it much quicker and easier and also I could test on my localhost (own computer) much easier by just dropping in the same template from FTP.

 

I tried changing the link to one of the images but it wouldn't work.

 

If anyone understands any of what I am asking and can help with this in any way then I would be exceptionally greatful.

 

Regards,

 

Mark Bowen

Share this post


Link to post
Share on other sites

Hi Peter,

 

Thanks for the reply. I had tried doing this but the images don't show up. If I check the resulting html code for the page when it has rendered in the browser then the links appear okay but the image doesn't show up. I was wondering if because STS has changed the page then maybe the URL of the created page isn't quite the standard sts_template.html and maybe something else?

 

If anyone could help on this at all then I would be extremely greatful.

 

Regards,

 

Mark Bowen

Share this post


Link to post
Share on other sites

PROBLEM FIXED - END

 

Hi Peter (and anyone else following this),

 

Just to let you know that what you said to do does work after all!!! I was believing that the URL's were taken from the sts_template.html location and wondered why they weren't working. I have now placed all of the images into a folder called sts_images in the main catalog folder and reference them as sts_images/image1.jpg and they all work fine. Sorry about the confusion but it all works fabulously now.

 

Thanks again as this will save me many many hours of finding and replacing code!!

 

Regards,

 

Mark Bowen

Edited by Mark Bowen

Share this post


Link to post
Share on other sites

Hi

 

I have this error after adding static pages toleft hand column, can anybody help ?

 

 

Template file doesn't exist: [includes/sts_template.html]

Warning: fopen(): SAFE MODE Restriction in effect. The script whose uid is 714 is not allowed to access includes/sts_template.html owned by uid 705 in /home/www/silkcafe/catalog/includes/sts_display_output.php on line 117

 

Warning: fopen(includes/sts_template.html): failed to open stream: No such file or directory in /home/www/silkcafe/catalog/includes/sts_display_output.php on line 117

Can't open Template file: [includes/sts_template.html]

Warning: filesize(): SAFE MODE Restriction in effect. The script whose uid is 714 is not allowed to access includes/sts_template.html owned by uid 705 in /home/www/silkcafe/catalog/includes/sts_display_output.php on line 121

 

Warning: fread(): supplied argument is not a valid stream resource in /home/www/silkcafe/catalog/includes/sts_display_output.php on line 121

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/www/silkcafe/catalog/includes/sts_display_output.php on line 122

Template file doesn't exist: [includes/sts_template.html]

Warning: fopen(): SAFE MODE Restriction in effect. The script whose uid is 714 is not allowed to access includes/sts_template.html owned by uid 705 in /home/www/silkcafe/catalog/includes/sts_display_output.php on line 166

 

Warning: fopen(includes/sts_template.html): failed to open stream: No such file or directory in /home/www/silkcafe/catalog/includes/sts_display_output.php on line 166

Can't open Template file: [includes/sts_template.html]

Warning: filesize(): SAFE MODE Restriction in effect. The script whose uid is 714 is not allowed to access includes/sts_template.html owned by uid 705 in /home/www/silkcafe/catalog/includes/sts_display_output.php on line 170

 

Warning: fread(): supplied argument is not a valid stream resource in /home/www/silkcafe/catalog/includes/sts_display_output.php on line 170

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/www/silkcafe/catalog/includes/sts_display_output.php on line 171

 

 

thanks

Share this post


Link to post
Share on other sites

I installed the newest version of sts (v 2.01) and it works fine,

but not with https.

 

The Posts in the supportarea are all very old, is it possible to make

it work with https easily.

 

Greetz,

nic

Share this post


Link to post
Share on other sites
I installed the newest version of sts (v 2.01) and it works fine,

but not with https.

 

The Posts in the supportarea are all very old, is it possible to make

it work with https easily.

 

Greetz,

nic

 

Sorry, my fault.

The simple answer is that the testserver i`m running has no https support.

 

>_<

 

greetz

Share this post


Link to post
Share on other sites

hello,anyone can tell me how to use the contribution to add the "enlarge the image." funcation.

Is anyone have a good example of product_info.php.html file.I really need one to learn how to use sts.

many many thanks.

Share this post


Link to post
Share on other sites

any one can help?

how can I use special price in this contribution please.

I know $regularprice is for original price and $specialprice is for specialprice.

so how to make a delete symbol on the original price when a item has a special price?

like this image dele.jpg

Share this post


Link to post
Share on other sites

Hi Adam,

 

As far as I can see, at the moment your images are trying to be loaded from http://www.blackorchiddesigns.ca/catalog/i...ton_buy_now.gif

 

You will probably need to change your links so that they reflect to not load from the catalog/index.php/cPath but just go straight into the includes folder.

 

P.S. I think it probably has something to do with what looks like you have added some mod to the store to allow for the 'cPath' folders.

 

Hope this helps.

 

Regards,

 

Mark Bowen

Edited by Mark Bowen

Share this post


Link to post
Share on other sites

i just found this thread - looks good but boy is it a long one

 

why not start a poll on this contribution to see what people think about it

Share this post


Link to post
Share on other sites

Hi there,

 

Just a quick question for Brian or any other users of STS.

 

I was just wondering how easy it would be to create an admin section that could update the main configure.php file where the STS Template variables are stored so that you could have say a folder called 'sts_skins' in the main catalog directory and then within this have different folders for different themes, say 'christmas', 'business', 'fun'. Then if the configure.php file was changed to reflect the desired folder for the skin and it would use the files in that folder instead?

 

I'm not too sure if this is even possible but it would make an excellent addition to the contribution as you could easily swap templates whenever you wanted to.

 

Also if this is at all possible then would it be equally possible to be able to maybe let users of the shop change the skin? Unfortunately they wouldn't be able to change the configure.php file as that would change the skin for everyone but maybe somewhere we could state for the time they are on the site as to which files to use?

 

Any help with this would be great as I really think this would be a nice addition to an already absolutely fantastic modification of osCommerce.

 

 

Regards,

 

Mark Bowen

Share this post


Link to post
Share on other sites

I am new to osc, and trying to install the template system. I copied all the files and updated the config file, and received this error:

 

Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in /home/burdland/public_html/ecommerce/os/catalog/includes/application_top.php on line 511

Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in /home/burdland/public_html/ecommerce/os/catalog/includes/application_top.php on line 511

Fatal error: main(): Failed opening required 'STS_START_CAPTURE' (include_path='.:/usr/local/lib/php') in /home/burdland/public_html/ecommerce/os/catalog/includes/application_top.php on line 511

 

Any idea of what I missed

Share this post


Link to post
Share on other sites

Mark,

 

Its really weird.

 

if i put back the original sts template

the buy now buttons loads perfectly.

but with my template it doesnt want to load

 

Any ideas why?

 

Adam,

 

Hi Adam,

 

As far as I can see, at the moment your images are trying to be loaded from http://www.blackorchiddesigns.ca/catalog/i...ton_buy_now.gif

 

You will probably need to change your links so that they reflect to not load from the catalog/index.php/cPath but just go straight into the includes folder.

 

P.S. I think it probably has something to do with what looks like you have added some mod to the store to allow for the 'cPath' folders.

 

Hope this helps.

 

Regards,

 

Mark Bowen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×