Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

Has anyone got the Poll Booth contribution to work with STS?

 

Is there a special trick to getting new infobox contributions to work in STS? I got the loginbox and the "we accept paypal" box to work, but they worked just by following the instructions that came with those contributions (I think). I'm not sure how to get others to work. :'(

 

 

:huh:

Share this post


Link to post
Share on other sites

Does anyone know how I can get Column Controller to work with STS? I'd like to be able to use the admin section to enable/disable blocks - and not have to edit my templates :(

Share this post


Link to post
Share on other sites

I couldn't edit the above - so here goes a reply instead:

 

I'm thinking I could perhaps edit column_left and column_right - so they at the top include this:

// STS: ADD

$sts_block_name = 'column_left';

require(STS_RESTART_CAPTURE);

// STS: EOADD

 

and ditto for ending and so for column_right.

 

Do new tags have to be "defined" anywhere - besides the above?

 

This way I could simply use $column_left and $column_right in my template - and leave the rest as done by column_controller?

Share this post


Link to post
Share on other sites

hmm - added the $columnleft and columnright, in the bottom of the two files -and it works fine.

 

Only problem now (a big one) is that for some reason $content is empty and what should have been in that variable is in my $rightblock.

 

Any clues to what I could have missed? :(

Share this post


Link to post
Share on other sites

Can anyone tell me why only the default template is used when the sts_output.php replacement from STS with Category Meta Tags & Article Manager is installed? And is there a fix?

Share this post


Link to post
Share on other sites
Reply if you want to help a stupid newbie. 

 

Sorry for asking such a dumb question, but any help would be apprediatedas I'm a total PHP/CSS newbie.  I 'THINK' I've installed this correctly as the appearance of my site changed once I did (www.partymaniaonline.com).  Now how do I go about modifying the background colors of boxes?  I'm sure this is REALLY basic, but I'm not sure what exactly to change.

 

Thanks for any help!

boxes are not modifed with sts. boxes are modified in the css style or use the contribution 'box skinner' or something like that. Good luck!


Keesjan

Share this post


Link to post
Share on other sites

I think variables also need to be defined in sts_display_output.php.

 

quote=fixion,Nov 25 2004, 02:43 PM]

hmm - added the $columnleft and columnright, in the bottom of the two files -and it works fine.

 

Only problem now (a big one) is that for some reason $content is empty and what should have been in that variable is in my $rightblock.

 

Any clues to what I could have missed? :(

Share this post


Link to post
Share on other sites
I think variables also need to be defined in sts_display_output.php.

 

I have done that. I simply looked at what was done for the cartbox variable and did the same for left and rightblocks. And it works beautifully - only problem is that the $content variable does not contain anything - which screws up the layout (as you can plainly see on the url I gave). And I didn't "fiddle" with $content - so something's forgotten - don't know what. I also tried to replace the product_info.php file with the product_info.php-SAMPLE file - but that just gave a lot of variables, that was undefined - no content :(

Share this post


Link to post
Share on other sites

Someone please explain to me how do I fix the following error,

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

 

Fatal error: main(): Failed opening required 'includes/sts_product_info.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

Share this post


Link to post
Share on other sites
Guest

I did a quick search on this and came up with nothing so If it's been asked before just point me... Thanks.

 

I've installed the STS and want to use SSI on my sts_template.html page. So I renamed it to a .php file (sts_template.php) and changed my configure.php to point to the new php file. But for some reason it's not rendering the includes. If I look at the source code it's just showing the include line (i.e. <?php require("http://www.mydomain.com/mypage.php"); ?>). What would cause the includes to not work? My entire site is using includes and I would like to keep it across the shopping cart. Thanks for any help. Peace.

Share this post


Link to post
Share on other sites
Guest

^^ Hmm...? I was thinking, maybe it's because the "includes" are handled by varaibles somehow throught the script? Like '$catmenu' is actually an include?

Share this post


Link to post
Share on other sites

Do you have the STS files uploaded to the catalog/includes directory?

 

Someone please explain to me how do I fix the following error,

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

 

Fatal error: main(): Failed opening required 'includes/sts_product_info.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

Share this post


Link to post
Share on other sites

I have a problem with worlspay callback problem to:

I use https://<wpdisplay item=MC_callback>

 

and get to https://secure.mysite.com/login.php?osCsid=blabla

I use STS and auto login (and several other contributions)

 

Should I add below code at the end of the page sts_display_output.php to avoid sts to wrapp the page? I tryed this but get no other solution, no status page nor is the product added to the databse as purchased.

 

 

 

Got the STS Templates Worldpay issue sorted by switching STS templates off when wpcallback.php is fed back - to do this I duplicated and edited an existing code in sts_display_output.php and added it back, so the added code reads

 

 

 

CODE 

if (strpos($scriptname, "wpcallback") !== false) {

$display_normal_output = 1;

$display_template_output = 0;

}

 


Keesjan

Share this post


Link to post
Share on other sites
Someone please explain to me how do I fix the following error,

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

 

Fatal error: main(): Failed opening required 'includes/sts_product_info.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

Share this post


Link to post
Share on other sites
Someone please explain to me how do I fix the following error,

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

 

Fatal error: main(): Failed opening required 'includes/sts_product_info.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/online/public_html/catalog/includes/sts_display_output.php on line 132

 

 

 

I'm having the same sort of problem, here is what I am getting:

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in C:\Inetpub\vhosts\mlj.wyrecompute.com\httpdocs\osCommerce\includes\sts_display_output.php on line 132

 

Fatal error: main(): Failed opening required 'includes/sts_product_info.php' (include_path='.;./includes;./pear') in C:\Inetpub\vhosts\mlj.wyrecompute.com\httpdocs\osCommerce\includes\sts_display_output.php on line 132

 

This is a test site set up for me to see if I am up to making a go of it - but I am not getting on very well so far :( any help with this would be greatly appreciated.

Share this post


Link to post
Share on other sites

Are your STS templates in your includes directory?

 

 

I'm having the same sort of problem, here is what I am getting:

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in C:\Inetpub\vhosts\mlj.wyrecompute.com\httpdocs\osCommerce\includes\sts_display_output.php on line 132

 

Fatal error: main(): Failed opening required 'includes/sts_product_info.php' (include_path='.;./includes;./pear') in C:\Inetpub\vhosts\mlj.wyrecompute.com\httpdocs\osCommerce\includes\sts_display_output.php on line 132

 

This is a test site set up for me to see if I am up to making a go of it - but I am not getting on very well so far  :(  any help with this would be greatly appreciated.

Share this post


Link to post
Share on other sites

It's very hard to troubleshoot your problem because the only information we have is that your content variable isn't being displayed. The only way I could troubleshoot something like this is to work with the files myself.

 

 

I have exact same problem. Unfortunately noone seems to know whats wrong :(

Share this post


Link to post
Share on other sites

anyone can help me please!

 

today I intalled the Simple Template System (sts).firstly i tested it in my own computer.It worked very well.but when i upload the files to the internet host,and got the erros blow.

 

Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in /hsphere/local/home/ultimate/laptopcraze.com/includes/application_top.php on line 511

Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in /hsphere/local/home/ultimate/laptopcraze.com/includes/application_top.php on line 511

Fatal error: main(): Failed opening required 'STS_START_CAPTURE' (include_path='.:/usr/local/lib/php') in /hsphere/local/home/ultimate/laptopcraze.com/includes/application_top.php on line 511

 

my configure.php code is below:

 

<?php
/*
?osCommerce, Open Source E-Commerce Solutions
?http://www.oscommerce.com

?Copyright (c) 2003 osCommerce

?Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
?define('HTTP_SERVER', 'http://laptopcraze.com'); // eg, http://localhost - should not be empty for productive servers
?define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers
?define('ENABLE_SSL', false); // secure webserver for checkout procedure?
?define('HTTP_COOKIE_DOMAIN', 'laptopcraze.com');
?define('HTTPS_COOKIE_DOMAIN', '');
?define('HTTP_COOKIE_PATH', '/');
?define('HTTPS_COOKIE_PATH', '');
?define('DIR_WS_HTTP_CATALOG', '/');
?define('DIR_WS_HTTPS_CATALOG', '');
?define('DIR_WS_IMAGES', 'images/');
?define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
?define('DIR_WS_INCLUDES', 'includes/');
?define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
?define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
?define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
?define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
?define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

?define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
?define('DIR_FS_CATALOG', '/hsphere/local/home/ultimate/laptopcraze.com/');
?define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
?define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
?define('DB_SERVER', '69.49.229.1:3306'); // eg, localhost - should not be empty for productive servers
?define('DB_SERVER_USERNAME', 'ultimat_craze');
?define('DB_SERVER_PASSWORD', 'comino');
?define('DB_DATABASE', 'ultimat_laptop');
?define('USE_PCONNECT', 'false'); // use persistent connections?
?define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'
?>

 

I think the configure.php should be something worry,so I changed it to (see below)

 

<?php
/*
?osCommerce, Open Source E-Commerce Solutions
?http://www.oscommerce.com

?Copyright (c) 2003 osCommerce

?Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
?define('HTTP_SERVER', 'http://localhost'); // eg, http://localhost - should not be empty for productive servers
?define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers
?define('ENABLE_SSL', false); // secure webserver for checkout procedure?
?define('HTTP_COOKIE_DOMAIN', 'localhost');
?define('HTTPS_COOKIE_DOMAIN', '');
?define('HTTP_COOKIE_PATH', '/ts/');
?define('HTTPS_COOKIE_PATH', '');
?define('DIR_WS_HTTP_CATALOG', '/ts/');
?define('DIR_WS_HTTPS_CATALOG', '');
?define('DIR_WS_IMAGES', 'images/');
?define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
?define('DIR_WS_INCLUDES', 'includes/');
?define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
?define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
?define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
?define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
?define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

?define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
?define('DIR_FS_CATALOG', 'd:/usr/www/html/ts/');
?define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
?define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
?define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
?define('DB_SERVER_USERNAME', 'root');
?define('DB_SERVER_PASSWORD', '');
?define('DB_DATABASE', 'zhangwei');
?define('USE_PCONNECT', 'false'); // use persistent connections?
?define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'
?// STS: ADD: Define Simple Template System files 
?define('STS_START_CAPTURE', DIR_WS_INCLUDES . 'sts_start_capture.php'); 
?define('STS_STOP_CAPTURE', DIR_WS_INCLUDES . 'sts_stop_capture.php'); 
?define('STS_RESTART_CAPTURE', DIR_WS_INCLUDES . 'sts_restart_capture.php'); 
?define('STS_TEMPLATE_DIR', DIR_WS_INCLUDES . 'sts_templates/'); 
?define('STS_DEFAULT_TEMPLATE', DIR_WS_INCLUDES . 'sts_template.html'); 
?define('STS_DISPLAY_OUTPUT', DIR_WS_INCLUDES . 'sts_display_output.php'); 
?define('STS_USER_CODE', DIR_WS_INCLUDES . 'sts_user_code.php'); 
?define('STS_PRODUCT_INFO', DIR_WS_INCLUDES . 'sts_product_info.php'); 
// STS: EOADD
?>

 

but there is anther erro which is below

 

Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /hsphere/local/home/ultimate/laptopcraze.com/includes/functions/database.php on line 19

Unable to connect to database server!

 

 

 

Actually i cann`t install any controbution.

they are all running very well in my localhost, but when i put onto the internet host,there will be something worry like

 

Warning: main(******'): failed to open stream: No such file or directory in /hsphere/local/home/ultimate/laptopcraze.com/includes/application_top.php on line ***

 

Warning: main(******'): failed to open stream: No such file or directory in /hsphere/local/home/ultimate/laptopcraze.com/includes/application_top.php on line ***

 

Fatal error: main(): Failed opening required '******' (include_path='.:/usr/local/lib/php') in /hsphere/local/home/ultimate/laptopcraze.com/includes/application_top.php on line ***

 

or

 

 

Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /hsphere/local/home/ultimate/laptopcraze.com/includes/functions/database.php on line 19

Unable to connect to database server!

 

my database.php code is below:

 

<?php
/*
?$Id: database.php,v 1.21 2003/06/09 21:21:59 hpdl Exp $

?osCommerce, Open Source E-Commerce Solutions
?http://www.oscommerce.com

?Copyright (c) 2003 osCommerce

?Released under the GNU General Public License
*/

?function tep_db_connect($server = DB_SERVER, $username = DB_SERVER_USERNAME, $password = DB_SERVER_PASSWORD, $database = DB_DATABASE, $link = 'db_link') {
? ?global $$link;

? ?if (USE_PCONNECT == 'true') {
? ? ?$$link = mysql_pconnect($server, $username, $password);
? ?} else {
? ? ?$$link = mysql_connect($server, $username, $password);
? ?}

? ?if ($$link) mysql_select_db($database);

? ?return $$link;
?}

?function tep_db_close($link = 'db_link') {
? ?global $$link;

? ?return mysql_close($$link);
?}

?function tep_db_error($query, $errno, $error) { 
? ?die('<font color="#000000"><b>' . $errno . ' - ' . $error . '<br><br>' . $query . '<br><br><small><font color="#ff0000">[TEP STOP]</font></small><br><br></b></font>');
?}

?function tep_db_query($query, $link = 'db_link') {
? ?global $$link;

? ?if (defined('STORE_DB_TRANSACTIONS') && (STORE_DB_TRANSACTIONS == 'true')) {
? ? ?error_log('QUERY ' . $query . "\n", 3, STORE_PAGE_PARSE_TIME_LOG);
? ?}

? ?$result = mysql_query($query, $$link) or tep_db_error($query, mysql_errno(), mysql_error());

? ?if (defined('STORE_DB_TRANSACTIONS') && (STORE_DB_TRANSACTIONS == 'true')) {
? ? ? $result_error = mysql_error();
? ? ? error_log('RESULT ' . $result . ' ' . $result_error . "\n", 3, STORE_PAGE_PARSE_TIME_LOG);
? ?}

? ?return $result;
?}

?function tep_db_perform($table, $data, $action = 'insert', $parameters = '', $link = 'db_link') {
? ?reset($data);
? ?if ($action == 'insert') {
? ? ?$query = 'insert into ' . $table . ' (';
? ? ?while (list($columns, ) = each($data)) {
? ? ? ?$query .= $columns . ', ';
? ? ?}
? ? ?$query = substr($query, 0, -2) . ') values (';
? ? ?reset($data);
? ? ?while (list(, $value) = each($data)) {
? ? ? ?switch ((string)$value) {
? ? ? ? ?case 'now()':
? ? ? ? ? ?$query .= 'now(), ';
? ? ? ? ? ?break;
? ? ? ? ?case 'null':
? ? ? ? ? ?$query .= 'null, ';
? ? ? ? ? ?break;
? ? ? ? ?default:
? ? ? ? ? ?$query .= '\'' . tep_db_input($value) . '\', ';
? ? ? ? ? ?break;
? ? ? ?}
? ? ?}
? ? ?$query = substr($query, 0, -2) . ')';
? ?} elseif ($action == 'update') {
? ? ?$query = 'update ' . $table . ' set ';
? ? ?while (list($columns, $value) = each($data)) {
? ? ? ?switch ((string)$value) {
? ? ? ? ?case 'now()':
? ? ? ? ? ?$query .= $columns . ' = now(), ';
? ? ? ? ? ?break;
? ? ? ? ?case 'null':
? ? ? ? ? ?$query .= $columns .= ' = null, ';
? ? ? ? ? ?break;
? ? ? ? ?default:
? ? ? ? ? ?$query .= $columns . ' = \'' . tep_db_input($value) . '\', ';
? ? ? ? ? ?break;
? ? ? ?}
? ? ?}
? ? ?$query = substr($query, 0, -2) . ' where ' . $parameters;
? ?}

? ?return tep_db_query($query, $link);
?}

?function tep_db_fetch_array($db_query) {
? ?return mysql_fetch_array($db_query, MYSQL_ASSOC);
?}

?function tep_db_num_rows($db_query) {
? ?return mysql_num_rows($db_query);
?}

?function tep_db_data_seek($db_query, $row_number) {
? ?return mysql_data_seek($db_query, $row_number);
?}

?function tep_db_insert_id() {
? ?return mysql_insert_id();
?}

?function tep_db_free_result($db_query) {
? ?return mysql_free_result($db_query);
?}

?function tep_db_fetch_fields($db_query) {
? ?return mysql_fetch_field($db_query);
?}

?function tep_db_output($string) {
? ?return htmlspecialchars($string);
?}

?function tep_db_input($string) {
? ?return addslashes($string);
?}

?function tep_db_prepare_input($string) {
? ?if (is_string($string)) {
? ? ?return trim(tep_sanitize_string(stripslashes($string)));
? ?} elseif (is_array($string)) {
? ? ?reset($string);
? ? ?while (list($key, $value) = each($string)) {
? ? ? ?$string[$key] = tep_db_prepare_input($value);
? ? ?}
? ? ?return $string;
? ?} else {
? ? ?return $string;
? ?}
?}
?>

 

My internet host is linux system.serves info is below

 

Server Information?

 

Server Host: tes54.open548sfer.com (67.17.153.5)? 

Database Host: 67.17.229.6:3404 (67.17.229.6:3404)

Server OS: Linux 2.4.27? ? ? Database: MySQL 4.0.21-standard

 

HTTP Server: Apache/1.3.31 (Unix) PHP/4.3.9 mod_ssl/2.8.18 OpenSSL/0.9.6b FrontPage/5.0.2.2635 mod_throttle/3.1.2

PHP Version: 4.3.9 (Zend: 1.3.0)

 

 

System? Linux tes54.open548sfer.com? 2.4.27 #1 SMP Sun Aug 15 06:14:24 CDT 2004 i686?

Build Date? Oct 11 2004 08:48:31?

Configure Command? './configure' '--localstatedir=/var/hsphere/php' '--with-apxs=/hsphere/shared/apache/bin/apxs' '--with-openssl=/usr' '--with-zlib=/usr' '--with-zlib-dir=/usr' '--with-bz2=/usr' '--enable-calendar' '--with-jpeg-dir=/usr' '--enable-ftp' '--with-gd' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--with-png-dir=/usr' '--with-gettext=/usr' '--with-imap=/hsphere/shared' '--with-mysql=/usr' '--with-pgsql=/usr' '--enable-sockets' '--with-zip=/usr' '--enable-versioning' '--enable-track-vars' '--enable-trans-sid' '--with-curl' '--with-mhash' '--enable-bcmath' '--with-pdflib' '--with-db' '--enable-dba' '--with-mnogosearch=/hsphere/shared/mnogosearch' '--enable-exif' '--with-mcrypt' '--enable-mbstring' '--with-kerberos' '--with-dbm' '--with-ndb' '--disable-debug' '--enable-xslt' '--with-xslt-sablot' '--with-sablot-js=/usr/include/js'?

Server API? Apache?

Virtual Directory Support? disabled?

Configuration File (php.ini) Path? /usr/local/Zend/etc/php.ini?

PHP API? 20020918?

 

Apache Version? Apache/1.3.31 (Unix) PHP/4.3.9 mod_ssl/2.8.18 OpenSSL/0.9.6b FrontPage/5.0.2.2635 mod_throttle/3.1.2?

Apache Release? 10331100?

Apache API Version? 19990320?

 

User/Group? httpd(398)/398?

Max Requests? Per Child: 0 - Keep Alive: on - Max Per Connection: 100?

Timeouts? Connection: 300 - Keep-Alive: 15?

Server Root? /hsphere/shared/apache?

 

PHP Extension? 20020429?

Zend Extension? 20021010?

Debug Build? no?

Thread Safety? disabled?

Registered PHP Streams? php, http, ftp, https, ftps, compress.bzip2, compress.zlib?

 

 

I have three Mysql Database in this host. I think the problem should be the root.but not very sure.I hope someone can help me. I`ll really appreciate you guys.

If you need further infomation,please be free to ask.

thanks very much. and sorry for this long reply...........

Edited by cnlx

Share this post


Link to post
Share on other sites
anyone can help me please!

 

Your configure.php file should look more like this for online

<?php
/*
osCommerce, Open Source E-Commerce Solutions
http://www.oscommerce.com

Copyright (c) 2003 osCommerce

Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
define('HTTP_SERVER', 'http://laptopcraze.com'); // eg, http://localhost - should not be empty for productive servers
define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers
define('ENABLE_SSL', false); // secure webserver for checkout procedure?
define('HTTP_COOKIE_DOMAIN', 'laptopcraze.com');
define('HTTPS_COOKIE_DOMAIN', '');
define('HTTP_COOKIE_PATH', '/');
define('HTTPS_COOKIE_PATH', '');
define('DIR_WS_HTTP_CATALOG', '/');
define('DIR_WS_HTTPS_CATALOG', '');
define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
define('DIR_FS_CATALOG', '/hsphere/local/home/ultimate/laptopcraze.com/');
define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
define('DB_SERVER', '69.49.229.1:3306'); // eg, localhost - should not be empty for productive servers
define('DB_SERVER_USERNAME', 'ultimat_craze');
define('DB_SERVER_PASSWORD', 'comino');
define('DB_DATABASE', 'ultimat_laptop');
define('USE_PCONNECT', 'false'); // use persistent connections?
define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

// STS: ADD: Define Simple Template System files
define('STS_START_CAPTURE', DIR_WS_INCLUDES . 'sts_start_capture.php');
define('STS_STOP_CAPTURE', DIR_WS_INCLUDES . 'sts_stop_capture.php');
define('STS_RESTART_CAPTURE', DIR_WS_INCLUDES . 'sts_restart_capture.php');
define('STS_TEMPLATE_DIR', DIR_WS_INCLUDES . 'sts_templates/');
define('STS_DEFAULT_TEMPLATE', DIR_WS_INCLUDES . 'sts_template.html');
define('STS_DISPLAY_OUTPUT', DIR_WS_INCLUDES . 'sts_display_output.php');
define('STS_USER_CODE', DIR_WS_INCLUDES . 'sts_user_code.php');
define('STS_PRODUCT_INFO', DIR_WS_INCLUDES . 'sts_product_info.php');
// STS: EOADD
?>


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×