Jump to content
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

I'm having a hard time understanding the multi-template feature. Can each page have its own template? I cant figure how to set this up.

Share this post


Link to post
Share on other sites

Figured out what the problem was with the multiple template feature!!!

 

In the configure.php file, just add a slash for your template directory definition:

define('STS_TEMPLATE_DIR', DIR_WS_INCLUDES . 'sts_templates/');

 

Thats the minor bug the contribution came with, it just didn't have a slash.

Share this post


Link to post
Share on other sites
Ok - I guess this has been posted before, but I can't for the life of me tell if the changes I am making are working...they don't appear in the main index.php when I upload, but that is expected because I'm uploading a different file right?

 

I know this will be a very short answer so if you could put me out of my misery and tell me what I've done wrong, or simply not done, I'd be most grateful.  Many Thanks!

 

Just would like to bring this to your attention again...I would like to solve this and I'm sure it's rediculously easy...I've had no error reports, I just cannot see my changes and instead, can just see the old osCommerce.

 

Please help...I'd be very grateful!

 

Any more info needed - just ask...

 

Many Thanks

Share this post


Link to post
Share on other sites

Ok - how come no responses guys? I really would like to use this contrib, but I can't at the moment because no-one is helping me. I, therefore, presume that I'm not giving you enough information. So what would you like?

Share this post


Link to post
Share on other sites

I am using STS no problem but I was wondering if there is a way to add a template for the front index page only. Index.php.html unfortunately loads the template anytime index.php is used. I know I could use a static page but I would like to keep the page as part of the store.

Share this post


Link to post
Share on other sites
Ok - I guess this has been posted before, but I can't for the life of me tell if the changes I am making are working...they don't appear in the main index.php when I upload, but that is expected because I'm uploading a different file right?

 

 

 

I'm not entirely sure what you're experiencing. Are you saying that as you make changes to sts_template.html, you don't see these changes when you refresh your main catalog page?

 

If this is the case, then something is not working correctly. As you alter sts_template.html, all of your osc pages should show these changes when refreshed. If this is not happening, then either your sts installation is incomplete, or your file uploads are not occurring correctly.

Edited by spoot

Share this post


Link to post
Share on other sites
I am using STS no problem but I was wondering if there is a way to add a template for the front index page only.  Index.php.html unfortunately loads the template anytime index.php is used.  I know I could use a static page but I would like to keep the page as part of the store.

 

I haven't used the multiple category templates business, but this is in the documentation:

 

2) You can have a default category template by

creating /catalog/includes/sts_templates/index.php.html

 

3) You can have a different template for the Main Catalog Page (cPath=0) by

creating /catalog/includes/sts_templates/index.php_0.html

 

If you've done this & it's not working, then there's something mysterious going on...

Share this post


Link to post
Share on other sites
Ok - how come no responses guys?  I really would like to use this contrib, but I can't at the moment because no-one is helping me.  I, therefore, presume that I'm not giving you enough information. So what would you like?

 

What problem are you having exactly? What changes are you making and where are you making them? Do you have a url we can take a look at?


The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Share this post


Link to post
Share on other sites

I'd like to get rid of the right-hand column only after a customer has entered the "check-out" part of the site. So everything would have a right-hand column, except for checkout_shipping.php, checkout_payment.php, checkout_confirmation.php, and all the other checkout_*.php pages.

 

Is there an established method for doing such a thing? I see how sts allows for additional templates in the product display sections, but I'm looking beyond that.

 

Any ideas, let me know, thanks -

 

Michael

Share this post


Link to post
Share on other sites

OK,

 

I know this has probably been asked before but I can't find where...

 

I am using STS which is working well and, thanks to this forum, have been able to add various othe contributions and get them working and I'm hoping that one of you wonderful people out there could help me. (have I grovelled enough yet?)

 

I have installed the RMA Returns Contribution and am trying to install an add-on to that contribution which creates a new infobox for RMA's but I can't work out how to get it to display using STS.

 

Any ideas anyone?

 

Thanks

 

Peter

Share this post


Link to post
Share on other sites
OK,

 

I know this has probably been asked before but I can't find where...

 

I am using STS which is working well and, thanks to this forum, have been able to add various othe contributions and get them working and I'm hoping that one of you wonderful people out there could help me. (have I grovelled enough yet?)

 

I have installed the RMA Returns Contribution and am trying to install an add-on to that contribution which creates a new infobox for RMA's but I can't work out how to get it to display using STS.

 

Any ideas anyone?

 

Thanks

 

Peter

 

Peter -

 

Add new boxes (or other files you'd like to include in the template) through sts_user_code.php. For example, if I want to add a box called "coolmenu.php," I'd add this to sts_user_code.php:

 

	$sts_block_name = 'coolmenubox';
require(STS_START_CAPTURE);
require(DIR_WS_BOXES . 'coolmenu.php');
require(STS_STOP_CAPTURE);
$template['coolmenubox'] = strip_unwanted_tags($sts_block['coolmenubox'], 'coolmenubox');

 

Now I've got a variable for my boxes/coolmenu.php box, $coolmenubox, that I can put wherever I like in sts_template.html.

 

I hope this helps -

 

Michael

Share this post


Link to post
Share on other sites

Thanks Michael, it worked perfectly.

 

I had added the same code to other files but hadn't looked in that one.

 

Thanks for your help.

 

Peter

Share this post


Link to post
Share on other sites
I'd like to get rid of the right-hand column only after a customer has entered the "check-out" part of the site. So everything would have a right-hand column, except for checkout_shipping.php, checkout_payment.php, checkout_confirmation.php, and all the other checkout_*.php pages.

 

Is there an established method for doing such a thing? I see how sts allows for additional templates in the product display sections, but I'm looking beyond that.

 

Any ideas, let me know, thanks -

 

Michael

 

"I see how sts allows for additional templates in the product display sections, but I'm looking beyond that."

 

How brilliant of me. I've stopped looking beyond it, and it works perfectly. This template system is something else.

Share this post


Link to post
Share on other sites

:-" :-"

 

Hello there all

 

I have been using this great contrib now for Months it is the best contrib to date.

 

our shop is going live shortly :'( :'( :'(

 

my problem lise with session id's not being transfered to the .swf file i have tried linking from the flash plugin

 

contact_btn.onRelease = function() {

getURL("contact_us.php?$sid);
}

 

all i get in the url is sitename/dir/contact_us.php?

 

i have tried the flash contrib avalibe but no luck it seams to not like STS

 

I must be doing somethoing wrong as i have seen several sites that use this

 

http://www.eclyptiq.com/flashosC

 

is there a way of sending the session id's into flash with STS

 

 

Many Thanks

 

Marc Turner

 

 

P.s i will be in your debt if you can help me ANYONE :D :D :D

Share this post


Link to post
Share on other sites

Romanicro,

have you found this answer already?

iam interesed too.

 

Anyone else?

 

 

Hello. I'm trying to put working together the Simple Template System and the Infobox Skin Manager. Having downloaded and installed the last versions of these two contributions, the web server (apache+php with the gd2 library available) can not render the oscommerce shop. I suppose this must be related to the includes/box directory modification made in the infobox skin manager installation, but I'm lost.

 

I'm a STS newbie so please if someone has posted a similar question consider to redirect me to the answer.

 

Thank you for your help


Keesjan

Share this post


Link to post
Share on other sites

Hi, :(

 

I'm having some problems. :blink:

I just installed OSCommerce - fresh install.

Works fine. :)

 

I install STS, i get this error. ;) Please help. :'(

 

Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in /var/www/html/catalog/includes/application_top.php on line 511

 

Fatal error: main(): Failed opening required 'STS_START_CAPTURE' (include_path='.:/php/includes:/usr/share/php') in /var/www/html/catalog/includes/application_top.php on line 511

Share this post


Link to post
Share on other sites
Hi,  :(

 

I'm having some problems. :blink:

I just installed OSCommerce - fresh install.

Works fine. :)

 

I install STS, i get this error. ;)  Please help. :'(

 

Warning: main(STS_START_CAPTURE): failed to open stream: No such file or directory in /var/www/html/catalog/includes/application_top.php on line 511

 

Fatal error: main(): Failed opening required 'STS_START_CAPTURE' (include_path='.:/php/includes:/usr/share/php') in /var/www/html/catalog/includes/application_top.php on line 511

 

Could you post your code around that particular line so we can take a look at it??

That will give us a little help


I only do what my Rice Krispies tell me to do!

Share this post


Link to post
Share on other sites

Hey m0oo0m,

 

Make sure that you have uploaded your configure.php file with the STS code at the bottom of that file. Check the example on the contribution, then just copy and paste to your configure.php.

 

I had that same problem because I forgot to upload file. Hope that helps.

 

Question:

 

I have the skin contribution for the boxes, but the problem is that the sizes of the boxes are not the same as i had them before. Any idea why is that?

 

www.lglivart.com

 

Also, my header image won't add the background image in order to work in a full page mode. I don't want to have it do a center page...

 

Any idea?

Share this post


Link to post
Share on other sites

Hi there,

I'm facing exactly the same problem as described below.

Meanwhile I've searched the whole forum, but I couldn't find a solution for my prob. I really hope that there is someone out there who can help me, because I spent already a couple of weeks on this problem, and I really don't know what to do.

So pleeeeaase, give me a hint!

 

Cheers, Tim

 

Posted this in its own topic, but it seems this is where the action is.

Everything was working great and now I'm not sure what I've done to cause the message below when I click on the link for the product detail. This seems to be the only snag, and I double checked for correct sts code in the configure file.

 

Warning: main(includes/sts_product_info.php): failed to open stream: No such file or directory in /blah/blah/blah/spiceswest.com/httpdocs/catalog/includes/sts_display_output.php on line 132

 

Fatal error: main(): Failed opening required 'includes/sts_product_info.php' (include_path='.:/usr/lib/php4/php') in /blah/blah/blah/spiceswest.com/httpdocs/catalog/includes/sts_display_output.php on line 132

 

am using just one main template, not a sepaprate one for products or categories.

Any hlep is appreciated. Thanks so much.

Brooke

<_<

Share this post


Link to post
Share on other sites

Hello...

 

Is there a way that STS can be easily changed to pick up the page title, keywords and description tags for each page that is loaded? I'm thinking about the search engines having different info for each page.

 

Thanks

 

Andy.

Share this post


Link to post
Share on other sites
Hello...

 

Is there a way that STS can be easily changed to pick up the page title, keywords and description tags for each page that is loaded? I'm thinking about the search engines having different info for each page.

 

Thanks

 

Andy.

 

Not real easy but the header tags controller does the job.


The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×