Jump to content
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

OK, i like this but could somebody helps me please ? I am confused with the instructions. I fresh installed with simple script from the host cpanel. How do I know which version I got ? Then what steps I have to do please after ?

 

I do not have much time to muck around and not really that great with computer programming ?

 

I got into this contribution because I want to add adsense. Is it possible to add like amazon product link here too ? How do I add the amazon product link the easiest way into the new product box containing image and link if possible ?

 

Thank you for your information.

 

Kind regards

Al

Share this post


Link to post
Share on other sites

How do I know which version I got ? Then what steps I have to do please after ?

 

 

I got this version from the admin area .... osCommerce Online Merchant v2.3.3

so, which files do I copy and what not please ?

 

Thanks

Share this post


Link to post
Share on other sites

@@soul21mate

 

 

Sure, you can place your adsense code just about anywhere. If you look at the contribution area, you will find an add column box contribution that would allow you to place it in the column. Basic PHP knowledge is required to use osCommerce and you will need it to place your code properly.

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Upgrading from very old STS contribution. To test, I copied the clean install files to a development directory to get it running before migrating to the live store. Admin works fine, installing the module, but the catalog is jacked. With STS set to false, I see the normal index.php. When set to true, I see basically nothing.

 

Here is the source code for the page I see.

<!-- whats_new //-->

<tr>

<td>

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td height="14" class="infoBoxHeading"><img src="deve/images/pixel_trans.gif" border="0" alt=""></td>

<td width="100%" height="14" class="infoBoxHeading">What's New?</td>

<td height="14" class="infoBoxHeading" nowrap><a href="http://www.rosegardenboutique.com/deve/products_new.php"><u>Click for More!</u></a><img src="deve/images/pixel_trans.gif" border="0" alt="" width="11" height="14"></td>

</tr>

</table>

 

 

I am seeing a single box. That is it.

 

I have confirmed that I have copied all of the files to correct location, but it is not working as it should. Can anyone point me in the right direction?

 

Thanks

Share this post


Link to post
Share on other sites

@@Avec

 

What versions are you using ?

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

I have installed STS on a fresh installation of OSC 2.2 and I am having a problem implementing category templates. At this point, the installation has been modified and the site design is near completion. The rest of STS seems to work fine. The problem relates to the "index.php.htm" template. This template works fine, however the template "index.php_21.html" is ignored when "catalog/index.php?cPath=21" is called. I have placed it in the root template folder and "/template/content" without success. I have "Use templates for index page" set to true.

 

I have limited knowledge of php so I am hoping that someone has a suggestion for a possible solution.

 

Thank you

Share this post


Link to post
Share on other sites

As far as I am aware this has not been updated to work with any of the 2.3 versions.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

I have my store installed in a folder named "cuisine" instead of catalog. The store works fine. I installed the STS and it does not change anything. It is activated in the admin panel and I have the folder set right. I have used this add on before but never had this problem. Could changing the main folder name be the reason?


White Wolf Spirits

Share this post


Link to post
Share on other sites

I recently moved a working site over to a new server. STS version 2.0. I was using the feature that provided for a different template for the Main Catalog Page  /catalog/includes/sts_templates/index.php_0.html however once I moved to the new server, the home page is now the default page for STS  /catalog/includes/sts_template.html. Anyone know why it flipped to the default and how I can get it back? Thanks!

 

Mark

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×