Jump to content
Latest News: (loading..)
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

Hi,

Ive added STS to a blank installation. All seems OK on install except the admin left hand lest is a bit all over the place, but thats not the problem.

Ive gone thro the whole installation, switched on all four modules in sts, loaded the simple template and none of the changes I have made are being reflected on the pages.

 

Its clearly not picking up the simple template.

 

Am I missing something. Has something been omitted from the instructions?

 

Thanks

Share this post


Link to post
Share on other sites

I am missing the next / previous buttons on the product search page. If you select a category from the left hand menu (say in my case shirts) the shirt page opens up, and currently I have set the maximum amount of images to be displayed as 200.

I had to up the number as we have 20/30 products in each category, but now the page is loading slower. I increased the search number as the previous / next buttons are not showing, although they do on the product new page.

 

I am not sure the reason which page to start looking at, any help - I can see some code in product.new which I assume is for the next/prev, but I can not see it index.php (is the right place to look)

 

Any help would be great

Share this post


Link to post
Share on other sites

I am missing the next / previous buttons on the product search page. If you select a category from the left hand menu (say in my case shirts) the shirt page opens up, [...] the previous / next buttons are not showing, although they do on the product new page.

[...]I can see some code in product.new which I assume is for the next/prev[...]

 

The issue is not connected with STS. The file where the "prev/next code" should be in is catalog/includes/modules/product_listing.php.

 

Find a clean file from the osCommerce version you are using, compare it with the one you have, and add the code

Share this post


Link to post
Share on other sites

That's brill - I did not think it would be a STS thing exactly - I just was not sure where to look , the STS documentation said that the main content is dragged from index.html - but I could not see any thing there - thanks for the heads up - I have done multiple site changes over the years, and I have obviously doe some thing silly along the way!!

Share this post


Link to post
Share on other sites

Hello, this is my first post here. So be gentle. I usually can find an answer by searching. I'm not even sure how to phrase this one for the search.

 

 

I have implemented version 4.6. and everything seems to be working correctly. I have installed a membership script and I am trying to use the same template I used for the STS and the site .

 

In the members folder I get the template with the place holder showing and not the actual oscommerce components.

 

I'm think it is a path issue, but just can't figure it out. Can anyone help.

 

Thanks in advance.

 

Michael

Share this post


Link to post
Share on other sites

Hello!

Does anyone can help me?

I have: osc V.2.2 RC2a and I'm trying to add dynamic meta tags to products page. I tried kissMT but it doesn't work, maybe it need some mod. to work correctly.

 

What contribution do you suggest to me? Please note that, if have dynamic meta tags isn't so easy, I can also fill a field with keywords product by product this isn't a big problem, the important is that it works correctly and promotes indexing on search engines.

 

Thanks!

Share this post


Link to post
Share on other sites

Hey franz85e I think this thread is dead. That was my first post to the forums. Not very promising.

 

I usually find what I need by searching. Seems most of the issues I have, have already been addressed except for this last one. I found a work around. Now I have I have a new one.

 

In the category box, I have to much space between the top and bottom of the category list. Only appears in IE and Chrome.

 

If any one is monitoring this thread with any idea for a fix, I'll check back periodically.

Share this post


Link to post
Share on other sites

We have a couple old sites in our network (that I'm now responsible for) that use OSC 2.2 MS2 and STS 1.2 - obviously pretty old. But so heavily modded that I don't really want to mess with them until we are ready to completely move them off of OSC into our new CMS system. I'm trying to do a couple things and am getting stuck due to STS. The main issue I'm having is that I'm trying to plug in an iframe into a few of the sts templates. I have the file that I'm framing hosted in the /catalog directory. It's a really basic .html file that consists of text and links. The problem I'm having is that the file that is showing up in the iframe is being wrapped in the sts template and I don't want that to happen. Is there a simple way to prevent specific files that are being iframed from having the sts template wrapper applied? I've done countless searches trying to find a way to do this with no luck.

Edited by ludachris

Share this post


Link to post
Share on other sites

OK, i like this but could somebody helps me please ? I am confused with the instructions. I fresh installed with simple script from the host cpanel. How do I know which version I got ? Then what steps I have to do please after ?

 

I do not have much time to muck around and not really that great with computer programming ?

 

I got into this contribution because I want to add adsense. Is it possible to add like amazon product link here too ? How do I add the amazon product link the easiest way into the new product box containing image and link if possible ?

 

Thank you for your information.

 

Kind regards

Al

Share this post


Link to post
Share on other sites

How do I know which version I got ? Then what steps I have to do please after ?

 

 

I got this version from the admin area .... osCommerce Online Merchant v2.3.3

so, which files do I copy and what not please ?

 

Thanks

Share this post


Link to post
Share on other sites

@@soul21mate

 

 

Sure, you can place your adsense code just about anywhere. If you look at the contribution area, you will find an add column box contribution that would allow you to place it in the column. Basic PHP knowledge is required to use osCommerce and you will need it to place your code properly.

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

Upgrading from very old STS contribution. To test, I copied the clean install files to a development directory to get it running before migrating to the live store. Admin works fine, installing the module, but the catalog is jacked. With STS set to false, I see the normal index.php. When set to true, I see basically nothing.

 

Here is the source code for the page I see.

<!-- whats_new //-->

<tr>

<td>

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td height="14" class="infoBoxHeading"><img src="deve/images/pixel_trans.gif" border="0" alt=""></td>

<td width="100%" height="14" class="infoBoxHeading">What's New?</td>

<td height="14" class="infoBoxHeading" nowrap><a href="http://www.rosegardenboutique.com/deve/products_new.php"><u>Click for More!</u></a><img src="deve/images/pixel_trans.gif" border="0" alt="" width="11" height="14"></td>

</tr>

</table>

 

 

I am seeing a single box. That is it.

 

I have confirmed that I have copied all of the files to correct location, but it is not working as it should. Can anyone point me in the right direction?

 

Thanks

Share this post


Link to post
Share on other sites

@@Avec

 

What versions are you using ?

 

 

 

Chris


:|: Was this post helpful ? Click the LIKE THIS button :|:

 

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

Share this post


Link to post
Share on other sites

I have installed STS on a fresh installation of OSC 2.2 and I am having a problem implementing category templates. At this point, the installation has been modified and the site design is near completion. The rest of STS seems to work fine. The problem relates to the "index.php.htm" template. This template works fine, however the template "index.php_21.html" is ignored when "catalog/index.php?cPath=21" is called. I have placed it in the root template folder and "/template/content" without success. I have "Use templates for index page" set to true.

 

I have limited knowledge of php so I am hoping that someone has a suggestion for a possible solution.

 

Thank you

Share this post


Link to post
Share on other sites

As far as I am aware this has not been updated to work with any of the 2.3 versions.


REMEMBER BACKUP, BACKUP AND BACKUP

Before installing the official version of oscommerce first look at a responsive version here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

I have my store installed in a folder named "cuisine" instead of catalog. The store works fine. I installed the STS and it does not change anything. It is activated in the admin panel and I have the folder set right. I have used this add on before but never had this problem. Could changing the main folder name be the reason?


White Wolf Spirits

Share this post


Link to post
Share on other sites

I recently moved a working site over to a new server. STS version 2.0. I was using the feature that provided for a different template for the Main Catalog Page  /catalog/includes/sts_templates/index.php_0.html however once I moved to the new server, the home page is now the default page for STS  /catalog/includes/sts_template.html. Anyone know why it flipped to the default and how I can get it back? Thanks!

 

Mark

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×