Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

I tryed to update STS. I have to say, it works very great. Only, there are showing about 2339 error messages and the shop is not longer available. But else, perfect biggrin.gif

 

I change back to the original files. Same before. The manual to install is ok. But it shows not how to install the latest STS version if you have a very stinky old versin installed already..........

 

 

If you were using STS4.x or later, it would simply be a matter of uploading everything from the latest build. If you were using STS3.x or older, then you would need to remove most if not all of the previous STS installation, such as you have to remove the old STS code from several files in the catalog/includes folder: header.php, footer.php, application_bottom.php and application_top.php, then you can start installing the new STS. Keep in mind, you will need both the new STS file modifications as well as the existing file modifications from the latest version.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Looks like you were simply missing the call to the default stylesheet and that would have taken care of your problem.

 

Its the default setup.

If thats the case, then why is the first line working using the same class?

 

 

Steve

Share this post


Link to post
Share on other sites

Hello everybody. Thanks for this fantastic addon. I love it!

 

There's a minor problem tough. I hope to find the answer to my question here!

 

This is my website. http://www.felzmade.com/index2.html .

Here is my shop. http://www.felzmade.com/Osx/

The problem is, when i'm in the shop (tough not the index page of the shop), i can't use the flash button's in the menu at the top!

 

I was hoping anybody has a idea how to fix this? There's a contribution claiming to fix flash, but it didnt work. Also a post in this topic told me i needed to use something with javascript, but that also didn't work!

 

Thanks in advance,

 

Jonathan

Share this post


Link to post
Share on other sites

Hello everybody. Thanks for this fantastic addon. I love it!

 

There's a minor problem tough. I hope to find the answer to my question here!

 

This is my website. http://www.felzmade.com/index2.html .

Here is my shop. http://www.felzmade.com/Osx/

The problem is, when i'm in the shop (tough not the index page of the shop), i can't use the flash button's in the menu at the top!

 

I was hoping anybody has a idea how to fix this? There's a contribution claiming to fix flash, but it didnt work. Also a post in this topic told me i needed to use something with javascript, but that also didn't work!

 

Thanks in advance,

 

Jonathan

 

Hmm, did you fix it as the flash buttons work.

 

Steve

Share this post


Link to post
Share on other sites

Hi Bill,

 

I'm hoping you can help me? I want to have 'Use template for infoboxes' set to 'true' (because it looks better), but when I do, the infobox header for the main new items box towards the bottom of the page (the bit that says 'new items for september' etc) disappears.

 

The infobox headers for the infoboxes in the columns remain. I know that this must be because of a setting in my template, but I don't know what it is? I presume it's something in the sts_template.html file, but when I open it and look at the code I can't see what it might be?

 

As always, I really appreciate any help you can offer.

 

Many thanks and my very best wishes,

 

Tom

 

P.S. My website is here

Share this post


Link to post
Share on other sites

Hello,

 

Did you go into the store? Not only in the index-page of the store? Thanks,

 

Jonas

 

 

Well I clicked Catalog and it still works.

 

Steve

Share this post


Link to post
Share on other sites

@stefan1959

 

If you're helping Andy with his big garage sale (*COUGH* *COUGH*) you need to visit the link below:

 

How to Secure Your Site

 

Pay close attention to "SECURING THE ADMIN" - The admin is vulnerable.

 

It's easier to do a few security fixes now than to clean up a hacked store later.

 

And if you don't secure the admin the shop will be hacked.

 

It's just a question of when...

:o


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

@stefan1959

 

If you're helping Andy with his big garage sale (*COUGH* *COUGH*) you need to visit the link below:

 

How to Secure Your Site

 

Pay close attention to "SECURING THE ADMIN" - The admin is vulnerable.

 

It's easier to do a few security fixes now than to clean up a hacked store later.

 

And if you don't secure the admin the shop will be hacked.

 

It's just a question of when...

:o

 

Thanks I will have a read.

But why the interest?

And why did you mention it to me and how did you know I was working on that site?

Its not from the above post as that not where the screen shots where taken from.

 

Are you a hacker?

 

 

Steve

Edited by stefan1959

Share this post


Link to post
Share on other sites
Guest

Hi all

 

I am trying to resolve a problem with this

<base href="http://www.landyspecials4x4.com//">

and this

<link rel="stylesheet" type="text/css" href="//includes/sts_templates/multiple/stylesheet.css">

were it has the double //.

 

Both of wich i have no idea of were the program gets this code from but looking at the code i found this :

 

return  "\n<!-- start $commentlabel //-->\n$tmpstr\n<!-- end $commentlabel //-->\n";

 

and i thought that things like <!-- //--> were there to comment things out and made the code become green , this however is in gray ( with just the word "return" in blue )

 

Is this correct??

 

Thanks for your time.

 

Gr, Rob

Share this post


Link to post
Share on other sites

Thanks I will have a read.

But why the interest?

And why did you mention it to me and how did you know I was working on that site?

Its not from the above post as that not where the screen shots where taken from.

 

Are you a hacker?

 

 

Steve

YES I did find the site info in the post with the screen shots. If you don't know how I did it you need to read up a little more on how web pages work.

 

NO I'm not a hacker.

 

If I was I wouldn't spend my time here HELPING people with their shops and trying to keep them out of the clutches of the evil-doers lurking in cyber space.


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Share this post


Link to post
Share on other sites

YES I did find the site info in the post with the screen shots. If you don't know how I did it you need to read up a little more on how web pages work.

 

NO I'm not a hacker.

 

If I was I wouldn't spend my time here HELPING people with their shops and trying to keep them out of the clutches of the evil-doers lurking in cyber space.

 

Where is andy's sale in the above screen-shots? No address line, only tabs and they don't show and name like andy.

In fact those screen-shots where taken from another site. I'm really curious where you got that info from!!!

 

Steve

Share this post


Link to post
Share on other sites

Where is andy's sale in the above screen-shots? No address line, only tabs and they don't show and name like andy.

In fact those screen-shots where taken from another site. I'm really curious where you got that info from!!!

 

Steve

 

Come on, the path of the images you placed is www.andysbiggaragesale.com/images/ScreenShot1.gif

Share this post


Link to post
Share on other sites
Guest

I am getting this message: Fatal error: Cannot redeclare class sts_popup_image in /home/empress4/public_html/shop/includes/modules/sts/sts_popup_image.php on line 16. Does anyone know how to resolve this?

Share this post


Link to post
Share on other sites

Hi!

I'm a newbie to STS for OSC.I have a localized version of OSC 2.2RC2a in hungarian, with some security tweaks, and others. I'have just installed it with sample data. The question is, how does STS affects my language localization on my installed OSC: all files should be copied are about english version. Do I need to have spec version os STS to work properly with my installation?

Many Thanks,

FG.

Share this post


Link to post
Share on other sites

Come on, the path of the images you placed is www.andysbiggaragesale.com/images/ScreenShot1.gif

 

Ahhh, didn't know that info was available, you do look close.

Share this post


Link to post
Share on other sites

Hi!

I'm a newbie to STS for OSC.I have a localized version of OSC 2.2RC2a in hungarian, with some security tweaks, and others. I'have just installed it with sample data. The question is, how does STS affects my language localization on my installed OSC: all files should be copied are about english version. Do I need to have spec version os STS to work properly with my installation?

Many Thanks,

FG.

 

 

You would need to add your language to any language files included in the STS contribution. For example:

admin/includes/languages/*your_language*/modules.php

and

admin/includes/languages/*your_language.php*

and

includes/languages/*your_language*/modules/sts/sts_default.php

includes/languages/*your_language*/modules/sts/sts_index.php

includes/languages/*your_language*/modules/sts/sts_popup_image.php

includes/languages/*your_language*/modules/sts/sts_product_info.php

 

You can use the files within any of the existing language folders/files to edit and modify to your desired language and then save it as the proper language file name.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi all

 

I am trying to resolve a problem with this

<base href="http://www.landyspecials4x4.com//">

and this

<link rel="stylesheet" type="text/css" href="//includes/sts_templates/multiple/stylesheet.css">

were it has the double //.

 

Both of wich i have no idea of were the program gets this code from but looking at the code i found this :

 

return  "\n<!-- start $commentlabel //-->\n$tmpstr\n<!-- end $commentlabel //-->\n";

 

and i thought that things like <!-- //--> were there to comment things out and made the code become green , this however is in gray ( with just the word "return" in blue )

 

Is this correct??

 

Thanks for your time.

 

Gr, Rob

 

 

Usually, the // double forward slash indicates an extra forward slash within your configure.php path settings and not related to STS.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

In the STS system, where would I disable the products from showing in the main page?

 

Edit***

 

Sorry for the post, I took a few minutes and read the pdf file included with the contribution and found what I was looking for.

 

Edit***

Share this post


Link to post
Share on other sites

In the STS system, where would I disable the products from showing in the main page?

 

 

Just so you're clear...you would do this simply by creating a "home page" template: index.php_0.html


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Something strange is happening, the sts system is working as intended, I can modify everything and I'm happy with it, but, when I try to test the actual cart features nothing is working, using the default products when I try to add it always says my cart is empty so I can't test the checkout process... Has someone else come across this problem?

Share this post


Link to post
Share on other sites

If you were using STS4.x or later, it would simply be a matter of uploading everything from the latest build. If you were using STS3.x or older, then you would need to remove most if not all of the previous STS installation, such as you have to remove the old STS code from several files in the catalog/includes folder: header.php, footer.php, application_bottom.php and application_top.php, then you can start installing the new STS. Keep in mind, you will need both the new STS file modifications as well as the existing file modifications from the latest version.

 

 

I ipload the files from the latest verison. Then on the shop i get a error message: *Fatal error*: Allowed memory size of 67108864 bytes exhausted (tried to

> allocate 30720 bytes) in

 

 

The emory_limit in php.ini is set already to 96mb. Is it realy possibli that STS need that much memory?

Share this post


Link to post
Share on other sites
Guest

Hi everyone,

 

Could I use also the latest release to work with OS 3?

 

Thanks for the answer

Share this post


Link to post
Share on other sites

Hi everyone,

 

Could I use also the latest release to work with OS 3?

 

Thanks for the answer

 

No, not at this time. Maybe a later STS release but the current 4.6 and older is not compatible with osC v3.x.

 

thumbsup.gif A new (final) version of the osCommerce 2.2 series is about to released as v2.3. I will be working to make STS compatible with that version first.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×