Jump to content
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

Important Posts for the STS newbie:

 

Post #3755: http://forums.oscomm...p;#entry1226986

 

Post #4326: http://forums.oscomm...p;#entry1303555

 

Post #4974: http://forums.oscomm...p;#entry1361366

 

Post #3772: http://forums.oscomm...p;#entry1227769

 

Post #3757: http://forums.oscomm...p;#entry1227006

 

Please review the above for insight on how the Simple Template System allows you to make templates for pages, categories, home page, products and infoboxes.

 

Hope this was helpful,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Topic: Contact and About Page Not Showing Content - STS

 

Hi all

I've searched this one and not found a solution yet. I've been trying out the STS-latest version and have created my own template, loaded it into the Modules section in the Admin Section and see the home page correctly. If I click on a link to the contact_us.php page it successfully finds and loads the page but none of the code from the page shows in the main area. The page displays identically like the home page. I've read the manual and see that the sts_template.php page has the includes for the header and the footer. I've not included these but don't see any code in them to affect the main area of the page.

Can anyone direct me in the right direction here?

Thanks,

Frank

Share this post


Link to post
Share on other sites

I have installed the latest version of STS 4.6 and osc 2.2, and have noted that the STS infoboxes positioned in the central area (where $content tag sits) does not display correctly- The title of the infobox does not appear. Although having checked the other freeoscommerce templates (e.g. http://freeoscommerce.com/demo/?demotemplate=freeoscommerce_009 ) this seems to be a generic problem as the infobox at the bottom should display "New products for..." as the vanilla version of osc does instead a number of products are displayed without a heading.

 

I have spent hours searching this forum and could not find a solution, advice would be much appreciated on how I can get the headings of the central infoboxes to display correctly

 

P.S Infoboxes on right and left display fine.

 

Thanks

Edited by Abu Maryam

Share this post


Link to post
Share on other sites

I am having a problem installing sts 4.6 i have noticed other people have had the same problem, and i have tried installing and reinstalling and copy the files countless times, but im still not getting anywhere...

 

any advice?

 

 

Warning: require(includes/classes/navigation_history.php) [function.require]: failed to open stream: No such file or directory in /home/sussext2/public_html/osc/admin/includes/application_top.php on line 128

 

Warning: require(includes/classes/navigation_history.php) [function.require]: failed to open stream: No such file or directory in /home/sussext2/public_html/osc/admin/includes/application_top.php on line 128

 

Fatal error: require() [function.require]: Failed opening required 'includes/classes/navigation_history.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/sussext2/public_html/osc/admin/includes/application_top.php on line 128

Share this post


Link to post
Share on other sites

I am having a problem installing sts 4.6 i have noticed other people have had the same problem, and i have tried installing and reinstalling and copy the files countless times, but im still not getting anywhere...

 

any advice?

 

 

Warning: require(includes/classes/navigation_history.php) [function.require]: failed to open stream: No such file or directory in /home/sussext2/public_html/osc/admin/includes/application_top.php on line 128

 

Warning: require(includes/classes/navigation_history.php) [function.require]: failed to open stream: No such file or directory in /home/sussext2/public_html/osc/admin/includes/application_top.php on line 128

 

Fatal error: require() [function.require]: Failed opening required 'includes/classes/navigation_history.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/sussext2/public_html/osc/admin/includes/application_top.php on line 128

 

You've accidentaly uploaded the in /includes/application_top.php from the catalog to the admin.

 

The admin doesn't use navigation history.

 

Or, you should take a look here.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi all I have just manaly installed this conntribution had a couple of problems but fixed them.

 

The one i cannot fix is it will not install the addon via the admin panel can anybody help me please

 

i have osc 2.2 rc2 :'(

Share this post


Link to post
Share on other sites

Hi all I have just manaly installed this conntribution had a couple of problems but fixed them.

 

The one i cannot fix is it will not install the addon via the admin panel can anybody help me please

 

i have osc 2.2 rc2 crying.gif

 

 

It appears you may have missed some of the admin files during the install. Use a file comparison to compare your files with those that came with the contribution.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Thank you for replying.

 

I have check and double checked the files both in admin and catalog and they are all there and are all correct as per your instructions. As I have a modified version of osc 2.2 rc 2, I chose to do it manualy might there be something else. it seams that everybody else has had a lot less problems than i lol, just my luck.

 

dj

Share this post


Link to post
Share on other sites

Thank you for replying.

 

I have check and double checked the files both in admin and catalog and they are all there and are all correct as per your instructions. As I have a modified version of osc 2.2 rc 2, I chose to do it manualy might there be something else. it seams that everybody else has had a lot less problems than i lol, just my luck.

 

dj

 

 

thumbsup.gif Just because you installed STS manually does not mean you shouldn't take advantage of the provided merged files. When someone tried to install it manually and then had proplems, they should take the files provided in the contribution and use a good file comparison tool such as Beyond Compare to compare with their manually modified files. This will show you visually where you may have made your mistake. Very fast and very reliable method.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Just because you installed STS manually does not mean you shouldn't take advantage of the provided merged files. When someone tried to install it manually and then had proplems, they should take the files provided in the contribution and use a good file comparison tool such as Beyond Compare to compare with their manually modified files. This will show you visually where you may have made your mistake. Very fast and very reliable method.

Bill Kellum

 

Hi Bill Did what you told me found a couple of differnces and one or two mistakes have fixed all but still it will not install from admin panel the green box with the + install is there nothing is under it on the left of that is the address of the folder for sts.

 

Module Directory: /mywebsite/*******/public_html/oscommerce/includes/modules/sts/ i have triple check this time making sure that all files are in the right folders all mods are correct and so on and so forth. Please help :(

 

DJ

Share this post


Link to post
Share on other sites

Hi Bill Did what you told me found a couple of differnces and one or two mistakes have fixed all but still it will not install from admin panel the green box with the + install is there nothing is under it on the left of that is the address of the folder for sts.

 

Module Directory: /mywebsite/*******/public_html/oscommerce/includes/modules/sts/ i have triple check this time making sure that all files are in the right folders all mods are correct and so on and so forth. Please help sad.gif

 

DJ

 

 

First, check for the obvious...

 

1. is the cart fucntioning properly without STS installed?

2. Can you install any of the other modules such as payment and shipping modules?

3. Do you have your configure.php files set correctly for a stable osCommerce installation?

3. What do you see on the catalog side, meaning, are you seeing your old shop prior to installing STS or are you viewing a STS template?

4. What version of osCommerce is your store?

5. What other contributions do you have installed and working properly?


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi Bill Did what you told me found a couple of differnces and one or two mistakes have fixed all but still it will not install from admin panel the green box with the + install is there nothing is under it on the left of that is the address of the folder for sts.

 

Module Directory: /mywebsite/*******/public_html/oscommerce/includes/modules/sts/ i have triple check this time making sure that all files are in the right folders all mods are correct and so on and so forth. Please help sad.gif

 

DJ

 

Also, did you try clicking on the "install" button? What happens when you do?


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
First, check for the obvious...

 

1. is the cart fucntioning properly without STS installed?

2. Can you install any of the other modules such as payment and shipping modules?

3. Do you have your configure.php files set correctly for a stable osCommerce installation?

3. What do you see on the catalog side, meaning, are you seeing your old shop prior to installing STS or are you viewing a STS template?

4. What version of osCommerce is your store?

5. What other contributions do you have installed and working properly?

Also, did you try clicking on the "install" button? What happens when you do?

 

Hi bill to answer the questions 1 at a time.

1. yes

2. yes

3. yes the store has been on line for about 18 months

4. 2.2 rc2

5. i have a discount coupon contribution added

yes i did and all it dose is resets the screen so to speak and nothing happens it apperas the same as befor i clicked.

 

regrads DJ :thumbsup:

Share this post


Link to post
Share on other sites

Hi bill to answer the questions 1 at a time.

1. yes

2. yes

3. yes the store has been on line for about 18 months

4. 2.2 rc2

5. i have a discount coupon contribution added

yes i did and all it dose is resets the screen so to speak and nothing happens it apperas the same as befor i clicked.

 

regrads DJ thumbsup.gif

 

 

Then you must have an incomplete installation. Try uploading all of the STS and modified files again as some FTP programs are known for being unreliable.

 

thumbsup.gif Anytime you manually install a contribution that also provides the files that need to edited as well, it helps to compare the two to see where things may have gone wrong.

 

Make sure you did not add an extra } at the end of that code segment. It should look like the following:

 

        eval('$keys .= ' . $value['set_function'] . "'" . $value['value'] . "', '" . $key . "');");
 // STS V4.6 drop start
       } else {
  if($key == 'MODULE_STS_TEMPLATE_FOLDER'){
   $dir_name = array();
   if ($handle = opendir('../'.MODULE_STS_TEMPLATES_FOLDER.'/')) {
       while (false !== ($file = readdir($handle))) {
     $pos = strpos($file, ".");
     if($pos === false){
      $dir_name[] = array("id" => $file, "text" => $file);
      $i++;
     }
    }
    closedir($handle);
   }
   $keys .= tep_draw_pull_down_menu('configuration[MODULE_STS_TEMPLATE_FOLDER]', $dir_name, $value['value']);
  }else{
   $keys .= tep_draw_input_field('configuration[' . $key . ']', $value['value']);
  }
       }
 // STS V4.6 drop end
       $keys .= '<br><br>';
       }
       $keys = substr($keys, 0, strrpos($keys, '<br><br>'));


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Sirs, could you please help me with this error (i did manual installation):

 

Warning: require(includes/classes/sts.php) [function.require]: failed to open stream: No such file or directory in C:\wamp\www\tienda\admin\includes\application_top.php on line 174

 

Fatal error: require() [function.require]: Failed opening required 'includes/classes/sts.php' (include_path='.;C:\php5\pear') in C:\wamp\www\tienda\admin\includes\application_top.php on line 174

 

Thanks in advance.

 

Yamal.

Share this post


Link to post
Share on other sites

Sirs, could you please help me with this error (i did manual installation):

 

Warning: require(includes/classes/sts.php) [function.require]: failed to open stream: No such file or directory in C:\wamp\www\tienda\admin\includes\application_top.php on line 174

 

Fatal error: require() [function.require]: Failed opening required 'includes/classes/sts.php' (include_path='.;C:\php5\pear') in C:\wamp\www\tienda\admin\includes\application_top.php on line 174

 

Thanks in advance.

 

Yamal.

 

Check once again that you did upload all of the new STS files as well as make the correct code modifications to the existing osCommerce files in your shop.

thumbsup.gif Tip: Use a good file comparison tool to check your modified files with the modified files provided in the contribution.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Check once again that you did upload all of the new STS files as well as make the correct code modifications to the existing osCommerce files in your shop.

thumbsup.gif Tip: Use a good file comparison tool to check your modified files with the modified files provided in the contribution.

 

Thanks.. but nothing yet...

 

I would like to understand the error message. The file 'includes/classes/sts.php' exists, and is the new one provided in the contribution package. I don't know why appears this message: (include_path='.;C:\php5\pear')

 

Some idea?

Share this post


Link to post
Share on other sites
Then you must have an incomplete installation. Try uploading all of the STS and modified files again as some FTP programs are known for being unreliable.

 

Posted Image Anytime you manually install a contribution that also provides the files that need to edited as well, it helps to compare the two to see where things may have gone wrong.

 

Make sure you did not add an extra } at the end of that code segment. It should look like the following:

 

Thanks bill for your time shall do so and get back to you

 

regards DJ

Share this post


Link to post
Share on other sites

Thanks.. but nothing yet...

 

I would like to understand the error message. The file 'includes/classes/sts.php' exists, and is the new one provided in the contribution package. I don't know why appears this message: (include_path='.;C:\php5\pear')

 

Some idea?

 

 

The error is telling you that you are missing some files or the file that it is looking for is in the wrong folder.

 

The folder structure should me maintained as set in the contribution.

For example, you should ftp everything inside of the STS folder, which would be the includes folder and everything in it to your catalog folder of your shop (http://mystore.com/catalog/).

 

Then you need to either FTP everything inside one of the osc version folders (Files for MS2, Files for RC1, or Files for RC2) to your catalog folder of your shop (http://mystore.com/catalog/).

 

Your catalog folder could be called anything from catalog, shop, store, or could be the very root of your domain such as http://mystore.com/.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hello!

 

I've a question regarding STS:

 

Is it possible to create a new_products page within STS and modify it to my liking (just like the other pages)?

If so, do I have to create any classes or something like that in the STS-files to be able to create a "new_products.php" page in STS?

 

Regards, Maxiimilian.

Share this post


Link to post
Share on other sites

Hi Bill,

Again i followed your instructions. compared files check and checked again to make sure that they were in the right folders catalog or admin and still no luck on the modual page the install bax is higher that others ie you can see the gray bar with a word in it just above the button but the box with button is over the bar almost 3/4. Realy need this to work but getting frustrated.

 

regrads DJ :'(

Share this post


Link to post
Share on other sites

Hello!

 

I've a question regarding STS:

 

Is it possible to create a new_products page within STS and modify it to my liking (just like the other pages)?

If so, do I have to create any classes or something like that in the STS-files to be able to create a "new_products.php" page in STS?

 

Regards, Maxiimilian.

 

Yes, you can create a template for this page that will effect everything but the "content" (stuff in the middle). If you wanted to modify the content, you would need to edit the actual new_products.php script.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi Bill,

Again i followed your instructions. compared files check and checked again to make sure that they were in the right folders catalog or admin and still no luck on the modual page the install bax is higher that others ie you can see the gray bar with a word in it just above the button but the box with button is over the bar almost 3/4. Realy need this to work but getting frustrated.

 

regrads DJ crying.gif

 

Yes, it can be frustrating trying to find out what you did wrong. If you truly feel that you did everything correctly, then it may just be a faulty FTP upload. Try uploading the files again or get a more reliable FTP program. This addon has worked for a ton of users and it wouldn't be in the top downloads if it didn't work for them.

 

In my opinion, STS has got to be one of the easiest contributions to install so focus on the installation instructions and keep trying.

 

Good luck.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Yes, it can be frustrating trying to find out what you did wrong. If you truly feel that you did everything correctly, then it may just be a faulty FTP upload. Try uploading the files again or get a more reliable FTP program. This addon has worked for a ton of users and it wouldn't be in the top downloads if it didn't work for them.

 

In my opinion, STS has got to be one of the easiest contributions to install so focus on the installation instructions and keep trying.

 

Good luck.

 

Oky doky Bill i'll print off the instruction. I must say i'm upload the file one by one via cpanel as my site have a few mods done to it and this way of uploading has always work for me in the past. But try ,try again i shall but this wan't be last you'll hear from me i bet :blush: :rolleyes:

 

Regrads DJ

 

ps thank you

Edited by djramm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×