Jump to content
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

You need to make an index.php_0.html template and include your graphic there. This will be used only for the "home" page

Then make an index.php.html template (without graphic) that will be used in all product listings

 

Hi have a site with STS and index.php_0.html which works great in English, but how do I get it to use a different page for each language. all the rest of the site is working in all 3 languages just the index.php_0.html

 

thanks

Share this post


Link to post
Share on other sites

I want to change the design of my cartbox and review box only? What are the names for it?

Must i copy this file in the directory: infobox_WHATNAMEHERE.php.html to edit the cartbox as example? only the cartbox?

 

And 1 more question: I wanna change this layout to 2 colums How do i do that and where? (SEE IMAGE)

layoutfromthis.png

 

P.S. I readed the DOC already. Hope for a quick response so i can go on ^^

 

Somebody? need really help :( can't go further :(((

Share this post


Link to post
Share on other sites

Hi have a site with STS and index.php_0.html which works great in English, but how do I get it to use a different page for each language. all the rest of the site is working in all 3 languages just the index.php_0.html

 

thanks

 

 

Look in the user manual regarding how to use the language variable.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Somebody? need really help sad.gif can't go further sad.gif((

 

 

You didn't read the entire doc as you would have found your answer :-)

 

Also:

 

Important Posts for the STS newbie:

 

Post #3755: http://forums.oscomm...p;#entry1226986

 

Post #4326: http://forums.oscomm...p;#entry1303555

 

Post #4974: http://forums.oscomm...p;#entry1361366

 

Post #3772: http://forums.oscomm...p;#entry1227769

 

Post #3757: http://forums.oscomm...p;#entry1227006

 

Please review the above for insight on how the Simple Template System allows you to make templates for pages, categories, home page, products and infoboxes.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I've a question.

 

Where i set my footer in the temlate, they are still all vertical like:

levering en garantie

Over ons

Algemene voorwaarden

Neem contact op

 

Want to have it like this:

levering en garantie Over ons Algemene voorwaarden Neem contact op

 

How to do that?

Edited by kanata_82

Share this post


Link to post
Share on other sites

I've a question.

 

Where i set my footer in the temlate, they are still all vertical like:

levering en garantie

Over ons

Algemene voorwaarden

Neem contact op

 

Want to have it like this:

levering en garantie Over ons Algemene voorwaarden Neem contact op

 

How to do that?

 

What I understand is that you want to have the links of the information box listed horizontally and to place them in the footer.

Following steps:

1) You need to remove the <br> (breaks) from file includes/boxes/information.php. (be careful to remove just this and take a backup first)

2) You make a template for the this box, call it infobox_information.php.html and place it into the boxes folder of your sts template folder. You will want to remove the box heading. Be careful with the html structure

3) You use the tag $informationbox to place this box wherever you like, top, bottom, left, right or in the center

 

PS please try to write in english whatever you post, how to understand that what you posted is supposed to be the content of the information box (is it?)

Edited by multimixer

Share this post


Link to post
Share on other sites

Having another glitch :(

 

I'm using sts in parallel with one page check out and when i try to sign in on the check out page, what SHOULD happen is that there is a login box appears, which does - except it's transparent, so whatever is written on the checkoutpage beneath where the popup box appears can still be seen.

 

So this:

if31ft.jpg

 

Becomes this:

htcxg4.jpg

 

Can anyone help?

Share this post


Link to post
Share on other sites

I want to center the text in the information box only.

 

I tried some things already like <center tags around it> but only work if 100% is off how can I do it?

 

I want to center the text in the information box only. (like text-align) (THINK i must remove the 100% from the information box only?)

 

Please help me!

Share this post


Link to post
Share on other sites

I hope this is'nt out of lie but I've been searching for it. I've never gotten the $myaccountlogoff to work. I need to display My account when not logged in and Log Off if they are logged in. Can anyone help me with this? Thanks for any insight!

 

Take care,

 

T

Share this post


Link to post
Share on other sites

I hope this is'nt out of lie but I've been searching for it. I've never gotten the $myaccountlogoff to work. I need to display My account when not logged in and Log Off if they are logged in. Can anyone help me with this? Thanks for any insight!

 

The $myaccountlogoff is a combination of 2 tags placed the one beside the other: $myaccount and $logoff. This happens in file sts_inc/general.php and the code looks like this

            $sts->template['myaccountlogoff'] = $sts->template['myaccount'] . " | " . $sts->template['logoff'];

The definitions of the "initial" tags look like this

      
$sts->template['myaccount'] = '<a href=' . tep_href_link(FILENAME_ACCOUNT, '', 'SSL') . ' class="headerNavigation">' . HEADER_TITLE_MY_ACCOUNT . '</a>';
$sts->template['logoff'] = '<a href=' . tep_href_link(FILENAME_LOGOFF, '', 'SSL')  . ' class="headerNavigation">' . HEADER_TITLE_LOGOFF . '</a>';

 

You see that this tags are nothing else that links. You can create as many links as you like and call them as you like

 

Now you want that some of the tags show a link only if the customer is registered else to be empty or opposite. I will show you an example about how I created a tag $register that shows up only if the customer is not logged in (else empty) and how the $myaccount is defined in sts_inc/general.php

   if (tep_session_is_registered('customer_id')) {
     $sts->template['myaccount'] = '<a href=' . tep_href_link(FILENAME_ACCOUNT, '', 'SSL') . ' class="headerNavigation">' . HEADER_TITLE_MY_ACCOUNT . '</a>';
     $sts->template['register'] = '';
   } else {
     $sts->template['myaccount'] = '';
     $sts->template['register'] = '<a href=' . tep_href_link(FILENAME_CREATE_ACCOUNT, '', 'SSL') . ' class="headerNavigation">' .  HEADER_TITLE_CREATE_ACCOUNT . '</a>';
  }

 

This says that if customer is registered show link for "my account" but not for "register" and if not logged in do the opposite. So now I use in my template $myaccount$register and the result is that I have only one link depending on if the customer is logged in or not.

 

I could also create a $accountregister tag like it is done for $myaccountlogoff

 

PS: There are ofcourse much more links in there I do not post them all to keep things clear. You do not need to repeat the if/else since it is already there, just enter any links you want into the proper place of the existing

Edited by multimixer

Share this post


Link to post
Share on other sites

Is there a loginbox compatbile with STS, so i can delete the default: (Mijn account | Inhoud winkelwagentje | Afrekenen) in the top?

Or what infoboxes are compatible with STS? Or how can I make a infobox compatible with STS?

Share this post


Link to post
Share on other sites

Thanks a bunch MultiMixer. I understand now. One thing...I think there is supposed to be a | between My Account and Logoff right? There is just a space with mine and I cant get a divider that only shows when logged in...

 

Thanks again!

 

Take care,

 

T

Share this post


Link to post
Share on other sites

Thanks a bunch MultiMixer. I understand now. One thing...I think there is supposed to be a | between My Account and Logoff right? There is just a space with mine and I cant get a divider that only shows when logged in...

 

Thanks again!

 

Take care,

 

T

 

 

You do not need to do any special coding to get the $myaccountlogoff to work correctly. If it is not working on your site, you either made changes to the default STS install or you did not install STS completely.

 

If customer is logged in: text link to the My Account page followed by a separator and then by a text link to the logoff page. Same as $myaccount | $logoff

 

If customer is not logged in: same as $myaccount.

Use SSL if available.

 

Created in: includes/modules/sts_inc/general.php

Possible use: text link in header.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Is there a loginbox compatbile with STS, so i can delete the default: (Mijn account | Inhoud winkelwagentje | Afrekenen) in the top?

Or what infoboxes are compatible with STS? Or how can I make a infobox compatible with STS?

 

 

Note: Does anyone ever read the STS Manual or search this thread for the answer??

 

You still need to define the STS tag for the new infobox being created by that contribution.

 

thumbsup.gif How to add a new infobox variable(tag) to STS:

Add this code to sts_user_code.php

$sts->start_capture();
  require(DIR_WS_BOXES . 'infobox_name.php');
  $sts->stop_capture('infobox_name', 'box');

 

The above would create a STS user tag called $infobox_name. Change what you need to make it work for your specific box name.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Is there a loginbox compatbile with STS, so i can delete the default: (Mijn account | Inhoud winkelwagentje | Afrekenen) in the top?

Or what infoboxes are compatible with STS? Or how can I make a infobox compatible with STS?

 

 

http://www.oscommerc...y/contributions,2302

 

  1. You would install the contribution above.
  2. Create a new tag for the new login box you just created.
  3. Add the new tag in your template where you want the login box to appear.

To do #2, you would add the following code to your includes/modules/sts_inc/sts_column_left.php file:

// Get Loginbox - don't show if member is logged in
// Uncomment the following lines if you want to use the login feature
// if (tep_session_is_registered('customer_id')) {
//   } else {
  require(DIR_WS_BOXES . 'memberlogin.php');
  $sts->restart_capture ('memberloginbox', 'box'); //Get the Loginbox with member name 

 

That would create your new tag: $memberloginbox

 

By the way, all infoboxes are compatible with STS.

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi All,

 

I have installed the horizontal categories extra contrib for sts, as i wanted a horizontal list going along the bottom of my pages. It installed fine, and i even managed to style it without too much difficulity. (the contrib is here:

http://www.oscommerce.com/community/contributions,4456/category,all/search,Horizontal+Category+Menu

dated: 16 Feb 2008)

 

the problem i did hit tho, was that the category names would not change as i changed language - even tho the vertical category listing changes category names into the correct languages.

 

here's the code in the modules/headcata.php file:

 

<table width="100%" cellpadding="0" cellspacing="0" align="center">
         <tr>
           <td>
<?php
 $query="SELECT * FROM categories c, categories_description d WHERE c.categories_id=d.categories_id AND c.parent_id='0' AND d.language_id='1' ORDER BY c.sort_order";
 $result=mysql_query($query) or die (mysql_error());
 echo '<table width="100%" border="0" cellspacing="0" cellpadding="0">
 <tr>
   <td height="37" align="center" valign="middle">
<div id="horizontalcats">
 ';

 $num=mysql_num_rows($result);
 $counter=0;
 while ($row=mysql_fetch_assoc($result))
 {
 $counter++;
 $cataid=$row['categories_id'];
 echo '<a class="horizontalcats" href="'.tep_href_link(FILENAME_DEFAULT, $cPath_new).'?cPath='.$cataid.'" >'.$row['categories_name'].'</a> ';
 if ($counter!=$num)
 {
 echo '| ';
 }

 }
echo '</span></div></td>
 </tr>
</table>';
?>
           </td>
         </tr>
         </table>
<!-- categories_eof //-->

 

I've completed the install correctly - otherwise it wouldn't show even the English categories. Is it something to do with the "AND d.language_id='1'" part of the above code, what should i change that to?

 

Can anyone help?

 

thanks in advance,

 

BarneyBruce / Vicky

Share this post


Link to post
Share on other sites

Sorry to bump my own post, but has nobody encountered this problem before or is it just that it can't be fixed?

 

Thanks for ANY help or advice,

 

vicky

 

 

Hi All,

 

I have installed the horizontal categories extra contrib for sts, as i wanted a horizontal list going along the bottom of my pages. It installed fine, and i even managed to style it without too much difficulity. (the contrib is here:

http://www.oscommerce.com/community/contributions,4456/category,all/search,Horizontal+Category+Menu

dated: 16 Feb 2008)

 

the problem i did hit tho, was that the category names would not change as i changed language - even tho the vertical category listing changes category names into the correct languages.

 

here's the code in the modules/headcata.php file:

 

<table width="100%" cellpadding="0" cellspacing="0" align="center">
         <tr>
           <td>
<?php
 $query="SELECT * FROM categories c, categories_description d WHERE c.categories_id=d.categories_id AND c.parent_id='0' AND d.language_id='1' ORDER BY c.sort_order";
 $result=mysql_query($query) or die (mysql_error());
 echo '<table width="100%" border="0" cellspacing="0" cellpadding="0">
 <tr>
   <td height="37" align="center" valign="middle">
<div id="horizontalcats">
 ';

 $num=mysql_num_rows($result);
 $counter=0;
 while ($row=mysql_fetch_assoc($result))
 {
 $counter++;
 $cataid=$row['categories_id'];
 echo '<a class="horizontalcats" href="'.tep_href_link(FILENAME_DEFAULT, $cPath_new).'?cPath='.$cataid.'" >'.$row['categories_name'].'</a> ';
 if ($counter!=$num)
 {
 echo '| ';
 }

 }
echo '</span></div></td>
 </tr>
</table>';
?>
           </td>
         </tr>
         </table>
<!-- categories_eof //-->

 

I've completed the install correctly - otherwise it wouldn't show even the English categories. Is it something to do with the "AND d.language_id='1'" part of the above code, what should i change that to?

 

Can anyone help?

 

thanks in advance,

 

BarneyBruce / Vicky

Share this post


Link to post
Share on other sites

Sorry to bump my own post, but has nobody encountered this problem before or is it just that it can't be fixed?

 

Look at the query, it is taking just the language with id=1, I guess it's english

$query="SELECT * FROM categories c, categories_description d WHERE c.categories_id=d.categories_id AND c.parent_id='0' AND d.language_id='1' ORDER BY c.sort_order";

 

Try to change it to

$query="SELECT * FROM categories c, categories_description d WHERE c.categories_id=d.categories_id AND c.parent_id='0' AND d.language_id='" . (int)$languages_id ."'  ORDER BY c.sort_order";

Share this post


Link to post
Share on other sites

It worked :D

 

Thank you SOOO much for your response! I really appreciate it!

 

vicky aka barneybruce

 

Look at the query, it is taking just the language with id=1, I guess it's english

$query="SELECT * FROM categories c, categories_description d WHERE c.categories_id=d.categories_id AND c.parent_id='0' AND d.language_id='1' ORDER BY c.sort_order";

 

Try to change it to

$query="SELECT * FROM categories c, categories_description d WHERE c.categories_id=d.categories_id AND c.parent_id='0' AND d.language_id='" . (int)$languages_id ."'  ORDER BY c.sort_order";

Share this post


Link to post
Share on other sites

thumbsup.gifNew STSv4.6 is now Available!!!

 

*Once upload is approved as it is 1MB in size (due to the new sample templates provided).

 

 

Added new Template Folder drop down menu in the admin to easily select all uploaded template sets similar to how Joomla! installs templates.Added new Open Source Template Sets to provide visual examples of the STSv4.6 features and ease of use.

 

Added several new variables in sts_user_code.php.

 

BUG FIXED: The $templatedir$ tag now works properly in all scripts.

 

BUG FIXED: Corrected the code for STS Default enabled to prevent errors (includes/classes/sts.php).

 

BUG FIXED: Corrected method for error messages appearing in the header (Use of $warning_header$ tag)

 

BUG FIXED: Several lines of code modified in the boxes.php file for seamless infobox template implementation.

 

Requires the use of Stop End Characters to facilitate proper variable functions.

 

Built around the idea to separate template sets from dependability of stock osC images and stylesheets.

 

Allows plug and play functionality to easily switch between properly designed template sets. This allows third party template set designers to easily port their designs.

 

STS files are still the same for all osCommerce 2.2 versions

 

Updated all STS documents.

 

Updated Support Thread links.

 


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

thumbsup.gifNew STSv4.6 is now Available!!!

 

*Once upload is approved as it is 1MB in size (due to the new sample templates provided).

 

 

Added new Template Folder drop down menu in the admin to easily select all uploaded template sets similar to how Joomla! installs templates.Added new Open Source Template Sets to provide visual examples of the STSv4.6 features and ease of use.

 

Added several new variables in sts_user_code.php.

 

BUG FIXED: The $templatedir$ tag now works properly in all scripts.

 

BUG FIXED: Corrected the code for STS Default enabled to prevent errors (includes/classes/sts.php).

 

BUG FIXED: Corrected method for error messages appearing in the header (Use of $warning_header$ tag)

 

BUG FIXED: Several lines of code modified in the boxes.php file for seamless infobox template implementation.

 

Requires the use of Stop End Characters to facilitate proper variable functions.

 

Built around the idea to separate template sets from dependability of stock osC images and stylesheets.

 

Allows plug and play functionality to easily switch between properly designed template sets. This allows third party template set designers to easily port their designs.

 

STS files are still the same for all osCommerce 2.2 versions

 

Updated all STS documents.

 

Updated Support Thread links.

 

 

I've just installed 4.6 on a fresh osc 2.2ms2 install for testing, but I can't enable the default template module.

If i change it from "Use Templates" -> false to True it won't save my settings...

 

Is there a solution or workaround for this? or am I doing something wrong.

 

Grtz

AR

Share this post


Link to post
Share on other sites

I've just installed 4.6 on a fresh osc 2.2ms2 install for testing, but I can't enable the default template module.

If i change it from "Use Templates" -> false to True it won't save my settings...

 

Is there a solution or workaround for this? or am I doing something wrong.

 

Grtz

AR

 

 

If you are not using RC2a, then you are experiencing an old osCommerce bug. If you do have RC2a, then you did not complete the STSv4.6 installation. Use a file comparison tool such as BeYond Compare or WinMerge to compare the download package with your site files.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Template file does not exist: [includes/sts_templates/single/boxes/infobox.php.html]

 

My fresh install has that error message and none of the columns with infoboxes show up. I changed 'use template for infoboxes' to false and all seems to be in order. What is that about?

Edited by sarafina

Contributions installed: Purchase without Account / STS/ All Products/ Header Tags Controller

Share this post


Link to post
Share on other sites

Template file does not exist: [includes/sts_templates/single/boxes/infobox.php.html]

 

My fresh install has that error message and none of the columns with infoboxes show up. I changed 'use template for infoboxes' to false and all seems to be in order. What is that about?

 

Well, let's look at the error...

 

  1. Template file does not exist
    Let's assume that we are missing a template here
  2. includes/sts_templates/single/boxes/infobox.php.html
    It would appear that you are missing infobox.php.html

What is happening here is that you are not running a fresh install. If you were, you would not be requiring the infobox template. I would have to think that you configured your STS Default Module to use the Infobox Template feature along with using the "Single" template set.

 

The STS User Manual explains each template set in Chapter 10, which tells us that the "Single" template set does not use the infobox template feature so you shouldn't turn it on for that template set. If you turn on the Infobox Template feature (set it to true), then STS will look for at least a default infobox template (infobox.php.html) in a "boxes" folder, inside the current template set.

 

STS is doing exactly what it is supposed to do. thumbsup.gif

 

 

 

 


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Okay,

 

I am having an issue with STS and dynamenu when doing vertical flyouts.

 

I have FINALLY gotten these two contributions to work together with flyouts (may have been working before, cause I just noticed something).

 

Here is my problem:

The flyout menu appears in the wrong location!!! But only when I'm using a template. When not using a template, it flys out correctly.

 

The flyout is starting at the VERY BOTTOM of the page, on the far left hand side. Outside of where ANYTHING should be located.

 

Now, this only happens when using a STS template (I've tried several, all with no luck).

 

Any help or tips would be appreciated. I've used firebug to try and find the problem and it is showing that the 3 DIV ID's for the 3 primary categories (new test OSC shop) show up after the footer.

 

Please help!!

 

You can see the test store http://nalsworkshop.com/chaosorc/index.php

 

Naloomi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×