Jump to content
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

Hey everyone, I have been working on my site the last couple months and landed on OSC. I was trying to do a Drupal Site first and decided that OSC would be a better route for me right now. However, I have hit a few bumps along the way. I had previously installed a sample template from templatemonster.com for OSC and then I found STS. So I figured I could get the job done by just creating my page in HTML and dumping in the corresponding variables. Well I took some basic HTML from an OSC template for testing and dropped in the variables. This is how it comes out. http://mmsnyc.com/catalog

 

1. As you can see the pictures are not showing. How do I fix this???

 

2. I need to know what should I be doing to create the look of the other pages e.g. "what's new" "specials" etc. Would I have to edit the whatsnew.php and specials.php files to do so?

 

Also, I noticed that when you go into a product and look at the reviews button it links the the correct path, but if you check the image link it shows a gif from the osc.template-help image and the add to cart is from my images...... any info on this?

 

Any help will do. I don't want to waist my time buying a template if i'm not going to be able to get it to work. Thanks in advance!

Share this post


Link to post
Share on other sites

Okay I also posted this in general but thought I might get some assistance here as well. Thanks!!

 

Okay here's my dilemma. I have a client that wanted the STS installed so I did it. Now she suddenly wants only one portion of it changed and I'm not sure how to make it happen. Any help would be greatly appreciated!

 

First here is the gallery index

http://www.liveforar...llery/index.php

You can see the STS is keeping that entire LH column the same, as it should. However, when you click on one of the specific artists such as

http://www.liveforar...ex.php?cPath=21

my client doesn't want to see the other artists. She either wants the LH column removed or just random works by that particular artist showing there, rotating.

 

I'm not sure how to change it since it's all revolving around the index template. :)


Cristina

 

Share this post


Link to post
Share on other sites

Hi folks,

 

i've been searching to find how to add a "back button" to a product_info template page - can it be done?

 

thanks for the help,

 

barneybruce

Share this post


Link to post
Share on other sites

I posted this in the General Question and dont know how to delete that one. What I would like to know is Im using STS Contribution and have been working on the sts_template in the Test folder, Should I of been using the Index.php in the Full folder instead. If so no big deal shouldnt be to hard to make changes since I have already done most of them on the sts_template in the Test folder.

 

PS--- If someone could delete the post about this in the General section I would appericate it. Sorry for posting wrong place.

 

 

The test folder should only be used upon the initial installation just to make sure you have installed STS correctly. After that, you should use the full template folder and familarize yourself with all of the advanced STS features such as infobox templates, specific page templates for categories, products, etc.

 

thumbsup.gif Note: Both the test and the full templates folders that came with STS are merely sample template folders. Review them and then create your own template folders for special occasions such as holidays, sales, etc.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

How do I go about making a single template for all the top level categories. I believe to customize a template for a top level category 1 I would name the file index.php_1.html - but what do I name it to make all the categories use one template?

 

 

Check out the following links that will help answer your questions:

 

Important Posts for the STS newbie:

 

Post #3755: http://forums.oscomm...p;#entry1226986

 

Post #4326: http://forums.oscomm...p;#entry1303555

 

Post #4974: http://forums.oscomm...p;#entry1361366

 

Post #3772: http://forums.oscomm...p;#entry1227769

 

Post #3757: http://forums.oscomm...p;#entry1227006

 

Please review the above for insight on how the Simple Template System allows you to make templates for pages, categories, home page, products and infoboxes.

 

Hope this was helpful,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

 

bkellum you weren't replying directly to me but your post helped me out as well so thank you! HOW EASY! :)

 


Cristina

 

Share this post


Link to post
Share on other sites

I have installed the STS addon on a new oscommerce I just set up for that sole purpose and I have downloaded a couple templates to see how it works. All templates look good even the default "test" and "full" sts_templates that come with the addon. However not one of those templates are showing me something where the $content tag is placed. All the sidebars work perfectly having the $carcontent tags or whatever tag it may be. Still when I click on them it should redirect me to lets say myshop.com/catalog/shipping.php 'cause I clicked on the shipping link. But this just shows me another blank page in the middle. Why isnt it picking up the information in that .php file!?!?! Do I need to try and rewrite all the php coding in html now? I just wanted to add a nicer design, not rewrite the php coding I have finally learn to understand tongue.gif

Anyways I am pretty frustrated by now cause all I keep seeing are blank pages wherever there is a $content tag. The only process I have made is that I can now add stuff to that center of the page like tables and other stuff by just adding some html coding where the $content was in the first place.

 

Please help me out!

Thank you in advance.

 

I can provide the link to the site since its online and working, didnt do so 'cause I'm not sure if I can post links on this forum.

 

You have to have the $content tag in the template page in order to be pulling in the dynamic content.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

bkellum you weren't replying directly to me but your post helped me out as well so thank you! HOW EASY! smile.gif

 

 

 

You are most welcome.

 

biggrin.gif Everyone....don't forget to check back in a few days (after New Years Day) to download the new STSv4.6 release.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi folks,

 

i've been searching to find how to add a "back button" to a product_info template page - can it be done?

 

thanks for the help,

 

barneybruce

 

Try this:

 

Add the following line to the location you want your back button to appear in your template:

 

<A HREF="javascript:history.back()"><?php echo tep_image_button('button_back.gif', IMAGE_BUTTON_BACK); ?></a>

 

Now look for this code in your sts_user_code.php file:

<?php echo '<a href="' . tep_href_link($navigation->path[$back]['page'], tep_array_to_string($navigation->path[$back]['get'], array('action')), $navigation->path[$back]['mode']) . '">' . tep_image_button('button_continue_shopping.gif', IMAGE_BUTTON_CONTINUE_SHOPPING) . '</a>'; ?>

 

change it to:

<?php echo //'<a href="' . tep_href_link($navigation->path[$back]['page'], tep_array_to_string($navigation->path[$back]['get'], array('action')), $navigation->path[$back]['mode']) . '">' . tep_image_button('button_continue_shopping.gif', IMAGE_BUTTON_CONTINUE_SHOPPING) . '</a>'; ?>

 

and add this:

<A HREF="javascript:history.go(-2)"><?php echo tep_image_button('button_continue_shopping.gif', IMAGE_BUTTON_CONTINUE_SHOPPING); ?></a>

 

it should now look like this:

<?php echo //'<a href="' . tep_href_link($navigation->path[$back]['page'], tep_array_to_string($navigation->path[$back]['get'], array('action')), $navigation->path[$back]['mode']) . '">' . tep_image_button('button_continue_shopping.gif', IMAGE_BUTTON_CONTINUE_SHOPPING) . '</a>'; ?><A HREF="javascript:history.go(-2)"><?php echo tep_image_button('button_continue_shopping.gif', IMAGE_BUTTON_CONTINUE_SHOPPING); ?></a>

 

Just a hack but it should do the trick for you.

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Try this:

 

Now look for this code in your sts_user_code.php file:

<?php echo '<a href="' . tep_href_link($navigation->path[$back]['page'], tep_array_to_string($navigation->path[$back]['get'], array('action')), $navigation->path[$back]['mode']) . '">' . tep_image_button('button_continue_shopping.gif', IMAGE_BUTTON_CONTINUE_SHOPPING) . '</a>'; ?>

 

Hi Bkellum, thanks for your reply.

 

Sorry for sounding dumb, but I can't find this in the sts_user_code.php that's in the includes/modules/sts_inc folder. I've also tried re-downloading the contribution and checking the sts_user_code from the original file and still can't find the bit you mentioned!

 

Is there another sts_user_code.php hiding somewhere?

 

barneybruce

Share this post


Link to post
Share on other sites

Hi,

 

I'm trying to integrate the header tags SEO contribution into STS so STS shows the social bookmarks and the title in the product info pages.

 

I use a template for the product pages

 

This is what i've tried:

I added in includes/modules/sts_inc/product_info.php

if (HEADER_TAGS_DISPLAY_SOCIAL_BOOKMARKS == 'true')

include(DIR_WS_MODULES . 'header_tags_social_bookmarks.php');

$template_pinfo['header_tags_social_bookmarks']=$sts->template['header_tags_social_bookmarks'];

 

and in product_info.php.html

$header_tags_social_bookmarks$

 

Now the social bookmarks show up in the header. It doesn't matter where i place the placeholder in the template file. I didn't even came close for the title...

 

Am I doing something wrong here?

 

Kind regards

Share this post


Link to post
Share on other sites

Hi Bkellum, thanks for your reply.

 

Sorry for sounding dumb, but I can't find this in the sts_user_code.php that's in the includes/modules/sts_inc folder. I've also tried re-downloading the contribution and checking the sts_user_code from the original file and still can't find the bit you mentioned!

 

Is there another sts_user_code.php hiding somewhere?

 

barneybruce

 

 

blush.gif My fault....

 

Just try placing the following anywhere in your template and see if that does the trick (don't worry about the other edits that I suggested earlier, that was for an older version):

 

<A HREF="javascript:history.back()"><?php echo tep_image_button('button_back.gif', IMAGE_BUTTON_BACK); ?><a>

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

will this work for version 3 ?

 

 

No, STSv4.5.8 is for osC RC2a and below. Version 3 has a complicated template system built-in much like the complicated Joomla! template system.

 

thumbsup.gif STS is much easier to use since all it requires is HTML knowledge.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

ah right thanks, sorry about the triple post don't know what happened, kept getting error messages saying there had been a server error and I'm pretty sure I did not put 3 posts in. oh well.

Share this post


Link to post
Share on other sites

Sorry for triple post before :(

 

But in which php files will I be able to change the content and layout in $content. I need to find it to proceed with my template.

 

Thank you!

Share this post


Link to post
Share on other sites

blush.gif My fault....

 

Just try placing the following anywhere in your template and see if that does the trick (don't worry about the other edits that I suggested earlier, that was for an older version):

 

<A HREF="javascript:history.back()"><?php echo tep_image_button('button_back.gif', IMAGE_BUTTON_BACK); ?><a>

 

 

Thanks for the reply - STILL having problems, not sure why! I entered the the above code in as suggested and got this message when i uploaded it and looked that the page:

 

Fatal error: Call to a member function image_button() on a non-object in /home/lim/public_html/includes/functions/html_output.php on line 104

 

 

plus - i'm having real difficulity trying to get sts and seo urls 5 to work together - can you help?

 

barneybruce

Share this post


Link to post
Share on other sites

 

plus - i'm having real difficulity trying to get sts and seo urls 5 to work together - can you help?

 

 

Sorry for multiple post - couldn't find the "edit" to change the last post, and wanted to clarifiy my problem with Ultimate Seo Ulrs and STS. Am i missing an extra addon, or are they just not compatable?

 

STS isn't calling the product_info templates (and they've been put to true in admin) for products when ultimate seo urls is turned on - if i turn usu off, my product_info template works just fine.

 

I think it might be because the product pages have been renamed with usu, that sts doesn't seem to see them as productpages to call the product_info template in the first place.

 

Has anyone had similar problems, or can suggest a workround?

 

barneybruce

Share this post


Link to post
Share on other sites

I want to change the design of my cartbox and review box only? What are the names for it?

Must i copy this file in the directory: infobox_WHATNAMEHERE.php.html to edit the cartbox as example? only the cartbox?

 

And 1 more question: I wanna change this layout to 2 colums How do i do that and where? (SEE IMAGE)

layoutfromthis.png

 

P.S. I readed the DOC already. Hope for a quick response so i can go on ^^

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×