Jump to content
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

Okay, im at a loss. It shows everything as unique with nothing similar... Is there a way I could email you an FTP login for my oscommerce and you could just see for yourself and then let me know? I can delete the FTP after? :)

Arron,

 

Yes, you can do that but I would ask for a donation ($) to do that. Please PM me offline so as we do not break any solicitation rules in this forum. I don't ever solicit for business in this forum and I offfer as much free support that I can here in this thread (forum), but any help outside of that it would take away from my time to my clients.

 

Before you spend any money, just go over the STS installation text to be sure everything got installed and configured correctly in the STS Modules in the Admin. STS is one of the easiest osCommerce contributions to install and configure so give it a try. Remember, you can always ask for help here in the forum if something confuses you.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I have a piece of code of the Header Tags Seo Contribution.

 

<!--- BEGIN Header Tags SEO Social Bookmarks -->

<?php if (HEADER_TAGS_DISPLAY_SOCIAL_BOOKMARKS == 'true')

include(DIR_WS_MODULES . 'header_tags_social_bookmarks.php');

?>

<!--- END Header Tags SEO Social Bookmarks -->

 

What's the better solution to add this in the layout?

Should I just put the code in the sts_template.html?

A box in the sts_user_code? Or a placeholder?

 

Thanks!

Share this post


Link to post
Share on other sites
I have a piece of code of the Header Tags Seo Contribution.

 

 

 

What's the better solution to add this in the layout?

Should I just put the code in the sts_template.html?

A box in the sts_user_code? Or a placeholder?

 

Thanks!

 

It's really up to you. The code could go directly into your template, or directly in the index.php file just as the HTC instructions state or you could create a placeholder in the sts_user_code.php file and then put the placeholder anywhere you want in your template.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hello,

 

I installed OS commerce (mnk package) and I try to install sts template from ezOSC.com.

 

My db is called tapisdes.

 

I have the following error when I activate the template :

 

1146 - Table 'tapisdes.TABLE_MENU' doesn't exist

Select * From TABLE_MENU Order By sort_order

[TEP STOP]

 

I have the impression that this error comes from inc_navigation.php in the following line :

			$rs_menu = tep_db_query("Select * From ".TABLE_MENU." Order By sort_order");

 

Any idea how I can sort this out ?

 

Thanks !!! :mellow:

Edited by fluo

Share this post


Link to post
Share on other sites

After installing the Review Approval System, I get this code at the top of my site:

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/f/i/s/fishera/html/sonicfishconsulting/clients/tricoast/includes/filenames.php:66) in /home/content/f/i/s/fishera/html/sonicfishconsulting/clients/tricoast/includes/functions/sessions.php on line 102

 

And this code on a blank white page when I click to write a review:

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/f/i/s/fishera/html/sonicfishconsulting/clients/tricoast/includes/filenames.php:66) in /home/content/f/i/s/fishera/html/sonicfishconsulting/clients/tricoast/includes/functions/sessions.php on line 102

Warning: Cannot modify header information - headers already sent by (output started at /home/content/f/i/s/fishera/html/sonicfishconsulting/clients/tricoast/includes/filenames.php:66) in /home/content/f/i/s/fishera/html/sonicfishconsulting/clients/tricoast/includes/functions/general.php on line 33

 

The site link is: http://www.sonicfishconsulting.com/clients...coast/store.php

 

Does anyone know how to fix this? Thanks!

Share this post


Link to post
Share on other sites
Hello,

 

I installed OS commerce (mnk package) and I try to install sts template from ezOSC.com.

 

My db is called tapisdes.

 

I have the following error when I activate the template :

 

1146 - Table 'tapisdes.TABLE_MENU' doesn't exist

Select * From TABLE_MENU Order By sort_order

[TEP STOP]

 

I have the impression that this error comes from inc_navigation.php in the following line :

			$rs_menu = tep_db_query("Select * From ".TABLE_MENU." Order By sort_order");

 

Any idea how I can sort this out ?

 

Thanks !!! :mellow:

 

 

It appears you are missing a table in your database. The template from ez... will only work 100% with their shopping cart. You can fix this by opening up the SQL file that came with shopping cart and adding the table and content using a portion of the SQL file that appiles or manually add the table yourself using phpMyAdmin or remove the custom PHP page from your template that is calling for that table.

 

Keep in mind that their templates also use custom STS tags that are defined in their shopping cart sts_inc/*sts files. You will need to add these new tags to your shop as well in order to make that template work 100%. This is a difficult thing to do but you should know it is not simply "plug and play".


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Didn't work. My error quotes lines 102 where it says" return session_start();

}"

 

 

This is not an STS issue but rather what was posted in the Knowledge Base article link that I provided earlier:

 

A common cause to the problem is spaces ("whitespace") existing before the first <?php tag and/or after the last ?> tag with the files involved. By removing all spaces so that <?php is at the very start of the file and that ?> is at the very end of the file, no content would have been sent to the client and headers can be set safely.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
This is not an STS issue but rather what was posted in the Knowledge Base article link that I provided earlier:

 

ah! it was the sessions file, not the other one. darn, such a simple fix. thank you!

 

Now I have another problem. I keep getting a 500 Internal Service Error after installing Ultimate SEO URLs. Anyone got a suggestion?

 

and this when I click on the store, which I renamed to store.php from index.php so it didn't conflict with index.html which is the site homepage.

 

Fatal error: Call to a member function add_current_page() on a non-object in /home/content/f/i/s/fishera/html/sonicfishconsulting/clients/tricoast/includes/application_top.php on line 312

Edited by sonicfishconsulting

Share this post


Link to post
Share on other sites
ah! it was the sessions file, not the other one. darn, such a simple fix. thank you!

 

Now I have another problem. I keep getting a 500 Internal Service Error after installing Ultimate SEO URLs. Anyone got a suggestion?

 

and this when I click on the store, which I renamed to store.php from index.php so it didn't conflict with index.html which is the site homepage.

 

Fatal error: Call to a member function add_current_page() on a non-object in /home/content/f/i/s/fishera/html/sonicfishconsulting/clients/tricoast/includes/application_top.php on line 312

What is on line 312 of your application_top.php file?

Share this post


Link to post
Share on other sites

This is the Support Thread for the Simple Template System.

 

Please ask general support questions as well as questions not relating to STS outside of this thread.

 

It will only confuse users of STS who are looking for solutions to STS related issues if allowed to do so.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Hi,

 

I'm using STS v4.5.8 with the index module enabled and its working absolutely perfectly. However, I'm now looking to create a template for the first page of results for a specific category.

 

While obviously I can create a template named index.php_11.html for category 11, this template will then be used for each set of results pages within this category. To avoid any Google penalties for duplicate content on pages 2, 3, etc within the category, I want the template to apply only to page 1.

 

Does anybody know if this is possible? If so, how would I got about it?

 

Cheers

 

Andy

 

Hi All !

 

Does anybody have any feedback on the above? I've been playing with it, but no joy. I'm worried that Google is going to penalise me and not index some of the pages due to duplicate text content.

 

Any help is always appreciated guys !

 

Cheers

 

Andy

Share this post


Link to post
Share on other sites
Hi All !

 

Does anybody have any feedback on the above? I've been playing with it, but no joy. I'm worried that Google is going to penalise me and not index some of the pages due to duplicate text content.

 

Any help is always appreciated guys !

 

Cheers

 

Andy

 

I've never had any issues with Google regarding the dynamic content. Think about it, every page nearly has the same header, footer, side columns, etc.

 

Now, if you are wanting to do this simply for having different content for those pages is worth the effort. You could add some PHP code into your index.php_11.html template that would display something different depending upon the page results being displayed.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

I currently have TinyMCE wysiwyg installed. Does this STS work with that or is it one or the other?

 

Thanks

Share this post


Link to post
Share on other sites
I currently have TinyMCE wysiwyg installed. Does this STS work with that or is it one or the other?

 

Thanks

 

TinyMCE only makes changes to the content so both work perfectly together.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

ok so i've been using STS and haven't had many problems. I'm now trying to upload my changes from the local version and all i'm getting when i have STS installed is a blank page. It takes down my whole site. are there any configurations are different from the local to live versions? when STS is disabled, the site works fine.

Share this post


Link to post
Share on other sites
ok so i've been using STS and haven't had many problems. I'm now trying to upload my changes from the local version and all i'm getting when i have STS installed is a blank page. It takes down my whole site. are there any configurations are different from the local to live versions? when STS is disabled, the site works fine.

 

Not a lot of information to go on here but this is mostly likely due to a bad FTP transfer (it happens). Try uploading it again as some files may have been corrupted or not uploaded at all.

 

Also, uninstall/reinstall each of the STS Modules in the Admin.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Warning: main(/home/mydomain/public_html/includes/languages/english/modules/sts/sts_default.php) [function.main]: failed to open stream: No such file or directory in /home/mydomain/public_html/admin/modules.php on line 136

 

I have installed this great contribution and it seems to be working at first glance, but for some reason on the modules configuration page I'm getting a series of Warnings (as Follows):

 

Warning: main(/home/mydomain/public_html/includes/languages/english/modules/sts/sts_default.php) [function.main]: failed to open stream: No such file or directory in /home/mydomain/public_html/admin/modules.php on line 136

 

 

there is a whole page of Warnings this being the first. I've just installed this tonight so haven't had much time to work on a fix, just wondering if anyone knows a simple solution/reason why. I previously installed the contribution Option Type V2, it still appears working fine; everything else also seems fine just Warnings.

 

Thank You

Share this post


Link to post
Share on other sites

 

First, make sure you are not trying to install this on osC v3.

 

Second, make sure you do not have any of the STSv2 or STSv3 versions installed.

 

Third, make sure you have uploaded the files from either the "Files for MS2" or "Files for RC1/2" folders (or at least merged in the differences using a good file comparison tool such as Beyond Compare or WinMerge) and then Uploaded ALL of the files included in the "STS" folder.

 

Fourth, leave the default settings as they are except for setting the "Use Templates" to true. Once you are sure everything is installed correctly, then you can play around with the module settings.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Thanks,

 

I'm using osCommerce 2.2 RC2... I have tried several times installing all the STS files (STS v4.5.8_1_2) and the files in the RC2 folder as described in the installation instructions. The template system comes up, and I'm able to change the default template to alter the main page from the "test" folder. However, I still get the messages

 

Warning: main(/home/mydomain/public_html//includes/languages/english/modules/sts/sts_default.php) [function.main]: failed to open stream: No such file or directory in /home/mydomain/public_html//admin/modules.php on line 136

 

(on the admin/modules page), and I am unable to successfully enable any of the other template options besides the test default. The only other contribution I've installed is Option Type v2. The files in the RC2 folder are the ones I should merge, and leave the RC1/MS2 files out, correct?

 

I'm new to this, thanks for your assistance.

Share this post


Link to post
Share on other sites
Thanks,

 

I'm using osCommerce 2.2 RC2... I have tried several times installing all the STS files (STS v4.5.8_1_2) and the files in the RC2 folder as described in the installation instructions. The template system comes up, and I'm able to change the default template to alter the main page from the "test" folder. However, I still get the messages

 

Warning: main(/home/mydomain/public_html//includes/languages/english/modules/sts/sts_default.php) [function.main]: failed to open stream: No such file or directory in /home/mydomain/public_html//admin/modules.php on line 136

 

(on the admin/modules page), and I am unable to successfully enable any of the other template options besides the test default. The only other contribution I've installed is Option Type v2. The files in the RC2 folder are the ones I should merge, and leave the RC1/MS2 files out, correct?

 

I'm new to this, thanks for your assistance.

 

Don't forget to upload all of the files in the "STS" folder as well.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

An issue I’m having now is integrating this with STS templates and wordpress integration contribution. I made a blog.php.html file which works fine when you go to mysite.com/blog.php. If I click on any link inside the blog then it will bring me to a link that is blog.php/year/month/id for which STS template couldn’t tell belongs to blog.php and thus uses the default template. My default template already have a right column set up so it will display two right columns making things ugly. Could anyone please point me in the right direction to make STS template know that blog.php/yr/mo/id should use the blog.php.html. Thank you.

Share this post


Link to post
Share on other sites

Hello all

 

I'm new to STS and I'm trying to understand the template-part.

 

I have done a template for default (sts_template.html) and index.php (index.php.html) and product_list box (infobox_product_listing.php.html) and it seems to be working fine.

 

Now, I want to change the layout of the product list that is visible after choosing a category. I want to change the table that list the product to just show picture and product name. I don't want the header that displays productname etc. and I want to remove the "buy now" button

 

What's the best way of styling the product list? Should I use some features in STS or chould I style it directly in the OScommerce code?

 

I'm all for not changing the actual OScommerce code to mutch but instead doing as much as posible in the STS templateing.

 

Can I use the sts_user_code.php in some way?

 

any hints?

Edited by fredriksk

Share this post


Link to post
Share on other sites

Am using STS on PHP5.2 - but have issue where blank or incomplete pages are being shown.

 

I have switched off gzip_compression in admin - but to no avail.

 

Has anyone encountered / found a fix for this issue?

 

TIA.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×