Jump to content
DiamondSea

[contribution] Simple Template System (sts)

Recommended Posts

Bill, it never ceases to amaze me as to how quickly you respond. Thanks!

 

I would be interested in the Header Tags Controller contribution. Do you by chance have a link so I make sure I get the right one to use with STS4?

 

Thanks a bunch,

 

-Jim

Jim,

I suggest the April 2007 HTCv2.6.3 version by Jack.

http://www.oscommerce.com/community/contributions,207

 

I also suggest that you follow my step by step on how to get it installed onto a STS shop (see link in my signature below).

 

Hope this helped you out,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

does anyone have a full code to of a checkout so i can insert it into my checkout page as i am running a catalogue without one as i have just started my website

 

yours sincerely

 

silkykameron

 

ps. im new

Share this post


Link to post
Share on other sites
does anyone have a full code to of a checkout so i can insert it into my checkout page as i am running a catalogue without one as i have just started my website

 

yours sincerely

 

silkykameron

 

ps. im new

Simon,

Have you installed the osCommerce program onto your web site?


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
Simon,

Have you installed the osCommerce program onto your web site?

 

i dont know how to install onto my wwebsite as i asked my provider and they said i have to ask oscommerse but im not sure anyone will know how to use my provider if they are all different

 

please help

 

yours sincerely

 

silkykameron

Share this post


Link to post
Share on other sites

The main thins I am stuck on right now are trying to figure out what the real "products" page is? All I can find is the index, but it does not seem to be the best products navigator.

 

Also, I would like to get rid of the images on the left and right side of the info box and search box... I tried modifying infobox.php.html but it did not help. Any ideas? Also, is there a way I can link directly to a specific product manually? What would the best method be?

Share this post


Link to post
Share on other sites
Jim,

I suggest the April 2007 HTCv2.6.3 version by Jack.

http://www.oscommerce.com/community/contributions,207

 

I also suggest that you follow my step by step on how to get it installed onto a STS shop (see link in my signature below).

 

Hope this helped you out,

 

Bill,

 

Thanks again for the sound advice. I installed HTC as per your instructions. It was a simple install when following directions and all worked just perfect. The customization that can be achieved using your templates and the header tag controller is far superior to a stock install.

 

-Jim

Share this post


Link to post
Share on other sites

Hi Folks,

 

I have just updated my STS system to 4.5.8 (MS2) and found a strange problem.

 

There was a lot of junk being rendered at the beginning of a page, that did not happen in STS 4.2 (ish)

 

I traced it back to this routine in /includes/classes/sts.php

 

function start_capture () {

// Start redirecting output to the output buffer, if template mode on.

if ($this->display_template_output) {

// ob_end_clean(); // Clear out the capture buffer. Removed in v4.3.3

ob_start();

}

}

 

re-enabling the ob_end_clean() fixed the issue.. my question is, why did this not work properly for me? Is there another part opf the code that replaces this routine, that I may have missed in my update?

 

Thanks a lot

Pete

Edited by xmanflash

Share this post


Link to post
Share on other sites
Simon,

Have you installed the osCommerce program onto your web site?

 

i have had a look through and its all complicated for me all i need is a simple checkout code start to finish a simple copy and paste if its not possible then i understand.

 

also any updates and inserts that may be needed later once the checkout is installed will be relatively easy for me to add as its just a case of scrolling down the text then inserting or replacing text.

 

incase anybody is wondering, the way i made my website was simple copy and paste, i know nohing what-so-ever about inputting code and have done this with pictures, i can add code later if i want which is why i am asking for a simple copy and paste technique, i go to text editor and paste then save then refresh my page and its there. simple.

 

hope someone can help

 

yours sincerly

 

silkykameron

 

ps my site is www.you-desire.co.uk and its adults only

Share this post


Link to post
Share on other sites

Greetings :) I have a problem with an InfoBox image correctly appearing in IE. FF is fine.

 

I've run my stylesheet through CSS validation and that fixed one silly thing I missed but my problem persists: The image repeats to the right when the $right_arrow is called (What's New Infobox, etc.)

 

The InfoBox header has 2 TD cells (the first handles the $headertext; the second handles the $right_arrow). I'm using a TR style:

TR.infoBoxHeading {

background : url('images/header_infobox.jpg') no-repeat 0% 0%;

}

infobox.php.html template:

 

<table width="100%" border="0" cellspacing="0" cellpadding="0">
 <tr class="infoBoxHeading">
<td height="38" class="infoBoxHeading">$headertext</td>
<td>$right_arrow</td>
 </tr>
</table>
<table width="100%" border="0" cellspacing="0" cellpadding="0" class="boxBorder">
 <tr>
<td class="boxText">$content</td>
 </tr>
</table>

 

Is there another way to get this to appear cross-browser without slicing the image and dumping that slice in the second TD?

 

On the way to certain baldness, I remain

 

jon


It's all just ones and zeros....

Share this post


Link to post
Share on other sites

Is there an easy way to use XTC-Templates for STS4 ?

I think XTC is using a template enginge, too - is it very different from the STS4-System ?

 

If so - what is modify in the XTC-Templates to use them for STS4 ?

 

Would be great if it could be possible to do that... :blush:


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites
Is there an easy way to use XTC-Templates for STS4 ?

I think XTC is using a template enginge, too - is it very different from the STS4-System ?

 

If so - what is modify in the XTC-Templates to use them for STS4 ?

 

Would be great if it could be possible to do that... :blush:

I don't know much about XTC-Templates but I can offer the following advice regarding purchased templates:

 

How to integrate a purchased template to STS:

 

To make an STS template out of a purchased osCommerce template,

  1. Install the store in a test directory (meaning, follow all of the installation instructions that came with your purchased template, but be sure to do this in a test osCommerce scenario. You will use these files in your final "live" osCommerce store.
  2. Open the store in your browser
  3. View the Source Code and Save the html code to your computer
  4. Use this html code as your default template (sts_template.html) and start replacing the different elements with their corresponding STS Tags.
  5. Use the boxes class (includes/classes/boxes.php) from the template you bought
  6. Modify the external stylesheet from the purchased template to your needs (if needed)

The above should get you started in the right direction.

 

Hope this helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Yes - that`s the way i did it before to test the sts and most features of OSC were working proper.

 

another question:

Is there a way to make a tmeplate choosing popup button which gives a list of installed templates the admin/user could choose from ?

 

Right now the admin hast to change some settings in backend to change the template.... :unsure:


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites
Yes - that`s the way i did it before to test the sts and most features of OSC were working proper.

 

another question:

Is there a way to make a tmeplate choosing popup button which gives a list of installed templates the admin/user could choose from ?

 

Right now the admin hast to change some settings in backend to change the template.... :unsure:

The current method is super easy...just change the template folder name in the STS Default Module in the admin. Only one field box to be changed.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hi, i was wondering if anyone here knows if its possible to run an SSL commerce site with Simple TEmplate System. My hosting company is telling me the images are <href's and do not work with SSL. Is there a fix for this or can someone point me in the right direction. SSL is very important to my site. Thanks

Share this post


Link to post
Share on other sites
Hi, i was wondering if anyone here knows if its possible to run an SSL commerce site with Simple TEmplate System. My hosting company is telling me the images are <href's and do not work with SSL. Is there a fix for this or can someone point me in the right direction. SSL is very important to my site. Thanks

 

whos hosting? Your hosting company is giving you a line of crap.

 

I am using bluehost and i am able to use their shared ssl connection. You simply alter the configure.php files in the includes folder accordingly.

 

mine was such.... see below. (site is still being built).

 

define('HTTP_SERVER', 'http://yourdomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://secure.bluehost.com/~myusername'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'yourdomain.com');

define('HTTPS_COOKIE_DOMAIN', 'secure.bluehost.com');

 

 

worked for me, because they offered this perk.

 

hope this helps.

Share this post


Link to post
Share on other sites

Can someone assist me?

 

What will i need to do to alter my configure.php files to allow for two sts sites that share the same DB? I have point them to the same database but i am finding that not everything is working properly. one reverts to the other template at times during login or whenever i cross into the ssl connection or the product images dont want to be seen on one or the other.

 

 

here is my configure from

/includes/configure.php

 

 

btw x's have censored my username and password

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

 Copyright © 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://fishingretailsupply.com'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://secure.bluehost.com/~XXXXXX'); // eg, [url="https://localhost"]https://localhost[/url] - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'fishingretailsupply.com');
 define('HTTPS_COOKIE_DOMAIN', 'secure.bluehost.com');
 define('HTTP_COOKIE_PATH', '/shop/');
 define('HTTPS_COOKIE_PATH', '/shop/');
 define('DIR_WS_HTTP_CATALOG', '/shop/');
 define('DIR_WS_HTTPS_CATALOG', '/shop/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/home/XXXXXXX/public_html/shop/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
   define('DB_SERVER_USERNAME', 'XXXXXXX_osc1');
 define('DB_SERVER_PASSWORD', 'XXXXXXXXXX');
 define('DB_DATABASE', 'XXXXXXX_osc1');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 

Here is the code from my ADMIN/INCLUDES/CONFIG

 

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

 Copyright © 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://fishingretailsupply.com'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http://fishingretailsupply.com');
 define('HTTPS_CATALOG_SERVER', 'https://fishingretailsupply.com');
 define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/home/XXXXXX/public_html/shop/'); // where the pages are located on the server
 define('DIR_WS_ADMIN', '/shop/admin/'); // absolute path required
 define('DIR_FS_ADMIN', '/home/fishingr/public_html/shop/admin/'); // absolute pate required
 define('DIR_WS_CATALOG', '/shop/'); // absolute path required
 define('DIR_FS_CATALOG', '/home/XXXXXX/public_html/shop/'); // absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'XXXXXX_osc1');
 define('DB_SERVER_PASSWORD', 'XXXXXXX);
 define('DB_DATABASE', 'XXXXXX_osc1');
 define('USE_PCONNECT', 'false'); // use persisstent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 

 

 

Any help on this would really be awesome thanks guys!

Share this post


Link to post
Share on other sites

Does anybody know how to change the front page of osc with stsv458 currently looks like this

 

 

 

What's New Here?

Welcome Guest! Would you like to log yourself in? Or would you prefer to create an account?

This is a default setup of osCommerce Online Merchant. Products shown are for demonstrational purposes. Any products purchased will not be delivered nor will the customer be billed. Any information seen on these products is to be treated as fictional.

 

Error Messages

 

If there are any error or warning messages shown above, please correct them first before proceeding.

 

Error messages are displayed at the very top of the page with a complete background color.

 

Several checks are performed to ensure a healthy setup of your online store - these checks can be disabled by editing the appropriate parameters at the bottom of the includes/application_top.php file.

Editing Page Texts

 

The text shown here can be modified in the following file, on each language basis:

 

[path to catalog]/includes/languages/english/index.php

 

That file can be edited manually, or via the Administration Tool with the Languages->English->Define or Tools->File Manager modules.

 

The text is set in the following manner:

 

define('TEXT_MAIN', 'This is a default setup of the osCommerce project...');

 

The text highlighted in green may be modified - it is important to keep the define() of the TEXT_MAIN keyword. To remove the text for TEXT_MAIN completely, the following example is used where only two single quote characters exist:

 

define('TEXT_MAIN', '');

 

More information concerning the PHP define() function can be read here.

Online Documentation

 

Online documentation can be read at the osCommerce Knowledge Base site.

 

Support is available at the osCommerce Support Site.

 

If you wish to download the solution powering this shop, or if you wish to contribute to the osCommerce project, please visit the support site of osCommerce. This shop is running on osCommerce Online Merchant v2.2 RC2.

 

 

I thought this would disappear when I installed the stsv458? as I am a non coder this can be very confusing? any help would be greatly appreciated.

Neil

Edited by sharkcart

Share this post


Link to post
Share on other sites
Does anybody know how to change the front page of osc with stsv458 currently looks like this

What's New Here?

Welcome Guest! Would you like to log yourself in? Or would you prefer to create an account?

This is a default setup of osCommerce Online Merchant. Products shown are for demonstrational purposes. Any products purchased will not be delivered nor will the customer be billed. Any information seen on these products is to be treated as fictional.

 

Error Messages

 

If there are any error or warning messages shown above, please correct them first before proceeding.

 

Error messages are displayed at the very top of the page with a complete background color.

 

Several checks are performed to ensure a healthy setup of your online store - these checks can be disabled by editing the appropriate parameters at the bottom of the includes/application_top.php file.

Editing Page Texts

 

The text shown here can be modified in the following file, on each language basis:

 

[path to catalog]/includes/languages/english/index.php

 

That file can be edited manually, or via the Administration Tool with the Languages->English->Define or Tools->File Manager modules.

 

The text is set in the following manner:

 

define('TEXT_MAIN', 'This is a default setup of the osCommerce project...');

 

The text highlighted in green may be modified - it is important to keep the define() of the TEXT_MAIN keyword. To remove the text for TEXT_MAIN completely, the following example is used where only two single quote characters exist:

 

define('TEXT_MAIN', '');

 

More information concerning the PHP define() function can be read here.

Online Documentation

 

Online documentation can be read at the osCommerce Knowledge Base site.

 

Support is available at the osCommerce Support Site.

 

If you wish to download the solution powering this shop, or if you wish to contribute to the osCommerce project, please visit the support site of osCommerce. This shop is running on osCommerce Online Merchant v2.2 RC2.

I thought this would disappear when I installed the stsv458? as I am a non coder this can be very confusing? any help would be greatly appreciated.

Neil

 

 

 

READ THE LINES MORE CAREFULLY. IT will tell you how to fix the problem.

 

"includes/languages/english/index.php" :)

 

 

Edit ----- define('TEXT_MAIN', 'whatever you want to say HERE AND BE SURE TO LEAVE THE QUOTES');

 

hope this helps.

Edited by evan wagner

Share this post


Link to post
Share on other sites
Hi, i was wondering if anyone here knows if its possible to run an SSL commerce site with Simple TEmplate System. My hosting company is telling me the images are <href's and do not work with SSL. Is there a fix for this or can someone point me in the right direction. SSL is very important to my site. Thanks

 

STS doesn't care whether or not you use SSL. It is the way you have linked your images and/or stylesheet within your template. You should be using relative links and not absolute links.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
READ THE LINES MORE CAREFULLY. IT will tell you how to fix the problem.

 

"includes/languages/english/index.php" :)

Edit ----- define('TEXT_MAIN', 'whatever you want to say HERE AND BE SURE TO LEAVE THE QUOTES');

 

hope this helps.

 

Sorry I didn't read clearly I am new to all this, I could look at code all day long and not see clearly, so if I leave this code only on the page it will be blank,

 

"includes/languages/english/index.php"

Edit ----- define('TEXT_MAIN', '');

 

regards

Neil :thumbsup:

Edited by sharkcart

Share this post


Link to post
Share on other sites

Can you edit this file index.php onsite or do I have to download it to my computer edit then upload to to osc.

Edited by sharkcart

Share this post


Link to post
Share on other sites
Can you edit this file index.php onsite or do I have to download it to my computer edit then upload to to osc.

 

I recommend downloading a php editor.. This one is free and you will probably need it later on too.

 

http://www.phpeditor.kit.net/

 

 

Download it and edit that line, save it then upload it back up to the correct folder. Only modify that line though,

 

define('TEXT_MAIN', 'whatever you want to say HERE AND BE SURE TO LEAVE THE QUOTES');

 

if you want it blank... CODE IT LIKE THIS - define('TEXT_MAIN', '');

 

 

GOOD LUCK.

Share this post


Link to post
Share on other sites
I recommend downloading a php editor.. This one is free and you will probably need it later on too.

 

http://www.phpeditor.kit.net/

Download it and edit that line, save it then upload it back up to the correct folder. Only modify that line though,

 

define('TEXT_MAIN', 'whatever you want to say HERE AND BE SURE TO LEAVE THE QUOTES');

 

if you want it blank... CODE IT LIKE THIS - define('TEXT_MAIN', '');

GOOD LUCK.

 

Thanks very much

Neil

Share this post


Link to post
Share on other sites

PROBLEM:

I´m hardly trying to get my layout working....tested around but could not find what is wrong here:

 

1.) This is my section where I call "$categorybox" in the sts_template.html:

<!-- categories //-->

<tbody><tr>

<td>

<table class="box_header_txt bg5" border="0" cellpadding="0" cellspacing="0" width="100%">

<tbody><tr>

$categorybox

</td>

</tr>

<!-- categories_eof //-->

 

2.) This is my /boxes/infobox_categories.php.html:

<td>$headertext</td>

</tr>

</tbody></table>

<table border="0" cellpadding="0" cellspacing="0" width="100%">

<tbody><tr>

<td><table style="margin-bottom: 5px;" class="box_body bg5" border="0" cellpadding="0" cellspacing="0" width="100%">

<tbody><tr>

<td style="padding: 0px 16px 14px;"><ul><li class="bg_list">$content</li></ul></td>

</tr>

</tbody></table>

</td>

</tr>

</tbody></table>

 

But it dosen`t work....

 

When I take a look into site code output than I can see:

 

<!-- categories //-->

 

<tbody><tr>

<td>

<table class="box_header_txt bg5" border="0" cellpadding="0" cellspacing="0" width="100%">

<tbody><tr>

 

<!-- start categorybox //-->

<table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td width="100%" class="infoBoxHeading">Kategorien</td>

</tr>

 

</table>

</td>

</tr>

</tbody></table>

<table border="0" cellpadding="0" cellspacing="0" width="100%">

<tbody><tr>

<td><table style="margin-bottom: 5px;" class="box_body bg5" border="0" cellpadding="0" cellspacing="0" width="100%">

<tbody><tr>

<td style="padding: 0px 16px 14px;"><ul><li class="bg_list"><table border="0" width="100%" cellspacing="0" cellpadding="3" class="infoBoxContents">

<tr>

<td><img src="images/pixel_trans.gif" border="0" alt="" width="100%" height="1"></td>

 

</tr>

<tr>

<td class="boxText"><a href="http://www.mysite.dede/shop-2/catalog/index.php?cPath=25&osCsid=89f0e9468bf2a59b4dd613718b3f83b5">Testkategorie-></a> (3)<br><a href="http://www.mysite.de/shop-2/catalog/index.php?cPath=1&osCsid=89f0e9468bf2a59b4dd613718b3f83b5">Hardware-></a> (8)<br><a href="http://www.mysite.de/shop-2/catalog/index.php?cPath=3&osCsid=89f0e9468bf2a59b4dd613718b3f83b5">DVD Filme-></a> (17)<br><a href="http://www.mysite.de/shop-2/catalog/index.php?cPath=21&osCsid=89f0e9468bf2a59b4dd613718b3f83b5">Sample Options-></a> (20)<br></td>

</tr>

<tr>

 

<td><img src="images/pixel_trans.gif" border="0" alt="" width="100%" height="1"></td>

</tr>

</table>

</li></ul></td>

</tr>

</tbody></table>

</td>

</tr>

</tbody></table>

<!-- end categorybox //-->

 

</td>

 

</tr>

<!-- categories_eof //-->

 

Take a look at the bold marked code - where does that code come from and how can i replace it ? I think it`s coming from my system boxes ?

 

 

The Category box should look like this code (that is working, but hard coded):

<!-- categories //-->

<tbody><tr>

<td>

<table class="box_header_txt bg5" border="0" cellpadding="0" cellspacing="0" width="100%">

<tbody><tr>

<td>Kategorien</td>

</tr>

</tbody></table>

<table border="0" cellpadding="0" cellspacing="0" width="100%">

<tbody><tr>

<td><table style="margin-bottom: 5px;" class="box_body bg5" border="0" cellpadding="0" cellspacing="0" width="100%">

<tbody><tr>

<td style="padding: 0px 16px 14px;"><ul><li class="bg_list"><a

href="http://mysite.de/index.php?cPath=1">Test</a></li><li class="bg_list"><a

href="http://mysite.de/index.php?cPath=3">Test</a></li><li class="bg_list"><a

href="http://mysite.de/index.php?cPath=4">Test</a></li><li class="bg_list"><a

href="http://mysite.de/index.php?cPath=5">Test</a></li><li class="bg_list"><a

href="http://mysite.de/index.php?cPath=6">Test</a></li><li class="bg_list"><a

href="http://mysite.de/index.php?cPath=7">Test</a></li><li class="bg_list"><a

href="http://mysite.de/index.php?cPath=8">Test</a></li></ul></td>

</tr>

</tbody></table>

</td>

</tr>

</tbody></table>

</td>

</tr>

<!-- categories_eof //-->


OSC Webmakers Edition modiefied with many other contribs and enhancements.

+ STS 4.5.7 for 2.2MS2 and RC1

Share this post


Link to post
Share on other sites
PROBLEM:

I´m hardly trying to get my layout working....tested around but could not find what is wrong here:

 

1.) This is my section where I call "$categorybox" in the sts_template.html:

2.) This is my /boxes/infobox_categories.php.html:

But it dosen`t work....

 

When I take a look into site code output than I can see:

Take a look at the bold marked code - where does that code come from and how can i replace it ? I think it`s coming from my system boxes ?

The Category box should look like this code (that is working, but hard coded):

 

Hey Runweb, that's the EXACT same question I asked here http://forums.oscommerce.com/index.php?sho...81&st=3440# last week, am still waiting for a coherant answer ...

 

Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×