Jump to content
Sign in to follow this  
Farrukh

[Contribution] All Products v3.0 MS 2.2 with Images

Recommended Posts

That message means you are missing the class splitepageresults. Look in the includes/classes directory to ensure it is there.

 

Jack

Share this post


Link to post
Share on other sites

my allprods script works fine... does enyone know how to display category name into allprods.php???

i've found few peoples looking for it and it seems no one had no idea... i guess some changes has to be in query and array but don't know what exactly to do...

 

any help will be appreciate, bye

Share this post


Link to post
Share on other sites
my allprods script works fine... does enyone know how to display category name into allprods.php???

i've found few peoples looking for it and it seems no one had no idea... i guess some changes has to be in query and array but don't know what exactly to do...

 

any help will be appreciate, bye

 

so???

nobody got idea to put category name into all prods??? it'll be really great if someone could explain it...

Share this post


Link to post
Share on other sites

Categories are displayed with the sitemap contribution and don't really belong in this one (although it wouldn't hurt). The database queries would have to be added along with the code to display them.

 

Jack

Share this post


Link to post
Share on other sites
Categories are displayed with the sitemap contribution and don't really belong in this one (although it wouldn't hurt). The database queries would have to be added along with the code to display them.

 

Jack

 

hm it is really strange that whole source does not support displaying the categories name together with product name... i need it in the new products modules, all product modules, and advanced search result modules and still didn't find any solution for my needs...

any help would be appreciate

Share this post


Link to post
Share on other sites

There is another Al Products contribution that, while not optimized for the SE's last I looked, does provide a categories listing (I think). You could try it.

 

Jack

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Very nice contrib!! However, I am experiencing some dificulty. When I choose to use the alternative table view(with multiple columns) I loose the correct price. Everything in my shop says $6.50 even items priced over $100.00.

 

This is not the case when your code calls product_listing.php. I think it may have to do with a multiple price contrib I have installed. If this is the case, what might I look for to change in allpods.php.

 

Also I would like to display all products on the same page... I don't know if I will like it but I'd like to see how it will look. What can I do to see this and not affect the rest of my store?

 

Thank You!


James Tomasello

Share this post


Link to post
Share on other sites

The contribution uses the allprods.php and product_listing.php files in includes/modules/ to display the products, depending upon which option you choose. You might have made changes to the product_listing.php file with the contribution you installed since that is a standard oscommerce file. You will need to make simialr changes to the allprods.file. The code is very similar between the two so you should be able to figure out where the changes go. To display all products would require quite a few changes to the code. You could go back a few versions since it used to display them all on one page. If you have a large amount of products, the page will time out before it loads, unless you disable images, thus the change.

 

Jack

Share this post


Link to post
Share on other sites

I have a problem

 

I got the contrib installed and the link in the catagories box for allprods.php only the index.php shows the other link works for the specials.php what do I need to do to fix this.

 

Thanks for any help in advance


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites

NM I gues i should learn to read it works fine now I forgot to install it in the admin section Im a dummy


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites
I enabled this All Products feature via the admin panel

 

i cant find a place in the admin for the All Prodcuts, also, when i click on the all products links in the category box, it takes me to the index page, and when i type the url to the all products page, it still directs me back to the admin page

 

thoughts?

Share this post


Link to post
Share on other sites

Excellent Contribution, just what I needed for the shop.

 

The feature (as described below) would be very useful to me also, as we only stock unique items with no repeats so when 1 is sold we would like them not to appear in the listings.

 

This works now in the standard OSC categories but these 'SOLD' items are still appearing in your contrib so this would be great.

 

We are manually removing them from the database at the moment.

 

You and your kind are the Knights of the OSC scripting world to the rest of us code-ignorant users,

i sincerely hope you keep churning out the good work.

 

Kudos

 

Bonibag

 

 

That's the out of stock indicator on a standard shop. I'll put it on the lsit of things to look into for the next version. Thanks for mentioning it.

 

Jack

Edited by Bonibag

Share this post


Link to post
Share on other sites

This has been changed in the next version but I'm still working on other changes/fixes so it won't be uploaded for a while. In the meantime, to fix it, in the allprods.php file, change this

  $where="where pd.products_name like '$firstletter%'";
}else {
 $where="where pd.products_name like '$firstletter%'";

to this

  $where="where pd.products_name like '$firstletter%' and p.products_status = '1'";
}else {
 $where="where pd.products_name like '$firstletter%' and p.products_status = '1'";

 

Jack

Edited by Jack_mcs

Share this post


Link to post
Share on other sites

Sweet As!

 

Many thanks for this,

 

Bonibag

 

This has been changed in the next version but I'm still working on other changes/fixes so it won't be uploaded for a while. In the meantime, to fix it, in the allprods.php file, change this
  $where="where pd.products_name like '$firstletter%'";
}else {
 $where="where pd.products_name like '$firstletter%'";

to this

  $where="where pd.products_name like '$firstletter%' and p.products_status = '1'";
}else {
 $where="where pd.products_name like '$firstletter%' and p.products_status = '1'";

 

Jack

Share this post


Link to post
Share on other sites

All products and Multi-stores.

I have nearly got it to work. I can get All products to list from the 'enabled' products or categories in main (current) store and not from other store. HOWEVER, the problem is that the A-Z is not working.

 

This is the original sql in all_prods.php

$listing_sql = "select p.products_id, p.products_model, pd.products_name, pd.products_description, p.products_image, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, p.products_date_added, m.manufacturers_name from " . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id  $where order by pd.products_name";

 

I changed it to this for multi-stores:

 

$listing_sql = "select p.products_id, p.products_model, pd.products_name, pd.products_description, p.products_image, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, p.products_date_added, m.manufacturers_name from " . TABLE_PRODUCTS . " p left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id left join " . TABLE_PRODUCTS_DESCRIPTION . " pd on p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id and s.stores_id = '" . STORES_ID . "',  " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c, " . TABLE_CATEGORIES . " c INNER JOIN " . TABLE_PRODUCTS_TO_STORES . " p2s ON p.products_id = p2s.products_id where p2s.stores_id = '" . STORES_ID . "' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id order by pd.products_name";

 

Thats all i changed. Now when i call the all_prod.php page, it lists ONLY the products on the store I am on.

BUT the A-Z does not work.

 

ANy help would be appreciated.

 

Many thanks.

Share this post


Link to post
Share on other sites

Hi

i have installed allprods 4.4

 

no errors but the link tho allprods shows the index page instead of the all products page

 

any ideas?

Share this post


Link to post
Share on other sites

i also use the ultimate seo url. is there some thing need to be changed in the chtaccess?

 

when i click the link to all rpoducts it goes first to domain/allprods.php then it get redirected to domain/index

 

my store is in the root

 

please help i am stuck :(

Share this post


Link to post
Share on other sites

gone thrue all the support thread found same problem but i dont have anything in my admin > configuration> to enable the all products.

 

 

anyone ?

Share this post


Link to post
Share on other sites

Did you upload the sql file? If so, you need to look in your database to see why the options are not showing up.

 

Jack

Share this post


Link to post
Share on other sites
Did you upload the sql file? If so, you need to look in your database to see why the options are not showing up.

 

Jack

 

 

yes i did. i use the sql from this version(4.4) and it was my first install of this contribution

Share this post


Link to post
Share on other sites

i hade doeble entrief for all of the configuration table but for some reason the one statemant for the configuration_group didnt work. i just added it and it seems ok

 

Thanks

Share this post


Link to post
Share on other sites

Hi

 

Nice contrib ;)

 

I just installed 4.4 and I get this above the site

 

Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/osc/includes/filenames.php:120) in /home/public_html/osc/includes/functions/general.php on line 1227

 

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/public_html/osc/includes/filenames.php:120) in /home/public_html/osc/includes/functions/sessions.php on line 67

 

I looked on the forum and couldnt find any reference to this

 

Any help would be great

 

Thanks

 

W

Share this post


Link to post
Share on other sites

It's a common problem with php. See here. The problem is in your filenames.php file.

 

Jack

Share this post


Link to post
Share on other sites
It's a common problem with php. See here. The problem is in your filenames.php file.

 

Jack

 

Thanks for your reply Jack... I spent another few hours on this last night and actually found the same link in the knowledgebase... Just saw your post this morning...

 

Thanks for being so diligent.. Problem does seem to be fixed on removing whitespace from the end of filenames.php

 

Btw.. The online manual references all products 2.8 which i installed first and foud it didnt do images. Maybe you should let the docs guys know that they need to update the html version...

 

 

Finally a small question

 

If i dont have an a-z catolog of products is there a way to change the a-z list so it doesnt show or only shows category names instead of the alphabet? A large almost empty a-z list looks a bit strange on my site

 

 

Thanks again

 

W

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×