Jump to content
Sign in to follow this  
Farrukh

[Contribution] All Products v3.0 MS 2.2 with Images

Recommended Posts

Changes made to display :

 

* Compatible with Milestone MS 2.2

* Displaying Images for every product

* Addded the ability to change the Image width and height from the Admin Section ( Admin => Configuration => Images => All Products * )

* Display Manufacturer's Name

* Displays Both Retail and Discount Price

* Implemented it with Header Tags Controller ( You need to have Header tags Controller installed for this)

* Ability to Turn On or Off through Admin

Share this post


Link to post
Share on other sites

farruck thanks for ur work ..

 

1.but i dont understand is why u didnt posted it after the last version , why make a new contibution page ?

 

2.why do u write compatible with ms2 , while it is WRITTEN for ms2 , cos incompatible for ms1

 

3.and finally why make a new thread for this version

 

for everybody all those "new" pages are confusing , and also all the people from the previuous MAIN post are not receving your information

 

this forum would be more simplier if u follow those rules .. or advices :idea:


MS2

Share this post


Link to post
Share on other sites

maybe u wanted to make a new page and new thread cos u implemented images and u mean it s a very different contribution that need a new post ... i dont think so, this all prod should permit to define what information we wanna show in it , maybe with a configutation in the php file or better in the admin part ... then it ll be a must have contribution that should be in the snapshot !


MS2

Share this post


Link to post
Share on other sites

I get the following error after installing it and using the sql files as described in the install file...

 

  

HEAD_DESC_TAG_ALLPRODS  





Product Image Product Name Manufacturer Price   

1054 - Unknown column 'c.categories_status' in 'where clause'



select s.specials_new_products_price, p.products_id, p.products_model, pd.products_name, p.products_image, p.products_price, p.products_tax_class_id, p.products_date_added, m.manufacturers_name from products p , categories c, products_to_categories p2c left join manufacturers m on p.manufacturers_id = m.manufacturers_id left join products_description pd on p.products_id = pd.products_id and pd.language_id = '1' left join specials s on p.products_id = s.products_id where c.categories_status=1 and p.products_id = p2c.products_id and c.categories_id = p2c.categories_id and products_status = '1' order by pd.products_name



[TEP STOP]

Share this post


Link to post
Share on other sites

Also I cannot change the image width/height. The only options in the admin are

allprods = true / false

and where the allprods.php file is located.

Share this post


Link to post
Share on other sites

I forgot to remove the c.categories_status field from the sql query command as I am also using Enable and Disable Category Mod.

 

I have updated the mod. You can download it again.

 

In order to change the image width/height, you will have to go to

 

Admin => Configuration => Images => All Products Wieght etc.

Share this post


Link to post
Share on other sites

sorted that one, there is a cellspacing and adding of 3 which i made 0.

 

Now it all looks ok execpt the bar across the top with the heading in it doesnt stretch all the way....try to fix now..

Share this post


Link to post
Share on other sites

Hi Farrukh, I installed your contribution and I enabled this All Products feature via the admin panel. The page shows beautifully with the product images but I foudn that if the product name contain the ' sign (for example, if the prodcut name is

 

A Bug's Life

 

then the links under these colums do not work (when I click on the links under tghese colums, it shows a page that says "Product not found!" although the product is available for sale) :

 

Product Name

Model

Manufacturer

Price

 

In other words, only the links under the product image column works. For example, if the URL of the the product under the product image column is

 

http://www.store.com/catalog/product_info....e/products_id/8

 

the URL of the product in these columns:

 

Product Name

Model

Manufacturer

Price

 

would get chopped off and show as

 

http://www.store.com/catalog/product_info....tore_Name/A_Bug

 

May I ask how I can fix the problem?

 

On a different note, may I ask what's the purpose of replacing the specials.php and whats_new.php under the boxes directory?

 

Thanks very much!


Best regards,

 

Elmo

Share this post


Link to post
Share on other sites

To fix your problem you can follow my instructions here.

 

To help simplify this for your site follow these instructions.

 

In allprods.php find this:

$this_url = tep_href_link(FILENAME_PRODUCT_INFO,  'store=' . str_replace(" ", "_", $this_name) . '&products_id=' . $this_id . (($this_language_code == DEFAULT_LANGUAGE) ? '' : ('&language=' . $this_language_code)), 'NONSSL', false);

 

Replace it with this:

$search_name  = array (" ", "'");

$replace_name = array ("_", "");

$this_url = tep_href_link(FILENAME_PRODUCT_INFO,  'store=' . str_replace($search_name, $replace_name, $this_name) . '&products_id=' . $this_id . (($this_language_code == DEFAULT_LANGUAGE) ? '' : ('&language=' . $this_language_code)), 'NONSSL', false);

 

Is what this will do is delete the ' in your product title, allowing the rest of it to show properly. So it would say "A Bugs Life" instead of "A Bug's Life" in the URL. This worked with version 2 and should work with 3 unless there has been some major code changes to allprods.php. If this is the case let me know and I will look at the file.

 

Hope it helps.


Lee

 

"Pleasure in the job puts perfection in the work" -- Aristotle

Share this post


Link to post
Share on other sites

HI, I have installed this contribution but need the prices to show the TAX as well as the price.

 

Can any one help me with this one?

 

 

Thank you

Angie

Share this post


Link to post
Share on other sites

In the readme instructions, it states in instruction 4

4. Add this hidden link to where ever you like it i placed it in the catalog/includes/Header.php but you can also place it in footer or whereecer you want too :-)
but there is no link given

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P


Support The Project
Documentation/Knowledgebase/Discussions
 

Share this post


Link to post
Share on other sites

I just installed this contribution and it is great!

 

I do have a slight problem tho.

 

When I set the image size using admin-->images

and click on update, it turns off the contribution.

 

I then have to go in thru admin-->all products and turn it back on.

 

Any idea how I messed this up?

 

Thanks in advance.

 

Wendy

Share this post


Link to post
Share on other sites

Is there a way display the allprods.php with 3 products per line instead of the row they are in now?

Other than this I am enjoying this contrib thanks


Thanks in advance for your help!

Stephen

Share this post


Link to post
Share on other sites
Is there a way display the allprods.php with 3 products per line instead of the row they are in now?

 

Well i dunno if there is a proper way to do this but I made mine so that it shows your products in two columns.

The way I did it was to basically duplicate parts of allprods.php.

 

Like so for the headings:

    <tr class="productListing-heading">
    <td align="left" class="productListing-heading">Product Image</td> 
    <td align="left" class="productListing-heading">Product Name</td>         
    <td align="left" class="productListing-heading">Price  </td> 
    <td align="left" class="productListing-heading">Product Image</td> 
    <td align="left" class="productListing-heading">Product Name</td>         
    <td align="left" class="productListing-heading">Price  </td> 
  </tr>

 

And then i did a few modifications to the FOR statement i changed the increment to $1+=2

 

I duplicated the data like so... for all the variables in that section

 

$this_id = $products_array[$i]['id']; 
$this_id2 = $products_array[$i+1]['id'];

 

And finally i copied the following

 

echo "<tr $row_col>";
.......
..to..
.......
{ 
 echo "<td class='productListing-data' align='left'><a href='$this_url'>".$currencies->display_price($this_price, tep_get_tax_rate($this_tax))."</a></td>"; 
}

 

I then created an if ($this_id2) {} and pasted inside the braces.

 

And then after pasting this i went through and changed all the variables eg. $this_id to $this_id2.

 

Now you may think this is really complicated and messy... and youd be right... but it gets the job done until someone makes it easier :P

Share this post


Link to post
Share on other sites

can someone post a link showing what this contribution does to the product page....sounds interesting.....but I am a visual person....need to see it

Share this post


Link to post
Share on other sites

I notice that there hasn't been any input to this thread in about 6 weeks, but I will post here anyway, with the hope of getting a timely response.

 

This mod states that the Header Tag Controller contrib should be installed for this mod to work properly, as stated in the readme. I've done that.

 

There are files included with this mod that I assume are to be compared to, or to replace the ones installed by the Header Tags Controller mod. However, when doing a file compare, the file included with this mod, is older (as indicated by the comment lines) than the files installed by Header Tags Controller. Version 3.0 in this mod, verses Version 3.2 in the Header Tags Controller mod. Specifically, the file named "header_tags.php" in catalog/includes. There may be others as I haven't checked them yet.

 

My question is this: Which version of this file (and the others, if any) should be used for replacement, or what code should be kept if doing a compare?

 

A quick response would be greatly appreciated, as I cannot go any further with a live shop until this is addressed.

 

Thank you, Stewart

Share this post


Link to post
Share on other sites
The url's generated by the AllProds contribution have:

 

Your_Store_Name="some product name"

 

Why is that there?

 

Hi, I see this is an old thread but hopefully someone will still reply?

 

I have 2 problems:

 

1-I also see Your_Store_Name=''some product name''

 

2- All prods just turns itself OFF (false) in admin without any reason.

 

Any answer to one of these will be greatly appreciated!

 

Best regards,

Yandus

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×