Jump to content
Sign in to follow this  
Guest

Option Type Feature v1.6 (for osc 2.2 MS2)

Recommended Posts

I installed Product Attributes - Option Type Feature on my site too. But I find that if my text option message is around 100 words it does not wrap around in the checkout_confirmation.php display - it does wrap around in the shopping cart display but throughs my tables out of alignment in the checkout_confirmation.php

 

Has anyone encountered this problem? Any ideas on how to fix it?

 

Thanks

 

Mohan

Share this post


Link to post
Share on other sites

Please could somone help me:-)

 

Great feature but i need to have radio buttons listed in 2-3 columns rather than just 1. Any ideas where i can go to fix this?

 

thanks mes

Share this post


Link to post
Share on other sites
Guest

i installed your contribution to a fresh install of ms2.2 and none of the textboxes show up when the attribute is added to the product.

 

What is wrong?

Share this post


Link to post
Share on other sites
Guest
If the customer is not logged in or signed up yet, they complete the order form and then prompted to log in or sign up, ok, when they are returned and complete the order process the text values have disappeared from order confirmation and email notifications, however if they are signed up or logged in before they start the order process everything works just dandy,

I think I have seen a fix for something similar with the refreshing of forms and dropdown data in country / state / zones or something like that where the session was being dropped between refresh, Does anyone know what the fix was I cannot find it now, and or does anyone have a little hack I could use, the site is ms2 and does have sts installed.

does anyone else have this problem? I am nearly there but not quite.

I appreciate your help.

Regards

Ian

 

I am having the same problem described here. Does anyone have a fix?

 

Thanks,

Ed

Share this post


Link to post
Share on other sites
Guest

All,

 

I fixed it myself. In case anyone else has the same problem, I apparently left out one of the code changes in catalog/includes/classes/shopping_cart.php. :blush: Made the mod based on the instructions and the problem was fixed. B)

 

ed

Edited by medvid

Share this post


Link to post
Share on other sites

I've read the entire thread and still can't find a fix for the problem of only receiving the workd TEXT at the end of the checkout.

 

Im running OSCMAX

 

Ive read the paypal fix posted by webpixie and I do not have any of those lines in my paypal.php file.

 

But the problem goes deeper then just paypal, it does not forward me the info for any payment modules. Paypal or Checks/Money Orders.

 

I see numerous people have posted "nevermind I fixed it" but havent posted what or where to fix. Any suggestions would be greatly appreciated.

Share this post


Link to post
Share on other sites
Guest

Bret,

 

Sorry. I don't know. Have you tried sending a message directly to the "I fixed it" people?

 

Good luck,

Ed

Share this post


Link to post
Share on other sites

Somethings weird I know its not a setup issue but an issue within the coding itself somewhere. I setup a test account on the AAbox.com website I beleive these are the people who put together the osCMax version and even their site does the same thing. either looses the Text input inf completely or lists it as TEXT when it comes through.

Share this post


Link to post
Share on other sites

Does anyone know of an installation guide for this contribution? I have a b2bsuite site and using beyondcompare yields ungodly results. I'm looking for a normal install guide for this contrib. with ordinary instructions, like

 

FIND:

 

cooooooooodeeeeeeeeeeee;

 

 

REPLACE WITH:

 

neeeeeeeeewcoooooooodeeeeeeeeeee;

 

 

 

Does such a guide exist?

Share this post


Link to post
Share on other sites
Does anyone know of an installation guide for this contribution?  I have a b2bsuite site and using beyondcompare yields ungodly results.  I'm looking for a normal install guide for this contrib. with ordinary instructions, like

 

FIND:

 

cooooooooodeeeeeeeeeeee;

REPLACE WITH:

 

neeeeeeeeewcoooooooodeeeeeeeeeee;

Does such a guide exist?

 

Well I thought I had everything under control with this contribution until I recieved my first paypal payment. I only tested using money orders/checks as payments. using MO/Checks the orders work perfectly. However using paypal all i get is the Word TEXT for any text box inputs. the radio and check box functions work properly with paypal though so im confussed. I have used beyond compare to compare all of the files and nothing is out of place. does anyone have any siggestions??

Share this post


Link to post
Share on other sites

Are you using any typr of PayPal IPN contribution or the stock PayPal payment module?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
Are you using any typr of PayPal IPN contribution or the stock PayPal payment module?

 

I'm using the paypal module that came with osCMax v. 1.7 which does have IPN

 

$Id: paypal.php,v 1.1.1.1 2005/01/15 06:43:55 Michael Sasek Exp $

modified by gregbaboolal@yahoo.com 2003/12/31

 

That is whats written accross the top.

Share this post


Link to post
Share on other sites
I'm using the paypal module that came with osCMax v. 1.7 which does have IPN

 

$Id: paypal.php,v 1.1.1.1 2005/01/15 06:43:55 Michael Sasek Exp $

  modified by gregbaboolal@yahoo.com 2003/12/31

 

That is whats written accross the top.

 

I'm not sure if this helps to diagnose anything but I just completed a test payment through paypal. the transaction goes as it should I click the final PAY button on paypals site, and then it says you are being redirected to my site. When I am redirected I am redirected back to the payment choice screen.

Share this post


Link to post
Share on other sites
I'm not sure if this helps to diagnose anything but I just completed a test payment through paypal. the transaction goes as it should I click the final PAY button on paypals site, and then it says you are being redirected to my site. When I am redirected I am redirected back to the payment choice screen.

 

took a little while to get to me but I also recieved an e-mail with the following subject line RallyGrafix PayPal IPN: Unknown Verfication

 

and this in the body

 

Connection Type

------------------------------------------------------

curl= 1, socket= , domain= www.paypal.com, port=

 

PayPal Response

Share this post


Link to post
Share on other sites
took a little while to get to me but I also recieved an e-mail with the following subject line RallyGrafix PayPal IPN: Unknown Verfication

 

and this in the body

 

Connection Type

------------------------------------------------------

curl= 1, socket= , domain= www.paypal.com, port= 

 

PayPal Response

 

I checked into the transaction through out the processes, could this problem be related to paypals shopping cart? I know paypals shopping cart only allows for 2 options. I'm trying to use 4 Driver Name, Driver Flag, Co-Driver Name, Co-Driver Flag. It is recording only the first 2 on the paypal side of things. But when the order is completed, the only ones that come through are the pull down menu options, the text options all say TEXT.

 

I've read just about everything on the paypal IPN setup, everything is set correctly. Ive compared all my code and nothing is out of place. I have no idea where else to look

Share this post


Link to post
Share on other sites
I checked into the transaction through out the processes, could this problem be related to paypals shopping cart? I know paypals shopping cart only allows for 2 options. I'm trying to use 4 Driver Name, Driver Flag, Co-Driver Name, Co-Driver Flag. It is recording only the first 2 on the paypal side of things. But when the order is completed, the only ones that come through are the pull down menu options, the text options all say TEXT.

 

I've read just about everything on the paypal IPN setup, everything is set correctly. Ive compared all my code and nothing is out of place. I have no idea where else to look

 

 

Do a search in this thread, that issue has been brought up and fixes have been posted a few times. I know it's in this thread somewhere, and I posted a fix a while back as well :)

 

It's an easy fix you just need to alter the paypal_ipn.php file or whatever paypal mod you have to use the options variable and not the stock variable.

Share this post


Link to post
Share on other sites
Do a search in this thread, that issue has been brought up and fixes have been posted a few times. I know it's in this thread somewhere, and I posted a fix a while back as well :)

 

It's an easy fix you just need to alter the paypal_ipn.php file or whatever paypal mod you have to use the options variable and not the stock variable.

 

Thank you Andrea,

I have read this entire thread twice before and dont recall it mentioning anything of such. But I will check again if not im sure i can search for it now that you have told me what the problem was. Thanks a bunch

Share this post


Link to post
Share on other sites
Thank you Andrea,

I have read this entire thread twice before and dont recall it mentioning anything of such. But I will check again if not im sure i can search for it now that you have told me what the problem was. Thanks a bunch

 

Andrea,

My paypal module seems to be extremely different then that one you are reffering to. here is the code for the product options part of my catalog/includes/modules/payment/paypal.php

 

//Customer Specified Product Options: PayPal Max = 2

if ($order->products[$i]['attributes']) {

for ($j=0, $n=sizeof($order->products[$i]['attributes']); $j<2; $j++) {

if($order->products[$i]['attributes'][$j]['option']){

$paypal_fields .= $this->_drawPayPalOptionSet($j,$index,$order->products[$i]['attributes'][$j]['option'],$order->products[$i]['attributes'][$j]['value']);

} else {

$paypal_fields .= $this->_drawPayPalOptionSet($j,$index,' ',' ');

}

}

} else {

for ($j=0; $j<2; $j++) {

$paypal_fields .= $this->_drawPayPalOptionSet($j,$index,' ',' ');

}

}

}

} else { //method 1

 

I can see it has a max option level of 2 set, and it appears that everything below "else" is where it compiles the options and such. is it as simple as changing the 2?? or am I looking for code to completely replace this section??

Share this post


Link to post
Share on other sites

Has anyone worked out how to make text fields mandetory, is there a simple peice of code that forces people to fill in fields before they can add to basket?

 

Thanks for your help guys:)

 

mes

Share this post


Link to post
Share on other sites

Hi,

I have installed version 1.7 and am having a problem. It seams to work well except when an item is added to the shopping cart - it only ads options with menues and not Text. Try this product: http://www.fauxbiz.net/stores/product_info...&products_id=41

 

I really need help here is anyone could help me. I read though the forums and don't see anything.

 

 

Thanks,

Philip

Share this post


Link to post
Share on other sites

When you added your Product Option, did you add ANYTHING in the Option Values? If you did, then you need to go back and remove the Option Values for the TEXT.

 

You only need ONE Option Values with an Option Value of TEXT and Option Name is left BLANK.

 

Did you choose TEXT for the Option Value for that item in the Products Attributes section?


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites
When you added your Product Option, did you add ANYTHING in the Option Values? If you did, then you need to go back and remove the Option Values for the TEXT.

 

You only need ONE Option Values with an Option Value of TEXT and Option Name is left BLANK.

 

Did you choose TEXT for the Option Value for that item in the Products Attributes section?

 

 

I had this version 1.6 and it ran fine. But I am upgrading the store and this version does not work.

I found the error. It was in the /catalog/includes/classes/shopping_cart.php - I compared it to an original oscom one and then copied the differences to my file.

 

I love this contrib - but there should really be directions - life find and replace or find and put after.

 

When I get the time - I am going to make directions for this contrib. If that was done - it would save allot of headaches for people like me :-D

Thanks,

Philip

Share this post


Link to post
Share on other sites

Hmmm, I had instructions when I installed it. I installed version 1.71 - it came with instructions and was very easy to install.


L8r,

PopTheTop

 

Published osC Contributions:

- eCheck Payment Module v3.1

- Reviews in Product Display v2.0

- Fancier Invoice & Packingslip v6.1

- Admin Notes / Customer Notes v2.2

- Customer Zip & State Validation v2.2

- Search Box with Dropdown Category Menu v1.0

 

Pop your camper's top today!

It's a popup thing...

You wouldn't understand

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×