Jump to content
Latest News: (loading..)
Sign in to follow this  
Chandra

Option Type Feature v1.6 (for osc 2.2 MS2)

Recommended Posts

I was wondering if anyone here could help me figure out how to make the option "color" (i.e. black, red, . . .as one of the options for the product I sell) to become a "click to enlarge" option the same way as the product image?

 

 

I gotta it figured out on my own. . . . . thanks though.

 

ski

Share this post


Link to post
Share on other sites

I am using version 2.02and it works great.

I am also using the Dynamic Force validation option which works fine for "Select" fields but does not work for text fields.

Has anyone developed a way to use force validation on text fields to ensure that text has been entered before entering the shopping cart?

 

I appreciate any help because in my case if the text is not entered the order would be invalid.

 

Thank you in advance.

Share this post


Link to post
Share on other sites

Could you try the following:

 

in a product textarea option, enter several words with a carriage return between each word (that is... one word per line) then add the product to the cart

 

Let me know if you can to change the quantity, or even remove the product from the cart.

 

Thanks!

Share this post


Link to post
Share on other sites
I am having a problem with Product Attributes - Option Type Feature (OTF) v. 2.01.

 

I have a text box which works ok. Shows up in the checkout process etc however it doesnt show up in the Admin section when reviewing the order. All I get is : .

 

Anyone know how to solve this issue?

 

I get the same thing but only when I use the payment module "Worldpay Junior" the options are blank in the order emails and reviewing the order in admin (except the default drop-down option).

 

The order details are fine when I use "Cash on Delivery" payment method. Having said that, only the option values are in the email.

 

This is becoming a major issue cos I don't know the customer's option's are.

 

I've just installed oscommerce-2.2rc2a with the OTF Full fix with additional changes:

 

shopping_cart.php file: Uncommented: echo tep_draw_hidden_field('id[' . $products[$i]['id'] . '][' . $option . ']', $value);

 

application_top.php file: Added the magic +++ line: $attributes = ($HTTP_POST_VARS['id'][$HTTP_POST_VARS['products_id'][$i].'+++'.$i]) ? $HTTP_POST_VARS['id'][$HTTP_POST_VARS['products_id'][$i].'+++'.$i] : '';

Share this post


Link to post
Share on other sites

Faaliyet,

 

I am a newbie to the world of e-commerce/OSCommerce.

 

I am contacting you to see if you can help me with a problem I have with the TEXT attribute.

 

I installed option_type_feature-v2.0.2_manual_installation(-new-) onto my OSC build standard of oscommerce-2.2rc2a. I then uploaded the excellent OTF contribution from faaliyet:

 

http://www.oscommerce.com/community/contributions,160

 

I also added the following because when you update in the shopping cart the options dissapeared:

 

http://forums.oscommerce.com/index.php?s=&...t&p=1199739

 

shopping_cart.php

Uncommented: echo tep_draw_hidden_field('id[' . $products[$i]['id'] . '][' . $option . ']', $value);

 

application_top.php

Added the magic +++ line: $attributes = ($HTTP_POST_VARS['id'][$HTTP_POST_VARS['products_id'][$i].'+++'.$i]) ? $HTTP_POST_VARS['id'][$HTTP_POST_VARS['products_id'][$i].'+++'.$i] : '';

 

The PROBLEM I have is when I opt for a credit card payment (my payment module is "Worldpay Junior" in Test mode) the shopping cart displays the text field correctly "- text field text data" but the resulting text field displayed in the Customer's Account Orders is as follows: "- text field: TEXT". The problem also propogates to the Admin/Orders invoice & packing slip and fnally the confirmation email sent to the customer and store owner.

 

When I go through the check out process and use "Cash on Delvery" everything works perfectly !!!!

 

I note that the DB table product_option_values has a field product_option_values _names that is set to TEXT, as per the insert_text_option_value sql file used during the OTF installation. It appears that when the software, on return from the the "Worldpay site" goes to the DB product_option_values table for the options rather than the customer_basket_attributes table.

Am I on the right lines or am I just guessing?

 

Any help in this matter would be greatly appreciated.

 

Alan

Share this post


Link to post
Share on other sites
Faaliyet,

 

I am a newbie to the world of e-commerce/OSCommerce.

 

I am contacting you to see if you can help me with a problem I have with the TEXT attribute.

 

I installed option_type_feature-v2.0.2_manual_installation(-new-) onto my OSC build standard of oscommerce-2.2rc2a. I then uploaded the excellent OTF contribution from faaliyet:

 

http://www.oscommerce.com/community/contributions,160

 

I also added the following because when you update in the shopping cart the options dissapeared:

 

http://forums.oscommerce.com/index.php?s=&...t&p=1199739

 

shopping_cart.php

Uncommented: echo tep_draw_hidden_field('id[' . $products[$i]['id'] . '][' . $option . ']', $value);

 

application_top.php

Added the magic +++ line: $attributes = ($HTTP_POST_VARS['id'][$HTTP_POST_VARS['products_id'][$i].'+++'.$i]) ? $HTTP_POST_VARS['id'][$HTTP_POST_VARS['products_id'][$i].'+++'.$i] : '';

 

The PROBLEM I have is when I opt for a credit card payment (my payment module is "Worldpay Junior" in Test mode) the shopping cart displays the text field correctly "- text field text data" but the resulting text field displayed in the Customer's Account Orders is as follows: "- text field: TEXT". The problem also propogates to the Admin/Orders invoice & packing slip and fnally the confirmation email sent to the customer and store owner.

 

When I go through the check out process and use "Cash on Delvery" everything works perfectly !!!!

 

I note that the DB table product_option_values has a field product_option_values _names that is set to TEXT, as per the insert_text_option_value sql file used during the OTF installation. It appears that when the software, on return from the the "Worldpay site" goes to the DB product_option_values table for the options rather than the customer_basket_attributes table.

Am I on the right lines or am I just guessing?

 

Any help in this matter would be greatly appreciated.

 

Alan

 

FIXED IT!!!!

 

In fact none of the payment modules work. I was looking at the /includes/modules/payment/world_junior.php file to see why the CoD module worked and WP didn't and noticed that the code in world_junior.php was the same as the checkout_process.php which had been modified in the OTF 2 change. I changed the code in world_junior.php in accordance with the changes for the checkout_process.php and hey presto, it worked!!!

 

I had a look at some of the other payment modules and they need to be changed aswel, if you need them.

 

Here the changes I implemented:

 

----------------------------------------------------------------

INSTALLATION

----------------------------------------------------------------

Open /catalog/includes/modules/payment/worldpay_junior.php

 

-----------------------

FIND: (around line 239)

 

$attributes_values = tep_db_fetch_array($attributes);

 

ADD BELOW

 

$attr_name = $attributes_values['products_options_name'];

 

if ($attributes_values['products_options_id'] == PRODUCTS_OPTIONS_VALUE_TEXT_ID) {

$attr_name_sql_raw = 'SELECT po.products_options_name FROM ' .

TABLE_PRODUCTS_OPTIONS . ' po, ' .

TABLE_PRODUCTS_ATTRIBUTES . ' pa WHERE ' .

' pa.products_id="' . tep_get_prid($order->products[$i]['id']) . '" AND ' .

' pa.options_id="' . $order->products[$i]['attributes'][$j]['option_id'] . '" AND ' .

' pa.options_id=po.products_options_id AND ' .

' po.language_id="' . $languages_id . '" ';

$attr_name_sql = tep_db_query($attr_name_sql_raw);

if ($arr = tep_db_fetch_array($attr_name_sql)) {

$attr_name = $arr['products_options_name'];

}

}

 

 

-----------------------

FIND: (around line 243)

 

'products_options' => $attributes_values['products_options_name'],

'products_options_values' => $attributes_values['products_options_values_name'],

 

REPLACE with

 

// OTF contrib begins

//'products_options' => $attributes_values['products_options_name'],

//'products_options_values' => $attributes_values['products_options_values_name'],

'products_options' => $attr_name,

'products_options_values' => $order->products[$i]['attributes'][$j]['value'],

// OTF contrib ends

 

-----------------------

FIND: (around line 427)

 

$products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . $attributes_values['products_options_values_name'];

 

REPLACE with

 

// OTF contrib begins

//$products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . $attributes_values['products_options_values_name'];

$products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . tep_decode_specialchars($order->products[$i]['attributes'][$j]['value']);

// OTF contrib ends

 

PLEASE NOTE for all those having problems with the text field and/or text data disappearing in the email/order details etc that the rules need to be adhered to:

 

1. After you install the OTF there is an sql script (insert_text_option_value.sql).This adds a record into the table products_options_values with a product_options_values_id of 0 and a products_options_values_name of TEXT. THIS IS IMPORTANT!!!

 

2. When you add a new text Product Option in the Admin/Catalog/Product Attributes it will automatically insert an Option Value of TEXT to the Product Option you have just added. NOTE that the Option Value ID is 0 (AGAIN IMPORTANT!!!).

 

3. Now add the Product Attributes to the product but make sure that you select TEXT as the Option Value.

 

4. DO NOT delete any text Option Values with an ID of 0 because all the text fields will be deleted with an ID of 0. The big problem if you do create another text field is that it will not automatically create an Option Value TEXT with an ID of 0, it will pick the next ID. The consequence is that you will lose the text field from you orders etc. If you do need to delete the text field Option Value the you need to run the insert_text_option_value.sql file again to create the default TEXT record in the table.

 

5. I also noted that it also automatically creates an Option Value of TEXT for Checkboxes aswel, don't ask me why.

 

That's it from the newbie, my next task is to implement the Attributes Sort Order, FINGERS CROSSED!!!

 

Alan

Share this post


Link to post
Share on other sites

I have just started using osCommerce and figured out how to install Option Type Feature 3.0, but I have a few problems.

 

1. On the top of my product info page, I have the following line right above Available Options: truefalse truefalsefalsefalse truefalse

2. When I use textarea I get () on the line below the option name

How do I get rid of the line and the ()?

 

Also, when using radio buttons, is there a way to get the options in a row instead of in a column?

 

TIA!

Share this post


Link to post
Share on other sites
Also, when using radio buttons, is there a way to get the options in a row instead of in a column?

 

Hi nazy,

 

I can't help with the first two problems, but I managed to get my radio buttons displaying horizontally! I posted about it on this thread before, take a look here:

 

http://forums.oscommerce.com/index.php?sho...mp;#entry935105

 

It's working really well on my website.

 

All the best,

Tatty

Share this post


Link to post
Share on other sites

Has anyone ever thought about or successfully added a multi-select drop down box to the list of options in the admin attributes section? I'd like to add this feature to the list. Does anyone have any suggestions?

Share this post


Link to post
Share on other sites
I am having the same problem with the TEXT showing up in the orders_products_attributes table field products_options_values. Did you have any luck solving this?

 

Thanks,

Bob

 

 

Hey guys.

 

I think I solved this one. This deals with the actual input from the text boxes appearing as TEXT on the checkout screen and in the order and invoice as well. Here's what I found out:

 

When I installed Option Type 2.0.2, I remember being confused about this step:

 

----------------------------------------------------------------
Open catalog/includes/class/order.php

-----------------------
FIND: (around line 232)

$attributes = tep_db_fetch_array($attributes_query);
$this->products[$index]['attributes'][$subindex] = array('option' => $attributes['products_options_name'],
						  'value' => $attributes['products_options_values_name'],

REPLACE WITH:

$attributes = tep_db_fetch_array($attributes_query);
// BOF Product Type Option
		if ($value == PRODUCTS_OPTIONS_VALUE_TEXT_ID){
		  $attr_value = $products[$i]['attributes_values'][$option];
		  $attr_name_sql_raw = 'SELECT po.products_options_name FROM ' .
			TABLE_PRODUCTS_OPTIONS . ' po, ' .
			TABLE_CUSTOMERS_BASKET_ATTRIBUTES . ' cba, ' .
			TABLE_PRODUCTS_ATTRIBUTES . ' pa WHERE ' .
			' pa.products_id="' . $products[$i]['id'] . '" AND ' .
			' pa.products_id="' . $products[$i]['id'] . '" AND ' .
			' pa.options_id="' . $option . '" AND ' .
			' pa.options_id=po.products_options_id AND ' .
			' po.language_id="' . $languages_id . '" AND ' .
			' cba.products_id="' . $products[$i]['id'] . '" AND ' .
			' cba.products_options_value_id="' . $value . '"';
			$attr_name_sql = tep_db_query($attr_name_sql_raw);
		  if ($arr = tep_db_fetch_array($attr_name_sql)) {
			$attr_name = $arr['products_options_name'];			  }

		} else {
		  $attr_value = $attributes['products_options_values_name'];
		  $attr_name  = $attributes['products_options_name'];
		}		  
		//$this->products[$index]['attributes'][$subindex] = array('option' => $attributes['products_options_name'],
		//														 'value' => $attributes['products_options_values_name'],
		$this->products[$index]['attributes'][$subindex] = array('option'	=> $attr_name,
																 'value'	 => $attr_value,
// EOF Product Type Option

 

What I realized is that instead of replacing JUST those 3 lines at the top, I ended up replacing everything in that function for some reason (brain fart). Take a closer look and see that the function has the top line, then two more lines under that need to be replaced, and that's IT. Do not replace any lines under that 3rd line. This is what caused those strings of text not to be pushed to the orders page.

 

Also, to fix the problem with the attributes not appearing at all after the shopping cart, you need to make sure you have the FIX for the attributes dissapearing after hitting the UPDATE button which can be found HERE. This fix cleared the problem of attributes not appearing on the orders page.

 

Hope this helps, I know searching through all these forums is a PAIN!

Share this post


Link to post
Share on other sites

Can anyone help me figure this out? When I go to add a new option type, I get the following error:

 

1062 - Duplicate entry '3-1' for key 1

 

insert into products_options (products_options_id, products_options_name, language_id) values ('3', 'Special', '1')

 

[TEP STOP]

 

But then when I click the browser back button, the option has been added. However, when adding the option properties, all the new options created get added and assigned an ID of 0. i.e:

 

ID Option Name Option Value Action

0 Special TEXT Update Delete

0 Text TEXT Update Delete

 

Then, when trying to view a product, I get the following error:

 

Parse error: syntax error, unexpected ';', expecting T_FUNCTION in /home/mesolve/public_html/byed/catalog/includes/classes/shopping_cart.php on line 595

Share this post


Link to post
Share on other sites

Okay, I found my problems, it was just in the combing of the source files.

 

How can I make the length stored in the textarea longer? I have changed the varchar length in the DB and also specified a longer length in the attribute setting, but it still only stores 32 chars. Can anybody provide a solution to this?

Share this post


Link to post
Share on other sites

Does anybody know if it's possible to get a sales report on which attributes are selling best, something like:

 

May's sales

Gem Necklace - red - 2

Gem Necklace - blue - 6

 

Or to track stock with Option Type installed? (I noticed lots of people have asked for this but there doesn't yet seem to be a solution)

 

I already installed two reports contributions, Monthly Sales Report and Sales Report 2. These are both useful in their different ways, and Sales Report 2 comes REALLY close to what I want, but doesn't give me figures for sales of attributes.

 

I think the code in Sales Report 2 that would need tweaking to fit in with Option Type is this:

 

// query for attributes
  $this->queryAttr = "SELECT sum(op.products_id) as attr_cnt, o.orders_id, opa.orders_products_id, opa.products_options, opa.products_options_values, opa.options_values_price, opa.price_prefix from " . TABLE_ORDERS_PRODUCTS_ATTRIBUTES . " opa, " . TABLE_ORDERS . " o, " . TABLE_ORDERS_PRODUCTS . " op WHERE o.orders_id = opa.orders_id AND op.orders_products_id = opa.orders_products_id";

 

and this:

 

// products_attributes
	// are there any attributes for this order_id ?
	$rqAttr = tep_db_query($this->queryAttr . " AND o.date_purchased >= '" . tep_db_input(date("Y-m-d\TH:i:s", $sd)) . "' AND o.date_purchased < '" . tep_db_input(date("Y-m-d\TH:i:s", $ed)) . "' AND op.products_id = " . $resp[$cnt]['pid'] . $filterString . " group by products_options_values order by orders_products_id");
	$i = 0;
	while ($attr[$i] = tep_db_fetch_array($rqAttr)) {
	  $i++;
	}

 

and this:

 

// set attr value
	  $resp[$cnt]['attr'] = $option;
	} else {
	  $resp[$cnt]['attr'] = "";
	}
	$resp[$cnt]['price'] = tep_add_tax($price, $resp[$cnt]['ptax']);
	$resp[$cnt]['psum'] = $resp[$cnt]['pquant'] * tep_add_tax($price, $resp[$cnt]['ptax']);
	$resp[$cnt]['order'] = $order['order_cnt'];
	$resp[$cnt]['shipping'] = $shipping['shipping'];

 

Any ideas?

 

Thank you!

Share this post


Link to post
Share on other sites

just installed this mod and everything looked fine all options were showing both in admin and in shop ect but then i tried to login to my test account and got the following error

 

Fatal error: Call to undefined function: count_contents() in /home/bstcouk1/public_html/login.php on line 142

 

which i think is strange cause ive not edited my login.php for anything

can anyone help as my store is crippled at the moment due to this error

i have posted the contents of my login.php below

<?php

/*

$Id: login.php,v 1.80 2003/06/05 23:28:24 hpdl Exp $

 

E-Commerce Solutions

 

Released under the GNU General Public License

*/

 

require('includes/application_top.php');

 

// redirect the customer to a friendly cookie-must-be-enabled page if cookies are disabled (or the session has not started)

if ($session_started == false) {

tep_redirect(tep_href_link(FILENAME_COOKIE_USAGE));

}

 

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_LOGIN);

 

$error = false;

if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'process')) {

$email_address = tep_db_prepare_input($HTTP_POST_VARS['email_address']);

$password = tep_db_prepare_input($HTTP_POST_VARS['password']);

 

// Check if email exists

$check_customer_query = tep_db_query("select customers_id, customers_firstname, customers_password, customers_email_address, customers_default_address_id from " . TABLE_CUSTOMERS . " where customers_email_address = '" . tep_db_input($email_address) . "'");

if (!tep_db_num_rows($check_customer_query)) {

$error = true;

} else {

$check_customer = tep_db_fetch_array($check_customer_query);

// Check that password is good

if (!tep_validate_password($password, $check_customer['customers_password'])) {

$error = true;

} else {

if (SESSION_RECREATE == 'True') {

tep_session_recreate();

}

 

$check_country_query = tep_db_query("select entry_country_id, entry_zone_id from " . TABLE_ADDRESS_BOOK . " where customers_id = '" . (int)$check_customer['customers_id'] . "' and address_book_id = '" . (int)$check_customer['customers_default_address_id'] . "'");

$check_country = tep_db_fetch_array($check_country_query);

 

$customer_id = $check_customer['customers_id'];

$customer_default_address_id = $check_customer['customers_default_address_id'];

$customer_first_name = $check_customer['customers_firstname'];

$customer_country_id = $check_country['entry_country_id'];

$customer_zone_id = $check_country['entry_zone_id'];

tep_session_register('customer_id');

tep_session_register('customer_default_address_id');

tep_session_register('customer_first_name');

tep_session_register('customer_country_id');

tep_session_register('customer_zone_id');

 

tep_db_query("update " . TABLE_CUSTOMERS_INFO . " set customers_info_date_of_last_logon = now(), customers_info_number_of_logons = customers_info_number_of_logons+1 where customers_info_id = '" . (int)$customer_id . "'");

 

// restore cart contents

$cart->restore_contents();

 

if (sizeof($navigation->snapshot) > 0) {

$origin_href = tep_href_link($navigation->snapshot['page'], tep_array_to_string($navigation->snapshot['get'], array(tep_session_name())), $navigation->snapshot['mode']);

$navigation->clear_snapshot();

tep_redirect($origin_href);

} else {

tep_redirect(tep_href_link(FILENAME_DEFAULT));

}

}

}

}

 

if ($error == true) {

$messageStack->add('login', TEXT_LOGIN_ERROR);

}

 

$breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_LOGIN, '', 'SSL'));

?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html <?php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">

<link rel="stylesheet" type="text/css" href="style.css">

<script language="javascript"><!--

function session_win() {

window.open("<?php echo tep_href_link(FILENAME_INFO_SHOPPING_CART); ?>","info_shopping_cart","height=460,width=430,toolbar=no,statusbar=no,scrollbars=yes").focus();

}

//--></script>

</head>

<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">

<!-- header //-->

<?php require(DIR_WS_INCLUDES . 'header.php'); ?>

<!-- header_eof //-->

 

<!-- body //-->

<tr>

<td width="182" align="left" valign="top">

<table width="182" cellpadding="0" cellspacing="0" border="0">

<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?>

</table>

</td>

<td width="509" valign="top" style="padding-left:2px;">

 

<table border="0" cellpadding="0" cellspacing="0" width="770">

<tr>

<td width="100%" height="100%" valign="top" bgcolor="#FFFFFF">

 

<table border="0" width="100%" cellpadding="0" cellspacing="0" >

<tr>

<td width="100%" height="25" valign="top">

<table width="100%" border="0" cellpadding="0" cellspacing="0" height="24">

<tr>

<td><img src="images/left_header.gif" width="4" height="24" alt="" /></td>

<td width="100%" style="background-image:url(images/header_bg.gif); text-align:left; color:#FFF; padding-left:5px; font-size:110%; font-weight:bold "><?php

echo HEADING_TITLE; ?>

</td>

<td><img src="images/right_header.gif" width="4" height="24" alt="" /></td>

</tr>

</table>

</td>

</tr>

<?php echo tep_draw_form('login', tep_href_link(FILENAME_LOGIN, 'action=process', 'SSL')); ?>

<tr>

<td height="409" valign="top" style="padding:0px 5px; " class="infoBox">

<table border="0" cellpadding="0" cellspacing="0" width="100%">

 

 

 

 

 

<?php

if ($messageStack->size('login') > 0) {

?>

<tr>

<td align="left"><?php echo $messageStack->output('login'); ?></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<?php

}

 

if ($cart->count_contents() > 0) {

?>

<tr>

<td class="smallText" align="left" style="padding:0px 5px; "><?php echo TEXT_VISITORS_CART; ?></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<?php

}

?>

<tr>

<td align="center"><table border="0" width="100%" cellspacing="5" cellpadding="0">

<tr>

<td class="main" width="50%" valign="top" align="left"><b><?php echo HEADING_NEW_CUSTOMER; ?></b></td>

<td class="main" width="50%" valign="top" align="left"><b><?php echo HEADING_RETURNING_CUSTOMER; ?></b></td>

</tr>

<tr>

<td width="50%" height="100%" valign="top" align="left"><table border="0" width="98%" cellspacing="1" style="border:1px solid #7A7F84;" cellpadding="2" class="infoBox">

<tr class="infoBoxContents">

<td valign="top"><table border="0" width="100%" height="100%" cellspacing="0" cellpadding="2">

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td class="main" valign="top" ><?php echo '<span style="font-weight:bold;">'.TEXT_NEW_CUSTOMER . '</span><br><br>' . TEXT_NEW_CUSTOMER_INTRODUCTION; ?></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '12'); ?></td>

</tr>

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

<td align="right" valign="top"><?php echo '<a href="' . tep_href_link(FILENAME_CREATE_ACCOUNT, '', 'SSL') . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></td>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

</tr>

<?php require('ppesetup.php'); $ppesetup = new ppesetup($language); echo $ppesetup->txt;

echo "<tr><td align='center'><a href='".tep_href_link('ppeb.php?shec=a', '', 'SSL')."'>".$ppesetup->ima."</a></td></tr>"; ?>

</table></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '5'); ?></td>

</tr>

</table></td>

</tr>

</table></td>

<td width="50%" height="100%" valign="top" align="left"><table border="0" width="98%" cellspacing="1" cellpadding="2" class="infoBox" style="border:1px solid #7A7F84;">

<tr class="infoBoxContents">

<td><table border="0" width="100%" height="100%" cellspacing="0" cellpadding="2">

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td class="main" colspan="2" style="font-weight:bold;"><?php echo TEXT_RETURNING_CUSTOMER; ?></td>

</tr>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td class="main"><b><?php echo ENTRY_EMAIL_ADDRESS; ?></b></td>

<td class="main"><?php echo tep_draw_input_field('email_address'); ?></td>

</tr>

<tr>

<td class="main"><b><?php echo ENTRY_PASSWORD; ?></b></td>

<td class="main"><?php echo tep_draw_password_field('password'); ?></td>

</tr>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td class="smallText" colspan="2" style="padding-left:5px; "><?php echo '<a href="' . tep_href_link(FILENAME_PASSWORD_FORGOTTEN, '', 'SSL') . '">' . TEXT_PASSWORD_FORGOTTEN . '</a>'; ?></td>

</tr>

<tr>

<td colspan="2"><?php echo tep_draw_separator('pixel_trans.gif', '100%', '6'); ?></td>

</tr>

<tr>

<td colspan="2"><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

<td align="right" style="padding-bottom:5px; "><?php echo tep_image_submit('button_login.gif', IMAGE_BUTTON_LOGIN); ?></td>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

</tr>

</table></td>

</tr>

</table></td>

</tr>

</table></td>

</tr>

</table></td>

</tr></table></td></tr></form>

</table></td>

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

</tr>

 

 

</table>

</td>

 

</tr>

 

<!-- body_eof //-->

 

<!-- footer //-->

<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>

<!-- footer_eof //-->

 

 

</body>

</html>

<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>


osCommerce 2.2-MS2

Share this post


Link to post
Share on other sites

Attributes don't show after Login.

 

Hello All,

 

I have had this problem on a cart I'm working on so I decided to do a test cart. I have a clean install of RC2a and tried to integrate Option Type Feature 3.0. The problem is when a customer puts a product with attributes in the cart and then clicks buy, they are prompted to login. After logging in, the product is still in the cart but none of the attributes are there.

 

Anyone else have this problem and a solution to go with it?!

 

Thanks! :blink:

Share this post


Link to post
Share on other sites

Hi everyone

 

Great contribution I now have a text box so that customers can 'Write a note' when they place and order, but this only appears on the Product Detailed page.

Is there any way I can get it to appear in the Product listing page because if a customer clicks the Buy Now button on this page they are directed directly to the cart and therefore miss the option of writing a note.

 

I've trawled through the inlcudes/modules/product_listing.php file but don't know what to do.

 

Any help greatly appreciated

Share this post


Link to post
Share on other sites

Hi, could someone please tell me if this mod could be made to work like the attributes on this site: http://www.kjbeckettbespokeshirts.com/bespoke-shirts.htm

 

It's a website selling shirts. First you select your fabric, then you enter a 6 step selection of attributes, one set of attribbutes on each step or each page. Is this possible to do with this mod or woth any other oscommerce mod? Thanks.

Share this post


Link to post
Share on other sites
Attributes don't show after Login.

 

Hello All,

 

I have had this problem on a cart I'm working on so I decided to do a test cart. I have a clean install of RC2a and tried to integrate Option Type Feature 3.0. The problem is when a customer puts a product with attributes in the cart and then clicks buy, they are prompted to login. After logging in, the product is still in the cart but none of the attributes are there.

 

Anyone else have this problem and a solution to go with it?!

 

Thanks! :blink:

 

yes I have this to?

 

I think it is to do with the Sessions

I have the fix in my includes/application_top.php

about line 350:

$attributes = ($HTTP_POST_VARS['id'][$HTTP_POST_VARS['products_id'][$i].'+++'.$i]) ? $HTTP_POST_VARS['id'][$HTTP_POST_VARS['products_id'][$i].'+++'.$i] : '';

 

this work only in the same Sessions but not in new Sessions ( when you login)

but need help????


Thanks Simon

 

osCommerce Version: Online Merchant v2.2 RC 2a - Test Site with: oscommerce-2.2ms2-060817

cPanel Version: 11.23.4-RELEASE - Apache version: 2.0.63 - PHP version: 5.2.5 - MySQL version: 5.0.51a-community - Operating system: Linux

========================================================================

Share this post


Link to post
Share on other sites

Hi - contrib is just what I need but I have a problem in that I need a very large text input box and so I need to specify the height and width of the box as it will not be standard.

 

I was wondering whether it would be possible to add three fields into the database to hold these parameters, but my PHP isn't good enough to understand how to add in the coding into the files. In the interim I'd be happy just to have ALL the boxes oversized so they pick up a default hard-coded width and height.

 

I tried to add a new section in the html_output.php file to create a new type of input box just for this (tep_input_attrfield or something) which basically took the coding for the normal text box and added some parameters but this was far too complex for me!

 

Anyone able to help at all? Thanks in advance.

 

Obviously with the size of this input I also need to solve how to get them to display correctly on other screens.

Share this post


Link to post
Share on other sites
Hi - contrib is just what I need but I have a problem in that I need a very large text input box and so I need to specify the height and width of the box as it will not be standard.

 

I was wondering whether it would be possible to add three fields into the database to hold these parameters, but my PHP isn't good enough to understand how to add in the coding into the files. In the interim I'd be happy just to have ALL the boxes oversized so they pick up a default hard-coded width and height.

 

I tried to add a new section in the html_output.php file to create a new type of input box just for this (tep_input_attrfield or something) which basically took the coding for the normal text box and added some parameters but this was far too complex for me!

 

Anyone able to help at all? Thanks in advance.

 

Obviously with the size of this input I also need to solve how to get them to display correctly on other screens.

 

 

Hi

 

frist are you getting this:

 

When the user logs in after selecting a product all of the attributes disappear?

 

also have you fixed the textbox error with f/fox and I/E?

Edited by West One Hosting

Thanks Simon

 

osCommerce Version: Online Merchant v2.2 RC 2a - Test Site with: oscommerce-2.2ms2-060817

cPanel Version: 11.23.4-RELEASE - Apache version: 2.0.63 - PHP version: 5.2.5 - MySQL version: 5.0.51a-community - Operating system: Linux

========================================================================

Share this post


Link to post
Share on other sites

Hi,

 

I have been using the contribution successfully for a while but now but when i add a new language to may existing catalogue i run into problems, i get a drop down instead of text field for the new language on the product attributes. any clues?

 

current language:

<input type="text" name ="id[txt_27]" size="75" maxlength="75" value="">

 

 

the new language:

<select name="id[27]"><option value="0" SELECTED>TEXT</option></select>

 

Thankful for any help...

 

//T.

Share this post


Link to post
Share on other sites
Hi

 

frist are you getting this:

 

When the user logs in after selecting a product all of the attributes disappear?

 

also have you fixed the textbox error with f/fox and I/E?

 

I haven't looked at the problem of attributes disappearing yet and I am unaware of the textbox error. Do either affect what I need?

 

Ideally I'd much rather have the checkout procedure for this one type of product that added in a whole new page with just a load of text boxes that got added to the order in much the same way that the order comments box works - I'd have to limit the product purchase to one per order but then again it's the sort of thing that people only want one of anyhow, indeed I think all other shops I have seen only allow you to purchase one at a time anyhow.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×