Jump to content
Sign in to follow this  
Chandra

Option Type Feature v1.6 (for osc 2.2 MS2)

Recommended Posts

Hi!

 

I'm sorry if this problem already has been stated/solved, but after going through all 34 pages, I still can't find a solution for my problem.

 

After installing the OTF 2.02, the option name column is lost...

 

In the heading of the table it says 'option name', but in the table beneath it says select, and where select should be it says 32, as the statement for the length and so on.

 

It seems to me that there is a "<td>"-paragraph missing in the products_attributes.php, but I can't figure out where...

The code for this file has not been modified after installation of this contribution.

 

Please help me, as I'm going nuts over this issue.

 

Thanks,

 

Morten

Share this post


Link to post
Share on other sites

Hello all,

 

I have what I hope to be a very quick question. I can read html fine but when it comes to php it looks like spanish to me. I installed the option type feature and when I complete an order I will get a fatal error on the checkout process page for line 241 (where the option type feature is located)

 

I was wondering if someone could take a look at this for me an let me know if something looks out of place.

 

		$products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . tep_decode_specialchars($order->products[$i]['attributes'][$j]['value']);

 

Thanks all!

-Kevin

Share this post


Link to post
Share on other sites

I'm having problems where when a product is purchased sometimes I will only get the size and sometimes I'll only get what they typed in the option type box. Is this a common problem or where could I begin my search on this?

Share this post


Link to post
Share on other sites
Hello all,

 

I have what I hope to be a very quick question. I can read html fine but when it comes to php it looks like spanish to me. I installed the option type feature and when I complete an order I will get a fatal error on the checkout process page for line 241 (where the option type feature is located)

 

I was wondering if someone could take a look at this for me an let me know if something looks out of place.

 

		$products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . tep_decode_specialchars($order->products[$i]['attributes'][$j]['value']);

 

Thanks all!

-Kevin

 

I think that line is supposed to be:

 

$products_ordered_attributes .= "\n\t" . $attr_name . ' ' . tep_decode_specialchars($order->products[$i]['attributes'][$j]['value']);

Share this post


Link to post
Share on other sites

Hello,

This contrib works great for me except for one very important thing. When using a text or textarea options, the price doesn't get added to the shopping cart. If I change the option to be anything else (raido, checkbox, select) it works fine. I've looked through the most obvious areas and can't seem to find a problem. Can anyone tell me what I might have missed or point me in the right direction?

Thanks!

Share this post


Link to post
Share on other sites
Hello,

This contrib works great for me except for one very important thing. When using a text or textarea options, the price doesn't get added to the shopping cart. If I change the option to be anything else (raido, checkbox, select) it works fine. I've looked through the most obvious areas and can't seem to find a problem. Can anyone tell me what I might have missed or point me in the right direction?

Thanks!

 

Fixed it. The problem was in the includes/local/configure.php file. My "define('PRODUCTS_OPTIONS_VALUE_TEXT_ID', 0);" didn't match the option value in my database.

Share this post


Link to post
Share on other sites

after i installed this contribution i get the following error:

 

Customer inputs the value or text in the new created text field, and when he goes to checkout all the other attributes that had a drop down menu simply disappear, but when he receives the order all the products are there.

any ideas?

Share this post


Link to post
Share on other sites

I am having a problem with Product Attributes - Option Type Feature (OTF) v. 2.01.

 

I have a text box which works ok. Shows up in the checkout process etc however it doesnt show up in the Admin section when reviewing the order. All I get is : .

 

Anyone know how to solve this issue?

Share this post


Link to post
Share on other sites
Hello,

 

I am new to all this and try to look up for the solution my self but unfortunately I cant find to solve this problem. Exactly the same with yours. How did u solve this? Did u change the

 

[$products_id]

 

or

 

[$products_id_string]

 

Please help..I am so afraid everything I have done will collapse. I took a lot of time doing this. but I did save the original though.

 

I too noticed this while doing the manual install. Go with your gut...the instructions are wrong.

 

Also keep reading this post as doing the manual install, the text is disappearing if you update the cart (at least mine is).

Share this post


Link to post
Share on other sites

Hi

I have spent what feels like weeks trawling through forums, and have now decided all I really need to add to my standard build are the following

All_in_oneFCKEditor_v1

Paypal IPN v2.3.3

Product attributes - OTF.

 

I have spent hours and hours reading topics 57259, 247976, 177853, 179917 as well as searching by file name etc.

 

First 2 no problem, but then this monster instal for OTF.

I am trying to instal product_attributes_option_type_2.02_1

 

Problem 1) I know there are issues with checkout_process.php and paypal IPN. I have managed to find the same code in CATALOG/INCLUDES/MODULES/PAYMENT/PAYPAL_IPN.PHP for the first 2 changes in the instructions, but I am not sure about the 3rd change. I assume I have to change IPN.PHP but the code is not identical. Please can someone help?

 

Problem 2) catalog/product_info.php

The first mod to this file is below.

 

FIND: (around line 27)

 

<script language="javascript">

function popupWindow(url) {

window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res

izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le

ft=150')

}

 

 

But in my version this is commented out so adding the code specified in the mod will have no impact.

 

What should I do?

 

Problem 3) catalog/includes/class/shopping_cart.php

The 7th change to this file says

FIND: (around line 105)

 

$this->contents[$products_id]['attributes'][$option] = $value;

 

But in my file I have

$this->contents[$products_id_string]['attributes'][$option] = $value;

 

I have also noticed that the instructions refer to a folder 'class', but I think it should be 'classes'

So now I a need to have a headache pill and go for a lie down.

 

I notice back in OTF vesion 1.7 (maybe others) there is a list of the 'original' OS2 MS2 files. Even in there the catalog/product_info.php file has the relevant part of the file commented out.

 

Do I need to instal RC1, or what? The instal notes indicate that this should work on version 060817 which is the version I think I have.

 

Please can someone help/ guide me

Share this post


Link to post
Share on other sites

OK, I have now spotted the suggestion from rich89 for the probable solution to Problem 3, although I don't understand why the instal instructions are therefore wrong.

 

However, I still can't find anything relating to my problems 1 and 2.

 

There must be a number of people out there who have installed IPN and OTF together, aren't there?

 

And many people installing OTF must have noticed the modification to an area which is commented out? Should the commenting out in catalog/product_info.php be removed to allow the code to work, or should I just ignore the new code?

 

Thanks in advance for your help.

Share this post


Link to post
Share on other sites

I'm having difficulties in getting this contribution to work on 2.2rc2. Let's say that it is doing 'something' but there are some bugs still in. I'm focussing now on managing text/area fields in the admin pages and i need quite some repairs there, do others have the same experience?

Is there a better alternative to this? Or should i just battle my way through the exceptions and queries?

Paul

Share this post


Link to post
Share on other sites

QUOTE(lee987 @ Feb 29 2008, 09:47 PM)

Hi

I am trying to install both paypal IPN v2.3.3 and Product attributes - Option Type Feature.

I have an issue with checkout_process.php, so I believe I need (in this case) to modify ipn.php

 

OTF says to change the following

 

$products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . $attributes_values['products_options_values_name'];

 

REPLACE with

 

// OTF contrib begins

//$products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . $attributes_values['products_options_values_name'];

$products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . tep_decode_specialchars($order->products[$i]['attributes'][$j]['value']);

// OTF contrib ends

 

However, ipn.php is not the same. It has the following

 

$products_ordered_attributes .= "\n\t" . $order->products[$i]['attributes'][$j]['option'] . ' ' . $order->products[$i]['attributes'][$j]['value'];

 

Please can someone advise exactly what I need to do in ipn.php

Thank you all very much

 

 

Can anyone out there help me on this one? Have I missed something. I think this is causing me a problem, when I turn on downloads, the stock updating stops working, and I think this is the reason.

Everything else works fine (order email, confirmed order/ delivered, stock updates etc) until I turn downloads on, then suddenly everything still works EXCEPT the stock update (this is the same even though I have not yet set up any download attributes)

 

I do not need the attribute stock updating, just the item stock (items are modified to suit the attribute set, so I do not have separate stock of items with different attributes, just stock of the standard item, which I need updating)

 

Please can someone help?

It's driving me round the bend!

 

Thanks very much

Share this post


Link to post
Share on other sites

Here's a little code modification I made to make the contrib compatible with Google Checkout... Please don't email me on how to install, it has been verified by 3 others so far to work, so I am just providing this code as is. Always remember to backup!

 

INTEGRATING GOOGLE CHECKOUT with PRODUCT ATTRIBUTES OPTION TYPE FEATURE

 

catalog/googlecheckout/gcheckout.php

 

FIND (line 142):

$attr_value = $attributes_values['products_options_values_name'];

 

CHANGE TO:

// Product Option Type

if ($value == PRODUCTS_OPTIONS_VALUE_TEXT_ID) {

 

$attr_value = $products[$i]['attributes_values'][$option] .

tep_draw_hidden_field('id[' . $products[$i]['id'] . '+++' .

$i . '][' . TEXT_PREFIX . $option . ']',

$products[$i]['attributes_values'][$option]);

 

} else {

$attr_value = $attributes_values['products_options_values_name'] .

tep_draw_hidden_field('id[' . $products[$i]['id'] . '+++' .

$i. '][' . $option . ']', $value);

}

// End Product Option Type

 

 

catalog/googlecheckout/responsehandler.php

 

FIND (line 631):

'products_options_values' => $attributes_values['products_options_values_name'],

 

CHANGE TO:

'products_options_values' => $order->products[$i]['attributes'][$j]['value'], // Product Options Changed

 

 

FIND (line 644)

$products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . $attributes_values['products_options_values_name'];

 

CHANGE TO:

// Product Option Type contribution

$products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . tep_decode_specialchars($order->products[$i]['attributes'][$j]['value']);

// $products_ordered_attributes .= "\n\t" . $attributes_values['products_options_name'] . ' ' . $attributes_values['products_options_values_name'];


Most Valuable OsCommerce Contributions:

Also Purchased (AP) Preselection (cuts this resource hogging query down to nothing) -- Contribution 3294

FedEx Automated Labels -- Contribution 2244

RMA Returns system -- Contribution 1136

Sort Products By Dropdown -- Contribution 4312

Ultimate SEO URLs -- Contribution 2823

Credit Class & Gift Voucher -- Contribution 282

Cross-Sell -- Contribution 5347

Share this post


Link to post
Share on other sites

Thanks very much Keith.

I will try to understand it.

 

Has anyone else managed to do this for Paypal IPN v2?

 

Thanks very much

Lee

Share this post


Link to post
Share on other sites
Hi,

 

I was having the similar issue where the attributes would disappear after updating the cart. I tried to uncomment out the mentioned line in shopping_cart.php but still see that the attributes are disappearing. The actual name of the Text Field remains on my cart page it just strips whatever the customer input for that value. Does anyone else have this issue?

 

I double checked my shopping_cart.php file and this is the line I uncommented around line 81.

 

echo tep_draw_hidden_field('id[' . $products[$i]['id'] . '][' . $option . ']', $value);

 

Thanks,

 

Jason

 

ihave same situation here after updating im loosing my customer comments

 

any body solved this problem plz help me

Share this post


Link to post
Share on other sites

Hi, I've installed OTF and AttributesWizzard and can't get them both to work correctly. If I want to add an TextAttribute I get

 

1136 - Column count doesn't match value count at row 1

 

insert into products_attributes values (null, '28', '12', '10', '0', '+')

 

[TEP STOP]

 

Can anybody help me?

Share this post


Link to post
Share on other sites

I have just upgraded from v1.72 to the v2.03 and it all works fine for me and my heavily modified site except one thing.

 

In Admin /orders I get

"1 x Blush

- : Small

- : Large

- : rfewfew ewr wer

 

As you see the titles of my attributes don't show up, the thing is that they DID before I upgraded . It must be a very simple fix but I have looked and looked and can't find it.

 

If anyone can help.

Share this post


Link to post
Share on other sites

graumelyn..........

Hi, I've installed OTF and AttributesWizzard and can't get them both to work correctly. If I want to add an TextAttribute I get

 

1136 - Column count doesn't match value count at row 1

 

insert into products_attributes values (null, '28', '12', '10', '0', '+')

 

[TEP STOP]

 

Can anybody help me?

 

 

 

I use OTF in combo with EP (easy populate) and find that works VERY VERY well with no hassles.

 

this way you handle you attributes as normal and then manipulate them via the downloaded EP file.

 

not an answer for you but i thought it might help?

 

tim

Edited by findtim

Share this post


Link to post
Share on other sites

... and I'm getting this error when trying to manually add the attribute through attributes page:

 

1136 - Column count doesn't match value count at row 1

insert into products_attributes values ('', '122', '16', '0', '', '+', '0')

[TEP STOP]

 

I am using Ajax Attributes contrib but this won't let me add the contrib.


SolarFrenzy

Solar powered gadgets at down to earth prices.

 

CheekyNaughty

Promoting British Design

Share this post


Link to post
Share on other sites

I thought the problem went away but it still happening.

 

After I used the OTF contribution of

pbor1234 Better support for text/area field

 

Everything is wroking fine but when I am in Administration - product attribute

I cant go to the following pages where I assigned the atrributes, Thus cannot coreect them either.

 

Anybody can point me to the right direction?

 

Amadeo

Share this post


Link to post
Share on other sites

I have a text box that is creating an error. The error is occurring when I type a comma into the text box (ex: atlanta, Ga or Smith, Jeff). Any ideas why this would be happening?

 

Here is the error:

 

1054 - Unknown column 'hhvs' in 'where clause'

select pd.products_name, p.products_model, p.products_image, p.products_id, p.products_price, p.products_weight, p.products_quantity, p.products_price1, p.products_price2, p.products_price3, p.products_price4, p.products_price5, p.products_price6, p.products_price7, p.products_price8, p.products_price1_qty, p.products_price2_qty, p.products_price3_qty, p.products_price4_qty, p.products_price5_qty, p.products_price6_qty, p.products_price7_qty, p.products_price8_qty, p.products_qty_blocks, p.products_tax_class_id, NULL as specials_new_products_price from products_description pd, products p where p.products_status = '1' and p.products_id in (282, 282, 322, hhvs) and pd.products_id = p.products_id and pd.language_id = '1'

[TEP STOP]

Share this post


Link to post
Share on other sites

Hello all.

 

I was wondering if anyone here could help me figure out how to make the option "color" (i.e. black, red, . . .as one of the options for the product I sell) to become a "click to enlarge" option the same way as the product image?

 

In other words, a customer would click on the color word "RED" and it would open a small pop-up window showing the item in "red color". The item is the same as the product, just in the color as the option color selected.

 

Thanks for any help.

 

ski

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×